Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Discussions

Closed Thread
Thread Tools Search this Thread Display Modes
Old 17th February 2014, 14:59   #1
DrO
 
Join Date: Sep 2003
Posts: 27,880
IMPORTANT: SHOUTcast Site, Directory (YP) and API Changes

For those who have not been keeping up on recent changes with SHOUTcast, it was purchased (along with Winamp) by Radionomy in January 2014.

Today (17th February 2014) marks the start of publically migrating the SHOUTcast site, Directory (YP) and API which is possibly going to cause some listing issues as well as reduced feature set on the website. Though every effort is being done to ensure minimal breakage of things (though it is to be expected there will be some during this transition).


This thread will be updated with any relevant information or expected issues and so on.

-------------------------------------------------------------------------------------

Currently migrated to Radionomy hosting:
Deprecated aspects:
  • shoutcast.com embedded player (the AOL provided version has now been removed as of 23/06/2014 and we suggest using jplayer or other 3rd party site players instead of the AOL version)
  • It is no longer possible to officially download sc_trans (as of 11/04/2014) or to obtain sc_trans MP3 unlock codes (as of late December 2013) and currently there are no plans to restore sc_trans due to code licensing issues and the amount of work needed to resolve those issues

Known issues:
  1. Stream playback on shoutcast.com in IE 11 does not play most listed streams - this is primarily an issue with how IE handles (or rather doesn't handle) the ICY protocol. It is strongly recommended to update to a v2.2.x DNAS which can provide HTML compatible responses
  2. Chrome 36 has broken jplayer support which means the shoutcast.com site player is not working correctly (hoping to have this fixed soon - last updated 22 July 2014)
  3. Some YP connections are randomly failing (this is being looked into though no reason / eta is known currently [as of 19th Feb])
  4. Some listings have had the 'Misc' genre incorrectly applied to them (this was from fixing an issue produced by the AOL setup and genres of affected listings will be restored in the coming days)
  5. Not all devids will work - email me at dro [@] winamp [d0t] com or send me a PM and it will be looked into
  6. Some v2 listings will require a new authhash being generated for affected streams (this should only affect any created since 13th February 2014)

Hints to help:
-------------------------------------------------------------------------------------

If there are other issues not covered here e.g. DNAS or API requests not working as expected, then please provide complete and replicable details on the issue so it can be fixed asap.

-------------------------------------------------------------------------------------

Note: Posts saying the site does not work will be ignored (as nothing can be done about it) until a temporary replacement site is put up to replace the old AOL provided site.
DrO is offline  
Old 17th February 2014, 15:24   #2
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 362
I knew there was something afoot about 2 hours ago when I couldn't find stations listed on the SC YP pages....

Thanks for the info DrO!! I guess we will have to watch this space.... going to be an interesting time for Internet radio that's for sure.



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now  
Old 17th February 2014, 15:37   #3
DrO
 
Join Date: Sep 2003
Posts: 27,880
ironing out any bugs is going to be the main thing for the next week or so, but yes it'll be interesting to see what happens (as i don't know what's going to happen but at least the YP and API are now off the AOL hosting so some of the existing issues which people have pm'd me about since the sale can be looked into again).

and i'd expect the temporary shoutcast.com site to appear in a few hours (will update the first post if it definitely happens) but it's going to be simple just to have something working.
DrO is offline  
Old 17th February 2014, 21:52   #4
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 362
Have to say the Main SC page looks a bit different already



Weird without the AOL branding ..... Run Shoutcast run you are free from the tyranny!!



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now  
Old 17th February 2014, 22:49   #5
isaacl
Junior Member
 
Join Date: May 2010
Posts: 34
Any idea why listings on the current shoutcast.com site can't be sorted by listeners?
Or this only a temporary thing, so not everything's working (yet)?
isaacl is offline  
Old 18th February 2014, 11:07   #6
bourbontobeale
Junior Member
 
Join Date: Feb 2014
Posts: 3
Note on Directory Issue

DrO,

Another thing I just noticed, while our station (Bourbon to Beale Blues Radio) is found in the directory if I search for "bourbon to beale", it's not listed in when I browse the Blues genre, or any of the Blues sub-genres.

Totally fine if this just has to work itself out (as no one else is listed in the sub-genres either), just wanted to mention it in case it's part of a larger issue.

Follow-on... We do show up in "contemporary blues" now, although the song title and listener count is still static and not updating.

Progress!

Thanks again, you guys rock!

Last edited by bourbontobeale; 18th February 2014 at 11:21. Reason: Follow-on
bourbontobeale is offline  
Old 18th February 2014, 11:58   #7
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
@DrO - I run full a lot and had the Directory Tester IPs in my RIP list. This morning, understandably, I'm seeing some NAK errors from time to time

Quote:
<02/18/14@04:50:29> [yp_add] yp.shoutcast.com gave error (nak)
<02/18/14@04:50:29> [yp_add] yp.shoutcast.com gave extended error (Cannot verify server since all listener slots are full. Please wait. [481])
You wouldn't happen to have the list of new IP addresses by any chance? That would be very helpful...
dotme is offline  
Old 18th February 2014, 14:23   #8
DrO
 
Join Date: Sep 2003
Posts: 27,880
UPDATE: the listing issues should now be resolved. apologies for the issues this has caused (it was far from intentional) and we'll be keeping an eye out for any further issues.

it is still likely that some DNAS will need to be restarted for them to see the new YP servers correctly i.e. you'll need to check the DNAS for any YP / NAK errors being reported.


i'll look back over all of the posts made and split out / reply once i've had a bit of a break.

[edit]
posts which were specific to the YP outage have now been moved to http://forums.winamp.com/showthread.php?t=375348 (to keep this thread easier to follow for my needs)
DrO is offline  
Old 18th February 2014, 14:47   #9
josephbe
Junior Member
 
Join Date: Jan 2014
Posts: 13
yes seems to be working now thx DrO

will shoutcast have again the embedded player like before ?
josephbe is offline  
Old 18th February 2014, 14:58   #10
nanakweku64
Junior Member
 
Join Date: Jun 2011
Posts: 6
I have 2 lines and now one is working but the other line is still not working
nanakweku64 is offline  
Old 18th February 2014, 15:08   #11
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 362
Doesnt seem like it's fully working with Shoutcast v1.9.8 at present.

Quote:
> [dest: 37.59.25.124] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<02/18/14@15:58:22> [yp_add] yp.shoutcast.com added me successfully
<02/18/14@15:58:22> [dest: 37.59.25.124] connection closed (2 seconds) (UID: 0)[L: 0]{Bytes: 16846}(P: 0)
<02/18/14@16:05:24> [yp_tch] error connecting to yp.shoutcast.com
I guess that things are still being worked on??



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now  
Old 18th February 2014, 15:26   #12
DrO
 
Join Date: Sep 2003
Posts: 27,880
josephbe: see the first post for the answer to your question.

nanakweku64: what's the address of the DNAS and are there any YP / NAK errors being reported in the DNAS?

garybaldy72uk: is it still happening and have you tried restarting the DNAS?
DrO is offline  
Old 18th February 2014, 15:48   #13
tigerboy87
Junior Member
 
Join Date: Feb 2014
Posts: 22
my one is working thanks dro greaat i hope that shoutcast will develop and new things will come thanks for your work dro
tigerboy87 is offline  
Old 18th February 2014, 15:51   #14
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 362
Quote:
garybaldy72uk: is it still happening and have you tried restarting the DNAS?
I just switched my shoutcast server on to test it so the DNAS was a fresh start up .... I'm off air at present so i can't check any further.



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now  
Old 18th February 2014, 16:06   #15
DrO
 
Join Date: Sep 2003
Posts: 27,880
ok, if it happens again, will need the DNAS address and the time it happened (and any error codes if at all) and i'll have to see if i can find the cause (though this is possibly an existing YP issue and just manifesting itself in a different way.
DrO is offline  
Old 18th February 2014, 17:21   #16
Nick_G
Junior Member
 
Join Date: Aug 2011
Posts: 11
Does anyone know how to get the list of stations in bit rate order starting with the highest please? It only wants to work the other way round at the moment.

Thanks,
Nick
Nick_G is offline  
Old 18th February 2014, 17:37   #17
DrO
 
Join Date: Sep 2003
Posts: 27,880
Nick_G: it's been passed on, but please note that the current site which replaces the AOL version is a temporary one and a more functional site will follow.
DrO is offline  
Old 18th February 2014, 18:06   #18
Nick_G
Junior Member
 
Join Date: Aug 2011
Posts: 11
Quote:
Originally Posted by DrO View Post
Nick_G: it's been passed on, but please note that the current site which replaces the AOL version is a temporary one and a more functional site will follow.
OK thanks for that.

It would also be excellent if you could sort stations by bit rate AND type, so for example I could search all AAC/AAC+ streams in descending bit rate order. That wasn't possible with the previous interface.

Regards,
Nick
Nick_G is offline  
Old 18th February 2014, 22:46   #19
sly2kusa
Junior Member
 
Join Date: Nov 2013
Posts: 13
Looks like they are still working out the kinks. Still getting a lot of these errors...

2014-02-18 23:34:40 ERROR [YP] Connect timeout Restarting in 30 seconds.

But for the most part, everything seems to be stabilizing. Wish my counter would not have reset for how long the station has been up, but oh well - if that is as bad as it gets from this point forward - I can live with it.
sly2kusa is offline  
Old 18th February 2014, 23:30   #20
beyers
Junior Member
 
Join Date: Feb 2014
Posts: 1
how do i listen to shoutcast with windows media?

I guess from what I read shoutcast has changed? I used to just click on a radio station and a little shoutcast window would pop up showing the song, artist, etc. Today the whole thing has changed, it wants me to open or save. I tried to open it with windows media center since that is what I use for everything but I am lost. Do I have to download another player?
beyers is offline  
Old 19th February 2014, 04:02   #21
Geeque112
Junior Member
 
Join Date: Sep 2006
Location: Chicago,IL
Posts: 31
Everything was back to normal since last night but two channels out of ten are now down after we kicked the source to do a LIVE show, do you guys know what might be causing that?
Geeque112 is offline  
Old 19th February 2014, 05:48   #22
MOraleSs
Junior Member
 
Join Date: Nov 2010
Posts: 14
The Connect Time Out error happens here too. I have two servers in different locations and I get the error on both of them. Here is a tailing log:

Quote:
014-02-19 08:35:36 ERROR [YP] Connect timeout Restarting in 30 seconds.
2014-02-19 08:36:37 ERROR [YP] Connect timeout Restarting in 30 seconds.
2014-02-19 08:37:07 INFO [YP] Updating listing details for stream #1 succeeded.
2014-02-19 08:37:38 ERROR [YP] Connect timeout Restarting in 30 seconds.
2014-02-19 08:38:08 INFO [YP] Updating listing details for stream #1 succeeded.
2014-02-19 08:39:42 INFO [ADMINCGI] Title update for stream #1 [www.radiocfm.ro]
2014-02-19 08:39:47 INFO [ADMINCGI] Title update for stream #1 [Ellie Goulding - Burn [Beatmix]]
2014-02-19 08:40:17 ERROR [YP] Connect timeout Restarting in 30 seconds.
2014-02-19 08:41:18 ERROR [YP] Connect timeout Restarting in 30 seconds.
2014-02-19 08:41:48 INFO [YP] Updating listing details for stream #1 succeeded.
2014-02-19 08:41:48 INFO [YP] Updating listing details for stream #1 succeeded.
MOraleSs is offline  
Old 19th February 2014, 07:27   #23
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 362
Quote:
Originally Posted by DrO View Post
ok, if it happens again, will need the DNAS address and the time it happened (and any error codes if at all) and i'll have to see if i can find the cause (though this is possibly an existing YP issue and just manifesting itself in a different way.
My SC server seems to be touching the shoutcast YP with no issues now....



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now  
Old 19th February 2014, 10:27   #24
DrO
 
Join Date: Sep 2003
Posts: 27,880
@everyone: the YP connection issues are being looked into (as i'm now able to replicate an issue from one of my test setups) and i've added it to the first post as a known issue for the time being.


Geeque112: it could be the connection issue being seen or it could be something else. without you checking the DNAS logs and providing the error message (if there is anything obvious) then it's hard to otherwise know what the issue is for you.


beyers: it's a temporary site so until it's decided what there will be on the proper replacement, there is no on-site player like there used to be (as the old one had a lot of issues and needed to be removed / replaced anyway).

what you can do, is copy the link for the listing, change .pls to .m3u and then add the altered link into WMP (as it supports m3u but not pls). not that WMP supports it, but .xspf also works as a playlist type now.


dotme: as it's not finalised on the number of servers, etc i'm not going to provide specific IP addresses (though it's easy enough to determine them for the case you're trying to deal with - though i'm reviewing the Directory Tester handling in relation to some of the cases where it fails so handling may change a little bit).


bourbontobeale: i've tried to describe why and what needs to be done in http://forums.winamp.com/showthread....81#post2986481 but the simple option is it's expected that it's not acting like the old site had (and will have to wait and see what happens when a proper site is provided).


isaacl: it's a temporary site so a lot of things are not going to work as ideally as they would be liked - all of which should be resolved when the proper site is provided (as what's up there at the moment was a very quickly put together solution).
DrO is offline  
Old 19th February 2014, 14:09   #25
DrO
 
Join Date: Sep 2003
Posts: 27,880
Update: we've made some changes which may help with the YP connection timeouts being seen, though my issue went away after a full restart to ensure the DNS cache had been cleared, though hopefully the tweaks we've made will mitigate the need to do that (maybe just the DNAS still).

there may be some such errors being seen still whilst we're doing continuous updates and tweaks now that most of the backend is running as expected.


Update 2: to ease the pain of the transition, the old embedded player will partially work again (we'll be looking at the broken url requests to see if we need to do much more for the most common requests coming through).
DrO is offline  
Old 19th February 2014, 18:35   #26
Eric de Noorman
Junior Member
 
Join Date: Nov 2006
Location: Geel, Belgium
Posts: 7
Embedded Shoutcast player

Dear DrO,

What's the use of putting back the old player ?
I removed it already from my site & I can't get it back as I can't even log in properly. I keep on getting errors.
Please come up with a clear & understandable sulution. Also pls (!) make sure we get informed if you plan to create new troubles next time.

Thx - best regards - EdN

Event log:
<02/19/14@20:25:24> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<02/19/14@20:25:24> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<02/19/14@20:25:24> [main] initializing (usermax:5 portbase:8000)...
<02/19/14@20:25:24> [main] No ban file found (sc_serv.ban)
<02/19/14@20:25:24> [main] No rip file found (sc_serv.rip)
<02/19/14@20:25:24> [main] opening source socket
<02/19/14@20:25:24> [main] source thread starting
<02/19/14@20:25:24> [source] listening for connection on port 8001
<02/19/14@20:25:24> [main] opening client socket
<02/19/14@20:25:24> [main] Client Stream thread [0] starting
<02/19/14@20:25:24> [main] client main thread starting
<02/19/14@20:25:48> [source] connected from 127.0.0.1
<02/19/14@20:25:49> [source] icy-name:e-Radio 2440 by "Eric de Noorman" ; icy-genre:Pop
<02/19/14@20:25:49> [source] icy-pub:1 ; icy-br:160 ; icy-url:http://www.shoutcast.com
<02/19/14@20:25:49> [source] icy-irc:#shoutcast ; icy-icq:0 ; icy-aim:N/A
<02/19/14@20:25:49> [dest: 46.105.114.166] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<02/19/14@20:25:50> [dest: 46.105.114.166] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 8192}(P: 0)
<02/19/14@20:25:50> [yp_add] yp.shoutcast.com added me successfully
<02/19/14@20:32:21> [yp_tch] yp.shoutcast.com gave error ()
Eric de Noorman is offline  
Old 19th February 2014, 20:31   #27
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
Originally Posted by Eric de Noorman View Post
What's the use of putting back the old player ?
the player download being returned is just a temporary thing which was felt best to do to help easy the transition (as no one on the new team knew how much it was used anyway) and so things were restored as best as can be once more critical issues were fixed (i.e. the main YP connectivity issues from yesterday) before everything else remaining to be done (i.e. a proper replacement shoutcast.com website) can be done.

Quote:
Originally Posted by Eric de Noorman View Post
I removed it already from my site & I can't get it back as I can't even log in properly.
the suggested way is to use a different flash / HTML5 player over what had been provided by AOL. as whatever the case, it was going to be killed off in its current state as things have moved on a lot since it was first made and the viable options (including HTML5 players) means it's deficiencies stand out more than they ever did.

Quote:
Originally Posted by Eric de Noorman View Post
Please come up with a clear & understandable sulution. Also pls (!) make sure we get informed if you plan to create new troubles next time.
despite what people are thinking, we are not intentionally trying to break things and as things are happening, they are being informed either via the forums or will be done via other means once things are fully setup. we are fully aware that peoples stations are the most important thing to them and that any disruption is never liked, though as i'll explain below, most things have transitioned as seemlessly as can be expected (not much can be done when DNAS servers and host platforms are still caching old YP server addresses for example).

as we're trying to go from zero to a working system as quickly as possible (it's only just over a month since the sale was completed) so it's known that it's not going to be as smooth as it could be and we can only apologise for that. but the reality is moving a whole platform from one owner to another was going to have some issues no matter what was able to be ironed out during testing.

and overall, it has been a lot less painful than was expected. yes some of the issues have not been what is ever wanted to be seeing but any migration to a new platform is going to have some teething issues - and for the record most have been ironed out in under 2 days since the backend YP / API went live. as the only other option would have been a complete stopping of the YP / API / website until everything is sorted which is not realistic when most of the issues arise with 'real' traffic loads' and would have caused _everyone_ issues.

------------------------------------------------------------------

as for the touch update issue (which based on a number of servers i'd been made aware off previously, has decreased in it's frequency), have you attempted a DNAS restart? does it later succeed to do a touch or does it only manage to do an add and then always fail on the touch update ?

also from looking in the raw listing details, the DNAS which i think might be yours cannot be accessed from trying to view it's public page so i'm not even sure it's the correct one / actually running to better check system logs to find out what might be going on.
DrO is offline  
Old 19th February 2014, 22:35   #28
LGN
Junior Member
 
Join Date: Sep 2010
Posts: 3
yp error

Dear DrO,

after a lot of hazzle and almost 48 hours I succeded to get my station www.radio50plus.se working again. I still got messages that "cannot connect to yp..." but the audio is not harmed. And station is listed as private and does not appear on the SHOUTcast site. Will that change automatically or do I have to do something?

All the best
Lars
LGN is offline  
Old 19th February 2014, 22:38   #29
DrO
 
Join Date: Sep 2003
Posts: 27,880
er, i'm not sure what your specific problem is as http://www.shoutcast.com/?action=sea...ng=Radio50Plus shows me your DNAS... so it is up and listed and all looks correct.

though maybe you've been having YP connection issues in the last 2hrs whilst i've been sorting out a few other issues with the YP which has required a number of restarts to test the fixes. which i've now completed doing as it's far too late to do anything else tonight.
DrO is offline  
Old 20th February 2014, 01:30   #30
TrexRadio
Member
 
TrexRadio's Avatar
 
Join Date: Sep 2003
Posts: 52
Send a message via ICQ to TrexRadio Send a message via Yahoo to TrexRadio
Quote:
Originally Posted by DrO
It is not currently possible to obtain sc_trans MP3 unlock codes (has down since late December 2013 and depends on the future of sc_trans as a product as to what will happen in relation to this)
So what good will it be to use SCv2.x If you cant use MP3 anymore? As 95% of Flash players cant play AAC+ streams.
TrexRadio is offline  
Old 20th February 2014, 09:23   #31
DrO
 
Join Date: Sep 2003
Posts: 27,880
let's put the commonly said myths about SC v2 to bed once and for all.

1) you do not have to sign up to get an authhash. the DNAS will auto-create it (if using the current version) or it allows you to create it. yes initially you had to do it via shoutcast.com but that was changed in early 2011!

2) you do not have to pay to get an authhash. it's essentially a token stored by the DNAS config to make listings reliable and a lot easier to cluster than a v1.x setup.

3) you do not need to use sc_trans to use a v2.x DNAS. the v2.x DNAS accepts any v1 and v2 style source software and sc_trans is just one possible piece of source software which can be used to provide the audio for the stream(s) on the DNAS. and with v2.2.1 it's even possible to get the DNAS to accept multiple v1 sources for each stream.

4) if you have a working v1.x DNAS, you do not need to re-create the configuration file to use it with a v2.x DNAS. there were a massive number of changes made in the v2.2.x DNAS to ensure where possible that you can just replace the DNAS program file without having to make configuration changes (especially with the automatic authhash generation).

5) the SHOUTcast Directory only supports one genre. overloading of the genre for a stream (which typically relates to v1.x DNAS) will be processed to find an appropriate genre from what is provided (which can lead to the wrong one for what you want to be used for the listing). that means you either need to a) just put up with it, b) specify a single genre from the list here or c) update to a v2.x DNAS and you can then select the correct genre via the authhash handling.

the old shoutcast.com site did things to make use of the overloaded genre string as a 'keyword' or 'tag' (which the authhash system allows to be explicitly specified) but that was site specific and despite what it seemed and to quote Highlander, "there can be only one" genre.
DrO is offline  
Old 20th February 2014, 11:48   #32
Eric de Noorman
Junior Member
 
Join Date: Nov 2006
Location: Geel, Belgium
Posts: 7
Thx !

Before I take any further action I think i'll wait & see what happens in the next days.
I keep on getting errors : <02/20/14@13:30:50> [yp_tch] yp.shoutcast.com gave error ()

Anyhow - do you have a solution for the .pls problem ?

Can I upgrade to SHOUTcast DSP Plug-in v2.2.3 for Winamp (07/19/2011) ? Without creating more trouble ? (link below).

"The updated version of the SHOUTcast DSP plug-in has now been released and is available from:
http://www.shoutcast.com/broadcast-tools
(Direct download link -> here)"

best regards - EdN
Eric de Noorman is offline  
Old 20th February 2014, 14:26   #33
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Even after restart, I'm getting the old mass-listener dumps on error. Station IS listed in the new YP so I'm assuming DNS is all up to date. Anything that can be done to fix the errors for those of us still on 1.9.8 would be appreciated though

<02/20/14@07:17:21> [yp_tch] error connecting to yp.shoutcast.com
<02/20/14@07:17:22> [dest: 71.39.68.41] connection closed (4542 seconds)...
<02/20/14@07:17:22> [dest: 161.57.49.88] connection closed (1260 seconds)...
<02/20/14@07:17:22> [dest: 198.150.66.2] connection closed (1808 seconds)...
<02/20/14@07:17:22> [dest: 50.167.91.129] connection closed (1808 seconds)...
<02/20/14@07:17:22> [dest: 97.68.195.147] connection closed (1261 seconds)...
<02/20/14@07:17:22> [dest: 158.106.52.10] connection closed (1261 seconds)...
<02/20/14@07:17:22> [dest: 88.159.99.155] connection closed (1036 seconds)...
<02/20/14@07:17:22> [dest: 107.194.6.9] connection closed (1259 seconds)...
<02/20/14@07:17:22> [dest: 81.149.219.184] connection closed (1260 seconds)...
<02/20/14@07:17:22> [dest: 204.128.220.10] connection closed (1258 seconds)...
<02/20/14@07:17:22> [dest: 212.117.194.66] connection closed (1259 seconds)...
<02/20/14@07:17:22> [dest: 74.219.177.194] connection closed (1246 seconds)...
<02/20/14@07:17:22> [dest: 201.42.79.219] connection closed (1258 seconds)...
<02/20/14@07:17:22> [dest: 74.113.151.1] connection closed (3496 seconds)...
<02/20/14@07:17:22> [dest: 23.115.149.225] connection closed (3598 seconds)...
<02/20/14@07:17:22> [dest: 178.162.199.142] connection closed (3276 seconds)...
<02/20/14@07:17:22> [dest: 71.184.102.50] connection closed (1255 seconds)...
<02/20/14@07:17:22> [dest: 206.53.70.130] connection closed (1240 seconds)...
<02/20/14@07:17:22> [dest: 151.42.228.69] connection closed (358 seconds)...
<02/20/14@07:17:22> [dest: 173.161.223.153] connection closed (731 seconds)...
<02/20/14@07:17:22> [dest: 173.27.217.83] connection closed (933 seconds)...
<02/20/14@07:17:22> [dest: 108.5.50.246] connection closed (191 seconds)...
dotme is offline  
Old 20th February 2014, 14:50   #34
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
Originally Posted by Eric de Noorman View Post
Anyhow - do you have a solution for the .pls problem ?
i don't know what .pls problem you are referring to. is it a specific link you were using that no longer works or something else? as i don't know what your issue actually is to know what the solution might be.

Quote:
Originally Posted by Eric de Noorman View Post
Can I upgrade to SHOUTcast DSP Plug-in v2.2.3 for Winamp (07/19/2011) ? Without creating more trouble ?
updating the broadcasting tools shouldn't have any effect on what the Directory backend is / isn't doing.

Quote:
Originally Posted by Eric de Noorman View Post
"The updated version of the SHOUTcast DSP plug-in has now been released and is available from:
http://www.shoutcast.com/broadcast-tools
(Direct download link -> here)"
there is a direct download link provided in the official thread for the plug-in -> http://forums.winamp.com/showthread.php?t=372044 (as is the case for all of the tools provided so it's easier to get at them).

Quote:
Originally Posted by dotme View Post
Even after restart, I'm getting the old mass-listener dumps on error. Station IS listed in the new YP so I'm assuming DNS is all up to date. Anything that can be done to fix the errors for those of us still on 1.9.8 would be appreciated though
and there i was thinking the v1.x DNAS was meant to handle YP connection issues, as i'm surprised it's booting listeners when a touch update fails (was never aware it did that). the problem we've got with that issue is we're not seeing it (i briefly saw it and a few load handling changes then resolved that on my version).

can you provide a link to one of the DNAS having issues and we'll have to see if we can find anything specific to it in the access logs...

also can you confirm if it's always after any add or it's just randomly happening so touches are working, just inconsistently?
DrO is offline  
Old 20th February 2014, 16:13   #35
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
208.85.240.83 (port 80)
Random - Sometimes every 60 mins, sometimes more frequent. So touches are working most of the time. Server is so full anyway, dropping a few connections at random lets others tune in but ideally this won't be a long term thing
dotme is offline  
Old 20th February 2014, 18:05   #36
Eric de Noorman
Junior Member
 
Join Date: Nov 2006
Location: Geel, Belgium
Posts: 7
Hi There DrO,
I managed to install a working HTML5 player on my website, so e-Radio 2440 is up & running again. Only : the soundcard input option is not working yet (such a shame....) any idea how to fix that ? All the rest seems to work fine now apart from this error that sometimes occurs : yp.shoutcast.com gave error ().

Thx for your help - keep up the good work !

EdN
Eric de Noorman is offline  
Old 20th February 2014, 21:24   #37
mikevardavas
Junior Member
 
Join Date: Feb 2014
Posts: 5
i still cannot update the authhash. yp is connectedt hough, however trying to update authhash gimes error....just 4 u to know
mikevardavas is offline  
Old 20th February 2014, 21:31   #38
DrO
 
Join Date: Sep 2003
Posts: 27,880
dotme: thanks, will see if that helps to track the failed connections down.

mikevardavas: this is the first time you've mentioned an authhash issue. as such, i need you to pm me a link to the DNAS as well as the authhash you're having issues with please so i can determine what is going on.
DrO is offline  
Old 21st February 2014, 09:58   #39
mikevardavas
Junior Member
 
Join Date: Feb 2014
Posts: 5
will do so in about an hour once i get home
mikevardavas is offline  
Old 21st February 2014, 12:58   #40
DrO
 
Join Date: Sep 2003
Posts: 27,880
mike: have replied to your pm.
DrO is offline  
Closed Thread
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump