Old 2nd December 2003, 14:00   #1
Paultx
Senior Member
 
Paultx's Avatar
 
Join Date: Feb 2001
Location: Brazil
Posts: 180
Jump on track change

One guy posted it on a Brazilian forum and then I found that it happens to me too: when Winamp 2.91 (my version) plays "one-track-disks" like live or some Pink Floyd's (eg, WYWH), even if there is no apparent track separation or at least it's not supposed to be, I hear that subtle "click" sound or something like a very brief silent pause between two tracks. What's wrong with that?


Always the latest free standard Winamp version | @ home: Windows 7 Pro - 64-bit • Intel Core i7 • 6 GB RAM
@ work: Windows 7 Ultimate - 64-bit • Intel Pentium D • 2 GB RAM | @ large 1 (me): Windows 7 Home Premium - 64-bit • Intel Core i5 • 6 GB RAM
@ large 2 (wife): Windows 7 Home Premium - 32-bit • Intel Core Duo • 2 GB RAM | @ large 3 (daughter): Windows 7 Home Premium - 64-bit • Intel Dual Core • 3 GB RAM
Paultx is offline   Reply With Quote
Old 2nd December 2003, 16:32   #2
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Gapless playback with Audio CD's

1. Prefs -> Plugins -> Input -> CD plugin -> config:
Checkmark "enable digital audio extraction"
Uncheck: "Use sonic engine" (see notes below)

2. Prefs -> Plugins -> Output -> DirectSound -> config:
Buffering tab: Increase "buffer ahead on track change" slider
(to eg. something between 300 and 1200ms or more if necessary)


Note: Step 1 might require a Winamp restart.

_____________________________________________________________


Gapless MP3 playback

Also applies to OGG, WAV, M4A, AAC, FLAC and unprotected WMA (not DRM)

1. N/A

2. Prefs -> Plugins -> Output -> DirectSound -> config:
Buffering tab: Increase "Buffer ahead on track change" slider
(to eg. something between 300 and 1200ms or more if necessary)

3. DirectSound Output -> config -> Other tab
Checkmark: "Remove silence at beginning/end of track"

Default Cut-Off value = -40dB
I wouldn't go much higher than -30dB
A happy medium is -35dB, though the default -40dB should suffice.

eg. If you went as high as the maximum -15dB
then you will start to notice a fair few seconds of the actual music missing from the beginning & end of the track, so don't do it!

Note: As from Winamp 5.2 (with native gapless mp3 playback support), step 3 is only required if the mp3's weren't encoded with LameEnc 3.90.3 or later (the only mp3 encoder which does gapless encoding).


Important:
Changes to DirectSound Output config only take effect after playback is restarted!

_____________________________________________________________


Notes:

Step #1 only applies to Audio CD's.
Step #2 is global, for all audio formats
Step #3 is mainly for MP3 (because, unless encoded by Lame Enc 3.90.3 or higher, it isn't a gapless format by default) and for any other formats that were encoded with any silence at the beginning/end of the track.


----------------------------------------------


In Winamp 5's CD Input plugin config, "use sonic engine" is checkmarked by default.

If you still don't get perfect gapless playback for Audio CD's, then uncheck this option and use wnaspi32.dll instead.

Note, you might not need to use wnaspi32.dll under WinXP/2003 as the native Windows SCPTI might suffice, so try without any ASPI first. However, if an ASPI manager (wnaspi32.dll) is already present in your System dir then it will take precedence over SCPTI.

Also note, wnaspi32.dll is only required for Win2k/XP. The Adaptec ASPI Layer is already installed under Win9x.
There might already be an Adaptec or Nero wnaspi32.dll in your System32 dir under Win2k/XP. In which case, you might not need to replace it. But if you don't get gapless playback with it, then backup the old version and replace it with the Nero 5.5 version linked here.
Alternatively, you can use wnaspi32.dll from Nero 6 instead.
This version of wnaspi32.dll goes in the Winamp root dir instead of the %System% dir.

Again, you may need to restart Winamp for any in_cdda config changes to take effect.

See above link for full details.


----------------------------------------------


If having any problems with attaining gapless WMA or MIDI playback, then see the relevant posts below.

_____________________________________________________________

v1.99 - Revised 21st Feb 2006
DJ Egg is offline   Reply With Quote
Old 7th January 2004, 13:18   #3
BPP
Junior Member
 
Join Date: Jan 2004
Posts: 5
I've done this on WinAmp 5.1 (increased the buffer all the way to 2000) but I still get that same tiny pause (and being a Techno/Trance junkie it makes me wince everytime)

Addicted to the visualizations (which we project onto the loungeroom wall - very cool) so really want to sort this out. Whazzup?
BPP is offline   Reply With Quote
Old 7th January 2004, 13:54   #4
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
some system specs might help (alas, we are not psychic)

pc or motherboard make/model
cpu & ram
cd-rom drive make/model
sound card
windows os & sp
directx version

Have you tried unchecking "use sonic engine"?
(plugins -> input -> in_cdda -> config)

Note: requires winamp restart to take effect

Is ASPI installed?
This answer will also depend on your Windows OS

The ASPI Layer is installed by default on Win9x/ME
but not on Win2k/XP/2003

Was this a clean install of Winamp 5.01?
If not, which version did you have before?
Have you installed any extra 3rd-party plugins?


btw, I get perfect gapless playback with all mix cd's.
DJ Egg is offline   Reply With Quote
Old 7th January 2004, 14:50   #5
BPP
Junior Member
 
Join Date: Jan 2004
Posts: 5
OK. Sorry about that. Here's my system. (I'm in Iraq so all my music is on my laptop HDD.)

ACER Travelmate 800LCi
Intel 855PM Centrino Chipset
1.3 GHz
512MB DDR
Realtek AC'97 Audio
XP Professional (so no ASPI???)
DirectX ver 9

I had Winamp 3 before but deleted it. Then got ver 5. Have installed a few of the visualization plug-ins (and I have to say ... they rock!)

Ive managed to minimize the gap but it's still there - just
BPP is offline   Reply With Quote
Old 7th January 2004, 23:47   #6
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Ok, well for WinXP, first check in the Windows\System32 dir
to see whether the file wnaspi32.dll already exists.

Note, you may first need to adjust settings in Folder Options -> View tab
eg. check: show hidden files, uncheck: hide extensions / hide protected os files

If it's there, back it up by renaming to eg.
wnaspi32.dll.off
then cut+paste it to a backup dir somewhere.

Next, download the zip file in my attachment
and unzip wnaspi32.dll to the Windows\System32 dir.

This is the Ahead Software version of wnaspi32.dll from Nero 5.5


If the problem persists, you can try the latest version of wnaspi32 from Nero 6,
but note that it must be placed in the Winamp dir, not System32

http://www.nero.com/en/631940733573829.html


Then follow the instructions again from my first post above.

You can also try checkmarking "allow hardware acceleration" in:
Prefs -> Plugins -> Output -> DirectSound -> config -> Device tab.
Also try changing the device to AC'97 sound chip driver (c/o dropdown menu)

Let us know how it goes.
Attached Files
File Type: zip wnaspi32.zip (65.0 KB, 1970 views)
DJ Egg is offline   Reply With Quote
Old 8th January 2004, 08:47   #7
BPP
Junior Member
 
Join Date: Jan 2004
Posts: 5
Tried all the above to no avail. Still have that tiny, split-second gap..... sometimes though, it lasts for a loooooong time (10 seconds or more) then starts the next track with a extra skip for good measure.

I've played around with the settings but the following seems to work best

DirectSound output with:
Allow Hardware Acceleration checked
20000ms buffer w/ 4000ms pre-buffer, 16000ms buffer-ahead
all fadeout disabled
Enabled CPU usage thingy
Remove silence checked (set to -15dB)
Status screen reads "not active" (????)

Also, what input plug-in should I be using for playback of WMA files from the HDD? (Does this make a difference?)

Please save me oh Great Guru
BPP is offline   Reply With Quote
Old 8th January 2004, 09:30   #8
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Hi. Is the problem actually with WMA playback, and not Audio CD playback?

Gapless WMA Playback

As long as your WMA files are not DRM-Protected, then....

For gapless WMA playback, if video support is installed,
all you need to do is:

1. Close Winamp
2. Go to the Winamp\Plugins folder
3. Rename in_wm.dll to in_wm.dll.off
(you can also move it to a backup folder somewhere if you wish)
4. Reopen Winamp
5. Go to: Prefs -> Plugins -> Input -> Nullsoft DirectShow Decoder -> config
6. Add ;WMA to the extension list

in_dshow.dll will now be the default handler of WMA files


Or, if video support was not installed...
You will need to replace the current version of in_wm.dll
with this older non-crippled version from Winamp 2.5


Basically, as from Winamp 2.60, the wma plugin licenced from Microsoft was hard-coded to use WaveOut only, therefore any changes you make to the DirectSound Output config are pointless and non-effective when playing back WMA files.

[Edit: June 2005]

Note: DirectSound Output (if selected) is now used again for WMA playback as from Winamp 5.092 and later

[/Edit]

__________________________________________________________


Which brings me to your config....

Those settings are way over the top.
You will notice it if you try play any MP3, WAV, OGG, MOD file.

Your main buffer is currently set to 20 seconds.
That means 20 seconds of audio will be buffered into memory.
The default setting is 2000ms (2 seconds)


If the problem is with WMA only, and not Audio CD...
before playing anything, all you will need to do now is:

1. Go back into DirectSound Output config
2. Set the main Buffer size back to 2000ms
3. Set Prebuffer back to 500ms
4. Set 'Buffer ahead on track change' to somewhere between 500ms and 1500ms
(start low at first, and increase only if necessary)
5. Other tab: Set cut-off value to -35dB (default is -40)

Ok everything

Assuming this was a gapless mix CD that you ripped to WMA,
you should now have perfect gapless WMA playback.



The only 3 formats which need extra tweaking are:
1) AudioCD: requires Digital Audio Extraction enabling in the in_cdda.dll config
2) WMA: Requires the above-mentioned fix
3) MIDI: Requires a few tweaks in in_midi config, which we won't go into here.


If the problem persists, or the problem was with Audio CD all along,
then post back and we'll take it from there... *gulp*

_____________________________________________________


[Edited in at a later date]


Important:

Sticky: Help! My protected Windows Media files don't play in Winamp anymore!!!

As from Winamp 5.08e, you can no longer use in_dshow or an older version of in_wm.dll to playback drm-protected WMA files. Therefore, if the same fixes for gapless mp3 playback don't work, then alas you are out of luck.

If your WMA files are NOT drm-protected, then you can still use any of the above workarounds (in_dshow.dll or older in_wm.dll).

____________________________________________________


FAQ

What is this DRM thing you keep referring to?

DRM stands for Digital Rights Management.

When you rip Audio CD's to WMA with Windows Media Player 8/9/10
unless you go into: "Tools > Options > Copy Music tab" first,
and uncheck "Copy Protect Music"
(Note: older versions might say "Enable Personal Rights Management")
then this means that all your WMA files will be encoded with DRM-Protection.

What this means is that your WMA files are encrypted with some extra code which links to a DRM license stored on your pc.

The DRM protection means that the WMA file is licensed to only play on the pc that it was encoded on. In other words, you won't be able to copy it to another pc, because it won't play on any other pc but yours.

If you lose that drm license or if you reformat or upgrade windows then you will lose those licencses in the process, thus rendering your WMA files useless.

Note, you may still be able to retrieve these licenses.
See here for further info/details:
http://www.tech-archive.net/Archive/...4-03/0104.html
http://forums.winamp.com/showthread.php?threadid=208878
http://forums.winamp.com/showthread.php?threadid=81838


DRM-Protection is also used by sites/services like Napster and Walmart.
A variation of DRM is also used by the likes of iTunes iTMS, except the encrypted format is M4P instead of WMA.
Basically, it means that you are paying money for a crippled format.

Sure, you can burn them to Audio CD with WMP9/10 (or with iTunes if M4P) and then re-rip them to MP3, or you may be able to use some other software to convert them, but by doing this you will lose even more quality (lossy compressed format to another lossy compressed format equals even more lossy result).


Lessons learnt?

1. Do NOT use Windows Media Player to rip Audio CDs to WMA.
Use any of Winamp, CDex, EAC (or any other decent ripper which uses the LAME Encoder and supports --alt-preset standard presets) to rip to MP3 instead.
Sure, you could also rip to any other decent lossy compressed format such as OGG or MPC, or a lossless compressed format such as FLAC.

2. Do NOT purchase drm-protected wma/m4p files.
Use one or more of the many other alternatives instead.
http://forums.winamp.com/showthread.php?threadid=52406
http://forums.winamp.com/showthread.php?threadid=64964
DJ Egg is offline   Reply With Quote
Old 8th January 2004, 10:03   #9
BPP
Junior Member
 
Join Date: Jan 2004
Posts: 5
YOU ARE THE MAN!

Ohhhhhhhhhhh YES!

THE M-A-N MAN!

Yes. All my music I copied onto the HDD before coming here so it's all in WMA format. Works like a charm now. So well, in fact, that I'm going to pay up and register (even though I don't need the extra stuff registration gives.)

Thanks man, you've just improved my lifestyle (and saved my sanity) in warzone 1, Iraq.
BPP is offline   Reply With Quote
Old 8th January 2004, 10:59   #10
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,568
"Winamp: Your number one choice in space, the gulf or even at home"

also, i'd like to say how much you guys in iraq rock

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 8th January 2004, 11:08   #11
BPP
Junior Member
 
Join Date: Jan 2004
Posts: 5
Well, I'm not a soldier. I run Security for an NGO (originally I tried to be a Human Shield but Saddam wouldn't let me in).... , so I'm one of the good guys.

Salaam (Literally "Peace")
BPP is offline   Reply With Quote
Old 24th January 2004, 16:59   #12
dushkinup
Junior Member
 
Join Date: Jan 2004
Posts: 7
-- I have the solution!! --
Apply egg's instructions but in addition set crossfading to 1 second. Works for me.
dushkinup is offline   Reply With Quote
Old 24th January 2004, 20:01   #13
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
You shouldn't need to use any crossfade settings to get gapless playback.
But if it works for you, then so be it.

btw, what file formats are you having the problem with?

Audio CD or WMA?
Surely not MP3, OGG, WAV, etc?
DJ Egg is offline   Reply With Quote
Old 24th January 2004, 20:39   #14
dushkinup
Junior Member
 
Join Date: Jan 2004
Posts: 7
I had that problem with AAC. The CD thingy fixed the rest.
dushkinup is offline   Reply With Quote
Old 30th January 2004, 05:37   #15
DerekBarton
Junior Member
 
Join Date: Jan 2004
Location: Manchester UK
Posts: 4
Send a message via AIM to DerekBarton
None of the above works for me,

I am using mp3 files, all of which are trance tracks, everytime play just about to finisheds on track 1 there is a 1 secound pause before track 2 starts.

Dell Dimension 2400
Win XP Home
512Ram


Any other ideas guys?

Thanks

Tricky
DerekBarton is offline   Reply With Quote
Old 30th January 2004, 17:36   #16
iver
Junior Member
 
Join Date: Jul 2002
Posts: 15
Likewise - None of the above seems to work for me playing cd-r discs (burned as audio discs)

The track breaks are in the middle of music (long jams) and I can't get rid of that 1 sec gap between tracks.

I got the latest version wnaspi32 from Nero 6 and put it in the winamp folder. Deleted all other wnaspi32.dll files that I could find. Tried all the settings above except for:

"You can also try checkmarking "allow hardware acceleration" in:
Prefs -> Plugins -> Output -> DirectSound -> config -> Device tab.
Also try changing the device to AC'97 sound chip driver (c/o dropdown menu)"

For whatever reason the "allow hardware acceleration" option is grayed out. And I'm not clear on how to change the devise to AC'97 - what is "c/o dropdown menu"?

I have a dell desktop, windows 2000/NT, 250 mb RAM.

I love the AVS in winamp but I always end up playing my discs in the cdplayer.exe that comes with Windows since it doesn't put gaps between the tracks.

Thanks for any help!

Iver
iver is offline   Reply With Quote
Old 30th January 2004, 18:05   #17
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
For Audio CD's, wnaspi32.dll is only used if "use sonic engine" is UNCHECKED in the CD Input plugin config.
Naturally, "enable digital audio extraction" also needs to be checkmarked.
You may also need to uncheck "sample input from soundcard".
Any changes to in_cdda.dll config require a winamp restart.

Re: DirectSound config
If "Allow hardware acceleration" is grayed out,
then this means that either your sound card or onboard sound chip is too old and doesn't support hardware mixing, or your (motherboard chipset / soundcard) drivers and/or DirectX need updating.

Or, if you paid a large amount of money for a so-called professional sound card, if it doesn't support hardware mixing, then I'm sorry, but you were ripped off!

In the Device tab, there is a drop-down menu which lists all the available devices.
The default device is "Primary Sound Driver".
This relates to whatever device is set as default in Windows Control Panel (Sound / Multimedia > Audio tab > Playback)

AC'97 will only be an option if your motherboard uses the AC'97 onboard sound chip.
If it doesn't, then it will list whatever other sound chip your motherboard uses, or if you've got a proper pci soundcard, then it will list the soundcard device driver instead.
Alas, I can't tell you what your sound chip is unless you tell me what your pc or motherboard model # is, and I can't tell you if you have a proper pci soundcard (instead of an onboard sound chip) unless you tell me.

If you've followed the exact instructions above, then you should definitely have gapless Audio CD playback with Winamp, for gapless mix CD's that are recorded with no gaps.




For gapless mix cd's that were ripped to MP3, then as well as adding some value to the "buffer ahead on track change" slider in out_ds config (eg. somewhere between 500 and 1500ms), you also need to checkmark "remove silence at beginning/end of track" in the "Other" tab.
The default "Cut-Off" setting of -40dB should suffice, though you can try a higher value, eg. -35dB
(note, anything higher than -30dB is NOT recommended, but you can try -25dB if you really must).

If you can still hear a gap/glitch then I've no idea why. It works perfectly for the large majority of users.
I can only assume that it is either something to do with the way you ripped the cd, or a problem with your sound drivers or config, or maybe because you've installed some shabby 3rd-party replacement mp3 plugin (eg. in_mp3pro or in_mad).

The only 3rd-party mp3 replacement plugin you can use for native gapless playback support is in_mpg123,
as this has an option in its config to "strip silence", and therefore the out_ds workaround (Other tab > Remove Silence) is not required with in_mpg123.

Though "Buffer ahead on track change" value is required no matter which method you choose.

Also note, any enabled "crossfade/fade" settings in out_ds config
will override gapless playback settings.
eg. if the crossfader is turned on in the main Winamp window > config drawer > EQ
or if any value is manually set for "on start" and "on end of song" in out_ds config > Fading tab.
ie. you need to disable these two settings (fade: on start & on end of song) if you want gapless playback to work.

Pretty simple & straightforward actually, hehe
DJ Egg is offline   Reply With Quote
Old 30th January 2004, 22:25   #18
iver
Junior Member
 
Join Date: Jul 2002
Posts: 15
Thanks for the quick reply!

These are audio discs burned Disc at Once - .shn files downloaded from ftp server, decompressed to .wav files, then burned DAO to disc using EZ CD Creator. No mp3 is involved whatsoever.

OK, just to make sure I'm doing everything correctly:

From your first post in this thread:

---------------
Gapless playback with Audio CD's

1. Prefs -> Plugins -> Input -> CD plugin -> config:
Checkmark "enable digital audio extraction"
(requires winamp restart to take effect)

OK, That's done

--------------------------
2. Prefs -> Plugins -> Output -> DirectSound -> config:
Buffering tab: Increase "buffer ahead on track change" slider
(to eg. something between 300 and 1200ms)

Yep, that's done - set 505 ms (buffer lenth is set at 2000ms and prebuffer is set at 500ms

From your next post:

pc or motherboard make/model

Alas, it's a work computer. I know it's a Dell. And under "My Computer" Properties, it says computer: x86 Family 6 Model 8 Stepping 10, AT/AT COMPATIBLE

cpu & ram

processor: Intel Pentium III, 1000MHz, 254mb ram

cd-rom drive make/model

HL-DT-ST CD-RW GCE-8080N

sound card
SoundMax Digital Audio

windows os & sp
windows 2000

directx version
directx version 8.1 (4.08.01.0881)

The ASPI is installed as mentioned previously

The crossfader is not turned on in the EQ and the fade: on start & on end of song are disabled.


If you can still hear a gap/glitch then I've no idea why. It works perfectly for the large majority of users.

Then it may very well be some hidden problem in my computer. But as I said before I can use the default windows cd player just fine - no gaps. I hear gaps with the WMA player though.

I can only assume that it is either something to do with the way you ripped the cd,
I didn't rip a cd to get the files, I downloaded the files from various ftp sites

or a problem with your sound drivers or config,

possible, sure wish I knew how to diagnose that

or maybe because you've installed some shabby 3rd-party replacement mp3 plugin (eg. in_mp3pro or in_mad).

nope

But I still get short gaps in between tracks.

So should I just throw in the towel on this issue?
Again, thanks for your help.
iver is offline   Reply With Quote
Old 30th January 2004, 22:44   #19
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Note: the section of my post about gapless mp3 playback was directed towards DerekBarton. The only bit which applied to you (iver) was the section about AudioCD's.
DJ Egg is offline   Reply With Quote
Old 5th February 2004, 03:14   #20
funkpunk
Junior Member
 
Join Date: Feb 2004
Location: Liverpool, U.K
Posts: 2
thanks for your help. the first thread was the winner. you're the don!
funkpunk is offline   Reply With Quote
Old 13th March 2004, 17:37   #21
thepunkerguy
Junior Member
 
Join Date: Mar 2004
Posts: 1
Send a message via AIM to thepunkerguy Send a message via Yahoo to thepunkerguy
Hi, i am using the Nforce2 SoundStorm 5.1 sound card with 5.1 speakers. I am using Direct sound and MP3s play through all 4 speakers, but WMA files will not. I have the latest version of Winamp. I tried your fix above for it, but when i add the ;WMA to the DirectShow input plug in thing and then try to play WMA files, Winamp crashes... i click on the more info link when it crashes and it says the problem was with out_ds.dll . What am i doing wrong?? I really want to be able to play WMA files through all 4 speakers!!
- Mike
thepunkerguy is offline   Reply With Quote
Old 27th March 2004, 07:13   #22
thoriphes
Junior Member
 
Join Date: Nov 2002
Posts: 3
Send a message via AIM to thoriphes
Hey guys, thanks for all the suggestions.

I finally got it working! Now my continuous tracks are seamless.

I set my Buffer-ahead on track change to 1200ms as someone mentioned above and now I can't detect a skip.
thoriphes is offline   Reply With Quote
Old 13th April 2004, 03:14   #23
Endemoniada
Junior Member
 
Join Date: Apr 2004
Posts: 22
Do I have to re-rip an .mp3(4) after I make those settings ? When one track leads into the next I get a skip or repeat at the end of the track. I'm talking about where just the track number changes with no real change in the music. Any ideas ?
Endemoniada is offline   Reply With Quote
Old 30th May 2004, 18:05   #24
digh
Junior Member
 
Join Date: Oct 2000
Posts: 7
Tried all the above suggesstions, and they did improve things, but I still get about a 2 second or so gap when a Napster DRM WMA starts. One thing, when I turned wm_dll off, Napster files would not play. Thanks.

aka DJ Johnny BE
digh is offline   Reply With Quote
Old 31st May 2004, 00:01   #25
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Well, you need in_wm.dll to be present,
otherwise you won't have any WMA playback support whatsoever.

Please read the thread again, in full, and provide all the necessary info (system specs, etc).

Also confirm that you are using Winamp 5.03 with the update patch (see sticky thread at top of this forum) and confirm whether you are definitely using in_wm.dll from the update patch.

Alas, you can't use the old in_wm or DirectShow (in_dshow.dll) workarounds (as referenced above) to play back DRM-protected WMA v9 files (of the type provided by Napster). Only the in_wm from 5.03 provides WMA9/DRM support. And the update patch includes a newer version of in_wm which fixes a few known bugs.

However, whether the latest in_wm also supports gapless playback (by using the DirectSound Output tweaks) is another issue... and one that I'm honestly not sure about. Basically, I avoid WMA like the plague, and I would certainly never pay money for DRM-protected files.
DJ Egg is offline   Reply With Quote
Old 31st May 2004, 09:15   #26
gaekwad2
Foorum King
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,149
Being bored I ripped two tracks to DRMed wma using wmp9 (horrible quality even at ~192kbps vbr).

Couldn't get them to play gapless, depending on buffer settings I either got stuttering at the start of track 2 or a ~1sec pause.

Wmp9 did play them without gap.

And the moral: avoid wma or you'll have to use wmp.

Fuck this place.
gaekwad2 is offline   Reply With Quote
Old 23rd June 2004, 15:59   #27
luminous
Junior Member
 
Join Date: Jan 2004
Posts: 5
I've been reading through quite a few of these gapless playback threads. Unfortunately none have totally solved my problem, although I have been able to track down the cause of my problem (I think).

I'm playing trance MP3s using Winamp 5.03a with DFX 6.4 and Tray Advanced Controls.

If DFX is turned off, my problems disappear. With it enabled there is a slight pause between tracks regardless of the settings I have tried.

Are other people able to get gapless playback when they are using DFX?
Is there a good alternative to DFX?

Settings tried:
Direct Sound Output - Direct Sound Device with Hardware mixing enabled, then again with primary buffer.
Changed device to NVida Nforce 2, again with/without hardware mixing and primary buffer

Pre buffers set to 2000ms overall, the other 2 to 1500ms.

All faders disabled.
Remove silence at start of track selected, settings changed to 35dBA

Obtained new ASPI layer

Tried all sorts of permitations of the above. Also clean installed Winamp 5 again.

I would like to point out that using Winamp 3 and DFX on the same machine, and with the same music, gapless playback is possible.

My system specs:
Asus A7N8X-Deluxe Rev 2 - latest firmware and drivers
AMD Athlon XP 2500+
1Gb RAM
Win XP Pro SP1a
Nero 6 (and its associated ASPI layer)
luminous is offline   Reply With Quote
Old 24th June 2004, 01:30   #28
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Although we don't support 3rd-party plugins here,
the only buffer relevant to gapless playback is:
"buffer ahead on track change"
(set to somewhere between approx. 400ms - 1500ms).

The main buffer size should be as small as possible.
Default is 2000ms, but you could try smaller.
The higher the main buffer size, the longer it takes for EQ and DSP/FX to take effect.
Prebuffer size should also be at the minimum/default 500ms setting.

btw, the aspi-layer bears no relevance to mp3 playback.
It is only used for Digital Audio Extraction mode with Audio CD playback
(and only if "use sonic engine" is unchecked in CD plugin config).

Good luck.
DJ Egg is offline   Reply With Quote
Old 24th June 2004, 11:12   #29
luminous
Junior Member
 
Join Date: Jan 2004
Posts: 5
Thanks for your help.

I have altered my buffer settings to:
Buffer length 1500
Prebuffer 500
Buffer ahead on track change 1000

This has made things a lot better than they were. Its still not totally perfect, but its a lot better than it was.

Thanks again for your help.
luminous is offline   Reply With Quote
Old 15th August 2004, 21:55   #30
solitary
Junior Member
 
Join Date: Aug 2004
Posts: 3
Thank you very much. I was having troubles with both CD's and mp3's, but I made some changes mentioned here, and now both formats have no gaps.

1) I downloaded the attached wnaspi32.dll from Nero 5.5

2) PlugIns -> Output -> Buffering:
Buffer length 1200
Prebuffer 500
Buffer ahead 1200

3) PlugIns -> Output -> Other:
Remove silence
Cutoff -35dB

Thanks again.
solitary is offline   Reply With Quote
Old 3rd September 2004, 19:23   #31
DigitalSounds
Junior Member
 
Join Date: Jul 2002
Location: Illinois
Posts: 43
Thanks. I scanned through it briefly, and saw an option to increase my "buffering ahead on track change" option in my Direct Sound Output settings from 0ms to 310ms.

NOW I HAVE GAPLESS PLAY! woohoo.

Thanks.
DigitalSounds is offline   Reply With Quote
Old 29th October 2004, 01:11   #32
HiBob
Junior Member
 
Join Date: Oct 2004
Posts: 8
Still no gapless play back

still not having gapless cd audio playback... I haven't installed this file from nero though, into my system32 folder, should I do this?
HiBob is offline   Reply With Quote
Old 29th October 2004, 09:33   #33
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
Yes. This will force Winamp to use ASPI instead.
Keep "Use DAE" checked and uncheck "use sonic engine", as instructed above :/
DJ Egg is offline   Reply With Quote
Old 17th November 2004, 03:44   #34
HiBob
Junior Member
 
Join Date: Oct 2004
Posts: 8
so why doesn't winamp have this automatically done?

So why the heck doesn't winamp automatically have a god darned simple option to check to mimic a normal cd player?!?!? is that too much to bloody ask?

instead of checking all kinds of options and copying files into your system folder...
HiBob is offline   Reply With Quote
Old 17th November 2004, 06:12   #35
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
The instructions in my first reply seem simple enough to me, heh :/


If we made Winamp play gaplessly by default, by enabling all gapless settings in the default distro, then we'd only get the reverse response of what we're getting here, eg.
How do I make my CDs/mp3's play with the 2 second gap that's meant to be there?


It's also got nothing to do with us or Winamp if you don't already have ASPI installed.
DJ Egg is offline   Reply With Quote
Old 8th December 2004, 23:30   #36
DVDyke
Junior Member
 
Join Date: Jun 2002
Posts: 46
Bumping this from following on from another thread.

Here is my recommendation to get absolutely seamless playback (No skips, no beats missed during DJ mixes. In fact you will probably never ever notice the join unless the tracks have been ripped REALLY badly in the first place) you use the following input and output plugins.

MAD input plugin for MP3 decoding (Move Nullsofts In_mp3.dll out of the plugins folder or it will still be used).

http://www.mars.org/home/rob/proj/mp...%200.14.2b.exe

MP3Splice output plugin available from this site and set it as the output in prefs.

http://www.winamp.com/plugins/details.php?id=112588

Now try it with your favorite 'mixed' album and tell me what you think.

There is a downside. There are no options to configure in MP3Splice and I don't think it uses DirectSound at all. Also note I have not tested it on other formats like CD audio (I think it works on Ogg OK).

If only Nullsofts own input and output plugins were as good at gap removal! I dare you to get a setting in either that can come even remotely close as these two plugins across *ALL* material (You can get it perfect with Nullsofts stuff for one thing then it's completely wrong for another). Whether that be Pink Floyd or some hardhouse compilation mix
DVDyke is offline   Reply With Quote
Old 9th December 2004, 00:12   #37
DVDyke
Junior Member
 
Join Date: Jun 2002
Posts: 46
It seems I hit a nerve (In another thread). I am not bashing Nullsoft at all. I am merely offering up another solution that some may find preferable. Please feel free to test my above method on MP3, Ogg, APE, FLAC, CD audio and any other formats and see if it does the trick for you.
DVDyke is offline   Reply With Quote
Old 9th December 2004, 00:36   #38
gaekwad2
Foorum King
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,149
Ogg Vorbis, Musepack and any lossless codec that deserves the name are natively gapless.

If your mp3s were encoded with Lame you could also use in_mpg123 (and a normal output plugin) instead of in_mad.

And btw, in_mp3 is also used to decode mp4/aac so instead of moving it out of the plugins directory you should remove MP1;MP2;MP3; from its extension list (unless you also use in_mp4 from audiocoding).

Fuck this place.
gaekwad2 is offline   Reply With Quote
Old 9th December 2004, 00:50   #39
DVDyke
Junior Member
 
Join Date: Jun 2002
Posts: 46
Good point. I used to use in_mpg123 but for some reason I have problems (Don't recall what but it resulted in crashing or somesuch). I moved to MAD for this reason.

Yes. Do not move the Nullsoft in_mp3.dll and do change the prefs and remove the MP3 extension instead or you may lose MP4/AAC if you don't have a seperate DLL for it.
DVDyke is offline   Reply With Quote
Old 9th December 2004, 04:51   #40
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,501
You're having a laugh, ain't ya?
in_mad and out_mp3slice? You've gotta be kidding, yes?
Those plugins are old dude. When was mp3splice last updated?

Did you have to hijack this thread with such lousy advice?

in_mad doesn't support id3v2 and doesn't correctly parse metadata to the library.
in_mpg123 is the only recommended 3rd-party mp3 plugin, but neither are supported here.

mp3splice uses the waveOut system, which isn't recommended on Win2k/XP.

Besides, as stated above, you don't need any 3rd-party plugins for gapless playback :/
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump