Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 27th March 2004, 06:57   #1
QZKotL
Junior Member
 
Join Date: Dec 2003
Posts: 9
WMA Plugin freezes and crashes Winamp.

I'm using Winamp 5.03 and
the new WMA plugin (I don't have the directShow plugin installed). Also I have WiMP 6.4 the WMP9 codecs installed. I'm noticing that whenever I play a WMA file, it will freeze Winamp, to the point it won't terminate properly.

When I ran a test install (Reinstalling Winamp with only the DirectSound and WMA plugins into another directory) it crashes with this message:

code:
Windows 98 Version 4.10.1998
WINAMP.EXE caused fault #c0000005 in WMVCORE.DLL at address 0177:4f51e59a

Registers:
EAX=00000000 CS=0177 EIP=4f51e59a EFLGS=00010246
EBX=00f9d534 SS=017f ESP=00739f40 EBP=00739f6c
ECX=00000000 DS=017f ESI=00863530 FS=58d7
EDX=00739f5c ES=017f EDI=00739fcc GS=0000

Bytes at CS:EIP:
8b 08 ff 51 44 85 c0 89 45 10 0f 8c 9e 04 00 00

Stack dump:
00000000 00739f5c 0045a190 0045d160 00000000 0084532f 000c0000 00000000 00000000 10167f74 00000000 00739f8c 00f85f87 00863530 00739fbc 00000000



Right now I'm back to using the old WMA plugin which works perfectly. Can this be a problem with the new plugin?
QZKotL is offline   Reply With Quote
Old 27th March 2004, 07:36   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Hmm, strange...
Any chance of uploading one of these WMA files somewhere and posting a link?
Might be wise to zip it up first...
DJ Egg is offline   Reply With Quote
Old 27th March 2004, 08:10   #3
QZKotL
Junior Member
 
Join Date: Dec 2003
Posts: 9
I'll see what I can do. I only have 56k, so It'll take a while. But is the WMA plugin independent of any other 3rd party application's DLL files, as in DirectShow or Windows Media Player?
QZKotL is offline   Reply With Quote
Old 27th March 2004, 08:34   #4
QZKotL
Junior Member
 
Join Date: Dec 2003
Posts: 9
Here's the WMA file
http://www.lbmixpro.com/Cirrus.wma
QZKotL is offline   Reply With Quote
Old 6th April 2004, 09:30   #5
Skytrooper
Junior Member
 
Join Date: Apr 2004
Posts: 4
I have a similar problem, my winamp 5.03 crashes whenever I try to play a WMA-file! I think this also has something to do with 'wmvcore.dll'
If you want, I can send the so called fault-reports windows is giving! Let me know

Tnx,

Skytrooper
Skytrooper is offline   Reply With Quote
Old 6th April 2004, 11:55   #6
thecameleon
Junior Member
 
Join Date: Apr 2004
Posts: 6
Same problem here. Upgraded from 5.02 to 5.03, and a wma stream I listen to crashes winamp. Switching back to the old, v1 wma plugin fixes the problem. The url of the stream is http://ms.stream.garnierprojects.com/kinkfm/.wma .
thecameleon is offline   Reply With Quote
Old 6th April 2004, 14:35   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Well, that stream plays fine in for me with Winamp 5.03a and the latest in_wm.dll.
No idea what I was listening to... the first tune sounded a bit like Sister Machine Gun,
followed by some pretty hefty grunge tune
(shame it doesn't show what's playing, 'cos I quite liked this one),
then some dude started speaking in part Dutch / part English,
but the next tune was a bit crappy so I switched off.

Could you all please provide some more information?
We need to know the following:
Basic system specs, including sound card/chip
Windows OS
Windows Media Player version
Version of WMA codecs installed
wmvcore.dll version (this can be found in your System dir, rt click -> properties -> version tab).

Plus any other useful information, including error reports/logs
(zip them up and use the Attachment feature c/o Post A Reply button).

Also include a list of all extra 3rd-party Winamp plugins installed, if any.


As for QZKotL's sample file, well, lord knows how I missed it first time around,
but the link is dead now, so I never got to test it.
But yes, links to sample files would certainly help...
(again, it would be best to zip them up first).
DJ Egg is offline   Reply With Quote
Old 6th April 2004, 15:34   #8
thecameleon
Junior Member
 
Join Date: Apr 2004
Posts: 6
Crash details

It's KinkFM, a dutch 'alternative' radio station. There are some playlists on http://www.kinkfm.com, though only of the non-stop programs.

I tried a fresh install of winamp 5.03a (the previous was installed over other versions of 5, though not over 2), and it still crashed. Details of my system are:
  • Athlon 900, 256MB RAM, Creative SB Live! Value
  • Windows 2000 Professional SP4
  • Clean full install of winamp 5.03a
  • Windows Media Player 6.4.09.1128
  • wmvcore.dll version 7.0.0.1956
  • Audio codec versions were a bit hard to find out; I finally found this: wmv version 9.0.1.0369, wma version 4.2.0, directshow wma decoder 4.1.00.3917, directshow wma voice decoder 9.00.00.3224, directshow wmv decoders 3.0.0.3433 and 8.0.0.0340
I've also attached the drwatson crash log (zipped) for the last crash. I've got a few other crash logs, but the stack trace is the same.

Let me know if there is anything else I can do to help.
Attached Files
File Type: zip winamp_503_wma_crash.zip (6.7 KB, 2117 views)
thecameleon is offline   Reply With Quote
Old 6th April 2004, 18:44   #9
dweilerthi
Junior Member
 
Join Date: Jul 2002
Posts: 5
Wimamp Crashes on .wma stream

I am getting the same error.

Attached is a jpg showing the gpf dialog box. 'nuff said already by others.
Attached Images
File Type: jpg winamp_failure.jpg (96.3 KB, 2311 views)
dweilerthi is offline   Reply With Quote
Old 7th April 2004, 01:10   #10
Skytrooper
Junior Member
 
Join Date: Apr 2004
Posts: 4
-Pentium(R) 4 CPU 2.00GHz, 256 MB RAM Creative SB Live! Value
-Windows XP Home version 5.1.2600 (Dutch)
-Also a clean full install of WinAmp 5.03a
-Windows Media Player 8.00.00.4487
-DivX WMA Audio Compressor versie 4.02
-wmvcore.dll version 8.0.0.4487

also I included a link to a sample WMA-file (the smallest I could find, but it crashes) and the standard crash-log, WinXP gives me.
http://people.zeelandnet.nl/skytrooper/wma-crash.zip
Skytrooper is offline   Reply With Quote
Old 7th April 2004, 04:22   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Hmm, well all the sample streams/files are playing ok for me.
No crashes whatsoever.

WinXP sp1 (english)
WMP9 / WMA9 codecs
wmvcore.dll version 9.0.0.2980


@thecameleon

I've studied the dr watson crashlog, but I'm not too sure what I'm looking for.

Application exception occurred:
App: (pid=1584)
Exception number: c0000005 (access violation)

Could be an incompatibility issue with old WMP6.4... not sure yet.
Maybe someone else will know?


@dweilerthi

The stream plays ok for me. Anyone else?
http://160.79.128.12/trance_low/.wma

"The instruction at 0x* referenced memory at 0x00000000. The memory could not be read"

This error is more than often caused by a potentially dodgy/old 3rd-party plugin.
Do you have any extra 3rd-party plugins installed?

btw, are you aware that Digitally Imported also broadcasts mp3 streams?
www.digitallyimported.com
Navbar at top -> Trance -> mp3 streams...
These same streams are also accessible at www.shoutcast.com
and via Winamp Library -> Internet Radio.


@Skytrooper

Again, thanks for the report.
Does the problem still occur if you disable the wincue plugin?
(I have to ask this, as it is the only 3rd-party plugin I can see that you've got installed).

Also, I'm not sure about this:
"DivX WMA Audio Compressor"
Have you tried disabling this codec and using the microsoft one instead?


Anyway, I'll be keeping my eye on this thread,
and will also report it to the dev team.

Thanks
DJ Egg is offline   Reply With Quote
Old 7th April 2004, 05:26   #12
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,384
I was having a WMA streaming issue, Winamp 5.03 crashed or just closed. It is a pre wmvcore.dll 9.0x conflict. Updating to WMP9 (wmvcore.dll 9.0.0.2980) solved the problem.
JonnyMac is offline   Reply With Quote
Old 7th April 2004, 06:20   #13
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
No problems.
Just had a look at the mysterious wmvcore.dll and it is indeed version 9.0.0.2890 that I'm using.

UJ
ujay is offline   Reply With Quote
Old 7th April 2004, 06:24   #14
dweilerthi
Junior Member
 
Join Date: Jul 2002
Posts: 5
I have switched my WMA plugin back to version 1.13 and it works fine. This is the version that was with WinAmp 5.0.

I tried doing a clean uninstall, clean install, etc, and no luck. I even uninstalled all plugins but the WMA 2.0 version, and still had the error.

Only after going downlevel with the WMA plugin can I get it to work.

My System:
Windows 2000 SP4
Windows Media Player: 6.4.09.1125
wmvcore.dll: 7.0.0.1956

Regarding my usage of WMA streams for services such as DI. It turns out that work figured out a way to block MP3 streams, but WMA streams still work. Also, as I work remotely, and connect via VPN to work, I need to limit bandwidth due to limit$ set by my ISP.
dweilerthi is offline   Reply With Quote
Old 7th April 2004, 06:40   #15
dweilerthi
Junior Member
 
Join Date: Jul 2002
Posts: 5
Yes - installing WM9 fixes the problem.
dweilerthi is offline   Reply With Quote
Old 7th April 2004, 10:44   #16
Skytrooper
Junior Member
 
Join Date: Apr 2004
Posts: 4
hmm...stupid, it wasn't such a clean install after all! well...I have uninstalled the mp3cue, and has got a little better now, it only crashes after a couple of WMA-files! :s
Also I switched back from the 'DivX WMA Audio Compressor' to the Microsoft one, but it still crashes after a couple of WMA's..:s It's not even a set number and even seems like the more times I try, the longer it doesn't crash! :s
But it still crashes..
Skytrooper is offline   Reply With Quote
Old 14th April 2004, 17:21   #17
prodangle
Major Dude
 
prodangle's Avatar
 
Join Date: Nov 2000
Location: Scotland
Posts: 718
I'm getting the this error too, with a few protected wma files I downloaded from http://mycokemusic.com.

code:
Unhandled exception in winamp.exe (wmvcore.dll): 0xC0000005: Access Violation.


Winamp sometimes works, but sometimes crashes, it's behaviour appears to be random. I'm using Windows XP and a completely fresh installation of Winamp 5.03.

When the error message pops up, Winamp continues to play in the background, but is unavailable. When I press either 'Send' or 'Don't send' on the message reporting dialog, Winamp then closes. The files always play fine in Windows Media Player.
prodangle is offline   Reply With Quote
Old 14th April 2004, 18:11   #18
Skytrooper
Junior Member
 
Join Date: Apr 2004
Posts: 4
jupz, same here but now I have upgraded my WMP to 9.0 and the error disappears...
But I am still curious why it did not work with the old WMP installed!
Skytrooper is offline   Reply With Quote
Old 14th April 2004, 20:29   #19
prodangle
Major Dude
 
prodangle's Avatar
 
Join Date: Nov 2000
Location: Scotland
Posts: 718
Quote:
Originally posted by prodangle
[B]I'm getting the this error too, with a few protected wma files I downloaded from http://mycokemusic.com.
The problem occurs with the following setup.

Windows XP Pro
Athlon 1200
SB Live! Value
Winamp version 5.03a
in_wm.dll Nullsoft WAM plugin v2.00
wmvcore.dll version 8.0.0.4487
Windows Media Player version 8.00.00.4487



Upgrading wmvcore.dll to version 9.0.0.2980 seems to have fixed the problem.
prodangle is offline   Reply With Quote
Old 19th April 2004, 01:30   #20
Christophe
Sexaholic
 
Join Date: Oct 2000
Posts: 114
This updated in_wm.dll (v2.02) should fix this crash bug:

http://ronwarez.com/in_wm.dll

-Christophe


[edit] please use v2.03 as included in the update patch [/edit]

- time heals but i'm forever broken
Christophe is offline   Reply With Quote
Old 19th April 2004, 22:46   #21
drake0013
Junior Member
 
Join Date: Apr 2004
Posts: 2
where can you find wmvcore.dll version 9.0.0.2980 to DL?
drake0013 is offline   Reply With Quote
Old 20th April 2004, 00:21   #22
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
wmvcore.dll v9.0.0.2980 comes with Windows Media Player v9

However, you should no longer need to upgrade to WiMP9.
The above fix posted by Christophe should resolve all issues.
Please test the new in_wm.dll and report back here
(with Winamp closed, save in_wm.dll to the winamp\plugins dir).

Thank you.
DJ Egg is offline   Reply With Quote
Old 20th April 2004, 10:03   #23
thecameleon
Junior Member
 
Join Date: Apr 2004
Posts: 6
The new plugin fixes this for me. Thanks!
thecameleon is offline   Reply With Quote
Old 21st April 2004, 22:11   #24
Calanan
Junior Member
 
Join Date: Apr 2000
Posts: 8
FYI, I used the plugin referred to above (in_wm.dll) on my XP Pro machine (fully-patched) and I still have problems with Winamp 5.03a (Mar 26 2004) crashing. In some cases I will see the XP debug dialog and in others Winamp just disappears completely. Here are the two events I see in these cases:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 4/21/2004
Time: 4:55:39 PM
User: N/A
Computer:
Description:
Faulting application winamp.exe, version 5.0.0.3, faulting module wmvcore.dll, version 8.0.0.4487, fault address 0x0001ef59.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 77 69 6e ure win
0018: 61 6d 70 2e 65 78 65 20 amp.exe
0020: 35 2e 30 2e 30 2e 33 20 5.0.0.3
0028: 69 6e 20 77 6d 76 63 6f in wmvco
0030: 72 65 2e 64 6c 6c 20 38 re.dll 8
0038: 2e 30 2e 30 2e 34 34 38 .0.0.448
0040: 37 20 61 74 20 6f 66 66 7 at off
0048: 73 65 74 20 30 30 30 31 set 0001
0050: 65 66 35 39 0d 0a ef59..


Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 4/21/2004
Time: 5:08:58 PM
User: N/A
Computer:
Description:
Faulting application winamp.exe, version 5.0.0.3, faulting module msvcrt.dll, version 7.0.2600.1106, fault address 0x00033a89.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 77 69 6e ure win
0018: 61 6d 70 2e 65 78 65 20 amp.exe
0020: 35 2e 30 2e 30 2e 33 20 5.0.0.3
0028: 69 6e 20 6d 73 76 63 72 in msvcr
0030: 74 2e 64 6c 6c 20 37 2e t.dll 7.
0038: 30 2e 32 36 30 30 2e 31 0.2600.1
0040: 31 30 36 20 61 74 20 6f 106 at o
0048: 66 66 73 65 74 20 30 30 ffset 00
0050: 30 33 33 61 38 39 0d 0a 033a89..

- mike
Calanan is offline   Reply With Quote
Old 21st April 2004, 22:22   #25
Calanan
Junior Member
 
Join Date: Apr 2000
Posts: 8
Just to clarify, I receive the errors whether I use in_wm.dll 2.00 that came with Winamp 5.03a or the one downloaded from ronwarez.com, version 2.02.


Also, Windows Media player 8.00.00.4487 is installed.

- mike
Calanan is offline   Reply With Quote
Old 23rd April 2004, 17:44   #26
Calanan
Junior Member
 
Join Date: Apr 2000
Posts: 8
I gave up on this and reverted back to Winamp 2.95 (found at http://www.oldversion.com/) and have had no problems playing WMA files since. The input plugin I'm now using is in_wm.dll v1.13 (x86). If I have time today I'll save that .dll, install 5.x again, copy the old .dll into the Plugins folder and try playing WMAs.

- mike
Calanan is offline   Reply With Quote
Old 26th April 2004, 10:07   #27
welcomerain
Junior Member
 
Join Date: Apr 2004
Posts: 2
concerning the tracklength bug with 5.03, i reinstalled 5.03 with the 5.01 version of in_wm.dll (33kbs) and nuked the library. after doing so, all the ID3 tags and meta data for .wma formats with song lengths over 7 minutes are being reported accurately in the playlist and library.
welcomerain is offline   Reply With Quote
Old 26th April 2004, 14:17   #28
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
The new in_wm.dll posted by Christophe above also fixes the tracklength issue.
DJ Egg is offline   Reply With Quote
Old 12th May 2004, 10:50   #29
xdc33
Junior Member
 
Join Date: May 2004
Location: Germany
Posts: 1
I had a similar problem with wa291, wma plugin1 &113 and wmp9 on win98se (wa didn't crash, but showed an error message [NO CODEC INSTAL] in the input-plugins box). For me the plugin posted by christophe worked fine, but i wonder if there is an official site where i can always get the latest wa-plugins, because i gotta admit that i first had doubts about downloadin a file that might contain 'bad code' from a domain that includes the word warez
xdc33 is offline   Reply With Quote
Old 12th May 2004, 12:56   #30
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
ronwarez.com is Christophe's personal site/domain
and is therefore as official as you are going to get.
DJ Egg is offline   Reply With Quote
Old 25th June 2004, 18:12   #31
Kalebmation
Junior Member
 
Join Date: Jun 2004
Posts: 1
http://www.winamp.com/plugins/details.php?id=80454

Download that, and install. It fixed all the Winamp crashing for me

I also have the Windows Media Player Beta version 10.
Kalebmation is offline   Reply With Quote
Old 25th June 2004, 18:25   #32
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Did you even try the updated version?

The old plugin in your link (also available here) doesn't support drm.

Then again... the latest in_wm.dll will probably need updating again when WiMP 10 Final is released
(beta versions are NOT supported).
DJ Egg is offline   Reply With Quote
Old 15th July 2004, 06:11   #33
n8s
Junior Member
 
Join Date: Jul 2004
Posts: 5
-The updated plugin still crashes... but the stream will start playing anyway if the error is not acknowledged.
-The older v1 plugin does work


I'm still using wmp8 and I don't intend to upgrade. WMP9 is a step backwards in the UI department IMO. I really am not too concerned about lacking DRM. in the older plugin, but it would be nice not to have the whine.

Last edited by n8s; 15th July 2004 at 06:45.
n8s is offline   Reply With Quote
Old 15th July 2004, 06:18   #34
n8s
Junior Member
 
Join Date: Jul 2004
Posts: 5
PS this was a fresh install of Winamp 5.03

winxp sp1a
mp8 player/wmp9 codecs
wwmvcore.dll ver: 8.0.0.4487 offset: 0001f3b7

Last edited by n8s; 15th July 2004 at 06:44.
n8s is offline   Reply With Quote
Old 15th July 2004, 08:19   #35
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Quote:
Originally posted by n8s
-The updated plugin still crashes...
but the stream will start playing anyway if the error is not acknowledged.
Which stream? url?

Exact error message?
(c/o "to view details of error click here")

No-one else with WMP8 has reported any problems after applying the patch...

EDIT:
Note, the version in the patch (2.03) is slightly newer than the one in this thread (2.02).
Please confirm you are using the newer version.
DJ Egg is offline   Reply With Quote
Old 16th July 2004, 05:01   #36
n8s
Junior Member
 
Join Date: Jul 2004
Posts: 5
Quote:
Originally posted by DJ Egg
No-one else with WMP8 has reported any problems after applying the patch... [/B]
Calanan and Prodangle also had WMP8. wmvcore.dll ver8.0.0.4487 in the error message means that WMP8 is the version installed

I think I put most of the info in my last post... but here goes again

oh, and the URL giving me trouble is... http://ccdig.liquidviewer.com/kfi/.wma
n8s is offline   Reply With Quote
Old 16th July 2004, 12:49   #37
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Quote:
Originally posted by n8s
... I'm still using wmp8 and I don't intend to upgrade. WMP9 is a step backwards in the UI department IMO ...
Have you tried using just the WMP 9 runtimes then?
MS have a redistribution package available.

[edit] The radio stream plays fine here btw [/edit]

UJ
ujay is offline   Reply With Quote
Old 16th July 2004, 17:58   #38
n8s
Junior Member
 
Join Date: Jul 2004
Posts: 5
I just found the problem. I applied the wa5update (which has in_wm.dll ver 2.03) then installed the in_wm.dll listed on this page which is ver 2.02. So, anyone having problems, DO NOT install the in_wm.dll linked on this page and you'll be fine.
n8s is offline   Reply With Quote
Old 16th July 2004, 23:15   #39
n8s
Junior Member
 
Join Date: Jul 2004
Posts: 5
spoke too soon apparently... played a couple times perfectly, and now it's crashing again everytime.

exact same error message as before although I am now have in_wm ver 2.03
n8s is offline   Reply With Quote
Old 18th July 2004, 03:33   #40
KingKongLives
Junior Member
 
Join Date: Jul 2004
Posts: 1
... hey mine doesn't crash, but it doesn't play any wma files? any idea what's wrong
i have WM 9, the posted plug-in, Winamp 5.03...

thanks for any help... i'm sorta confused, i just realized a few days ago that my wma files weren't playing on winamp, then i updated everything, and it still doesn't work
KingKongLives is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump