Old 21st June 2004, 02:55   #1
subzerobob
Junior Member
 
Join Date: Jun 2004
Posts: 1
DirectSound Output v2.2.10 Bad Sound Driver

Problem started when I updated from Winamp 2.X to 5.X Before that the only thing was the CDDB thing – whenever I logged online it will interrupt the continues flow of the CD with a dialog box saying “CD info cannot be retrieved” but after clicking OK, it just continued with the next song. That only happened when I was logged online. It was annoying so I thought – maybe I have to upgrade!

Current problem emerged after I finally decided to upgrade to 5.x. I have Windows 98 on Pentium I with 200MHZ. Here I have to mention that I started off with a different problem right after upgrading. The original problem was that playing a CD will be broken up into 2 seconds of each song, followed by a humming sound of the CD player and then another 2 seconds of the same songs. I looked into the thread in regards to the “4 seconds then stops” issue. I had my browser hijacked before, so I already had Hijackthis installed. I also had SpyBot SnD. Please see my hijackthis log attached (currently I am only worried about
C:\WINDOWS.000\SYSTEM\KERNEL32.DLL
C:\WINDOWS.000\SYSTEM\MSGSRV32.EXE
C:\WINDOWS.000\SYSTEM\MPREXE.EXE
C:\WINDOWS.000\SYSTEM\mmtask.tsk

However I am not sure what they are and Hijackthis does show them as items to be fixed. Spybot SnD only shows DSO interrupt as a threat every time I run it, even though I ask it to fix it.

I uninstalled Winamp and reinstalled it completely. I tried the generic CD player in Windows, which worked fine. I tried playing Mp3’s with Winamp and that was fine too. Only the CD was humming.

Then I saw this somewhere else in the forum:
"Try the following:

Winamp -> Prefs (Ctrl+P) -> Plugins -> Output -> DirectSound -> config:
Device tab:
-Make sure your sound card is selected as Device (c/o drop-down menu)
-Checkmark "enable hardware acceleration"
Buffering tab:
-Checkmark "enable cpu usage control"

And I did it – which resulted in the appearance of the even more annoying dialog box:
“DirectSound Output v2.2.10 error” – Bad direct sound driver - please install proper drivers or select another device in configure. Error code: 8004005

After pressing the only option available – OK another identical dialog box appears. Another OK, and then the CD plays as if nothing ever happened. After the song is finished, however, I have to go through that same error dialog box OK clicking thing in order for it to go to the next song. So basically I am back to square one, except that this time I have to click OK (not once but twice) even though I am offline.

HELP! I really like Winamp, but I want to be able to listen to CDs too!
Attached Files
File Type: txt hijackthis.txt (2.2 KB, 2202 views)
subzerobob is offline   Reply With Quote
Old 21st June 2004, 09:10   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Your HijackThis log is fine.
There's no malware/spyware/hijackers listed there.
I assume that your default Windows Dir is "C:\Windows.000"
(ie. this is the folder where Windows 98 SE is installed).

What is the make/model of CD-ROM Drive and Sound card?
Do you have the correct/latest sound drivers installed?

Is DirectX 9.0b installed?
(note, DirectSound Output requires DirectX 8 or higher)

Start > Run > dxdiag
Anything there?
If so, DirectX version info can be found at the bottom of the General tab.
Also, are there any problems reported under any of the other tabs?

That all said and done, waveOut Output is recommended under Win9x,
though there shouldn't be any problem with using DirectSound Output.
However, your system is quite old (p200),
so you'll probably be best sticking with waveOut.


Did you install Winamp 5.03 Full? (or Lite?)
Was it a clean install?
(note, you should also install the update patch afterwards)


Does your CD Drive support Digital Audio Extraction?
Try going to:
Prefs > Plugins > Input > Nullsoft CD...plugin > config:
Uncheck: Use Sonic Engine...

Close Prefs, close & reopen Winamp.
If the problem persists, go back in and
Uncheck: Enable Digital Audio Extraction...
(again, requires Winamp restart to take effect).
Still no joy?
Uncheck: Sample input from soundcard (for vis)


Further tips for running Winamp 5 on older/slower systems:
Like The Wind



Going back to your HJT log...

Although these startup processes are legit,
you could try disabling them to free up resources.
Note: Microsoft Office StartUp / FindFast and QuickTime Taskbar icon are known resource hoggers...

O4 - HKLM\..\Run: [QuickTime Task] C:\WINDOWS.000\SYSTEM\QTTASK.EXE
O4 - Startup: Office Startup.lnk = C:\Program Files\Microsoft Office\Office\OSA.EXE
O4 - Startup: Microsoft Find Fast.lnk = C:\Program Files\Microsoft Office\Office\FINDFAST.EXE
O4 - Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office\OSA9.EXE

Also note that you don't need to use HJT to stop those processes from loading at startup.
You can just move/delete the shortcuts from:
Start -> Programs > StartUp

iirc, the corresponding folder in Win98 is:
C:\Windows\Start Menu\Programs\Startup
(or "C:\Windows.000\..." in your case)

QTTASK can be disabled via unchecking it in msconfig > startup tab:
Start > run > msconfig
(though you'll be prompted to reboot if using msconfig).

Also note that HJT lists ALL running processes, startup items, browser plugins & activex controls.
It doesn't just list bad items... most of the entries will always be perfectly safe/legit.
It is not recommended to try fix anything with HJT without seeking professional advice first.
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump