Old 18th April 2005, 14:13   #1
haiku
Junior Member
 
Join Date: Apr 2005
Location: Earth
Posts: 2
"Always on Top" Broken

Hello,

I want to report that the "Always on Top" Feature breaks when my screensaver launches. If I've left my PC for a while and come back after the screensaver has launched, when I clear my screensaver than the "Always on Top" features wont be working. The only way to fix it is to turn it off and back on by hitting CTRL+A 2X.

I'm using 5.08 of course, and Windows XP home SP2, and a basic windows screensaver. (windows logo floats around a black screen)

Can this please be fixed in the next update?
haiku is offline   Reply With Quote
Old 18th April 2005, 14:34   #2
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,494
Moved from Bug Reports to Tech Support

Winamp > Prefs (Ctrl+P) > General Preferences
Uncheck "disable aot when fullscreen apps are focused"
DJ Egg is online now   Reply With Quote
Old 18th April 2005, 16:37   #3
haiku
Junior Member
 
Join Date: Apr 2005
Location: Earth
Posts: 2
hey,

thanks alot I wasn't aware of this. It's a great help!
haiku is offline   Reply With Quote
Old 20th April 2005, 04:24   #4
Xechorizo
Junior Member
 
Join Date: Apr 2005
Location: Riverton, UT.
Posts: 11
I have the same problem, only I have Winamp sitting on a spot on my Taskbar, but whenever I click anything on the taskbar, it overcomes the Always On Top function, hiding Winamp altogether, until I refocus it.
Xechorizo is offline   Reply With Quote
Old 1st August 2005, 20:40   #5
enrique85
Junior Member
 
Join Date: Aug 2005
Posts: 1
Show Desktop and Always on top

What about when I have always on top activated, and click on show desktop button, winamp docks but if I open another window, winamp won't come on top again.

I'm using modern skin on Windows XP pro and Windows 2000, I use it in 2 computers and the same thing happens in both.

Thanks a lot.
enrique85 is offline   Reply With Quote
Old 1st March 2006, 22:50   #6
ampersand17
Junior Member
 
ampersand17's Avatar
 
Join Date: Oct 2001
Posts: 3
my "always on top" feature is also, as you say, broken. i haven't exactly found out what overrides it regularly, but my browser will sometimes appear over it. i have the "disable aot when fullscreen apps are focused" unchecked, and i am using winamp 5.13 (until the on end of queue bug is fixed in 5.2) and winXP pro.

thanks to anyone with any ideas!!
ampersand17 is offline   Reply With Quote
Old 25th May 2006, 12:41   #7
NickMikh
Member
 
NickMikh's Avatar
 
Join Date: Mar 2006
Location: Russia
Posts: 90
Send a message via ICQ to NickMikh Send a message via Yahoo to NickMikh
Excuse me for not finding this thread(I swear I searched)

I just want to know whether this problem is going to be fixed, as first reports seems to be made a year ago

Last edited by NickMikh; 25th May 2006 at 12:57.
NickMikh is offline   Reply With Quote
Old 25th May 2006, 13:14   #8
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,372
It is a known issue which means it does have the attention of the developers. However, there is no ETA on when it will be fixed. Sorry.

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 25th May 2006, 13:44   #9
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,494
Hmm, is it...?

What's the exact problem/issue again? And how do we reproduce it?

(note, the original issue in the first post was resolved in the 2nd post, and confirmed in the 3rd post)
DJ Egg is online now   Reply With Quote
Old 25th May 2006, 13:56   #10
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,372
Just a difference of interpretation, I guess. IMHO, unchecking 'Disable AOT when fullscreen applications are focused' is more of a workaround that a fix.

However, I do understand what your are saying.
JonnyMac is offline   Reply With Quote
Old 26th May 2006, 05:54   #11
NickMikh
Member
 
NickMikh's Avatar
 
Join Date: Mar 2006
Location: Russia
Posts: 90
Send a message via ICQ to NickMikh Send a message via Yahoo to NickMikh
Thanks for information

That`s exactly what I wanted to say about workaround

But this checker just enable this bug, as I still don`t see Winamp AOT when fullscreen application is active when it is unchecked.

So there appears to be another bug.
NickMikh is offline   Reply With Quote
Old 24th July 2006, 11:54   #12
Darcey76
Junior Member
 
Join Date: Jul 2006
Posts: 16
WinAMP Always on top reset bug

Hi,
I have an annoying problem with winamp v5.24...

I am running MMD3 skin.

The always ontop feature resets without actual use of the CTRL A and/or the Selection of this option.

So far I found that this happens when:
1). Going from mini mode to full mode (not minimise)

I will record more when I can.

Look forward to the bug fix...

D
Darcey76 is offline   Reply With Quote
Old 24th July 2006, 11:56   #13
Darcey76
Junior Member
 
Join Date: Jul 2006
Posts: 16
Media menu scaling and content rendering problems

Media menu bug:

Using default skin of new style...

This often doesn't scale its contents in the main window correctly.

It resizes but only to a certain point and this doesn't reset when winamp is closed and re-opened..

Takes some playing around with and closing and opening to get it to be back to normal.....

D
Darcey76 is offline   Reply With Quote
Old 8th October 2006, 20:41   #14
cuoresportivo
Junior Member
 
Join Date: Oct 2006
Posts: 1
I have the solution. In MINI mode, there is a button CFG as configuration. Click it and uncheck the ALWAYS ON TOP(auto) option. Finnaly i found the cause of the problem. I have searched for a long time.
cuoresportivo is offline   Reply With Quote
Old 8th October 2006, 20:50   #15
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,372
Talking about the MMD3 skin? MMD3 has a has semi-independent AOT setting. When it is on, Winamp's own AOT is enabled.

screenshot of cuoresportivo's instructions

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 28th December 2006, 14:10   #16
Spent
Junior Member
 
Join Date: Nov 2006
Posts: 5
Quote:
Originally posted by cuoresportivo
I have the solution. In MINI mode, there is a button CFG as configuration. Click it and uncheck the ALWAYS ON TOP(auto) option. Finnaly i found the cause of the problem. I have searched for a long time.
You absolute legend.

Just to make it a little more clear for others, the CFG button is on the far left of the mini window and looks a little like a crosshair.
Spent is offline   Reply With Quote
Old 21st March 2007, 21:32   #17
tony359
Junior Member
 
tony359's Avatar
 
Join Date: Mar 2007
Location: Firenze - Italy
Posts: 10
Same issue here.

Sorry, what is the "mini" mode?

Ciao
A

[edit > JonnyMac] Please continue discussion of tony359's post in his orgional thread [/edit]
tony359 is offline   Reply With Quote
Old 21st August 2009, 12:10   #18
Hannes Rannes
Junior Member
 
Join Date: Jun 2007
Location: Styria, Austria
Posts: 12
Send a message via ICQ to Hannes Rannes
Hello,

I finally found this topic after this issue has been bothering me for many years now.

The bar highly likely disappears in the background after a full screen application was run. This also includes functions like Win Flip or screenshot programs.

Can you confirm, that this is definitely a bug of Winamp (and not a problem of Windows restoring window states) and if yes, if this is ever going to be fixed?

Thanks.
Hannes Rannes is offline   Reply With Quote
Old 30th August 2009, 20:51   #19
Moleculor
Junior Member
 
Join Date: Aug 2000
Posts: 5
Send a message via ICQ to Moleculor
So... it's been four years. I have Always On Top checked. I have disable Always On Top when fullscreen blah blah checked. I run a fullscreen app (like, say, World of Warcraft in maximized windowed no-border mode) and WinAMP is no longer on top. That's fine. I like it like that.

However, when I quit WoW, WinAMP no longer stays on top of windows, like Firefox.

Four years since the 5.08 release, and it's been a bug since then. Any progress?
Moleculor is offline   Reply With Quote
Old 30th August 2009, 21:04   #20
Hannes Rannes
Junior Member
 
Join Date: Jun 2007
Location: Styria, Austria
Posts: 12
Send a message via ICQ to Hannes Rannes
I started a thread at TechNet because I really thought this was a problem of Windows, but they think it's Winamp's fault.

So, at least an official statement regarding this problem would be nice.
Hannes Rannes is offline   Reply With Quote
Old 1st September 2009, 16:45   #21
TheCorp
Junior Member
 
Join Date: Nov 2006
Posts: 3
Ya I have had this same issue for years and years through many versions of Winamp (starting at version 5.x) and many versions of Windows.

Basically AoT works but will randomly stop working after some period of time. For example right now it is on and is currently floating over a Thunderbird window. After sometime it will drop off behind the Thunderbird application and the only way to get it to stay AoT is to alt tab to the application (or in my case click the systray icon since I don't have it pinned as an application to the taskbar) and uncheck/recheck the AoT option in the config menu.

Any ideas why this might be happening? I can't seem to pin down any specific reason or set of steps that can reproduce this so I know this may not be very useful of a bug report but this has been happening for some time now and not really sure how to fix it.
TheCorp is offline   Reply With Quote
Old 1st September 2009, 16:53   #22
Hannes Rannes
Junior Member
 
Join Date: Jun 2007
Location: Styria, Austria
Posts: 12
Send a message via ICQ to Hannes Rannes
@TheCorp:

As I wrote above:

Quote:
The bar highly likely disappears in the background after a full screen application was run. This also includes functions like Win Flip or screenshot programs.
I get it back to top with selecting Winamp in the taskbar and pressing F5 to refresh the Window. Imo, this is the fastest possibility.
Hannes Rannes is offline   Reply With Quote
Old 17th December 2009, 12:52   #23
Hannes Rannes
Junior Member
 
Join Date: Jun 2007
Location: Styria, Austria
Posts: 12
Send a message via ICQ to Hannes Rannes
At least it got a bit better with 5.57 and Windows 7:

The bar still disappears in the background after full screen applications were launched, but it's at least possible to bring the window to front for a short time, when you click on the taskbar preview thumbnail.

Anyway Winamp will go to the background again as soon as another window is selected.

To bring it permanently back to front again, you still have to refresh the Winamp window by pressing F5.

Useless for me because dragging and dropping files on the Winamp window still won't work this way, but maybe this new possibility is useful for someone else at least.

EDIT:
Or maybe that was already possible with 5.56 or before and I just never noticed it...
Hannes Rannes is offline   Reply With Quote
Old 11th October 2010, 14:43   #24
cparker
Junior Member
 
Join Date: Feb 2005
Location: Massachusetts
Posts: 29
Send a message via ICQ to cparker Send a message via AIM to cparker Send a message via Yahoo to cparker
Just thought I would point out that this is still an issue in v5.581. If I switch to a fullscreen app then switch back to a non-fullscreen app, then Winamp no longer stays on top of the non-fullscreen app. I have to disable then re-enable "always on top". If I implement the workaround, then Winamp ALWAYS stays on top, even on top of fullscreen apps, which is not an acceptable permanent solution.
cparker is offline   Reply With Quote
Old 3rd August 2011, 04:30   #25
KitD17
Junior Member
 
Join Date: Aug 2011
Posts: 3
And 5 years after this bug's inception (even though I have only owned this program for around 2 days), I have finally found a way to keep winamp always on top when it windowshade/ docked mode easy steps for how I made it work.

Step 1: Go into Winamp Preferences and disable the always on top while fullapps are focused --- Ctrl+P > General Preferences > Disable always on top while fullscreen applications are focused (last check box), make sure this is unchecked, not checked.

Step 2: Go into windowshade mode by clicking the title bar twice, Right click the resulting winamp player to bring up a config menu (preferably the WINAMP watermark so we can reduce the margin for error here) ---Window Settings > Docked Toolbar > Auto hide and Always on top ticked (enabled).

Step 3: After making sure those are ticked right click the WINAMP watermark --- Options > Always on Top Ticked (Enabled) and Easy Move Ticked off (Disabled).

I have tried many combinations of this, but it seems that EasyMove being enabled was always the issue.

Specifications:
OS: Windows 7 Ultimate x64 SP1
Graphics Card: nVidia 9800 GT
Processor: i7 720QM

Fullscreen applications results prior to change:
Firefox 5-8: None
Safari 5:None
Opera 11.5-12: None
Google Chrome: None
Paint Tool Sai: Conflict
Adobe Master Collection 5.5: All had conflicts
Cinema 4d, Autodesk 3DS Max: Conflict

Post Change:
No conflicts
KitD17 is offline   Reply With Quote
Old 3rd August 2011, 04:32   #26
KitD17
Junior Member
 
Join Date: Aug 2011
Posts: 3
Bah forgot 1 more bit of important information Winamp Version 5.621 Pro

Edit: Why did this load before my solution...? Should I repost it or just wait for it to come around randomly?
KitD17 is offline   Reply With Quote
Old 19th September 2011, 06:20   #27
stevether
Junior Member
 
Join Date: Sep 2011
Posts: 1
For some added clarification on this, there were 3 areas that I had to disable in order to stop Winamp from being on top. This process should probably be made simpler (Especially since ctrl+a can be used as select all).

http://i.imgur.com/MqQbe.png
stevether is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump