Old 17th January 2006, 18:03   #1
ColdFrixion
Junior Member
 
Join Date: Jan 2006
Posts: 3
Quicktime hijacking MP3's in Browser -- SOLVED

Ok, I had an issue I was trying to resolve earlier and there didn't seem to be a concrete fix listed in the FAQ's. However, I now know how to resolve the issue with almost no effort.

Problem: Quicktime plays MP3's in your browser, even though you've already disabled the MIME extensions for it in Quicktime's application preferences and have also associated MP3's to Winamp in Winamp Preferences >File Types. MP3's will play automatically in Winamp when accessed from the harddrive but refuse to play in said application when attempting to access an MP3 via the browser(in my case IE).

Comments: I tried ***everything*** (and I mean EVERYTHING) to disassociate Quicktime from playing MP3's in the browser, short of uninstalling Quicktime, and **NOTHING** worked.

The solution turned out to be astoundingly simple.

Solution: Load Windows Media Player and set it as the default MP3 player(put a check mark beside MP3 in File Types, under Tools >Options). Then load Winamp and reassociate MP3's under File Types, in Winamp's Preferences.

I hope this saves some poor soul from going through the same hair pulling frustration I experienced with this issue.
ColdFrixion is offline   Reply With Quote
Old 17th January 2006, 18:14   #2
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,520
I've added a link to this thread in the relevant section of the FAQ

MP3 and other streams always open in QuickTime browser plugin
http://forums.winamp.com/showthread.php?threadid=229287
http://forums.winamp.com/showthread.php?threadid=230361
http://forums.winamp.com/showthread.php?threadid=235714
DJ Egg is online now   Reply With Quote
Old 20th January 2006, 22:51   #3
elvissinatra
Junior Member
 
Join Date: Nov 2000
Location: Chicago
Posts: 4
I've been struggling with this for months! Apple should be ashamed of itself for creating software that takes over browser functionality without a user's consent.

I can't wait to get home and try this suggestion. Hope it works.
elvissinatra is offline   Reply With Quote
Old 21st January 2006, 00:26   #4
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,520
Pretty certain that this is referred to in those other links, eg.
http://forums.winamp.com/showthread....66#post1810666
http://forums.winamp.com/showthread....04#post1820204

but if you're comfortable with editing the registry with regedit then the relevant sub-keys to delete (bold text below) are:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\Extensions\.mp3

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\MIME\audio/mpeg


(note, the above keys are automatically removed if you use the .reg fix in the first link)

[edit] re: below --> cool, whatever... [/edit]
DJ Egg is online now   Reply With Quote
Old 21st January 2006, 04:56   #5
ColdFrixion
Junior Member
 
Join Date: Jan 2006
Posts: 3
Trust me, I scoured FAQ's here and abroad. I didn't find any reference to it in either of those two links.
ColdFrixion is offline   Reply With Quote
Old 21st January 2006, 05:59   #6
elvissinatra
Junior Member
 
Join Date: Nov 2000
Location: Chicago
Posts: 4
Woo hoo! It worked. I searched high and low for a solution to this. And this was the first thing that actually worked.

You wouldn't believe how this affected the way I listen to music on the internet. I basically stopped listening to mp3s on the web. Now I can start listening again. I'm so happy.

But still... FUCK Quicktime! Arrogant motherfuckers think they have the right to take over your computer.
elvissinatra is offline   Reply With Quote
Old 21st January 2006, 18:01   #7
ColdFrixion
Junior Member
 
Join Date: Jan 2006
Posts: 3
LOL, I know. I wanted to choke somebody at Apple.
ColdFrixion is offline   Reply With Quote
Old 13th August 2006, 08:43   #8
RAHR
Junior Member
 
Join Date: Aug 2006
Posts: 1
i registered just to say..

THANK YOU!! that has been annoying me for months!! (and yes apple SHOULD be ashamed!) my sister found this fix for me and thank goodness she did. i uninstalled quicktime and everything - and still it lingered. i had no idea what to do. i was about to reinstall windows. =P this worked tho, THANK YOU SO MUCH!! =)
RAHR is offline   Reply With Quote
Old 15th March 2007, 23:50   #9
RaZor Edge
Junior Member
 
Join Date: Mar 2007
Location: Québec
Posts: 1
Hi,

Searching for a solution to this really annoying problem in Google have given me this page.

In case somebody else is having this problem too, I just want to share this easy fix that actualy worked for me:

Quote:
Try unchecking MP3 options in QT MIME settings. Then uncheck the Mp3 setting in WMP (Windows Media Player). Hit apply, close WMP. Reopen and then check Mp3 file type and apply. Close WMP. Try to open an mp3 files in your browser. Give it a try. You might have to reboot.
This solution was found on the Apple forum: http://discussions.apple.com/thread....79734&#1079734

I did'nt needed a reboot to get this done.

If you want Winamp to play these mp3 files, after having done it with WMP, do it with Winamp.

Good Luck!!
RaZor Edge is offline   Reply With Quote
Old 16th July 2007, 15:41   #10
williamc
Junior Member
 
Join Date: Jul 2007
Posts: 1
Quote:
Solution: Load Windows Media Player and set it as the default MP3 player(put a check mark beside MP3 in File Types, under Tools >Options). Then load Winamp and reassociate MP3's under File Types, in Winamp's Preferences.
If you find that the MP3 file type is *already* checked, uncheck it, apply, re-check it and apply. Learned this from Mike Nelson's blog (Google 'quicktime sucks mp3' and look for Mike Nelson's blog), and it works.
williamc is offline   Reply With Quote
Old 7th August 2007, 05:22   #11
DJ MichaelAngel
Junior Member
 
Join Date: Aug 2007
Location: Chandler, AZ
Posts: 1
Send a message via AIM to DJ MichaelAngel
You guys ROCK! I was having this exact same problem (QuickTime = the devil) and found this thread by luck, searching on Google. DJ Egg or any of you other geniuses know the answer to this question? I'm wondering if it's possible to have WinAmp still be my default player for all mp3's....except have Windows Media Player play the mp3's I open within Internet Explorer. Probably a stupid question, I know....is this even possible?
DJ MichaelAngel is offline   Reply With Quote
Old 4th November 2008, 23:02   #12
calldon
Senior Member
 
calldon's Avatar
 
Join Date: Dec 2005
Location: The Airstream
Posts: 138
Re: Quicktime hijacking MP3's in Browser -- SOLVED

Quote:
Originally posted by ColdFrixion
Ok, I had an issue I was trying to resolve earlier and there didn't seem to be a concrete fix listed in the FAQ's. However, I now know how to resolve the issue with almost no effort.

Solution: Load Windows Media Player and set it as the default MP3 player(put a check mark beside MP3 in File Types, under Tools >Options). Then load Winamp and reassociate MP3's under File Types, in Winamp's Preferences.

I hope this saves some poor soul from going through the same hair pulling frustration I experienced with this issue.
-----------------

Well, just about one week ago, I finally REMOVED quicktime from my computer. I didn't find this fix until just now.

But now, I must reinstall quicktime in order to view some video clips! Hope I can do this when QT still tries to take-over my computer again!

D*
www.airstreamfm.com
calldon is offline   Reply With Quote
Old 5th November 2008, 01:22   #13
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,520
No need to install Quicktime Player unless you need support for DRM-protected iTMS M4P files (in which case, QT is installed alongside iTunes anyway).

QuickTime Alternative
http://www.free-codecs.com/download/...lternative.htm
DJ Egg is online now   Reply With Quote
Old 22nd December 2008, 21:41   #14
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
Actually, no need to edit the registry and so on.

Open Quicktime Player, Go to Preferences > Quicktime Preferences (not Player Preferences), go to Broswer tab, uncheck Play movies automatically and click "MIME settings..." button at the bottom and uncheck everything you can.

And if you also want Quicktime not to be associated with files on your computer (not from the web) go to the File Types tab and uncheck everything you can. While you're at it you can turn off the Check for updates automatically in the Updates tab, but Quicktime will still talk to the internet regardless.
stopasking is offline   Reply With Quote
Old 9th June 2010, 18:26   #15
jssapo
Junior Member
 
Join Date: Jun 2010
Posts: 2
Great! I have been looking for solutions regarding MIME. Good to know that it is already posted in this forum. I will try editing the settings later when I got home.

Good thing that file association works with quicktime.
jssapo is offline   Reply With Quote
Old 29th July 2011, 19:03   #16
winmanus
Junior Member
 
Join Date: Jul 2011
Posts: 5
Quote:
Originally Posted by ColdFrixion View Post
Ok, I had an issue I was trying to resolve earlier and there didn't seem to be a concrete fix listed in the FAQ's. However, I now know how to resolve the issue with almost no effort.

Problem: Quicktime plays MP3's in your browser, even though you've already disabled the MIME extensions for it in Quicktime's application preferences and have also associated MP3's to Winamp in Winamp Preferences >File Types. MP3's will play automatically in Winamp when accessed from the harddrive but refuse to play in said application when attempting to access an MP3 via the browser(in my case IE).

Comments: I tried ***everything*** (and I mean EVERYTHING) to disassociate Quicktime from playing MP3's in the browser, short of uninstalling Quicktime, and **NOTHING** worked.

The solution turned out to be astoundingly simple.


Solution: Load Windows Media Player and set it as the default MP3 player(put a check mark beside MP3 in File Types, under Tools >Options). Then load Winamp and reassociate MP3's under File Types, in Winamp's Preferences.

I hope this saves some poor soul from going through the same hair pulling frustration I experienced with this issue.
I wanted to choke somebody at Apple.
winmanus is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump