Old 24th February 2006, 14:35   #1
goublabba
Junior Member
 
Join Date: Jan 2006
Posts: 5
Playlist Editor upper case

I've noticed in 5.2 that the song title is now upper-cased when you put the Playlist Editor in windowshade mode. I thought there would be an option to disable this, but I can't find one.

I don't like the title being in uppercase for two reasons. First, since the font used is a proportional font, you can't see as much of the song title since uppercase letters are wider than lowercase letters. And the second reason is that much like in email or in forums, ALL UPPER CASE MAKES IT LOOK LIKE I'M BEING SHOUTED AT, WHICH IS JUST UNPLEASANT.

When you look at the Playlist Editor in non-windowshade mode, the titles are correctly displayed using both upper and lower case letters. Why is everything forced to be upper case in windowshade mode?
goublabba is offline   Reply With Quote
Old 24th February 2006, 15:01   #2
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Upper casing was the only way to make sure that these three requirements are met:

1) Chinese characters are displayed correctly
2) latin characters with underhang (e.g. "g") are displayed correctly
3) letters do not go onto the surface of the 'skin'

Capital letters with a wide separation was the only choice.

You can go back to the old behavior by checkmarking:
"Use skinned font for main window title display" in Preferences -> Classic Skins.

Of course you lose the ability to display non-latin characters (and it only displays undecorated latin characters, at that)
Benski is offline   Reply With Quote
Old 24th February 2006, 15:25   #3
goublabba
Junior Member
 
Join Date: Jan 2006
Posts: 5
Well, I have to apologize for complaining in the first place. I just discovered that the windowshade mode was already using uppercase letters in older versions like 5.13. It's just that the letters are now wider in 5.2, and that really stuck out to me.
goublabba is offline   Reply With Quote
Old 25th February 2006, 04:12   #4
BastardKidKris
Senior Member
 
Join Date: Sep 2005
Posts: 222
Send a message via AIM to BastardKidKris
good "fix", totally made the track display look out of place with the classic skin im using

ThinkPad T61, C2D @ 2.2GHz, 4GB DDR2, Win7x64Pro
BastardKidKris is offline   Reply With Quote
Old 25th February 2006, 06:37   #5
spacefish
Junior Member
 
spacefish's Avatar
 
Join Date: Sep 2003
Location: Denmark
Posts: 35
Quote:
Originally posted by BastardKidKris
good "fix", totally made the track display look out of place with the classic skin im using
I have to agree, the fix is not very elegant. I don't understand how the fix affects classic skins. I can guess how it affects modern skins if the Font Rendering tab is any indication but I never use modern skins and I always use classic windowshade mode. Why CAPS is necessary, I have no idea. I understand the explanation, I just don't understand the implementation.
spacefish is offline   Reply With Quote
Old 8th March 2006, 17:50   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Quote:
Originally posted by Benski
You can go back to the old behavior by checkmarking:
"Use skinned font for main window title display" in Preferences -> Classic Skins.
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump