Old 8th June 2006, 13:02   #1
evolution76
Member
 
evolution76's Avatar
 
Join Date: Apr 2003
Location: +38.20000 -84.86170
Posts: 90
Send a message via Yahoo to evolution76
Green Line

There is now a big ugly Green "image not found" bitmap in the modern skins that were broken by 5.23. Also scroll bars in the ML now seem to have the same problem. Is that a third party plugin problem or is winamp?
evolution76 is offline   Reply With Quote
Old 8th June 2006, 13:40   #2
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
its a problem with the skins. there was a bug fixed in winamp that some skins were expecting to be there and hacked around. obviously now the bug has been fixed, the hack doesnt work, hence the issue.

as for a solution, no idea? re-break winamp?

CraigF is offline   Reply With Quote
Old 8th June 2006, 13:43   #3
evolution76
Member
 
evolution76's Avatar
 
Join Date: Apr 2003
Location: +38.20000 -84.86170
Posts: 90
Send a message via Yahoo to evolution76
Well thanks for the info........winamp still rules
evolution76 is offline   Reply With Quote
Old 9th June 2006, 00:17   #4
JohnnyBlazE
Junior Member
 
Join Date: Jun 2006
Posts: 6
So all skins need a redesign to comply with something winamp fixed? what ever happened to something not being broken therefore it does not need to be fixed?
JohnnyBlazE is offline   Reply With Quote
Old 9th June 2006, 00:33   #5
Chris000001
Senior Member
 
Join Date: Nov 2003
Location: CA
Posts: 105
Here's how I "fixed" it (it worked for clearONE and Simplicity as far as I can tell, maybe it'll work for other skins too.) Go to the folder Program Files\Winamp\Plugins\freeform\xml\wasabi\window. rename 'error.png' to something else (error.png.old.) Make a copy of 'transparent.png' from that same folder. Rename the copy you just made 'error.png'. That's it, start Winamp to test. The skins still need to be fixed, but this way you don't have the green X's.
Chris000001 is offline   Reply With Quote
Old 9th June 2006, 01:55   #6
evolution76
Member
 
evolution76's Avatar
 
Join Date: Apr 2003
Location: +38.20000 -84.86170
Posts: 90
Send a message via Yahoo to evolution76
Hey Chris000001, it worked the green line is gone. Thanks


Long live Winamp
evolution76 is offline   Reply With Quote
Old 9th June 2006, 19:22   #7
jtbse
Senior Member
 
Join Date: Oct 2005
Posts: 111
Send a message via AIM to jtbse Send a message via Yahoo to jtbse
Quote:
Originally posted by JohnnyBlazE
So all skins need a redesign to comply with something winamp fixed? what ever happened to something not being broken therefore it does not need to be fixed?
Not an especially helpful comment. First of all if there are known bugs, I for one appreciate the Winamp devs fixing them. Second of all, I don't think CraigF said anything about "all skins".

Just one of the unfortunate facts of life when developing software that allows 3rd party interfaces.
jtbse is offline   Reply With Quote
Old 10th June 2006, 14:55   #8
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
Since ive not touched modern skinning since testing wasabi in its early stages, I cant say what the exact issue was.

From my understanding, it was simply a bug that skinners, in some instances, assumed would exist. When it was corrected, the assumption fails, and you get a missing image; in winamp's case, a green image the size of whatever region the skinner defined (in this instance, a line).

CraigF is offline   Reply With Quote
Old 10th June 2006, 18:39   #9
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
Quote:
Originally posted by Chris000001
Here's how I "fixed" it (it worked for clearONE and Simplicity as far as I can tell, maybe it'll work for other skins too.) Go to the folder Program Files\Winamp\Plugins\freeform\xml\wasabi\window. rename 'error.png' to something else (error.png.old.) Make a copy of 'transparent.png' from that same folder. Rename the copy you just made 'error.png'. That's it, start Winamp to test. The skins still need to be fixed, but this way you don't have the green X's.
instead of fixing the skin error you hacked wasabi engine


The universal god of light, love, wisdom and rok n rol
Cianca is offline   Reply With Quote
Old 21st June 2006, 21:18   #10
evolution76
Member
 
evolution76's Avatar
 
Join Date: Apr 2003
Location: +38.20000 -84.86170
Posts: 90
Send a message via Yahoo to evolution76
Do mean to bit$h, Still green line in the new version of winamp 5.24. Winamp still rules
evolution76 is offline   Reply With Quote
Old 21st June 2006, 21:50   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
and has been mentioned here it's something down to the skinners to basically fix since the skinning engine is now working correctly as it was meant to do (hence the green cross to indicate missing images). a fix for the better i'd say since it used to work correctly in the old wasabi engine but was broken when it went into gen_ff for 5.x. Mr Jones had a far better post describing it but i can't remember which thread i saw it in, heh

-daz
DrO is offline   Reply With Quote
Old 21st June 2006, 21:57   #12
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
Quote:
Originally posted by DrO
Mr Jones had a far better post describing it but i can't remember which thread i saw it in, heh

-daz
Perhaps this post?
Bubba Smith is offline   Reply With Quote
Old 21st June 2006, 22:19   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
that's the puppy

-daz
DrO is offline   Reply With Quote
Old 23rd July 2006, 21:19   #14
moktoman
Member
 
moktoman's Avatar
 
Join Date: Oct 2003
Location: Bay Area, California
Posts: 71
Send a message via AIM to moktoman Send a message via Yahoo to moktoman
Quote:
Originally posted by Cianca
instead of fixing the skin error you hacked wasabi engine

Well... whatever works, right?
moktoman is offline   Reply With Quote
Old 18th October 2006, 03:00   #15
kevgozoom
Junior Member
 
Join Date: Oct 2006
Posts: 1
Green line in Drone skin

-------------------------------------------------------------
Quote:
Here's how I "fixed" it (it worked for clearONE and Simplicity as far as I can tell, maybe it'll work for other skins too.) Go to the folder Program Files\Winamp\Plugins\freeform\xml\wasabi\window. rename 'error.png' to something else (error.png.old.) Make a copy of 'transparent.png' from that same folder. Rename the copy you just made 'error.png'. That's it, start Winamp to test. The skins still need to be fixed, but this way you don't have the green X's.


Chris000001 ...
Thanks for posting this solution! I can now enjoy the Drone Skin again. The green line and "x" in the notifier was driving me crazy. Not anymore thanks to you!

Peace bro.
Kevgozoom
kevgozoom is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump