Old 3rd June 2000, 02:02   #1
tapdog
Junior Member
 
Join Date: Jun 2000
Posts: 1
I recently downloaded Wrapster.This uses Winamp.Somehow all my others files(movies,pictures,etc. )are now changed to Winamp media files.I managed to transform some back but I still am not able to get back my jpg.pictures.Somehow my Photo Editor got turned off.What do I have to do to change this and prevent it from happening again when I use Wrapster?
tapdog is offline   Reply With Quote
Old 4th June 2000, 04:38   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Is there an options or preferences menu in Wrapster where you can set the filetype associations ?
[Like there is in Winamp : File Menu -> Options -> Preferences -> File types]

If so, then remove the check marks [or equivalent necessary action] next to the extensions that you don't want to be associated with Wrapster/Winamp [most of them by the sound of it].
"Okay" everything and exit Wrapster and/or Winamp.

Next, open the programs that had the original associations and repeat the above process for each in turn, but this time put a check mark next to the relevant filetypes.

This is an easy option with programs such as Windows Media Player, Quicktime, RealPlayer, IrfanView etc etc, but sadly not all programs have such facilities.
One of these is MS Photo Editor.

To associate JPG with Photo Editor you have to goto :
"Start -> Settings -> Folder Options -> File Types"
and edit the entry from there.

Search down the list and find the entry for the .JPG extension
This is normally found under: JPEG Image (JPEG JPG JPE JFIF)

If the entry already exists, "Edit" the entry as described below.

If there is no entry for JPG then click on "New" and type in the following:

Description = JPEG Image
(or whatever you want to refer to them as, eg: Joint Photographic Experts Group Image, etc)
Content Type = image/jpeg
Default Extension = JPG
[Actions -> New]
Action = &Open
Application used = "C:\Program Files\Common Files\Microsoft Shared\PHOTOED\PHOTOED.EXE" "%1"

Click "Okay"

Now hi-lite this entry and click "Set default".

This is all assuming that MS Photo Editor is/was your default viewer.
If it's a different program then click on "browse" for the "app. used" entry and locate the relevant program.
You should still have to type in the "%1" as above as this is the DDE command line that most programs use when opening media files.
The ampersand in &Open makes the "O" underlined in the Explorer file menu . . . though you probably already knew that . . . better safe than sorry though !

Some people have JPG files setup to be associated with Internet Explorer, which is the default Windows setting.
More info on this here:
From: TSGH -> Useful Links
"File Formats & associations" section:
http://forums.winamp.com/showthread.php?threadid=30923
http://forums.winamp.com/showthread.php?threadid=30880
http://forums.winamp.com/showthread.php?threadid=30442

The commandline for Internet Explorer is simply the path to IE (no "%1" required)

If you encounter an error message that says "Unable to [blah blah], the JPG extension is already registered as [blah blah]", then this means that you're going to have to run RegEdit and edit the Registry entry for JPG association. Hopefully it won't come to this, but if it does, I'll tell you what to do . . . but only if the above methods fail [please God no !].

Another method is to goto any folder which contains a JPG,
Shift + Right Click on any .JPG file and select "Open With"
Checkmark "always open with this program"
Select your preferred program and click Okay.

Bear in mind that if the Winamp Agent is enabled (v2.64+), you will need to disable it first for any of these changes to take effect.
Winamp Prefs -> Agent : uncheck all three options
(especially "maintain file associations"; the other 2 settings are optional)

Best of luck !
Peace -> DJ-Egg.

[This message has been edited by DJEgg (edited July 01, 2000).]

[Edited by Jayn on 12-18-2000 at 11:31 PM]
DJ Egg is offline   Reply With Quote
Old 4th June 2000, 04:47   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
ps.
Both sets of inverted commas (" ") are also necessary in the command line !
"C:\Program Files\.......\Photoed.exe" "%1"

[Edited by DJEgg on 12-19-2000 at 07:31 PM]
DJ Egg is offline   Reply With Quote
Old 1st July 2000, 11:56   #4
melc
Junior Member
 
Join Date: Jul 2000
Location: Houston, Texas
Posts: 1
Winamp is still converting my pic files into music files...and I don't have a clue as to what you were talking about in the second message...I don't want to have to download some other program to get my current programs to work (if that was your suggestion).
melc is offline   Reply With Quote
Old 2nd July 2000, 04:20   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
No, you don't have to download a new program.
I never said that at all !

Read carefully and follow the instructions in my first reply.
I've edited it especially, to make it even clearer.
It should all hopefully make sense now !

BTW, what exactly was your default jpg program before ?
Was it MS Photo Editor or something else ?
If you are still having problems, state your answer in the reply . . . and we'll take it from there.

Other helpful tips [maybe]:
1. Goto Winamp Prefs -> File Types
Uncheck the option to "Register Files on Winamp start"
2. Prefs -> Options
Blank out the box "Default ext's for unknown filetypes" [usually mp3]
3. Disable the Winamp Agent if you have it running (Prefs -> Agent -> uncheck all 3 options)

Further helpful links:
http://forums.winamp.com/showthread.php?threadid=32735

------------------
**********
DJ - Egg
**********
^/^
`v

{Edited by Jayn on 12-18-2000 at 11:33 PM}

[Edited by DJEgg on 12-19-2000 at 07:35 PM]
DJ Egg is offline   Reply With Quote
Old 2nd July 2000, 04:23   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
ps. How comes your name's changed from tapdog to melc ?

Just wondering !?!?

------------------
*******
DJ - Egg
*******
^/^
`v
DJ Egg is offline   Reply With Quote
Old 23rd July 2000, 09:12   #7
Winsane
Moderator Alumni
 
Winsane's Avatar
 
Join Date: Jun 2000
Location: U.S. (eastern time zone)
Posts: 2,598
Quote:
Originally posted by DJEgg:
The inverted commas are also necessary
Do you mean quotation marks?

Quote:
2. Prefs -> Options
Blank out the box "Default ext's for unknown filetypes" [usually mp3]
Why?

[Edited by Jayn on 12-18-2000 at 11:36 PM]
Winsane is offline   Reply With Quote
Old 25th July 2000, 04:36   #8
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
1. Yes I do !
"Inverted commas" is the official grammatical term for "quotation marks".
Or at least it is here in England where the crazy language originated !

2. A frequent occurrence between thee 'n' me.
Why don't you tell us the answer oh wise one ?
< It seems pretty obvious to me ! >

?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?!?

------------------
*******
DJ - Egg
*******
^/^
`v

[Edited by Jayn on 12-18-2000 at 11:37 PM]
DJ Egg is offline   Reply With Quote
Old 25th July 2000, 06:30   #9
Winsane
Moderator Alumni
 
Winsane's Avatar
 
Join Date: Jun 2000
Location: U.S. (eastern time zone)
Posts: 2,598
Unless Winamp's code is pretty screwed up, or unless I've completely lost it (quite likely, actually), that "Default extension for unknown file types" setting only affects which plug-in a file will be sent to if the file extension for that file is not recognized by any of the installed input plug-ins (i.e. is not in Winamp's list of Associated extensions, although I think there are a few exceptions where plug-ins don't add their supported extensions to the list but still associate themselves with a file extension). For example, let's say you've downloaded a file called "song.l3p". None of your plug-ins recognize that .l3p extension. Double-clicking on the file in Windows Explorer would just bring up Windows' "Open With" dialog box, unless the file extension was taken by another program. But if you dragged the file onto Winamp, or opened it by clicking on the Open file(s) button, Winamp would check the "Default extension..." setting. If it was set to the default of "mp3", Winamp would treat the song.l3p file as an mp3 file and so would send it to your mp3 decoder plug-in (which in this case would probably be the right one to send it to). Now if you have a bunch of files in a different format that your Winamp supports, but for some reason the file extension is different than what Winamp recognizes (e.g. you have a bunch of WAV files with a .raw extension instead of a .wav extension, and for some reason you don't want to or can't rename them), then you might want to change the default extension setting to something else ("wav" in the last parenthetical example). But there shouldn't be any reason to have it blank. <incorrect sentence erased>. Generally not really a big deal, but still I don't see any reason to clear that box. It shouldn't have any effect on Windows file type associations.
(Dang, I wasn't expecting to write nearly that much!)

[This message has been edited by Winsane (edited July 24, 2000).]

[Edited by Jayn on 12-18-2000 at 11:38 PM]
Winsane is offline   Reply With Quote
Old 25th July 2000, 06:39   #10
Winsane
Moderator Alumni
 
Winsane's Avatar
 
Join Date: Jun 2000
Location: U.S. (eastern time zone)
Posts: 2,598
Just discovered something that would seem to make that last post irrelevant: If you do clear that default extension box, and then try to open an unrecognized file type, Winamp resets the box back to "mp3" (regardless of whether the file type you tried actually was in mp3 format). Oh well, nevermind. Still, might as well not confuse anyone or waste anyone's time bothering with the step of clearing that box. It shouldn't have any effect on the problems they've been asking about.
Winsane is offline   Reply With Quote
Old 26th July 2000, 05:20   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Point taken & noted !

Basically, I think it's when you've got the "register filetypes at winamp start" option checked that the "default ext for unknown filetypes = mp3" has a major impact on Windows.
I once experienced this problem a fair while ago [in version pre 2.5c], where files such as "PUB" and "FAX" [with no extensions] were being displayed as Winamp media files in Windows folders.

------------------
*******
DJ - Egg
*******
^/^
`v
DJ Egg is offline   Reply With Quote
Old 26th July 2000, 07:13   #12
Winsane
Moderator Alumni
 
Winsane's Avatar
 
Join Date: Jun 2000
Location: U.S. (eastern time zone)
Posts: 2,598
Oh. Hmm. Weird.
Winsane is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump