Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 1st April 2007, 02:52   #1
monkchild1
Junior Member
 
Join Date: Apr 2007
Posts: 1
USB hard-drive mistakenly listed as "portable drive" in media library.

Hi.

I have a USB hard drive with mp3s, on, and once WInamp asked me if i wanted it to manage it as a portable drive and i mistakenly pressed YES. I want to remove the drive from the "portable" list in media library because it slows down winamp alot. is there a way to do this? i tried to reinstall winamp but it didn't work, same problem!
monkchild1 is offline   Reply With Quote
Old 1st April 2007, 03:24   #2
DJ Egg
Techorator
Winamp Team
 
Join Date: Jun 2000
Posts: 35,509
Go to: Winamp -> Prefs (Ctrl+P) -> Plugins -> Portables -> USB Device Plugin -> config:
Select the relevant drive letter from the drop-down list
Click: Blacklist Drive

Close Prefs
Close & reopen Winamp

If for some reason that doesn't work....

1. Close Winamp
2. Delete pmp_usb.ini and winamp_cache_001.xml from the root folder of the drive
3. Reopen Winamp
4. This time, select "No" when prompted if you want Winamp to manage the drive.

Note, the two files you need to delete have the 'hidden' attribute, so make sure you can view hidden files first (via: Control Panel > Folder Options> View tab)
Attached Images
File Type: png usb.png (53.9 KB, 1738 views)
DJ Egg is online now   Reply With Quote
Old 29th August 2007, 21:20   #3
dlynn
Junior Member
 
Join Date: Aug 2007
Posts: 25
My son accidentily hit YES to this prompt.

I followed the steps and removed both hidden files from my external hard drive, however this didn't fix the issue completely.

Winamp will open, and it no longer is frozen; however, it will not play any music.

Is there something else I need to do?

I am using Version 5.35.

What does it mean for Winamp to manage a portable device?

Thanks!
dlynn is offline   Reply With Quote
Old 7th September 2007, 23:18   #4
mlkj100
Junior Member
 
Join Date: Sep 2007
Posts: 1
Hi,
Delete pmp_usb.ini and winamp_cache_001.xml from the root folder of the drive
AND update winamp.ini:
Open %AppData%\Winamp\Winamp.ini
Find the [pmp_usb] section
Type blacklistnum=0
erase all sublines until the next section

open Winamp
That time, the pop-up will appear again (if your drive is connected).
mlkj100 is offline   Reply With Quote
Old 8th September 2007, 22:21   #5
BastardKidKris
Senior Member
 
Join Date: Sep 2005
Posts: 222
Send a message via AIM to BastardKidKris
i was having the same problem, but didnt realize that what was slowing down winamp


nice fix

ThinkPad T61, C2D @ 2.2GHz, 4GB DDR2, Win7x64Pro
BastardKidKris is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump