Old 26th September 2007, 00:41   #1
Blaubaer
Junior Member
 
Blaubaer's Avatar
 
Join Date: Nov 2005
Location: Germany
Posts: 29
Send a message via ICQ to Blaubaer Send a message via AIM to Blaubaer Send a message via Yahoo to Blaubaer
Unicode Problem

Hi,

I am using Winamp 5.35 (clean install, no plugins except the defaults) on Vista (32bit) and can only get unicode characters to work if i UNCHECK the freetype internal font rendering in the modern skin font rendering options, even though i have unicode or auto selected.

Unfortunately, the fonts look really ugly if i dont use the internal renderer. any way to get it to work with the internal rendering?
Blaubaer is offline   Reply With Quote
Old 2nd October 2007, 22:36   #2
Blaubaer
Junior Member
 
Blaubaer's Avatar
 
Join Date: Nov 2005
Location: Germany
Posts: 29
Send a message via ICQ to Blaubaer Send a message via AIM to Blaubaer Send a message via Yahoo to Blaubaer
bump
Blaubaer is offline   Reply With Quote
Old 2nd October 2007, 22:39   #3
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
It might be a font issue. Are you seeing squares in place of the unicode characters? Or are you seeing questions marks? Or the wrong characters? Unfortunately the freetype renderer doesn't "fallback" to a different font on unsupported characters (unlike the win32 renderer that is used when freetype is off)

p.s. The renderer that is used when freetype is 'off' is smarter, faster and is more accurate in its display
unfortunately most skins are built around the freetype renderer so the net effect is that it looks worse)
Benski is offline   Reply With Quote
Old 3rd October 2007, 05:08   #4
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
How do you make skins that display unicode when freetype is checked? Bento and Modern seem to be immune to this on my PC.

Thanx
iron2000 is offline   Reply With Quote
Old 4th October 2007, 18:41   #5
Blaubaer
Junior Member
 
Blaubaer's Avatar
 
Join Date: Nov 2005
Location: Germany
Posts: 29
Send a message via ICQ to Blaubaer Send a message via AIM to Blaubaer Send a message via Yahoo to Blaubaer
Benski: the winamp main window looks like this:



the taskbar, playlist and tag editor display the characters correctly though.
Blaubaer is offline   Reply With Quote
Old 6th October 2007, 13:24   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,867
Quote:
Originally posted by iron2000
How do you make skins that display unicode when freetype is checked? Bento and Modern seem to be immune to this on my PC.
From the 5.5 Beta thread:

Notes:

-Re: Skinned ml scrollbars
For support, Wasabi version needs to be specified as 1.3 in skin.xml, eg.
<WasabiXML version="1.3">
Also note that v1.3 skins no longer use the internal freetype font renderer.


Changelog:

-Misc: Added 'for older skins' note to 'use internal freetype font renderer' setting
(Prefs > Modern Skins > Font Rendering)
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump