Old 6th November 2007, 10:10   #1
postertag
Junior Member
 
Join Date: Mar 2006
Posts: 8
Seek changes sound

My spec:

Windows XP Sp2
P4 2.8 GHz
SB Audigy 2 ZS - latest drivers
7.1 speaker settings in control panel and CMSS2 enabled

and these 3rd part plugins
in_flac.dll
in_cue.dll
in_mpc.dll
in_shn.dll

After first seek in song (by dragging slider or by arrow) sound goes only to front speakers. After next seek again to 7.1. After next to 2 and again to 7.1. This is repeating. I am using DirectSound output with all fadings disabled. It is occurring during ogg, mp3, xm, it, modules playback. In the contrary, MIDI files are played always in the same way. From 3rd part plugins - flac, mpc and monkeys audio files are also alway played in the same way. So summing this... ogg, mp3 and modules have buggy playback and midi, flac, mpc, ape are played in the same way invariant of seeking.

Has anybody similar problem?
postertag is offline   Reply With Quote
Old 6th November 2007, 13:53   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
You have the following options:

1. Winamp > Prefs > Playback:
Uncheck "Allow 24bit"

The Audigy 2-ZS was not a true 24bit soundcard, or to be more precise, it only supported a single 24bit audio stream...

or

2. Keep the 'Allow 24bit' option enabled, and go to:

Winamp > Prefs > Plugins > Output > out_ds > config > Fading tab:
Disable all fades, especially 'fade on seek' and 'fade on pause/stop'

These features require a 2nd audio stream.

This is where the problem/limitation arises with the Audigy 2-ZS.
Because it only supports a single 24bit audio stream, and not 2 or more simultaneous 24bit audio streams, then the 2nd stream is played at 16bit - and this is what causes the problem when cmss is enabled.

or

3. Keep those options enabled and upgrade to a newer soundcard (eg. SB X-Fi) which supports multiple simultaneous 24bit audio streams.
DJ Egg is offline   Reply With Quote
Old 6th November 2007, 16:37   #3
postertag
Junior Member
 
Join Date: Mar 2006
Posts: 8
thanks

I just switched 24 bit off and it works fine. Thanks
postertag is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump