Old 3rd December 2007, 13:59   #1
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Winamp 5.51 Beta Preview (Build 1741)

Winamp 5.51 Beta, Build 1741

Winamp 5.51 Beta Full (US English version)
Winamp 5.51 Beta Pro (US English version, asks for key during install)
Winamp 5.51 Beta Lite (basic 2.x-style mp3/cd player)

Winamp 5.51
* New: Autoplay Handlers for Audio, MP3 and Video CD's on WinXP & Vista
* New: Default Programs registration for installations on Windows Vista
* New: Optional Constant-Q Equalizer and optional ISO Standard frequency bands
* New: [in_flv] Flash Video decoder (vp6 only, not h.263)
* New: [ml_local] BPM column
* Improved: Browser download manager now uses CD Ripping destination folder
* Improved: Deletion of embedded album art via Artwork tab in File Info
* Improved: More accurately translated Language Packs (see note below)
* Improved: More miscellaneous UI/dialog tweaks & improvements
* Improved: Option to set the number of pixels to scroll for modern songticker
* Improved: [Gracenote/MusicID] Better error checking & memory cache optimizations
* Improved: [gen_ff] More miscellaneous freeform skinning engine optimizations
* Improved: [gen_hotkeys] Added optional WM_APPCOMMAND support for media keys
* Improved: [gen_hotkeys] Added increase + decrease rating on current track
* Improved: [in_dshow] Reading of length and bitrate for non-default video formats
* Improved: [in_flac] Optimized disk caching for increased performance
* Improved: [in_mp3] Better optimization for older Pentium Pro/2/3 cpu's
* Improved: [in_mp3] Support for reading ALBUM ARTIST field if TPE2 not present
* Improved: [in_mp4] Better Unicode support and metadata read optimizations
* Improved: [in_mp4] Optimized disk caching/reading
* Improved: [in_vorbis] Support for reading YEAR field if DATE not present
* Improved: [ml_disc/in_cdda] Disc reading tweaks and other general optimizations
* Improved: [ml_history] New tracking control options
* Improved: [ml_local] Album column sorting order logic
* Improved: [ml_local] Better playlist handling
* Improved: [ml_local] Bumped track# metadata guessing limit from 130 to 999
* Improved: [ml_local] Database query and memory optimizations
* Improved: [ml_pmp] Support for drag&drop from Explorer into portable device view
* Improved: [ml_transcode] Prompt to delete aborted transcodes
* Fixed: Artwork not found if .nfo filename contains a period
* Fixed: ASX Parser converting all stream links in .asx playlists to upper case
* Fixed: Classic songticker wraparound glitchiness
* Fixed: Global Hotkeys list destroyed when changing language packs
* Fixed: Gracenote/MusicID not using Winamp's proxy setting
* Fixed: Parsing of ansi ASX playlists containing non-standard characters
* Fixed: Restore from System Tray if previously closed in a minimized state
* Fixed: Setup resetting desktop icons :-o
* Fixed: Spectrum vis incompatibility crash with some 3rd-party input plugins
* Fixed: Truetype replacement font alignment in Winamp Modern winshade songticker
* Fixed: Various miscellaneous keyboard shortcut issues
* Fixed: Winamp Agent registry entry typo (wianmpa.exe)
* Fixed: [Bento] Collapse/Expand Playlist not respecting 'Show Album Art' setting
* Fixed: [gen_ff] Potential high CPU usage of songticker object
* Fixed: [gen_hotkeys] Restore from minimized state whilst About dialog is open
* Fixed: [gen_ml] Blank ML when restarting Winamp from a minimized state
* Fixed: [gen_ml] Cancelling Online Media password prompt clears password & filters
* Fixed: [in_dshow] Miscalculation of some mpeg video lengths
* Fixed: [in_flac] Divide-by-zero crash on corrupt files
* Fixed: [in_mp3] Deleting Lyrics3 tag in Alt+3 Editor also deletes ID3v1 tag
* Fixed: [in_mp3] Handling of ID3v2 with bad version/revision #'s
* Fixed: [in_mp3] ID3v2 parsing crash with some mp3's
* Fixed: [in_mp3] ID3v2 tag not showing when ID3v1 tag reading is disabled in config
* Fixed: [in_mp3] MPEG Info not showing in Alt+3 for files with large ID3v2 tags
* Fixed: [in_mp3] Now only reads first ID3v2 tag if more than one is present
* Fixed: [in_mp3] Winamp UI freezes when loading certain corrupt mp3's
* Fixed: [in_mp4] Playback of mp3 in mp4 container
* Fixed: [in_mp4] Seeking when paused
* Fixed: [in_mp4/jpeg.w5s] Crash when Art field is in metadata with no embedded art
* Fixed: [in_vorbis] UTF8->UTF16 optimized (fixes File Info delay bug)
* Fixed: [libmp4v2] Corrupt m4a's not playing, better handling of ones beyond repair
* Fixed: [ml_autotag] Stops processing when switching to another ml view
* Fixed: [ml_disc] CD view/titles not refreshing when ejecting old/inserting new CD
* Fixed: [ml_disc] Crash when using invalid strings in playlist filename generation
* Fixed: [ml_disc] No Burn button under some system configurations
* Fixed: [ml_disc/ml_pmp/ml_transcode] Processing of # in Destination Folder path
* Fixed: [ml_local] Artist column in descending order when sorting by Year
* Fixed: [ml_local] Down key in Search field not focusing the Simple View list
* Fixed: [ml_local] Last Updated, Album Gain & Podcast column sorting orders
* Fixed: [ml_playlists] Shift+Enter hotkey to Enqueue playlist
* Fixed: [ml_plg] Crash when stopping Playlist Generator scan or resetting database
* Fixed: [ml_pmp] Column sorting orders
* Fixed: [ml_rg] Restore from minimized state whilst rg results dialog is open
* Fixed: [ml_transcode] Restore from minimized state whilst config dialog is open
* Fixed: [ml_wire] Podcasts not being downloaded if <title> includes carriage returns
* Fixed: [ml_wire] Lockup when encountering scripts in <description> field
* Fixed: [out_disk] Output folder always resetting to My Documents\My Music
* Fixed: [pmp_ipod] 'Add album art' option always checkmarked
* Fixed: [tataki] Potential crash when encountering an invalid/superficial error
* Misc: Alt+3 Auto-Tag now saves Gracenote FileId and ExtData fields
* Misc: Double-click Stereo indicator to open Playback prefs (Bento & Modern skins)
* Misc: Installation is now prevented on Win9x
* Misc: Split the Playback prefs into 3 tabs: Playback, Equalizer & Replay Gain
* Misc: Various installer setup & localization translation tweaks
* Misc: Various Bento skin fixes, tweaks and improvements
* Misc: Various Winamp Modern skin 5.5-related updates
* Misc: [ml_local] Removed deprecated 'Show album gain values' option in Prefs
* Updated: Bento skin #116
* Updated: libpng 1.2.22
* Updated: [vis_milk2] MilkDrop 2.0b

__________________________________________________________________________

Notes:

1. The new Flash Video Decoder (in_flv) only plays VP6 content.

It will not play files with older h.263 video content, such as the FLV videos on youtube.
The main reasons for this are:
i) We currently aren't licensed to decode h.263 (this may change in the future)
ii) AOL Video streams are switching to VP6 codec in an FLV container.

Please do not post here to ask why you only hear audio but see no video when trying to play FLV files from youtube (or similar sites).

If you require support for youtube style h.263 FLV playback, then you can either:
i) Choose not to install the FLV Decoder in the Installer Options, and use the known in_dshow workaround instead, or
ii) Install the FLV Decoder so that it handles AOL/Winamp FLV streams, and save/rename all your youtube FLV files with e.g. the .FLV1 extension, and add ;FLV1 to the in_dshow extension list instead.


2. Re: Optional Constant-Q Equalizer and optional ISO Standard frequency bands

Please refer to this page for further info:
http://meggamusic.co.uk/winamp/docs/...eq_changes.htm


3. Re: Option to set the number of pixels to scroll for modern songticker

You can find this new option via:
Winamp > Prefs > Skins > Modern Skins -> General tab:
Move text x pixels

It was hard-coded to 5 pixels in Winamp 5.5
but the new default value in 5.51 is 1 pixel.

A neat little trick is to set it to 0 pixels, which scrolls the same as 1 pixel except, if you're using the Modern Songticker Scrolling method, there'll be no delay on the bounce (ie. when it switches direction from left-to-right or vice-versa).


4. Album Art config still isn't implemented (refer to the 5.5 Released thread)


5. The simple offline CD Info Editor from 5.35 still hasn't been re-implemented.


6. Re: Improved: More accurately translated Language Packs

Of the lang packs included with the default distribution, the French, Dutch, German, Spanish & Polish packs have been greatly improved by the community. The Italian pack has also received some updates. The Swedish pack hasn't been updated at all, because no-one volunteered (or if they did, they either backed-down afterwards and/or didn't produce the goods).

However, for legal reasons, only the English installer is available in this preview.

The updated lang packs will be included with the final release of 5.51,
though there is a chance that they might be included with a follow-up beta...

More Information About Language Packs: 1 | 2 | 3

__________________________________________________________________________

Reporting Bugs:

Please report any issues with the beta in this thread only.
Make sure your report is complete, according to the sticky threads in Bug Reports, ie.
Clean install, no 3rd-party plugins, list of plugins, full step-by-step method of reproduction, relevant system specs, exact error messages, screenshots, which skin (one of Classic, Modern, or Bento only, or all three), links to sample files, etc.
If error reports, screenshots, sample files, etc are smaller than 200kb, then please attach them to your post here. Otherwise, please upload to one of stashbox.org (recommended), mediafire.com, or sendspace.com and post the url here (no rapidshare or imageshack or similar links please).
Note that incomplete/lame bug reports may be totally ignored.


Particular areas which need testing are:
  • CD Burning, Ripping & Playback (incl. cddb)
  • MusicID Playlist Generator (play tracks similar to)
  • Milkdrop 2.0b
  • New EQ options (Constant-Q & ISO Freq bands)
  • Language Packs (general functionality)
  • Check for any gen_ff/skinning bugs, esp the new pldir.mi maki library
  • Unified File Editor
  • Installer & Setup (check all sections)
__________________________________________________________________________

Known Bugs/Issues:

-Switching between language packs or from/to English (US) can lead to some of the online related media library tree items (effectively ml_orb and ml_online) losing their position and dropping to the bottom of the tree

-ml_autotag might return wrong results for some tracks if songs are not in the online Gracenote fingerprint database. Alas, there's not much that we can do about this....

-Auto-Tag results dialog is hidden under Winamp when Always On Top is enabled

-Winamp won't restore if minimized whilst Milkdrop & AVS config/about dialogs are open

-Drag+Drop from Bento skin Open Files Dialog clears the playlist instead of adding to it

-Playlist contents are blank when in docked toolbar mode and Winamp is minimized

-Changing the TrueType replacement font in Prefs doesn't update in real-time and requires a Winamp restart to take effect (most noticeable in Winamp Modern skin) *

-Two filters is always checkmarked in Edit View for Simple views *

-CDDB Editor genre glitches, eg. saves with "General" at front *

-Winamp disappears from taskbar on reopening if previously closed in a minimized state *

-[in_flv] Bad/stuttery audio when EQ or 24bit playback enabled *

* = fixed internally

__________________________________________________________________________

Common Requests:

Commonly requested features taken from all of the 5.5 beta/final threads.
Feedback is welcome, though there's no need to keep making requests for any of these:
  • Bento skin: Vertically resizable main player area
  • Bento skin: Options to hide MCV Info Pane / tabs / etc
  • Bento skin: Options to detach vid/vis/other windows
  • Bento skin: Options to add/edit/remove tabs or rearrange windows/components
  • Gecko/other engine for Bento browser (instead of IE)
  • Winamp Modern skin: AlbumArt in Notifier
  • Winamp Modern skin: Any other missing new Bento features
  • Album Art window for classic skins (if possible?)
  • Lang pack updates for other locale translations
  • Same scrollbar/buttons for Playlist as ML
  • Select/Edit fields in Mass Autotagger results before updating
  • Publisher (or other fields) shown in AlbumArt Columns and/or Details view
  • Anything else already covered in the above notes, eg. AlbumArt config
  • Any other items already on the official Wishlist
__________________________________________________________________________

Updates & Extras:

Color Editor 2.1.1
Check this thread for the latest installer - some feedback on Vista is required!.

Winamp Essentials Pack v5.51 Beta
* Added Winamp3-style Playlist Sidecar for Winamp Modern skin
* Added DrO's Time Restore & Autoplay v2.1.1
* Updated Lite-n (gen_nopro) to v1.4 (info)
* Updated Nullsoft Waveform Wrapper to v1.01 (info)
* Updated Skins In Submenu to v1.9.1 (More Info)
* Updated enc_vorbis to v1.1 for better localization support
* Removed deprecated ml_lite_n plugin (installer now auto deletes this on upgrades)
* Note: Language files are still incomplete (more info here)
* Otherwise, same as 5.35 EP
* Full Changelog
* More Info & Mirrors


Official Bento skin Color Themes thread

Winamp Skin Development Pack v1.02
Includes updated maki libs (pldir.mi, std.mi)

______________________________________________
Old Winamp 5.5 Released thread
Old Winamp 5.5 Beta Preview 3 thread
Old Winamp 5.5 Beta Preview 2 thread
Old Winamp 5.5 Beta Preview 1 thread
Old Winamp 5.36 Beta Preview thread
Old Winamp 5.35 Released thread
DJ Egg is offline  
Old 3rd December 2007, 16:59   #2
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
yay!
Please check out/test the new maki functions, that are bundled with WaSDP (http://forums.winamp.com/showthread.php?threadid=278579) and stored in lib/pldir.mi

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 3rd December 2007, 17:35   #3
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Wow!!! A lot of fixes... This is really good!!!
Quote:
* Improved: Option to set the number of pixels to scroll for modern songticker
Finally after so many days of annoying songticker behavior!

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 3rd December 2007, 18:24   #4
WINAMP Boy
Junior Member
 
Join Date: Oct 2007
Posts: 17
After changing equalizer settings (using Vista) then closing [select=yes] options window Winamp crashes.

Very nice! Fixes so many glitches and the songticker scroll is smooth. Thank you

Last edited by WINAMP Boy; 3rd December 2007 at 19:36.
WINAMP Boy is offline  
Old 3rd December 2007, 18:32   #5
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Is the other equalizer any better? In fact I tried both and also both the frequency bands but found the Winamp equalizer and Winamp freq bands sound better.

I would like to point out a few things here...
After changing the equalizer, it asked me to restart Winamp... On restarting Winamp by clicking OK, the ML in Bento appeared black and green like the Winamp classic skin. In addition it got stuck for about 30 sec after which it returned control to the usable window... I wonder if there's some problem with the Bento skin or is is not saving the settings properly as was the issue earlier (once I had reported in the 5.5 beta thread, I don't remember exactly).

The 'launch Winamp' after exit from installer didn't work. Winamp did start but in an instant it closed down. I can't see the reason why. Again I was using Bento skin and I had installed this beta over my working 5.5.

The songticker scroll is again smooth!!! Thanks again!

Switching to the browser causes Winamp UI to freeze until it downloads the entire page or fails to retrieve the page. Isn't the browser meant to run in a separate thread?

I'm only having the essentials pack as addons.
I strongly feel none of these has anything to do with a clean install... However if anything more serious happens I'll try that too!

A small suggestion : If the album art detected is an embedded one then can the artwork tab have a mention of that... Since it detects album art from embedded as well as various file formats in the folder, it would be easier to know if its an embedded one or not... If its a file in the folder then the name of the file will be useful.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 3rd December 2007, 18:56   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Where does it say that the Constant-Q EQ or ISO Frequency bands sound better?
It says they're optional...

They sound a bit better to me, and I prefer them. But I guess it depends on personal taste, system (soundcard, settings, speakers, etc), quality of source files, and ears...

I couldn't repro any of the other issues.

After clicking 'Yes' to the restart prompt, Winamp closes and reopens within a few seconds (with Classic, Modern, or Bento skins). Tested on both WinXP and Vista.
Though it did seem to take a bit longer for Bento...

And Winamp always auto starts for me when that 'Launch Winamp after the installer closes' option is checkmarked (which it is by default) at the end of the installer setup.


@WINAMP Boy

Please see the only bit of bold red text in the first post ;-)
DJ Egg is offline  
Old 3rd December 2007, 19:02   #7
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,047
Quote:
Originally posted by TheUniqueTiger
Is the other equalizer any better? In fact I tried both and also both the frequency bands but found the Winamp equalizer and Winamp freq bands sound better.
Not better, only different. Just a few more tools in the sonic arsenal. Your EQ settings for one particular configuration won't work as well for another, you'll have to re-tweak.
Benski is offline  
Old 3rd December 2007, 19:04   #8
YtseJam
Forum King
 
YtseJam's Avatar
 
Join Date: Dec 2000
Location: Israel
Posts: 2,399
Send a message via ICQ to YtseJam Send a message via AIM to YtseJam
Is there somewhere an explaination regarding the various files under \System?

YtseJam is offline  
Old 3rd December 2007, 19:10   #9
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Quote:
Originally posted by YtseJam
Is there somewhere an explaination regarding the various files under \System?
Yes, here (mid-post).
DJ Egg is offline  
Old 3rd December 2007, 19:26   #10
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally posted by Benski
Not better, only different. Just a few more tools in the sonic arsenal. Your EQ settings for one particular configuration won't work as well for another, you'll have to re-tweak.
Yes perhaps I'll have to re-tweak if I wish to get something out of the other EQ. I just asked if it was better... Never mind.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 3rd December 2007, 19:43   #11
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
1. The ML window bug is still here (opens behind other windows).

2. The songticker bug is still here (shows "5.51.." instead of song).. This happens on startup only, and only when the title of the song is too short to scroll.. If the text is long enough to scroll, the bug is not there.. Benski may know a little bit more about this..
I repeat - It happens only when the title is too short to scroll, and it happens only in Winamp Modern Skin.

3. And, the Winamp Modern Skin winshade mode songticker still has not the same options as in the normal mode..

Besides that, 5.51 looks nice =)

EDIT:
4. When I install Winamp 5.51, the installer sets "Winamp Agent" to be disabled, even though I had it enabled before.. It always disable it when I install... Bug?
Kn0tte is offline  
Old 3rd December 2007, 19:56   #12
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
@Kn0tte
It helps to provide the full method of reproduction.

For #2, are you maybe double-clicking a saved playlist (m3u, etc) in Windows Explorer to start Winamp with...?

Re #3
What options are you talking about?
If mentioned in some previous post then please provide a link to said post.

And I still can't reproduce #1, though I can't speak for Benski or anyone else.

Re: #4
Yeah, there's something funky going on there, though I'm not sure what.
DJ Egg is offline  
Old 3rd December 2007, 20:09   #13
pjn123
Major Dude
 
pjn123's Avatar
 
Join Date: Jan 2006
Location: /\/¯¯¯¯¯\/\ , South-Africa
Posts: 1,030
Will report this again:

Steps:
1) With the song ticker in bento set to classic scrolling.
2) Now get a song that scrolls the text.
3) Now resize that area bigger, so that the text can fit in the area. The text shouldnt slide now, but it still does and resets back to start position somewhere in the middle of the text scroll.

[Edit --> DJ Egg]
Fixed. Thanks.

ClassicPro© v2.01 : This plugin allows you to use cPro skins in Winamp. ClassicPro skins are all SUI skins and loads very quickly. ClassicPro skins is even easier to skin than Winamp Classic skins. A new layout have been added since version 2.
Download ClassicPro© ==== cPro Skins ==== ClassicPro© Homepage ==== SC Forums
pjn123 is offline  
Old 3rd December 2007, 20:13   #14
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
Quote:
Originally posted by DJ Egg
@Kn0tte
It helps to provide the full method of reproduction.

etc etc etc
1. Benski has said that he can reproduce that bug, but couldnt get it fixed in time for 5.51 (beta).. I can write a list of reproduction, but not right now..

2. Yes, I have a saved playlist on my desktop. I am double-clicking that to start Winamp (and it automatically starts to play song #1 when shuffle is OFF).. Then this bug occurs..
IF I press F5 (refresh), the songtext is showing..
But as I said, this bug only occurs when the songtitle is too short to scroll in the songticker...

3. Yes, here is the link.. See #4..
http://forums.winamp.com/showthread....62#post2272162

"Yeah, the Winamp Modern skin had been a bit neglected.
In 5.51, the WA Modern winshade songticker also has the classic ticker option, and also now has the rt-click options for the Album Art window, and maybe a few other 5.5-related updates.
"

4. OK.. =)
Kn0tte is offline  
Old 3rd December 2007, 20:17   #15
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,336
Winamp Essentials Pack v5.51 Beta

Download: | Mirror 1 | Mirror 2 | Mirror 3

Full Changelog

Changelog:

5.51:
* New: [Installer] Finnish translation from Jusa1
* New: added translations for Time Restore & Autoplay plug-in
* Improved: [Installer] tweaked the script a little bit
* Updated: Nullsoft Waveform Wrapper to v1.0.1
* Updated Lite-n Winamp Preferences to v1.4
* Updated: [Installer] Polish, Spanish, Turkish, French and German translations to v1.07
* Updated: [Installer] to NSIS v2.33

I'm still looking for Essentials Pack translations, if you're able to create a small or update an existing language file, just take a look at this thread: Link
Koopa is offline  
Old 3rd December 2007, 20:37   #16
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
@Kn0tte
Well, I wouldn't have posted to suggest that was the method of reproduction in the first place if I couldn't reproduce it ;-)

Re: #3
Those features are now implemented.
ie. Winamp Modern winshade songticker respects the modern or classic scrolling option,
and the Album Art window now has the right-click options (Get Album Art, etc).
DJ Egg is offline  
Old 3rd December 2007, 20:40   #17
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
Quote:
Originally posted by DJ Egg
Well, I wouldn't have posted to suggest that was the method of reproduction in the first place if I couldn't reproduce it ;-)
Out of that sentence it seems that you might know where the problem is in the code, but I need a good answer.. Heh... Yes or no? :P

[Edit --> DJ Egg]
Yes, I can reproduce it now. No, I don't know the cause or the fix. But maybe Benski does... Please can we drop this subject now, and move on?!

Last edited by Kn0tte; 3rd December 2007 at 20:56.
Kn0tte is offline  
Old 3rd December 2007, 20:50   #18
Chrissyx
Member
 
Chrissyx's Avatar
 
Join Date: Jul 2006
Location: Germany
Posts: 63
Send a message via ICQ to Chrissyx
I see, Win9X users are getting now a messagebox. Would be nice, if you can install anyway...

I like "silly devs"!

At the going down of the sun and in the morning ...
we will remember Winamp ♥
Chrissyx is offline  
Old 3rd December 2007, 20:53   #19
geoffroy
Junior Member
 
Join Date: Jul 2007
Posts: 15
Hi!

I still have the same pb when inserting a CD that Gracenote doesn't match. I press Cancel and then Winamp doesn't "see" the CD and I can't play it.
It works when Gracenote knows the CD.

Best

geoffroy

[Edit --> DJ Egg]
Hmm, I guess you're referring to home-made burned compil CD's, yes? I don't bother with them myself (who needs them?), but this issue will be looked into. Thanks.

[Edit #2]
Hmm. I can't reproduce the problem. It all works fine for me.
geoffroy is offline  
Old 3rd December 2007, 21:47   #20
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,458
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Quote:
Originally posted by Chrissyx
I see, Win9X users are getting now a messagebox. Would be nice, if you can install anyway...
Why, it will not work.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline  
Old 3rd December 2007, 22:15   #21
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
Quote:
Originally posted by Kn0tte
[Edit --> DJ Egg]
Yes, I can reproduce it now. No, I don't know the cause or the fix. But maybe Benski does... Please can we drop this subject now, and move on?!
Yes, we can =) Just fix that and the other bugs, and I will be glad.
Keep up the good work.
Done. "Finito" :-)
Kn0tte is offline  
Old 3rd December 2007, 23:02   #22
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
just switched back to winamp modern and found that opening the media library doesn't bring it to the front (if when it's open it is in a space where the main window or playlist window also are), and clicking on it doesn't bring it to the front. you have to click in the playlist and then the media library windows to make it top.

Request: A little SmartView Query Language love.
osmosis is offline  
Old 4th December 2007, 01:50   #23
Omega X
Forum King
 
Omega X's Avatar
 
Join Date: Feb 2003
Location: A Parallel Dimension
Posts: 2,252
Send a message via AIM to Omega X Send a message via Yahoo to Omega X
Does this build have the bug for the replaygain issue that Update 3 had?
Omega X is offline  
Old 4th December 2007, 02:11   #24
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
@Omega X
No. That issue is fixed (or to be more precise, is a non-issue).
Note, it's virtually the same in_mp3, except that it required a few extra tweaks in winamp.exe and some of the ml plugins (which are in 5.51 beta) for it to work properly.
DJ Egg is offline  
Old 4th December 2007, 04:00   #25
mindlessmissy
Junior Member
 
Join Date: Oct 2007
Posts: 4
I was having a problem with the Final ie. Playlist generator failed to Initialize when i try to play similar tracks..

Tis beta also has the same problem and i was wondering if it was only me experiencing this issue... i am on x64 btw..
mindlessmissy is offline  
Old 4th December 2007, 04:52   #26
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
@mindlessmissy

Alas, you need to delete the Playlist Generator database and start a new scan from afresh.

With Winamp closed, delete the following 2 files:

Winamp\Plugins\Gracenote\cddbplm.pdb & cddbplm.idx

The path will either be the %AppData%\Winamp or %ProgramFiles%\Winamp folder.

The error message should not occur again after this.

The bug was caused in 5.5 by starting the scan but not letting it fully complete before exiting Winamp, which resulted in a corrupt PLG database. The error would also occur at Winamp startup if you had "Automatically start background scanning when Winamp launches" checkmarked in: Prefs -> Plugins -> Media Library -> Playlist Generator (ml_plg) -> config.
DJ Egg is offline  
Old 4th December 2007, 06:02   #27
Zero2FiftyIn4
Senior Member
 
Join Date: Sep 2007
Location: In my head....the voices there are nice
Posts: 170
Waits for someone to come in saying "5.51 is buggy you guys are really dropping the ball" You know someones thinking about typing that even though it says beta

Anyway nice fixes working fine for me so far!

[Edit --> DJ Egg]
Yeah, cue Serpher ;-)

"It is, in the end, whatever the Hell I want it to be,
And when I'm through with it, it's gonna blow a hole,
This wide, straight through the worlds own idea of itself.
They're throwing bottles at your house.
Come on, lets go break their arms."
Zero2FiftyIn4 is offline  
Old 4th December 2007, 08:14   #28
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 145
You won't believe me...

When I installed this new version (and choosed new Winamp Modern skin), installed Winamp Essentials 5.51 and started program - Winamp disappeard!!!
First time I saw something like that...
Winamp showed himself only for first 1-2 sec. and then disappeard. There is only a process, not window.

Anybody knows what happend??

EDIT:
Installation on the older (5.5 Final) version was the cause.
In 'new' place, theres no problem.

EDIT (2):
At old place, when I select Bento skin, Winamps launches 'normal'.
1. ML doesn't show up.
2. Taskbar button doesn't show up.
3. Playlist doesn't show up.
But look at the screenshot I made.



EDIT (3):
Wow, what a buggy version...
1. Error feedback doesn't work (R6025 - pure virtual function call).
2. New EQ doesn't work either...

You know what? I'll wait for new final version...

[Edit --> DJ Egg]
Sorry, but we can't reproduce any of this...
ps. see first post, re: no imageshack!

[Edit #2]
Not sure if this is what you meant, but we can reproduce a problem where if Winamp Modern skin is closed in a minimized state, it disappears from the taskbar on reopen.

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern

Last edited by Serpher; 4th December 2007 at 08:43.
Serpher is offline  
Old 4th December 2007, 08:50   #29
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
for the bento users:
there is a new snap option under menu: options > Window Sizing > Snap to bottom/top when collapsing the main wnd.
For all who like to have bento as a footer app

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 4th December 2007, 08:53   #30
Pidgeot
Senior Member
 
Pidgeot's Avatar
 
Join Date: Jan 2002
Location: Denmark
Posts: 136
The issues described in http://forums.winamp.com/showthread....hreadid=278615 still exist (Bento browser search field/address bar drawing kanji incorrectly, Unicode searches improperly converted to ANSI).

I also found Now Playing to come up with rather strange results for one of my files - I don't *think* it did this in 5.5, but I'm not sure: http://download.birdiesoft.dk/nowplayingbug551.png

I've not been able to replicate it with other files using a similar tag structure, though, so I'm at a loss as to why it's doing this.
Pidgeot is offline  
Old 4th December 2007, 09:20   #31
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally posted by martin.deimos
for the bento users:
there is a new snap option under menu: options > Window Sizing > Snap to bottom/top when collapsing the main wnd.
For all who like to have bento as a footer app
Thats cool! In addition I would suggest you to make the text shown in mcv and songticker to have antialias="1"... That would make it look smooth (as I had been using 5.5 all these days after DJ Egg's suggestion). It would be better if it was in the default Bento.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 4th December 2007, 12:58   #32
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
perhaps there will be an option for this in future, but i cannot promise, since it was taber's and my wish to prohibit antialias

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 4th December 2007, 13:18   #33
daimaah
Junior Member
 
Join Date: Sep 2007
Posts: 4
Quote:
* New: Default Programs registration for installations on Windows Vista
Is that supposed to show up here (screenshot)? Because it doesn't seem to... and still having problems with file associations (and filetype icons) on Vista.

http://i5.tinypic.com/6tb0jmp.png
http://i5.tinypic.com/6tb0jmp.png
daimaah is offline  
Old 4th December 2007, 13:32   #34
J.Heezy
Junior Member
 
Join Date: Mar 2001
Posts: 47
Send a message via Yahoo to J.Heezy
i get this pop-up when when i start winamp with the covertag plugin installed from my previous wa 5.5 install.



the plugin uses the video window to display album art and id3 tags. after i click ok, winamp works fine, but doesn't display anything in the video window.
J.Heezy is offline  
Old 4th December 2007, 13:43   #35
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,458
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
With Bento the video window is a part of the main skin and not a separate window. Try switching to another skin and see if the issue persists. It is something the plugin author will have to resolve, but Winamp does have native Album Art support.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline  
Old 4th December 2007, 13:45   #36
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
@Martin
Antialias looks loads better on e.g. Vista when using fonts like SegoeUI


@daimaah
Did you maybe cancel the Setup section at the end of the installer?
You need to run Setup with the installation, otherwise the Default Programs registry entries won't be created.
This is because Vista will only allow 'elevated' processes to write to the HKLM section of the registry. The installer/setup is elevated when Vista prompts you to confirm the action and allow it to run.

If you did run Setup as part of the installation, and clicked Next -> Next -> Finish, then try running the installer again, but this time when the Setup section appears at the end, try unchecking/checking a couple of extensions on the File Associations page.

It all works perfectly fine for me anyway, heh

http://stashbox.org/56957/Vista_Default_Programs.jpg
http://stashbox.org/56960/Vista_Default_Programs2.jpg
http://stashbox.org/56962/Vista_Default_Programs3.jpg

Or maybe you've disabled the User Account Control thing, and therefore you don't get prompted and the Winamp installer is never elevated - in which case it won't be able to write to the registry (yes, Vista sucks, heh).


@J.Heezy
covertag? Hmmmm...
Which skin are you using?
Does the problem occur with all skins (Classic, Modern, Bento), or just one of them?
Have you tried contacting the 3rd-party plugin author?
DJ Egg is offline  
Old 4th December 2007, 13:51   #37
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
daimaah,
Try running Winamp as an administrator, and then (re)set file associations in Winamp preferences. That might help fix things.

Winamp team,
Thanks for the new release guys! All seems working well so far



~ss
soulstace is offline  
Old 4th December 2007, 14:35   #38
J.Heezy
Junior Member
 
Join Date: Mar 2001
Posts: 47
Send a message via Yahoo to J.Heezy
Quote:
Originally posted by DJ Egg
@J.Heezy
covertag? Hmmmm...
Which skin are you using?
Does the problem occur with all skins (Classic, Modern, Bento), or just one of them?
Have you tried contacting the 3rd-party plugin author?
i like to use the classic skin, but the problem occurs with all skins when using the video window. the plugin is located here,

http://www.angelfire.com/blog/richter/
http://www.angelfire.com/blog/richter/

i will try to contact the author. thanks!!
J.Heezy is offline  
Old 4th December 2007, 15:51   #39
retchless
Member
 
Join Date: Oct 2003
Location: Canada
Posts: 97
Boo.. Skippy video in Vista isn't fixed Any ETA on that one?

Great work on the rest of the stuff! The Bento interface feels much snappier (especially when expanding/collapsing windowshade). Love it!
retchless is offline  
Old 4th December 2007, 16:19   #40
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
No skippy video on Vista here.
Bad/old video drivers or DirectShow splitters/filters/codecs maybe?

What's the system specs?
(cpu, ram, graphics, etc)
DJ Egg is offline  
Closed Thread
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump