Old 11th December 2007, 11:30   #1
ssohn
Junior Member
 
Join Date: Dec 2007
Posts: 2
File type association issue under WinVista x64

While I do enjoy using new Winamp 5.5, there's one issue I'd like to see it fixed in next release.

No matter how many times I reinstall Winamp 5.5, default file types (such as mp3, of course) never gets associated with Winamp automatically on my WinVista x64 system.

Yes, I am aware that I can just go to Control Panel and choose Default Programs to manually associate whatever files types with Winamp, but I am talking about the Winamp's internal bug.

And same problem is still there with Winamp 5.51 beta.

Here's the precedures to reproduce the issue under WinVista x64.

1. Run Winamp 5.5 lite installer
2. Choose only Winamp (required) and Multimedia Engine (including all componets under Multimedia Engine) to be installed.
3. When Winamp Setup started, select preferred skin (Winamp Classic, in my case)
4. In next step, choose preferred file types associations w/ 'Show Winamp in Folder context menu in Windows Explorer' checked.
5. In next step, fill out personal information and choose 'Finish' to complete the setup.
6. Now start Winamp, and double click any mp3 file to see if it is associated with Winamp. (In my case, WMP starts up when I double click mp3 files).

Please, fix this annoying bug in next release.

Thank you.


---edit---
One thing I've noticed is that files which are not originally associated with Windows Media Player (such as .flac files) do seem to get associated with Winamp well. Only files that are associated with WMP stays with WMP even after Winamp installation.

Last edited by ssohn; 11th December 2007 at 14:23.
ssohn is offline   Reply With Quote
Old 11th December 2007, 13:20   #2
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Winamp 5.51 Beta

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 11th December 2007, 14:18   #3
ssohn
Junior Member
 
Join Date: Dec 2007
Posts: 2
>>Sawg,

Thanks for your suggestion, but in my original post, I've stated as following:

Quote:
And same problem is still there with Winamp 5.51 beta.
Maybe, I wasn't clear enough.
I am experiencing the same issue regarding file type associations with the latest beta version of Winamp. (5.51 Build 1741)
ssohn is offline   Reply With Quote
Old 11th December 2007, 15:54   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Right-click the Winamp shortcut icon on your desktop
(you can repeat this for other icons, eg. Start Menu / QuickLaunch)
and select "Run as administrator"

Or to make it permanent, select "Properties" instead,
then click "Advanced"
and checkmark "Run as administrator"

"Winamp -> Prefs -> File Types" will now work :-)
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump