Old 9th August 2000, 07:56   #1
Winner
Guest
 
Posts: n/a
This message was posted by Megaman on July 13. I've search all over the web for a solution, and haven't found one yet. I'm sure a lot of people are affected by this. Please post if you have a solution!!

when trying to tune to a station from a web link..
IE5.5 (Final) prompts for Open/Save the .pls file
and the check box "Always ask before opening this file type" is marked, and unavailable (cant be unmarked).
what can I do?
  Reply With Quote
Old 9th August 2000, 19:00   #2
iomegajaz
Balled and Chained
Alumni
 
Join Date: Jun 2000
Posts: 5,239
I'm pretty sure it has something to do with your IE5.5 security settings. Play around with them a bit and see if this helps at all.

Cheers,
jaz

------------------
http://iomegajaz.cjb.net
iomegajaz is offline   Reply With Quote
Old 10th August 2000, 06:12   #3
Winner
Guest
 
Posts: n/a
Nope. Tried default settings for security and got the same problem. Anyone have some other ideas?
  Reply With Quote
Old 11th August 2000, 05:36   #4
Winner
Guest
 
Posts: n/a
OH... I forgot to mention that I DID play around with the security settings also. The options that seemed to me most likely to affect this did not do anything.
  Reply With Quote
Old 11th August 2000, 06:18   #5
iomegajaz
Balled and Chained
Alumni
 
Join Date: Jun 2000
Posts: 5,239
This is directly from the IE 5.0 Help file:

The Always ask before opening this type of file check box is not available for some file types, such as files with the extensions .exe or .com, which run programs or commands. When this check box is not available, you will always be asked before opening this type of file.

--end extract

With my version of IE (5.0) it never asks me what I want to do, it opens automatically. Sounds like MS has screwed up another "upgrade" with IE 5.5.

Cheers,
jaz

------------------
http://iomegajaz.cjb.net
iomegajaz is offline   Reply With Quote
Old 11th August 2000, 09:08   #6
Winner
Guest
 
Posts: n/a
Thanks, Iomega. I did see that also. But why would microsoft consider .pls to be a dangerous executable file? I did extensive searches of the registry on my system for .pls and terms relating to this quirk, but with no conclusive findings. Maybe another one of those infamous Microsoft patches will be coming for this. Who knows?
  Reply With Quote
Old 11th August 2000, 11:16   #7
iomegajaz
Balled and Chained
Alumni
 
Join Date: Jun 2000
Posts: 5,239
I think MS doesn't trust PLSs, because Winamp is the devil.

Cheers,
jaz

------------------
http://iomegajaz.cjb.net
WSDskins
iomegajaz is offline   Reply With Quote
Old 12th August 2000, 13:17   #8
Dansken
Guest
 
Posts: n/a
Actually Microsoft would do anything to promote their own MediaPlayer 7.x.

Regards Dansken
  Reply With Quote
Old 12th August 2000, 18:31   #9
SNAkEYE
Junior Member
 
Join Date: Aug 2000
Posts: 10
Send a message via ICQ to SNAkEYE
Have u tired to reinstall IE5.5?
Or try to unregister .pls files and register them again... Regedit rulez!!! lol q

------------------
I'm so tired of myself... Ooh god plz take me away...
<UL TYPE=SQUARE>
<LI> iCQ: 44734186
<LI> iRC: #ThEpLaNeT @ irc.ptnet.org
</UL>

[This message has been edited by SNAkEYE (edited August 12, 2000).]

[This message has been edited by SNAkEYE (edited August 12, 2000).]
SNAkEYE is offline   Reply With Quote
Old 5th September 2000, 17:44   #10
Thor
Major Dude
 
Thor's Avatar
 
Join Date: May 2000
Location: Gent, Belgium (Europe)
Posts: 968
Send a message via ICQ to Thor Send a message via AIM to Thor
I've got the smae problem !

Plzzzz !!!
HELP us !!!
Damn ! Nullsoft, READ THIS !!!!


Thor
Thor is offline   Reply With Quote
Old 6th September 2000, 03:28   #11
Winner
Guest
 
Posts: n/a
Well, I've found a Microsoft document that rates directly to this, at
http://support.microsoft.com/support...q232/0/77.asp.

It says that certain file types are hardcoded so the "Always ask before downloading" prompt appears all the time. It does not, however, specify that .pls files are among these. If someone has figured out a fix or easy workaround for this nuisance, please post!!!!
  Reply With Quote
Old 6th September 2000, 03:31   #12
Winner
Guest
 
Posts: n/a
If you could not link to the above location, it's because a period appeared after the URL. Try this:
http://support.microsoft.com/support.../q232/0/77.asp
  Reply With Quote
Old 7th September 2000, 04:04   #13
Surge
Guest
 
Posts: n/a
I managed to fix it. What I did:
Deleted anything related to .pls, .m3u, audio/mpegurl, and audio/x-mpeg-url in the registry.
Reinstalled mplayer 6.4
Reinstalled winamp.
I believe reinstaling winamp was the key (maybe deleting reg values too) since only after doing that did it stop asking me save/open.
  Reply With Quote
Old 7th September 2000, 04:43   #14
Surge
Guest
 
Posts: n/a
Scratch that. Stoped working after first try.
What did work was go into Foler Options (file types), and change the Content Type (MIME) for Winamp playlist fropm wahtever it is to audio/mpeg . Winamp will open it now instantly.
  Reply With Quote
Old 7th September 2000, 16:04   #15
getfah
Junior Member
 
Join Date: Sep 2000
Posts: 7
Yip. That works puff, surge.

Thanks
getfah is offline   Reply With Quote
Old 25th September 2000, 00:01   #16
megaman
Guest
 
Posts: n/a
Thanks Surge, your solution works. (the latter)
  Reply With Quote
Old 26th September 2000, 18:48   #17
Alcatraz
Guest
 
Posts: n/a
Do you have RealPlayer installed?
If so go to your preferences,upgrade,re-associate and unclick mp3 pls.
Than re-associate your pls file in win amp.
  Reply With Quote
Old 29th September 2000, 02:43   #18
jsnow50
Junior Member
 
Join Date: Sep 2000
Posts: 8
I tried changing the association of the winamp playlist to audio/mp3 but winamp kept changing that the winamp playist file association back to audio/mp3url so it would only temporarly work for me (I didn't want winamp to not associate file extentions for me automatically). So anyways the way I fixed this problem was by deleting everything that was associated to winamp in file types, then the next time I opened up winamp it automatically re-associated all the winamp file types, and now I don't have that problem anymore. I think this problem may be cause by not uninstalling an original winamp before installing a newer verion.
jsnow50 is offline   Reply With Quote
Old 30th September 2000, 17:01   #19
TC Sound
Guest
 
Posts: n/a
The answer from surge, "go into Folder Options (file types), and change the Content Type (MIME) for Winamp playlist from whatever it is to audio/mpeg ." is correct, but it will only work if you go into winamp > options > preferences > file_types first.
in winamp filetypes you must UNclick "register file types on winamp start". If you don't, winamp resets it to "audio/mpegurl".

[edited out old erroneous ubb imported code]

[Edited by DJEgg on 01-03-2001 at 10:16 PM]
  Reply With Quote
Old 2nd October 2000, 05:02   #20
Winner
Guest
 
Posts: n/a
Surge and TC Sound, THANKS and HIGH FIVES!!! It worked!!! On my system, the MIME file type was set as "audio/scpls." I had previously tried changing it to "audio/pls," but that didn't work.
  Reply With Quote
Old 4th October 2000, 07:10   #21
jccalhoun
Guest
 
Posts: n/a
Well I can't get the suggested method of file types folder options to work. I change it but as soon as I click on listen, it changes back. I have unchecked the register filetypes on start box in wimamp and it dodn't help. Any suggestions?
  Reply With Quote
Old 12th October 2000, 10:29   #22
PCX1000
Guest
 
Posts: n/a
The solution to this problem is in the web browser not the file associations.Open internet options by right clicking the internet explorer icon on the desktop and choosing properties or in the browser click tools/internet options. Then click the advanced tab,under Browsing uncheck the box on the 12th item down "Reuse windows for launching shortcuts". Press apply,then ok.
  Reply With Quote
Old 25th October 2000, 07:07   #23
GhostKat
Guest
 
Posts: n/a
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by PCX1000:
The solution to this problem is in the web browser not the file associations.Open internet options by right clicking the internet explorer icon on the desktop and choosing properties or in the browser click tools/internet options. Then click the advanced tab,under Browsing uncheck the box on the 12th item down "Reuse windows for launching shortcuts". Press apply,then ok.<HR></BLOCKQUOTE>

I don't feel that this is the culprit. I tested both on and off, what I found was that if I don't have the Winamp agent running, and change the mime type of the extension to audio/mpeg it opens just fine, as soon as I turn on the Winamp agent it resets the mime type back to audio/mpegurl. In my opinion it is the option of having the agent maintain file associations that is causing this problem. as I write this I had the agent off and unchecked the box marked maintain file assoiations then turned on the agent. PLS files work great turn on the option to maintain file associations and it will reset the file mime type. I am unable to dertermine the amount of time it takes to reset the file association because I don't know how long it takes the agent to refresh the assosiations. The way I tested this was to have nothing open on the task bar, and the only programs I have running are task scheduler, Nortoan AV, Norton CrashGuard and the volume control. I have shortcuts on my desktop for a PLS file, Windows Explorer and IE 5.5 among other things. Open an app, change a setting, close the apps down, test it muliple times as this has to work more then just for a few seconds or minute. Hope others can confirm this :-)
  Reply With Quote
Old 10th December 2000, 16:26   #24
george883
Junior Member
 
Join Date: Dec 2000
Posts: 3
i was able to successful reinable this option. the full description is here:
http://forums.winamp.com/ubb/Forum11/HTML/003025.html
george883 is offline   Reply With Quote
Old 12th December 2000, 00:05   #25
claypigeons
Junior Member
 
Join Date: Nov 2000
Posts: 6
Stop making this complicated - all you have to do is click "open it" then your windows system boc will open asking you which program you would like to open it with - just click on "WINAMP" and there you go...
claypigeons is offline   Reply With Quote
Old 30th January 2001, 03:50   #26
Winner
Junior Member
 
Join Date: Jan 2001
Posts: 5
Well, this problem has returned and the fix that worked before no longer works. If anyone has another idea what might be causing this, please post a reply. Thanks.
Winner is offline   Reply With Quote
Old 3rd February 2001, 02:11   #27
Winner
Junior Member
 
Join Date: Jan 2001
Posts: 5
Solution FOUND!

Well, after revisiting the common problems post in the SHOUTcast Discussions forum, the solution for my system was found in a newer thread for the same problem.

The solution was found at http://forums.winamp.com/showthread.php?threadid=37053 .

JWNIN's third post explained: I created the key below, and put in the value below:
HKCR\MIME\Database\Content Type\audio/x-scpls
Extension | ".pls"

This solved the problem, even though my "Content Type (MIME)" setting for "Winamp playlist file" in Windows Explorer is "audio/mpeg" (Windows Explorer: View -> Folder Options -> File Types) AND NOT "audio/x-scpls."

Doesn't seem to make much sense to me, but it works.

If anyone does continue to have this problem despite trying the fix that worked here, visit the thread I pointed to above. It includes more possible solutions with registry hacking.
Winner is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump