Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 29th April 2000, 01:58   #1
Maxine
Guest
 
Posts: n/a
I just installed Winamp 2.61 and I'm quite happy with it. When I double-click on an mp3 file on my own machine, it opens with Winamp. When I click on an mp3 file on a web site from within Internet Explorer it opens with Real Player (my previous player). How can I get Winamp to automatically play mp3 files from my browser?

Thanks,

Maxine
  Reply With Quote
Old 29th April 2000, 20:11   #2
bluetooth
Junior Member
 
Join Date: Apr 2000
Location: Boston, MA, USA
Posts: 26
Send a message via ICQ to bluetooth
Realplayer tries to dominate internet playback (this can be disabled in RealPlayer during install)...what you can do is enable the Winamp Agent (Ctrl+P -> Agent -> Check "Enable Winamp Agent" and "Maintain File Associations") Also, you might have to disable the RealPlayer tray icon thingie (try right clicking on the icon in the tray if its there). I hope this helps.

~Adam

<!-- edited out erroneous old ubb code -->

[Edited by DJEgg on 12-17-2000 at 06:13 PM]
bluetooth is offline   Reply With Quote
Old 2nd May 2000, 04:06   #3
mg
Junior Member
 
Join Date: Apr 2000
Location: Oakland, CA
Posts: 6
Thanks. I tried everything that you suggested, but with no luck. I uninstalled Real Player and only then did the internet Mp3 links correctly played using Winamp. When I re-installed Real Player, it took over the playing of internet Mp3 links. I didn't see any place to disable this feature.

Any other suggestions?

Thanks,

Maxine
mg is offline   Reply With Quote
Old 2nd May 2000, 08:27   #4
KXRM
Guest
 
Posts: n/a
Look in your system tray, while Real Player is off, you will see a little Real Player Icon, right click on it and choose properties, then click Settings for The Real Smart Center, Dispable it by ticking the Disable box in the following dialog, restart your winamp and check to ensure that file type associations are still with MP3.

Try using the browser, if it is still not working, restart your system, and try going into file types and disabling Real Media Associations to MPEG or Audio/mpeg

KXRM http://www.ShoutClub.com
"Broadcasting with the Web in Mind
  Reply With Quote
Old 2nd May 2000, 21:32   #5
mg
Junior Member
 
Join Date: Apr 2000
Location: Oakland, CA
Posts: 6
Thanks for your reply.

I had already disabled Smart Center, and that didn't help. I don't see any Real Media associations with MPEG or Audio/mpeg files.

My Winamp file associations are correctly set.

As I said in my original post, MP3 files are correctly playing with Winamp when the files reside on my machine, but play with Real Audio when they're a link on a web site.

Anybody have another suggestion?

Thanks,

Maxine
mg is offline   Reply With Quote
Old 3rd May 2000, 05:55   #6
bluetooth
Junior Member
 
Join Date: Apr 2000
Location: Boston, MA, USA
Posts: 26
Send a message via ICQ to bluetooth
When RealPlayer 7 runs for the first time, it comes up with a window called "Personalize your RealPlayer". After you press next the 1st or 2nd time, you get the option: "Make RealPlayer the default media player for supported media types". You can leave the box checked, but press customize and make sure that MP3 Audio is unchecked AND MP3 PlayLists (.m3u, .pls) is unchecked. Press "OK" and then press "Next" to continue the personalization process.

~Adam
bluetooth is offline   Reply With Quote
Old 3rd May 2000, 20:21   #7
mg
Junior Member
 
Join Date: Apr 2000
Location: Oakland, CA
Posts: 6
Well, I tried what you suggested, but that didn't work either.

However, I did finally find the solution!

There's another preference in Real Player which I hadn't spotted before. It's on the performance tab, and is called "Playback from Web Links". The description of the setting says:
"RealPlayer can play a clip from a Web page even when the clip has not been set up to stream to RealPlayer from a RealServer by using instant playback. Note: These settings only affect playback in Microsoft Internet Explorer".

This setting is on by default. I turned it off and my problem was solved. This is exactly the kind of thing that got me to switch from Real Player to WinAmp.

Thanks everyone for your suggestions. Hopefully this will help others solve this problem more quickly.

-Maxine
mg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump