Old 6th June 2000, 16:34   #1
Sycia
Junior Member
 
Join Date: Jun 2000
Posts: 1
Hi, I downloaded Winamp quite some time ago, so here's the problem I have:
Winamp automatically registers all sound file types to be opened by the program (winamp). And now, I want to change a few sound file formats to be opened and read by the default programs set by Windows.
However, when I UNSELECT the sound file type under SET: FILE TYPES, I find that sound file is still opened by Winamp, and still retains the same Winamp icon assigned by Winamp and is still named as a "Winamp Media File". I'm afraid to toy around with Window's file setup because of this.
Anyone care to offer a solution or patch for this?

Sycia.
Sycia is offline   Reply With Quote
Old 6th June 2000, 16:53   #2
old and quite mad
Major Dude
 
old and quite mad's Avatar
 
Join Date: May 2000
Location: The PLANET Pluto
Posts: 773
What type files are you trying to play with (I assume) windows media player?
You can "unassociate" a file from winamp but until you "reassociate" it with windows media player, the file will default to its last registered application association.
Open windows media player and you will find a menu that allows you to associate files. Choose the file type you want and proceed.
A word of CAUTION: Do you have winamp agent enabled???? This well-intentioned little beast hangs on to a file extension like white on rice.
Gandalf (a moderator) has written about this somewhere... See his posting for more details.
old and quite mad is offline   Reply With Quote
Old 7th June 2000, 03:04   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
In the Winamp "Options -> Preferences -> File Types" section, try by unchecking the "Register types at Winamp start" option. Choose whichever files you do or don't want associating with Winamp (are you doing this correctly ??? hi-lited blue is "on", white is "off"), then exit Winamp.

If you have it running, also close the Winamp Agent in the systray taskbar. First, you may also want to disable the agent from maintaining file extensions. This can be done in the "Preferences -> Agent" section (uncheck all 3 options)

Next, open WindowsMediaPlayer and goto "View/Tools -> Options -> Formats tab" and re-associate the extensions. Close WMP and I believe that should have solved your problem.

If you want to re-associate WAV with Sound Recorder and Audio CD's with CD Player, then you have to do this via Windows Folder Options -> File Types tab.
Please don't make me have to explain this as well . . . pleeeeasssse !!!!!!!!

If you have any further problems, leave another post here and we'll take it from there. Though, seeing you've not responded to the above reply, you've probably already solved the problem and I've just wasted my time (knowing my luck!) . . . but hey, maybe this will prove useful for anyone else with a similar problem, eh ?!?

Laterz -> DJ-Egg.

ps.
If you do want to associate and maintain Winamp with certain file types then simply do the reverse of the above instructions.
For Real Player related problems, go here
------------------

DJ - Egg

{Edited by Jayn on 12-18-2000 at 11:44 PM}

[Edited by DJEgg on 01-03-2001 at 09:36 PM]
DJ Egg is offline   Reply With Quote
Old 18th August 2002, 01:00   #4
Pagan Wizard
Junior Member
 
Join Date: Aug 2002
Posts: 1
Quote:
If you want to re-associate WAV with Sound Recorder and Audio CD's with CD Player, then you have to do this via Windows Folder Options -> File Types tab.
OK......tried that.......WAV is no longer even listed there, and when I try to create it as a new file type, Windows tells me that WAV files are associated with WinAmp3. I have no idea as to how to rescue my WAV files from the clutches of WinAmp3.

Pagan Wizard is offline   Reply With Quote
Old 18th August 2002, 03:06   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
For starters, this is the WA2 Tech forum, not WA3,
but I'll try to help regardless...

Have you been to:
Winamp3 -> Preferences -> Media
and unselected WAV from the list?
Also uncheck the four options to the right, under "Protect Associations"

Close, reopen and close WA3 again.
Maybe reboot too.

WAV will now no longer be listed under:
"Winamp Media File" in Folder Options -> File Types.

Now, if you want to associate WMP with WAV,
the instructions are the same as above:
WMP -> Tools/View menu (depending on whether it's WMP v6 or v7+)
-> Options -> Formats tab: checkmark "Audio File" (.wav)

To make Sound Recorder the default, the best way would be to associate it first with WMP (as above), then goto:
Folder Options -> File Types tab
Wave Sound (WAV) -> Edit (Win9x) / Advanced (Win2k/ME/XP)
Under "Actions", hi-lite "Play" -> click "Edit"
App used command line = C:\WINDOWS\SNDREC32.EXE /play
Click "Okay"
Back in original Edit/Advanced box, hi-lite "Play", click "set default"
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump