Old 16th July 2000, 11:19   #1
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
Howdy, I downloaded the new version of winamp and some of the visuals. Welp at some point all my jpg icons got coverted to wav icons and they will now only open into winamp. Any ideas on how the fix the dang things?
OkeeGirl is offline  
Old 16th July 2000, 16:23   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Sounds like you've installed a plug-in that supports image formats such as jpg etc.

1. Goto the Winamp Prefs [CTRL + P] and click "File Types".
2. Scroll down the list and uncheck any extensions you don't want associating with Winamp.
NB: Hi-lited blue is on, unhi-lited [white] is off.
3. Click "okay" and exit Winamp.
4. Open the programs with the original associations and re-associate each relevant extension.
If this can't be done via the specific program's options, then you can make your associations via "Windows Settings -> Folder Options -> File Types".

Any further problems, reply below and we'll take it from there !

------------------
*******
DJ - Egg
*******
^/^
`v

[Edited by Jayn on 12-18-2000 at 11:40 PM]
DJ Egg is offline  
Old 17th July 2000, 01:29   #3
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
howdy, the jpg ext. wasn't listed and there was no way to change it from windows folder options. i have just noticed however that not only did it change the icon itself it changed the detail "type" to winamp media.
OkeeGirl is offline  
Old 17th July 2000, 01:44   #4
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

(1) In "Folder Options" the registered file types should be listed alphabetically, and there should be an entry named "JPEG Image", which would normally include the .jpeg, .jpg, and .jpe extensions. Are you using Windows 98 or some other operating system?

(2) The designation of "Winamp media file" as the file "Type" doesn't really mean anything, except that Windows has been told to associate that file with Winamp.

(3) Try the following:

Open Winamp, go to Winamp Preferences (Ctrl+P), and click on "Options". Near the bottom right of the window is an option named "Default extension for unknown file types" and the default is probably "mp3". Erase "mp3", then close Winamp, reboot, and see if anything changes.

Post a reply and let us know what happens. My guess is that you may need to reconfigure the guilty plugin, or delete it altogether if it keeps trying to control your image files.

[This message has been edited by Reverend Ike (edited July 16, 2000).]
Reverend Ike is offline  
Old 17th July 2000, 01:49   #5
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
howdy, jpg wasn't even listed in the ext for winamp and there was no way to fix it under folder options. not only is the icon itself changed but under details "type" is now winamp media. *sigh* i can't find a jpg icon to save my life.

------------------
Thank ya kindly!
OkeeGirl is offline  
Old 17th July 2000, 01:57   #6
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

First, JPG is not normally included in Winamp's list of file extensions, so don't be discouraged because you couldn't find it.

Second, under Folder Options, did you find an entry named "JPEG Image"?

Third, did you try what I suggested and, if so, what happened?
Reverend Ike is offline  
Old 17th July 2000, 02:13   #7
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
ok i tried what you suggested and no change, yes i did find jpeg image under file options then file type but couldn't change the icon

------------------
Thank ya kindly!
OkeeGirl is offline  
Old 17th July 2000, 02:25   #8
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

First - In Folder Options, when you select "JPEG Image" does it say "Opens with: WINAMP"?

(By the way, don't worry about changing icons - the correct icons will automatically return when the file type is fixed)

Second - Do you know what plugin you installed just before your Jpg's started going crazy? (I assume it was some type of Visualization plugin).

Post the answers and we'll go to the next step.


Reverend Ike is offline  
Old 17th July 2000, 02:37   #9
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
we tried 3D plugin, but now we have plugin executable files plus i still have original plug in with winamp, the last we tried was CAP, but that's been deleted too, it was right after those that we updated winamp and then this happened. the jpeg image says it's opened with IEXPLORE
OkeeGirl is offline  
Old 17th July 2000, 02:49   #10
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

Well, that's encouraging - IEXPLORE is the "normal" program for JPEG images.

Sorry about all the questions, but there's a lot of possible causes and it's the only way to narrow it down.

Next steps: Open Winamp and play a song and if you have a visualization plugin that is active, right-click on it and select "Close". Then, go to Winamp Preferences (Ctrl+P), click on "Plug-ins" and make sure that the box next to "Auto execute visualization plug-in on play" is UNCHECKED.

Then close Winamp, reboot, and see if your Jpg files are still Winamp media files.
Reverend Ike is offline  
Old 17th July 2000, 03:02   #11
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
i can play mp3. we havent had any visualizations active since the updated download and the box next to the auto exec was never checked
OkeeGirl is offline  
Old 17th July 2000, 03:15   #12
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

(1) If you right-click on one of your Jpg files, what are the top two choices?

Normally, it would be "Open" (in bold) and "Send to".

(2) If you try to open one of your Jpg files now, does it still try to use Winamp?
Reverend Ike is offline  
Old 17th July 2000, 03:27   #13
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
the jpgs still open into winamp. when i right click on a jpg my options are enqueue in winamp - pay in winamp - add to winamps bookmark list - add to zip - scan with norton - send to - cut - copy - create shortcut - delete - rename - properties.
OkeeGirl is offline  
Old 17th July 2000, 03:52   #14
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

OK, it looks like one of those evil plugins re-wrote the "actions" for your JPG files (Enqueue, Play, Open are all "actions"). So when you try to open your JPG file, it executes the first "action" which is "Enqueue in Winamp".

What needs to be done is "Open" needs to be inserted as the first "action", and the three Winamp actions (enqueue, play, and add to bookmarks) need to be deleted. This is done by going into Folder Options / File Types and editing the "JPEG Image" filetype information.

Well, even if we don't know HOW the filetype actions were changed, it's not too big a deal to fix them. I would suggest that you wait overnight - someone else may be able to offer a shortcut way to make these changes. Otherwise, later tonight I will give you instructions for editing the filetype information the normal slow way. And then everything should be back to normal for you.
Reverend Ike is offline  
Old 18th July 2000, 01:00   #15
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

Well, I guess nobody wanted to offer any shortcuts ...

Before you start, you will want to verify the location of your "iexplore.exe" file. Mine is located at:

C:\Program Files\Internet Explorer\iexplore.exe

If you don't know where it is or can't find it easily, you can click the Start button and select "Find / Files or Folders" and do a quick search to locate it.

Next, open Windows Explorer, select "View / Folder Options", and click the "File Types" tab. Under "Registered file types", scroll down to "JPEG Image" and click the "Edit" button.

You are now in the "Edit File Type" window. Click the "New" button. In the "Action" box, enter "Open" (no quotes) and then click the "Browse" button. Navigate to the location of your iexplore.exe file, select it, and click "Open". Then click "OK".

You are now back in the "Edit File Type" window. Under "Actions", highlight "Open" and click the "Set Default" button.

Next, highlight "Enqueue in Winamp", click the "Remove" button, and click "Yes" in the dialog box. Using the same process, remove the "Play in Winamp" action and remove the "Add to Winamp's Bookmark list" action.

Exit the "Edit File Type" window by clicking "OK".

You are now back in the "Folder Options" window. Under "Registered file types", scroll down to "GIF Image" and click the "Edit" button. If this file type also has three Winamp items under "Actions", you will need to repeat the above steps, making "Open" the default action and removing the Winamp actions.

If "GIF Image" DOESN'T have the three Winamp actions, click the "Edit" button and make a note of the following:

(1) Under "Application used to perform action" write down any commands that appear AFTER the filename. For example, if it says:

...\iexplore.exe" -nohome

write down: [space]-nohome

(2) See if the "Use DDE" box is checked. If it IS checked, write down exactly what appears in the four boxes (named "DDE Message", "Application", etc.).

Click "OK" to exit that window and click "Close" to exit the next window.

You are now back in the Folder Options window.

(A) If "GIF Image" DID have those three Winamp actions, click the "Close" button so you're back in Windows Explorer. Reboot and see what happens. Post a reply if everything isn't back to "normal".

-OR-

(B) If "GIF Image" DIDN'T have those Winamp actions, and you wrote stuff down for items (1) and (2), scroll down, highlight "JPEG Image", and click the "Edit" button. In the "Edit File Type" window, click the "Edit" button. See if all of the information in this window matches what you wrote down. If not, edit it so it does. Be careful that everything matches exactly.

Click "OK" to exit that window and click "Close" to exit each of the next two windows, and you should be back in Windows Explorer. Reboot and see what happens. Post a reply if everything isn't back to "normal".

[This message has been edited by Reverend Ike (edited July 17, 2000).]
Reverend Ike is offline  
Old 26th July 2000, 17:39   #16
OkeeGirl
Junior Member
 
Join Date: Jul 2000
Location: Midwest City, Oklahoma, USA
Posts: 8
WOOHOO!!! It worked!!! Thank ya Thank ya Thank ya!!
OkeeGirl is offline  
Old 26th July 2000, 23:30   #17
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
OkeeGirl -

On behalf of DJ Egg and myself:

Ya welcome Ya welcome Ya welcome!!

Reverend Ike is offline  
Old 14th May 2005, 18:05   #18
Matt2h
Junior Member
 
Join Date: May 2005
Posts: 2
Send a message via AIM to Matt2h
want to change file icon from blueish to white

Do you know how to get rid of that blue hilighting on the icon? I'd prefer white. Perhaps the .ico file for the white icon is online somewhere.. or there's some hidden preference for changing that blueish icon back to white? (in the preferences, actually, it appears as white, but when I close the preferences and everything it actually appears on my computer.. in my folders as blueish tinted) Trying to get rid of the blue tint. Any help would be greatly appreciated. Thanks so much and have a good one
Matt




Quote:
Originally posted by DJ Egg
Sounds like you've installed a plug-in that supports image formats such as jpg etc.

1. Goto the Winamp Prefs [CTRL + P] and click "File Types".
2. Scroll down the list and uncheck any extensions you don't want associating with Winamp.
NB: Hi-lited blue is on, unhi-lited [white] is off.
3. Click "okay" and exit Winamp.
4. Open the programs with the original associations and re-associate each relevant extension.
If this can't be done via the specific program's options, then you can make your associations via "Windows Settings -> Folder Options -> File Types".

Any further problems, reply below and we'll take it from there !

------------------
*******
DJ - Egg
*******
^/^
`v

[Edited by Jayn on 12-18-2000 at 11:40 PM]
[Edit --> DJ Egg]
Please do not revive 5 year old threads, especially with a crosspost
Matt2h is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump