Old 21st September 2000, 18:04   #1
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
I'm actually using Winamp 2.65

Since some versions there's a problem appearing (don't know since which version since I would have backdated to this one) which is more than strange.

My configuration:
- Windows 98 Second Edition
- Creative Labs Soundblaster 16 ASP (Windows-Drivers)
- Changing Graphics card, no matter if Elsa Victory Erazor PCI (latest Elsa Drivers), Guillemot 3D Prophet (Geforce, latest nVidia Reference Drivers) or Asus V7100 (Geforce 2MX, no matter if Asus modified 5.33 Drivers or nVidia 6.18 Reference Drivers)
- Via MVP3 based Socket 7 Board (Tyan S1590 with K6-2 300 and 128MB PC-100 DIMM), latest VIA AGP Drivers in Turbo (AGPx2) Mode

Following problem appears: If something moves on my screen while playing MP3s with winamp I have some distortion in sound output.

This screen movement could be (e.g.)
I hide and restore a fullscreen-window
I run a winamp fullscreen plugin (e.g. the Direct3D "Dancing Can", the 3Dfx-Glide version works without Sound distortion)

The distortion sounds like a stretched cassette tape or a vinyl record when the record player plays at an unregular speed (playback slows down and sound frequency gets lower)

I think it has something to do with the output-plugins (tried DirectSound as well as Waveout) because the same problem appears when playing a WAV instead of a MP3 file.

Any Idea? My Soundcard works great in any other game or application so I don't think it's a hardware problem.
darklord is offline   Reply With Quote
Old 21st September 2000, 18:35   #2
Twilightseer
Frenchoderator
 
Join Date: May 2000
Location: Lavabo, fond du couloir, 3è porte à droite
Posts: 6,309
When the distortion occurs, kick your screen as strongly as you can and the problem will be solved

Seriously though, this is odd. Check that you don't have a pitch/tempo/speed-altering plugin activated: hit ctrl+P, in the window, set DSP plugin at none and see if it works. Sorry, it's all I can think of right now.

------------------
Twilightseer

Life is but a dream
covered by the sky...
Twilightseer is offline   Reply With Quote
Old 21st September 2000, 20:25   #3
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
No DSP plugins active, also tried all priorities for the output plugins (from low to time critical)
darklord is offline   Reply With Quote
Old 22nd September 2000, 11:49   #4
Twilightseer
Frenchoderator
 
Join Date: May 2000
Location: Lavabo, fond du couloir, 3è porte à droite
Posts: 6,309
If it's on, turn off the EQ.
Do your sound files play correctly in other applications such as (sorry) Windows Media Player ?

------------------
Twilightseer

Life is but a dream
covered by the sky...
Twilightseer is offline   Reply With Quote
Old 22nd September 2000, 12:11   #5
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
EQ is always off, Windows Media Player and all other applications have great sound
darklord is offline   Reply With Quote
Old 22nd September 2000, 13:29   #6
Twilightseer
Frenchoderator
 
Join Date: May 2000
Location: Lavabo, fond du couloir, 3è porte à droite
Posts: 6,309
Dammit ! I'm not gonna surrender.
1) Try to update your sound card drivers.
2) In the preference window, choose the Wave out plugin, hit configure and try changing the output device. See if it works.


And if it doesn't work, post again, we will eventually figure out what is wrong and kick the distortion's ass !
I feel better now

PS: Tell me also what version of Media player is installed on your system. I'm not 100% sure but I think I remember a post where someone stated that WMP7 screwed up the sound of the mp3s played in Winamp.

------------------
Twilightseer

Life is but a dream
covered by the sky...


[This message has been edited by Twilightseer (edited September 22, 2000).]
Twilightseer is offline   Reply With Quote
Old 22nd September 2000, 14:25   #7
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
New Sound card drivers: Did not work
Wave out plugin: Worked through the complete permutation of any option. But recognized: When setting small block sizes the sound is really crappy, only with big block sizes I have a chance to play the sounds in good quality when the system is undisturbed (from screen movements). Same with DirectSound Out Plugin
darklord is offline   Reply With Quote
Old 23rd September 2000, 19:03   #8
spumpkins
Junior Member
 
Join Date: Sep 2000
Posts: 1
I had the same problem as darklord, except in my case the distortion (slowed down, broken output) occured with all players I tried - Winamp, Sonique, Windows Media player, Real...and a couple others. After reading your post, I changed my Winamp o/p from the default 'Wave Mapper' to 'DS-XG Wave' and it seems to have done the trick, at least with Winamp (which is my default player so that's all I care about!!)
Thanks for the tip, Twilightseer!
Take it easy,
Vai
spumpkins is offline   Reply With Quote
Old 23rd September 2000, 19:23   #9
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
Hi

this did not work, I could use the Waveout plugin and if I chose Wavemapper or SB16 Waveout it's both the same.

But K-Jöfol (www.kjofol.org) seems to work and as it supports some of the Winamp Plugins I will try the Dancing Can Direct3D Version in some days and look if the sound is distorted again.

My tests ended in the strange result: Winamp is better but K-Jöfol runs better (hmpf, will try to get Winamp running again)
darklord is offline   Reply With Quote
Old 24th September 2000, 12:02   #10
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
I tried around a bit and had following results:

When Winamp distorts the sound slightly when moving, hiding and restoring windows, all other players like Windows Media Player and K-Jöfol are unaffected.

By playing some Direct3D Plugins I can screw up Winamp so far that it even does not play clear when nothing is moving.

Then a slight distortion also begins in the other applications, beginning with K-Jöfol and later continuing with Windows Media Player (by the way I (don't) use Version 6.5)
Quote:
Originally posted by Twilightseer
Dammit ! I'm not gonna surrender.
1) Try to update your sound card drivers.
2) In the preference window, choose the Wave out plugin, hit configure and try changing the output device. See if it works.


And if it doesn't work, post again, we will eventually figure out what is wrong and kick the distortion's ass !
I feel better now

PS: Tell me also what version of Media player is installed on your system. I'm not 100% sure but I think I remember a post where someone stated that WMP7 screwed up the sound of the mp3s played in Winamp.
darklord is offline   Reply With Quote
Old 26th September 2000, 23:25   #11
dice|man
Guest
 
Posts: n/a
If you are running win2K I found this to be a problem. I believe if you are running this OS then it is because of the large amount of RAM you need to just keep the OS running good. When I minimized windows it would become crackly and distorted, also when running multi-apps it would do this. This is the system I run currently, so if you are running anything lower than this then you may have the same problems... 128MB RAM, celly 466 overclocked to 525, Asus board. I think those would be the main things that contributed to speed when playing mp3z so that is all I will list... This problem might could be fixed just by adding more RAM, but since I don't have any compatible sticks handy I can't verify that.

Like said earlier, this is a win2K issue. Win98SE none of these problems occur....


Hope this helps,
dice|man
  Reply With Quote
Old 27th September 2000, 00:04   #12
darklord
Junior Member
 
Join Date: Sep 2000
Posts: 9
*Grmpf* no, I'm running Win98SE. You had SE running on the same machine like 2K?

According to the system manager I have still about 60MB of my 128 available.
darklord is offline   Reply With Quote
Old 27th September 2000, 04:46   #13
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
What version of DirectX do you have?
For details: Start -> Run -> DXDIAG
If you've never upgraded the Win98 v6, then try installing v7 or higher (v8+ recommended)

Also, you might want to try some of the relevant tips from the "problems with freezing & skipping" links in the following thread:
TSGH -> Useful Links

There's potentially loads of internal Windows & Winamp settings that could be causing the problem.

Relevant Winamp settings:
If not set already, try these:
Prefs -> Options | Priority class = Normal
Prefs -> Plugins | Priority = Normal
You've already played around with the WaveOut config [device / buffers / block sizes / priority / etc] so I won't go into that.
Also try DirectSound Output (after you upgrade DirectX, if relevant)
Try checking both "create" & "play primary buffer" in DS Out config.

Also, do you have any General Purpose or DSP/FX plug-ins enabled ?
If so, try disabling them first.

Windows Settings:
Folder Options -> View -> Visual settings
Uncheck : Smooth edges of screen fonts & Show Window contents while dragging

Mouse Control Panel
Motion tab -> Uncheck "Show Pointer trails"

Internet Control panel / IE Options
Advanced tab
Uncheck "Use smooth scrolling"

Try reducing hardware acceleration for graphics:
Win9x/ME: System Control Panel -> Performance tab -> Graphics
WinXP: Display Control Panel -> Settings -> Advanced -> Troubleshoot

There's similar options for Sound acceleration in the Multimedia / Sounds & Audio Devices Control Panel (note: this varies depending on Windows OS)
Audio tab -> Advanced -> Performance

There's also similar options for reducing Hardware Acceleration in the DirectX Diagnostic Tool (dxdiag) -> Sound tab

You've already checked for updated soundcard drivers, but maybe it's time to upgrade to a newer/better card ?!?!

Also, try looking for newer videocard/display adapter drivers.

Other things to check:

Make sure all drives are configured to run in DMA Mode
(System Control Panel -> Device Manager)
Again, the settings vary for each Windows OS.
Win98 = Disk Drives -> (hard drive) -> properties -> settings tab:
Checkmark "DMA"
Ditto for CDROM -> (Drive) -> . . . etc

In WinXP, select "DMA if available" under:
System CP -> Hardware -> Device Manager:
IDE Controllers -> (channel) -> properties -> advanced

etc etc etc

-------
DJ-Egg
DJ Egg is offline   Reply With Quote
Old 28th September 2000, 20:14   #14
DirtyJim
Guest
 
Posts: n/a
I hope I can Help you all with this problem.
The following text is borrowed from the creator of the "pitch fork" plugin for Winamp. Here goes..

....."Also, if your computer has problems with the graphics taking bandwidth from audio
(i.e. sound stutters or slows dows when you scroll or move a window) you will
need to take care of it before attempting to beatmix. This is the fault of the
*display adapter driver*. Changing to microsofts driver (the one that is on the
win95/98 cd) usually solves the problem. If no driver for your card came with
win95, try upgrading to win98. If that didn't work either, look for a setting
like "Allow PCI retries" and enable it. If that doesn't exist (or work) you will
need to bug your manufacturer for new drivers. It is the DRIVERS fault - not the
hardware - but if you can't get an updated driver or information on how to fix
the problem with your present driver (there is usually an undocumented option to
enable through the INI file)"

Also, I found IMMENSE help by increasing the buffer size for the output in the options/preferences/plugins/output configure option. Crank it up man. It helped a great amount.
  Reply With Quote
Old 28th September 2000, 22:29   #15
DirtyJim
Guest
 
Posts: n/a
After several bios adjustments and other winamp tweaks, I found no one adjustment that cured the problem, however adjusting the output buffer size made a noticeable improvement. As for my previous post, I only added it for information, although I have found nothing there that really worked. There are No inf. files for the win98se ver. driver for my card that could be molested with my trusty keyboard. I still believe that the problem is definitely a video card issue lying somewhere in the bus transfer area.
After reading several other posts, I found only one thing that worked 100 percent.
roll back the hardware acceleration slider in the Graphics Performance tab in System Properties menu. Some people said to set it to minimum, then set it back up when gaming.
I found that I only had to bring the slider back one increment and all of my stutter problems disappeared completely. I currently use an addon voodoo2 card for gaming, so I dont know if the hardware acceleration slider affects the performance of the voodoo2 card or not. Havent tried it. A new GeForce card is on the way, so Ill have to explore this all over again if the problem comes back. This card is AGP, so setting the Graphics Aperture size in bios to 128 or greater may help improve agp bus performance.

Well find a cure soon. gl
  Reply With Quote
Old 13th April 2002, 16:20   #16
BBnet3000
Junior Member
 
Join Date: Apr 2002
Posts: 16
Quote:
Originally posted by spumpkins
I had the same problem as darklord, except in my case the distortion (slowed down, broken output) occured with all players I tried - Winamp, Sonique, Windows Media player, Real...and a couple others. After reading your post, I changed my Winamp o/p from the default 'Wave Mapper' to 'DS-XG Wave' and it seems to have done the trick, at least with Winamp (which is my default player so that's all I care about!!)
Thanks for the tip, Twilightseer!
Take it easy,
Vai
This is the problem ive been having, but makin the change he said above DID NOT WORK!! All my sound files (128k and above) sound like 40 k streams or worse!!!! (*cry for help please*)
BBnet3000 is offline   Reply With Quote
Old 20th February 2003, 03:30   #17
DUCKMON69
Junior Member
 
Join Date: Feb 2003
Posts: 1
distortion

thanks

changing graphics accelleration in system properties from full to one step less vastly improved both the problem with distortion as well fixing a mouse prob i was having.

thanks again
DUCKMON69 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump