Old 9th May 2000, 18:50   #1
itipton
Junior Member
 
Join Date: Apr 2000
Location: San Luis Obispo
Posts: 3
Send a message via ICQ to itipton
I believe I have a solution for those who have MusicMatch Jukebox installed and cannot get Winamp to auto play CD's. I noticed WinAmp would not auto play and would not let me reselect the "associate CD's with Winamp" option in Winamp's preferences after installing a MusicMatch upgrade. If you are in the same situation, I solved the problem by uninstalling both Winamp and MusicMatch and then reinstalling Winamp first and then MusicMatch. I went so far as removing all references to both programs in the Registry. My opinion is that this may not be necessary but it doesn't hurt either. Before reinstalling MusicMatch be sure the following options are selected in Winamp: "Register types on WinAmp start", "Enable Winamp agent", and "Maintain file associations." This should allow you to maintain the CD association when MusicMatch is reinstalled. It worked for me I hope it helps those with the same problem.

Note: I have had the same problem with the two programs with past versions. I hope someday someone figures out how to avoid it, it's a pain in the butt.
itipton is offline   Reply With Quote
Old 12th May 2000, 08:24   #2
czar
Guest
 
Posts: n/a
Thank you so much ! - just what i was looking for.

  Reply With Quote
Old 12th May 2000, 12:58   #3
Cody
dot com bomb
Beta Team
 
Join Date: May 2000
Location: PA USA
Posts: 111
Yes thank you vary much for the Info.
Cody is offline   Reply With Quote
Old 17th May 2000, 03:14   #4
MitchB
Guest
 
Posts: n/a
I don't have Musicmatch and still the Associate with audio CD, will not stay checked. I have even gone so far as to remove and reinstall and also have gone into the folder options to assign it, but it still unchecks it after reboot. What can I do to keep this checked off?
  Reply With Quote
Old 20th July 2000, 11:25   #5
Dr-Wily
Junior Member
 
Join Date: Jul 2000
Posts: 1
Originally posted by MitchB:


> I don't have Musicmatch and still the >Associate with audio CD, will not stay >checked. I have even gone so far as to >remove and reinstall and also have gone >into the folder options to assign it, but >it still unchecks it after reboot. What can >I do to keep this checked off?


This is something inherent in WinAmp and/or MusicMatch and/or RealJukebox for over 2 years now. I've tried to isolate what causes it, but, it only occurs when one of these other programs is installed along with WinAmp, and WinAmp is associated with audio CD's.


At first, with MusicMatch, the solution was to install the software in specific order, but, even that doesn't work now. Here's the one sure fire fix I've found for this. (I had to do this myself just last week after updating MusicMatch.)


Use REGEDIT.EXE, the Microsoft Registry Editor. NOTE! There are a few things to be aware of with REGEDIT. 1.) Sometimes, REGEDIT won't run on a system. (It wouldn't on mine; it just sits there after executing.) If REGEDIT.EXE won't Run in the Run button, then, if you've got Norton SystemWorks, use Norton Registry Editor. (It's what I have to do.) 2.) Not knowing what you're doing can really screw things up, so, use REGEDIT to make a backup of the Registry first.


Find the text "AudioCD" Under that should be the following:

Shell (Default Value) is "Play"
Previous Default "Some text here"

If you don't have a Previous Default, skip it. If you do, highlight Previous Default and right click on it. Choose Modify. Replace whatever text "Some text here" is with the following text:

"WINAMP.EXE" %1

Be sure to put in the folder/directory path of where WINAMP.EXE is before WINAMP.EXE, e.g. C:\WINAMP\WINAMP.EXE


Also under Shell, you should see this:

Play (Default Value) (value not set.)
Command (Default Value) "Some text"


Repeat the above steps and replace "Some text" for Command (Default Value) with the WINAMP.EXE text from above.


Close your Registry editor of choice and insert an audio CD. WinAmp should now return to being your CD player of choice.


[Edited by Jayn on 12-20-2000 at 03:19 AM]
Dr-Wily is offline   Reply With Quote
Old 26th August 2000, 20:10   #6
Vikander
Junior Member
 
Join Date: Aug 2000
Location: Montreal, Quebec, Canada
Posts: 2
I can't seem to associate winamp with audio cd's and I have installed Music Match in the past. I tried the registry thing listed below but my registry looks different than what is described. To the right of Audio Cd, I have Default Value - value not set. Within the Audio CD dir, I have a shell dir - to the right of that I have Default Value - value not set...and that's it. How do I fix this so winamp will automatically start playing cd's when I put them in the drive. Thanks
_____________________________________________________________________

Quote:
Find the text "AudioCD"
Under that should be the following:

Shell (Default Value) is "Play"
Previous Default "Some text here"

If you don't have a Previous Default, skip it. If you do, highlight Previous Default and right click on it. Choose Modify. Replace whatever text "Some text here" is with the following text:

"WINAMP.EXE" %1

Be sure to put in the folder/directory path of where WINAMP.EXE is before WINAMP.EXE,
e.g. C:\PROGRAM FILES\WINAMP\WINAMP.EXE


Also under Shell, you should see this:

Play (Default Value) (value not set.)
Command (Default Value) "Some text"


Repeat the above steps and replace "Some text" for Command (Default Value) with the WINAMP.EXE text from above.


Close your Registry editor of choice and insert an audio CD. WinAmp should now return to being your CD player of choice.
_____________________________________________________________________

[EDIT]

Further instructions inserted by DJ-Egg

My Computer/HKEY_CLASSES_ROOT/AudioCD

In left column, hi-lite entry for AudioCD
In right column, hi-lite entry for (Default)
From Edit menu, select modify
Type in : AudioCD -> Okay
Data entry should now read as "AudioCD"

In left column, hi-lite entry for AudioCD
From Edit menu, select New -> Binary value
Name the value EditFlags -> Enter
Hi-lite -> Edit -> Modify -> Type in : 02 00 00 00 -> Okay
(if EditFlags already exists, simply modify the value data as above)

In left column, hi-lite entry for AudioCD
From Edit menu, select New -> Key
Name the key DefaultIcon -> Enter
From Edit menu, select New -> String
Name the string (Default) -> Enter
Edit -> Modify -> Value data
Type in : C:\WINDOWS\SYSTEM\shell32.dll,40 -> Okay
* (Default) string should already exist when new key is created, so simply modify Value data.

In left column, hi-lite Shell
In right column, hi-lite (Default) -> Edit -> Modify
Type in : Play
(You'll need to create this key/string, as above, if it doesn't already exist)

In left column, hi-lite Shell
From Edit menu, select New -> Key
Name the key : Play -> Enter
From Edit menu, select New -> String
Name the string (Default) -> Enter
Edit -> Modify -> Value data = &Play
(or modify (Default) string if it already exists)

In left column, hi-lite Play
From Edit menu, select New -> Binary value
Name the value EditFlags -> Enter
Hi-lite -> Edit -> Modify -> Type in : 01 00 00 00 -> Okay

In left column, hi-lite Play
From Edit menu, select New -> Key
Name the key : command -> Enter
From Edit menu, select New -> String
String name = (Default) -> Enter
Edit -> Modify -> Value data = "C:\Program Files\Winamp\Winamp.exe" %1
(or modify (Default) string if it already exists)

I could do with someone confirming the command line because my default CDPlayer is CDSpectrumPro
The command line for that is:
C:\PROGRAM FILES\CDSPECTRUM PRO\CDSPRO.EXE /play %1
The command line for Windows CDPlayer is:
C:\WINDOWS\CDPLAYER.EXE -play %1

You can add as many keys as you wish under "Shell" if you follow the basic pattern above.
Each new key should have a different name, eg:
Play | Play with CDPlayer | Play with Winamp | Play with CDSpectrum Pro | etc
Whichever key you specify in "Shell -> (Default)" will be the default action.

Please note that you should only attempt to modify the Registry if you are qualified & experienced enough.
Even though I've outlined the exact procedure above, only execute these orders if you are confident enough to do so. Otherwise, get someone qualified to do it for you instead.

A much easier way would be to goto:
Start -> Settings -> Folder Options -> File Types
Scroll down for AudioCD
Hi-lite -> Edit
You can set all the default actions | display icon | etc. from here, without having to worry about potentially messing up your Registry. Tho', I'd say that your Registry is already messed up if you're reading this!
Post a new message in this thread if you need further instructions.
Alternatively, use the forum search facility or "TSGH -> Useful Links" to find the directions.

Another important thing to check is:
System Control Panel -> Device Manager
CDROM -> expand & hi-lite name of CD-ROM -> Properties -> Settings tab
Make sure "Auto insert notification" is checkmarked.
Make sure all the other relevant settings comply with your system, etc.

Remember that you should also be able to play your AudioCD's in Winamp by choosing:
"Play -> AudioCD" from the main Winamp menu.

I hope this helps -> DJ-Egg.

[/EDIT]

[EDIT #2]

UPDATE:

Don't bother with all ^this^ manual crap

From: TSGH -> Useful Links

RE: Problems with AudioCD : Playback / Association / Autorun / CDDB
http://forums.winamp.com/showthread.php?threadid=52410 (MMJB "associate with" bug)
http://forums.winamp.com/showthread.php?threadid=40123 (Win9x/ME regfix)
http://support.microsoft.com/support.../Q259/4/73.ASP (Win2k/XP fix)


[/EDIT #2]
Vikander is offline   Reply With Quote
Old 7th October 2000, 08:25   #7
syieka
Guest
 
Posts: n/a
I had the same problem. After trying all the suggestions in this forum (including X-teq X-Setup), I still had the same problem. That darned box just wouldn't stay checked.

I solved it by uninstalling the CD player that came with Windows (via Windows Setup in Add/Remove Programs of the Control Panel). Then I reinstalled it. Then I reinstalled WinAmp. Finally autoplay in WinAmp worked!

Originally posted by Vikander:
I can't seem to associate winamp with audio cd's and I have installed Music Match in the past. I tried the registry thing listed below but my registry looks different than what is described. To the right of Audio Cd, I have Default Value - value not set. Within the Audio CD dir, I have a shell dir - to the right of that I have Default Value - value not set...and that's it. How do I fix this so winamp will automatically start playing cd's when I put them in the drive. Thanks


  Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump