Old 13th November 2000, 20:52   #1
EclecticBoogie
Guest
 
Posts: n/a
Yo, my Winamp player is continually skipping mp3s. It only happens when I start doing something on my computer like open up explorer or any other program. It also skips when I use the mouse wheel and scroll down a page. I have tried installing the newest player, but it didn't work. I have a newer, fast computer...Windows 98, AMD processor. I also tried putting all of the priorities up all the way on the player. Still didn't work. I'm hopeless. Please respond soon as I am slowly going insane...Thanks.
  Reply With Quote
Old 13th November 2000, 22:43   #2
fish
Pretty Cool Guy
 
Join Date: Sep 2000
Location: Cle, OH, USA
Posts: 4,847
Send a message via AIM to fish
Close all programs you don't need at the time and if that doesn't work, reboot to clear the RAM.
That should clear it up - it worked for me.
fish is offline   Reply With Quote
Old 14th November 2000, 06:47   #3
cwg01
Member
 
Join Date: Oct 2000
Posts: 75
Good luck.
Does it to me all the time, especially when I'm moving windows about.
I've tried everything to make it stop, it the situation is, when windows needs the CPU Power, it's going to take it.
BTW: TechSpecs.
AMD-K6 350mhz
96megs RAM
20gig WD hard drive with 9ms access.
OLD Soundblaster 16.
Diamond Speedstar Video.
DidIleaveanythingout?

------------------
turbochargedbylynx
cwg01 is offline   Reply With Quote
Old 15th November 2000, 06:08   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
cwg01
I think you may have hit the nail on the head with OLD SB16
Maybe it's time to upgrade to an SBLive ?!?!
(or a better quality, none-CreativeLabs soundcard)

EclecticBoogie [nice name, btw]
Including your full sys specs always helps.
See cwg01's example, although he did leave out his Windows OS (oops, naughty).
Anyway, if this problem mainly occurs when you scroll pages in Explorer, there's a few settings that you may want to check are disabled.

Folder Options -> View tab
Visual Settings :
1. Show windows content while dragging
2. Smooth edges of screen fonts

Internet Explorer Options -> Advanced tab
1. Use smooth scrolling
2. [optional] Enable page transitions

TweakUI -> General tab
Uncheck "Smooth Scrolling"

Mouse Control Panel -> Motion tab
Uncheck "Use pointer trails"

Try unchecking all the above options and see if they have any effect.

Other things you can do:
Make sure you've got the latest drivers for both your soundcard & videocard.
Make sure you've got DirectX v7.0a or higher (current version = 8.1a)

Details c/o DirectX Diagnostic Tool
C:\Windows\System\dxdiag.exe
(start -> run -> dxdiag)

Plus:
Multimedia Control Panel -> Devices/Advanced tab
Audio Compression Codecs:
Change the priority orders of the codecs by placing the ones you use most to the top.
This is done via the "Properties" for each individual codec, eg.
Mine are set with the Fraunhofer MPEG Audio codec = #1, M$ ADPCM = #2, WMA codec =#3, etc.

Talking of which, make sure you have got at least the Advanced version of the Fraunhofer MP3 codec (this comes with WMP6.4), though the Professional version is the one you should really look for

You can also increase the playback buffer in:
Media Control Devices -> Wave Audio Device -> Properties -> Settings.

Also, check your soundcard & videocard settings in:
System Control Panel -> Sound, video & game controllers
Look for any anomalous settings that may be causing the skipping phenomenum.
Particularly check to see if the 2 cards are sharing any resources.
One way round this, apart from editing the BIOS settings @ bootup, is:
Add the following line to the SYSTEM.INI file (Windows dir)
[display]
busthrottle=1

As you can see, there are many different things that can cause skipping.
It could be one little setting, one dodgy driver, or a combination.
The best way to troubleshoot is the process by elimination method.
Especially if your sys specs are well above the minimum requirements for MP3 playback.
__________________________________________________________________

[addendum]

There's always Winamp workarounds you can try, namely tweaking the buffer settings etc in the Input & Output plugins.

There's already plenty of information scattered all over the forums regarding tweaks for the default WaveOut plugin. The best of these can be accessed via TSGH -> Useful Links -> Problems with Skipping section.

However, imho, the DirectSound Output plugin provides a better solution for those who are suffering the skipping phenomenum.

Prefs (Ctrl+P) -> Output -> DirectSound -> config
Increase "Main Buffer" size to max (5s)
Change "Output Device" to soundcard driver (c/o drop-down menu)
DirectSound Block Size - increase to somewhere between 32 & 64k (max)
Checkmark both: Create & Play Primary Buffer
Polling Delay - Increase to 20ms or higher (max=100)

Don't go straight to max on all settings, use my recommendations first, then increase further if needs be so. Naturally, you need to keep DirectSound hi-lighted for it to remain active before you close the prefs.

For input plugins . . . and in this particular case, MP3:
Prefs -> Input -> MPEG Audio Decoder -> config
General tab -> full file buffering: increase this value, eg. I have mine set to 512 kb, you might want to try 1024kb (1mb), or 2048, or even 5120.
For internet streams: goto the Streaming tab
Increase "streaming data buffer" (same principle as above)
Increase "Streaming Pre-Buffer" slider/s.

Hope this helps!


[IMPORTANT UPDATE]

WA2.78 users, install this official update patch:
Winamp 2.78 Update

Updates both out_wave & out_ds plugins to peter's new versions, also updates in_mod.dll, in_midi.dll & in_wave.dll to new pre v2.79 / 2.80 versions.
Also includes optional Experimental DS Output, extra Gapless WaveOut, in_vorbis.dll . . .

Further details: (READ THIS FIRST)
http://forums.winamp.com/showthread.php?threadid=68811


Basically, the new output plugins provide better skip protection.
Once the update is installed, open Winamp & goto:
Winamp Prefs -> Plugins -> Output
Select one of the new DirectSound Outputs to make it active
(Crossfading DS or Experimental DS).
You can also increase the buffer size in the plugin's config,

Full instructions here:

DirectSound Output Manual:
http://www.blorp.com/~peter/ds_manual.htm



-------
DJ-Egg

[Edited by DJEgg on 04-03-2001 at 03:37 PM]
DJ Egg is offline   Reply With Quote
Old 18th November 2000, 16:02   #5
mattjsimps
Senior Member
 
Join Date: Nov 2000
Posts: 107
Is your video card and sound card both PCI? i had that prob on my computer and its because both the video and sound cards are trying to use the same bus and there "aint enough bandwidth on this ere Computer for the both of us"


mattjsimps is offline   Reply With Quote
Old 19th November 2000, 05:35   #6
magnezium
Guest
 
Posts: n/a
you just might wanna try playing around with your plugin settings. try configuring your waveout plugin as such:

buffer length: 7000ms
priority: time critical
max blocks: 28
max blocksize: 64kb
min blocksize: 8kb

you may also want to change your mpeg decoder's process thread priority to highest. hope this helps. =]
  Reply With Quote
Old 27th January 2001, 19:48   #7
cwg01
Member
 
Join Date: Oct 2000
Posts: 75
Reply Above or Below? Decisions, decisions....
Above.
After being away for a period of time in which I was in programming mode, I came back by to see how some of them there old threads I left hanging were doing.
For all revelant readers, Unchecking 'Show window contents' does eliminate that stutter.
Smooth Edges was off.
And upgrading sound card was also a help.
BTW: old card was dropped into a bare bones machine which is used for nothing more than creating HUGE wave files, like 30-60 minutes in size.
Runs in a OLD 486dx66 machine with a BARE BONES Windows install.
Ultimate in recycling, I'm fixing to resurrect another old 486 for a print server.

Quote:
Originally posted by DJEgg
cwg01
I think you may have hit the nail on the head with OLD SB16
Maybe it's time to upgrade to an SBLive ?!?!

EclecticBoogie [nice name, btw]
Including your full sys specs always helps.
See cwg01's example, although he did leave out his Windows OS (oops, naughty).
Anyway, if this problem mainly occurs when you scroll pages in Explorer, there's a few settings that you may want to check are disabled.

Folder Options -> View tab
Visual Settings :
1. Show windows content while dragging
2. Smooth edges of screen fonts

Internet Explorer Options -> Advanced tab
1. Use smooth scrolling
2. [optional] Enable page transitions

Try unchecking these options and see if they have any effect.

Other things you can do:
Make sure you've got the latest drivers for both your soundcard & videocard.
Make sure you've got DirectX v7+
[C:\Windows\System\dxdiag.exe]

-------
DJ-Egg
cwg01 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump