Old 20th June 2000, 20:50   #1
fatal_error_909
Junior Member
 
Join Date: Jun 2000
Posts: 3
help! i had a hard drive failure and just got my pc back. when i installed winamp, it won't let me associate it with cd's. if i check the box that says 'associate with cd's' and close and the reopen, the box is unchecked! what's going on? how can I fix it?

oh yeah, i'm running win98se
fatal_error_909 is offline   Reply With Quote
Old 21st June 2000, 05:06   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Does your PC actually play Audio CD's and, if so, what is the current default player ?

Can you play CD's in Winamp by using the "Play Audio CD" option in the File Menu ?

Have you checked out Windows "Settings -> Folder Options -> File Types" to see if there is an entry for Audio CD ?
If not, then you may have to re-install Windows !
However, the entry should already exist. Click on "Edit" and then "New".
In the Action Field, type : Play In Winamp
In the App. Field, type : "C:\PROGRAM FILES\WINAMP\WINAMP.EXE"
Click OK, then in the original Edit Box, hi-lite this new entry and click "Set Default".

If none of the above works, then I'm pretty much baffled !

BTW, what's your soundcard and have the [current] drivers been properly [re]installed ?

Post a reply !

------------------
*******
DJ - Egg
*******
^/^
`v

[Edited by DJEgg on 02-10-2001 at 03:03 AM]
DJ Egg is offline   Reply With Quote
Old 21st June 2000, 08:19   #3
Mr. Ice
Captain Moderator
 
Join Date: May 2000
Location: USA
Posts: 763
the easier thing to do would be to enable the winamp agent to prevent whatever program is stealing the association from doing so. (preferences -> setup -> agent. check all three boxes.) note that you'll have to turn off the agent if you want to run scandisk or defrag (or any program that does the same thing).

on a guess, do you have realplayer, realjukebox, or any other programs by real installed?

[Edited by Jayn on 12-20-2000 at 12:46 PM]
Mr. Ice is offline   Reply With Quote
Old 21st June 2000, 10:05   #4
fatal_error_909
Junior Member
 
Join Date: Jun 2000
Posts: 3
Well, I got Winamp to play my CD's when I insert them. Thanks for the tip DJEgg. I don't know why I didn't think about that. Allthough I think I will reinstall Windows. I am all of a sudden having too many problems. what I tried first was to uninstall Winamp and see if the defualt windows CD player would play the CD's. It would play them if I opened the CD player and manually pressed play, but it wouldn't automatically start. There was no defualt player for audio CD's. I think that Gateway screwed up the installation. Anyway (don't ever buy a Gateway, it's not worth it!) I am about to FDISK and start from scratch. Hopefully, that fixes my problems. Oh yeah, I have a SBLive! Value. I didn't install the drivers for it, they were preinstalled by Gateway. But I checked it out and the drivers are the latest, so I don't think that has anything to do with it. (Although I am looking for a new sound card. Any suggestions welcome, preferably audio recording cards.)

And no, Mr. Ice, I haven't installed any Real products yet. I hate real Real Player and am looking for a decent alternative before I reinstall it. And Winamp Agent is enabled, and the problem persits.

Thanks guys, I'll post again to let you know if it works after I reinstall my system.

Peace, Cheers & Beers, And All That Jazz. Catch ya on the flipside...
fatal_error_909 is offline   Reply With Quote
Old 21st June 2000, 23:35   #5
mjp9055
Junior Member
 
Join Date: Jun 2000
Posts: 6
i was having this same problem...here is what you need to do...

download x-setup, http://www.xteq.com/downloads/index.mv#xset, it is a program along the lines of tweakUI, but far better...once you have installed it, run it (you can get to it thru the control panel)

click on system
then on file system
then on cd autostart
then on autostart audiocd

check the box that reads "play audio cd-roms automatically"

exit and restart your machine...

then re-install winamp and your audio cds should autolaunch...

also, do you have the autolaunch option enabled on that drive?

right click on "my computer" --> properties --> device manager --> cd rom -> click on the correct drive --> properties --> settings --> check the auto insert notification box

you will need to restart your machine again after this...

hopefully this will solve your problem...


[This message has been edited by mjp9055 (edited June 21, 2000).]

[Edited by Jayn on 12-20-2000 at 12:47 PM]
mjp9055 is offline   Reply With Quote
Old 22nd June 2000, 03:03   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
mjp9055 has a good valid point there. I should've thought of that too [Re: Device Manager -> CD-ROM -> Properties etc.]

Another utility that's similar to x-setup / tweakUI is More Properties, a freeware download from http://www.imaginary.co.za/ which also gives you the enable autoplay CD option, along with many many other top tweaks etc.
I highly recommend it . . . trust me !

Anyway, glad to be of assistance & best of luck.

ps. For anyone having problems with unassociating extensions from that darn pesky Real Player . . . go here. Follow the simple instructions and then open Winamp afterwards to associate file extensions with WA to your hearts' content.

------------------
*******
DJ - Egg
*******
^/^
`v

[This message has been edited by DJEgg (edited June 22, 2000).]

[Edited by Jayn on 12-20-2000 at 12:48 PM]
DJ Egg is offline   Reply With Quote
Old 23rd June 2000, 07:25   #7
Roger W
Junior Member
 
Join Date: Jun 2000
Posts: 4
I have been having the exact same problem and I used your suggestions and I am VERY VERY VERY VERY thankful, because WinAmp now plays my CDs again as soon as I insert them.

Thank you guys very much!

*dances to CD autoplaying on WinAmp*
Roger W is offline   Reply With Quote
Old 24th June 2000, 04:48   #8
slim-shady
Junior Member
 
Join Date: Jun 2000
Location: independence, iowa
Posts: 1
i'm kinda havin the same problem but with mine winamp will play the cd but i cant hear anything. the songs will show up in the playlist and winamp will act like its playin and the time is runnin and everything but i cant hear the music. i can hear the music for everything else i play but cds. any suggestions. help please.

slim-shady
slim-shady is offline   Reply With Quote
Old 24th June 2000, 05:01   #9
sgtfuzzbubble011
 
sgtfuzzbubble011's Avatar
 
Join Date: Jun 2000
Posts: 60,837
If the cd-rom drive you are using is connected with another IDE device, you need to make sure that it's not the slave device. You can only hear audio cds if the cd-rom is the master IDE device.
sgtfuzzbubble011 is offline   Reply With Quote
Old 24th June 2000, 08:52   #10
Mr. Ice
Captain Moderator
 
Join Date: May 2000
Location: USA
Posts: 763
sgtfuzzbubble99, that info is absolutely wrong. it makes no difference if an ide cd-rom is master or slave.
Mr. Ice is offline   Reply With Quote
Old 24th June 2000, 09:01   #11
sgtfuzzbubble011
 
sgtfuzzbubble011's Avatar
 
Join Date: Jun 2000
Posts: 60,837
When I put in an audio cd in a slave cd-rom, it wouldn't send the sound to the sound card. When I put the cd in a master cd-rom drive, the sound was sent to the sound card. I should know, I've got two cd-rom drives. If I'm wrong, what's right?

[This message has been edited by sgtfuzzbubble99 (edited June 24, 2000).]
sgtfuzzbubble011 is offline   Reply With Quote
Old 24th June 2000, 09:06   #12
Tom
Moderator
 
Join Date: Apr 2000
Posts: 4,491
sgtfuzzbubble99,
What Mr. Ice said is correct. I have two CD-ROMS (on master and one slave) and they both can play audio just fine.
As for your problem it is likely that the Slave drive doesn't have a wire going to the soundcard like the Master does. If this is the case you would need to install a wire or install the CD Reader plugin so the aduio is extracted as data rather than passed to the soundcard via that wire.

Tom
http://players.shoutclub.net
Tom is offline   Reply With Quote
Old 24th June 2000, 09:18   #13
sgtfuzzbubble011
 
sgtfuzzbubble011's Avatar
 
Join Date: Jun 2000
Posts: 60,837
Thanx for the info. I'll do that
sgtfuzzbubble011 is offline   Reply With Quote
Old 24th June 2000, 21:02   #14
fatal_error_909
Junior Member
 
Join Date: Jun 2000
Posts: 3
Well, I got my system back up and Winamp is running fine. I noticed this though, on my system, when I uninstall the Windows CD player, nothing is associated with CD's. Maybe it's a bug in the Gateway installation disk. What I did (this is for anyone who owns a Gateway/Dell/etc...) is downloaded the Windows 98 bootdisk from www.bootdisk.com. If you don't want all the crap that your PC manufacturer has setup to install from their disks, you can get a normal Windows installation using a standard boot disk.

One more question... Does anyone know of a CDDB address that the CD Reader plug can use? I have a DSL connection, and evertime I put a CD in, it either can't find the host or can't resolve the host. It's like it thinks my PC is not connected to the internet when in fact it is.
fatal_error_909 is offline   Reply With Quote
Old 24th June 2000, 23:21   #15
Tom
Moderator
 
Join Date: Apr 2000
Posts: 4,491
For the CD Reader plugin use the address cddb.cddb.com for the cddb connection
Tom is offline   Reply With Quote
Old 24th June 2000, 23:25   #16
sgtfuzzbubble011
 
sgtfuzzbubble011's Avatar
 
Join Date: Jun 2000
Posts: 60,837
Tom,
thanx for the help. I got my slave cd drive to play music like you said.

Mr. Ice,
sorry for posting incorrect information. Just trying to help out. But from now on I'll try and make sure that what I post is accurate.
sgtfuzzbubble011 is offline   Reply With Quote
Old 2nd July 2000, 09:02   #17
Kanti
Junior Member
 
Join Date: Jul 2000
Location: London Ontario Canada
Posts: 1
Quote:
Originally posted by sgtfuzzbubble99:
Tom,
thanx for the help. I got my slave cd drive to play music like you said.

Mr. Ice,
sorry for posting incorrect information. Just trying to help out. But from now on I'll try and make sure that what I post is accurate.

Hi Everybody!

I have followed all the suggestions made here. I am still having a problem with WinAmp as it does play most of the English Audio CDs but not other non-English Audio CDs. I don't have entry for 'Audio CD' in Windows settings but most of the English Audio CDs does show up in Windows CD Player without WinAmp. But for non-English Audio CDs I get an message 'CD-ROM is not accessible. The device is not ready'. I have also installed 'X-set' program and followed up but 'Associate with cds' remains unchecked in WinAmp.

I am a new man on the Winamp Forums but I found them very helpful. Would someone can help me what is going on with my system. I did not have these problems before. They have come up recently.

Kanti


[Edited by Jayn on 12-20-2000 at 12:50 PM]
Kanti is offline   Reply With Quote
Old 19th July 2000, 13:57   #18
lorenzo massaccesi
Junior Member
 
Join Date: Jul 2000
Posts: 1
I have the same problem of slim-shady. When I put a audio CD in computer, winamp starts like reading music but i don't hear nothing. With other kinf of music file, winamp is great! If i start other CD readers it's all ok. Perhaps , I have to adjust some settings??

Please, help me!
lorenzo massaccesi is offline   Reply With Quote
Old 21st July 2000, 05:51   #19
bguerra
Junior Member
 
Join Date: Jul 2000
Posts: 1
I to am having the same problem. I can play all other formats but not audio CD's. WinAmp shows the song titles and it appears to be playing but no sound comes out of the speakers. All I hear is the sounds going into my microphone. I can play CD's using MS CD player or Media Player but not WinAmp.

Please help.
bguerra is offline   Reply With Quote
Old 22nd July 2000, 05:38   #20
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
For those still having problems :

Have you only got the default CD Input plug-in (IN_CDDA.DLL) ?
If so, then try replacing it with the CD Reader plug-in (IN_CDREADER.DLL)
I've a sneaky feeling that this might do the trick.

For those who don't know how to find this out:
1. Open Winamp Prefs (Ctrl + P)
2. Goto : Plug-ins -> Input
3. Check the list for the above mentioned.
4. If no CD Reader, goto the CDReader site and follow the instructions from there.
_____________________________________________

If you already have CD Reader and are still having this problem :
1. Repeat steps 1 + 2 above.
2. Hi-lite entry for CDReader Plug-in
3. Click "Configure"
4. Set the priority to High (or Highest if it still doesn't work)
(Set back to "normal" or "high" if this makes no difference)

Post below if you still experience problems after this and we'll take it from there.

I suppose it's a bit of a stupid suggestion, but have you made sure that the Winamp volume control is up high enough ?

Also have you made sure that your Output Plug-in is not set to anything other than Wave Out or Direct Sound ?
____________________________________________

Hope this helps !

------------------
*******
DJ - Egg
*******
^/^
`v

[Edited by DJEgg on 12-27-2001]
DJ Egg is offline   Reply With Quote
Old 22nd July 2000, 06:20   #21
Reverend Ike
Evangelical Alumni
 
Join Date: Jun 2000
Location: Sacramento, CA
Posts: 1,533
DJ Egg -

A little addendum to your advice, culled from this link:

http://forums.winamp.com/showthread.php?threadid=33142

... to wit (with some paraphrasing):

First off if you downloaded the CD Reader from Winamp.com you should probably take a trip over to the authors site at:

http://www.url*****~copah/CDReader.htm

and download the version there, it is newer and has a few bugfixes.

Also, before using CDReader, disable the default CD plugin, so both plugins are not running simultaneously. In Windows Explorer, go to the plugins folder of Winamp and rename the in_cdda.dll to something like in_cdda.dll.old. Restart Winamp and you should be set.

[Edited by Jayn on 12-20-2000 at 12:42 PM]
Reverend Ike is offline   Reply With Quote
Old 23rd July 2000, 06:10   #22
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Cheers Ike, you're a gem !
Truly the perfect addendum.

I might just go and do that myself ! (visit author's site)


------------------
*******
DJ - Egg
*******
^/^
`v
DJ Egg is offline   Reply With Quote
Old 7th December 2000, 01:32   #23
Spook816
Junior Member
 
Join Date: Dec 2000
Posts: 8
i am an amateur dumbass and i was wondering how you rename the original CD plugin so it will not work. I have a feeling this is my problem too cuz i loaded cdreader and it wont work
Spook816 is offline   Reply With Quote
Old 7th December 2000, 03:37   #24
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Quote:
Originally posted by Reverend Ike:

First off if you downloaded the CD Reader from Winamp.com you should probably take a trip over to the authors site at:
http://www.url*****~copah/CDReader.htm
and download the version there, it is newer and has a few bugfixes.

Also, before using CDReader, disable the default CD plugin, so both plugins are not running simultaneously. In Windows Explorer, go to the plugins folder of Winamp and rename the in_cdda.dll to something like in_cdda.dll.old. Restart Winamp and you should be set.
1. Make sure Winamp is fully closed.
2. In Explorer, goto : C:\Program Files\Winamp\Plugins
3. Locate & hi-lite "in_cdda.dll" *
4. From "File" menu, select "Rename"
5. Rename to (eg.) "in_cdda.dll.old" -> Okay
6. Re-open Winamp . . . & voila !

*If you can't see this file at all, or if you only see "in_cdda", goto:
Windows Folder Options -> View tab
Uncheck: hide extensions for known file types
Checkmark: show all files (under "Hidden Files")


Current version available from author's site = v1.93

-------
DJ-Egg

[Edited by DJEgg on 12-28-2001]
DJ Egg is offline   Reply With Quote
Old 7th December 2000, 04:43   #25
Spook816
Junior Member
 
Join Date: Dec 2000
Posts: 8
thanks DJ- but still the eq that the reader is supposed to fix doesnt work. The eq button is on and i have the new 1.83 version and have checked tons of FAQs and forums. if someone could answer this i would stop bothering you guys i promise
Spook816 is offline   Reply With Quote
Old 5th March 2001, 13:28   #26
kermit61
Junior Member
 
Join Date: Mar 2001
Posts: 21
Still no CD autoplay

Hey Folks,
I've read this thread with a lot of interest. I've downloaded the CD-Reader(ver1.91), renamed the default reader to *.*.old. Still, I can not get WinAmp to autostart when I insert an CD. Also, I still can not get WinAmp to keep a check in the 'associate with audio CDs' checkbox. I'm running Win2000pro and winamp 2.72.
kermit61 is offline   Reply With Quote
Old 7th March 2001, 05:58   #27
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
kermit61
Do you have an entry for "AudioCD" in Windows Folder Options -> File Types?
If not, check out this thread:
http://forums.winamp.com/showthread.php?threadid=40123
If you do or don't, check out this thread anyway!

spook816
Read my previous post again.
I've edited it especially for you
DJ Egg is offline   Reply With Quote
Old 10th March 2001, 01:17   #28
Dope
Junior Member
 
Join Date: Mar 2001
Posts: 1
Hey Tom...
Thanks bud...you are a major dude.
Dope is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump