Old 14th December 2000, 02:07   #1
Tone Matrix
Guest
 
Posts: n/a
I hope someone can help me here. Somehow Quicktime has taken over as the player for playing .m3u files. For example when I go to mp3.com and click on lofi or hifi, instead of it nicely going into winamp, its going to a new blank page that then loads that inbrowser quicktime plugin which plays the track. But its very annoying to have it playing that, Winamp makes it so much more convenient. But I've tried everything. Uninstalling both, Reinstalling both, updating IE to IE 5.5, when I uninstall Quicktime and try it, then it says that I dont have a player to play it and refers me to some general microsoft activex page. So after everything I'm pretty much in the same place. Oh I've even toyed with the registry as well and file associations. no luck. If anyone can shed some light, I'd definitely appreciate it. If possible please email me so I can see the message quicker. Thanks, Eric (gold@netrox.net)
  Reply With Quote
Old 14th December 2000, 02:40   #2
Rayman
Guest
 
Posts: n/a
Press ALT+O in winamp. (Goes to prefences)
Choose "file types" from the left and associate the file type again.

Rayman
  Reply With Quote
Old 14th December 2000, 03:22   #3
Tone Matrix
Guest
 
Posts: n/a
Wellll, I wish were that easy, because trust me I already tried that, and even to double check again, I unchecked all of the file associations.. restarted... came back seeing that sonique was the default player which was fine.. went back into winamp, put the file associations all back.. restarted came back winamp was default, butttttttt. still doesnt play the streams, IE still appears to be looking for that quicktime plugin.
Any other ideas? Thanks, Eric gold@netrox.net
  Reply With Quote
Old 14th December 2000, 04:26   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Firstly you'll need to reinstall QT, preferably v4

Goto Windows Control Panel -> Quicktime

From the drop down menu : choose "File Type Associations"
Uncheck anything you don't want associating with QT.
Also uncheck : notify me if other app's modify these associations

Next, from the drop down menu : choose "Browser Plug-in"
Click the "MIME Settings" button
Unselect MP3 (audio/mpeg & audio/x-mpeg) by removing the + sign to the left (double click entry).
You may also wish to remove a few other + signs ????
Especially if there's one for mp3/m3u stream (audio/mpegurl & audio/x-mpegurl)

Bear in mind that by uninstalling QT will mean that you'll no longer have support for most QuickTime file types, including MOV, QT* & PIC. You may also experience some problems with some MPEG videos & JPEG images. QT also supports Digital Video (DV & DIF) & SoundDesigner2 (SD2).
Uninstalling QT is not recommended.
At least QTv3 should be installed on all Windows OS's, though I recommend v4. Note that v5 is very buggy and tends to screw things up.

Anyway, close QT Prefs & open Winamp.
Goto Prefs (Ctrl + P) -> FileTypes and reset your associations.
Make sure MP3 M3U PLS are all selected (hi-lited blue) & any others of your choice.

If you still encounter problems, checkmark "Register files on Winamp start"

You may also wish to enable the Winamp Agent:
(Prefs -> Agent -> checkmark all 3 options)
Be sure to disable the agent b4 running Scandisk or Defrag.

Hope this has helped.

-------
DJ-Egg
DJ Egg is offline   Reply With Quote
Old 28th September 2001, 05:32   #5
criggs
Junior Member
 
Join Date: Jun 2001
Posts: 5
Yes, my problem is identical to that described above. However, I have NOT been able to play with my registry at all. I've spent four hours with Microsoft with a technician who didn't know how to edit the registry and who wasted my time for an interminable evening having me screw around with every menu in Winamp and Quicktime under the sun with no results whatsoever.

I've also tried everything listed in this thread without success. At this point, there is absolutely no doubt whatsoever in my mind that there is a problem in the registry and that if ever I want this problem solved that is what I will have to hit. So please lay it on me. Yes, I know I need to back up my registry, yes, I understand that it's "dodgy", etc. etc. But I'm confident that's the only solution.
criggs is offline   Reply With Quote
Old 28th September 2001, 23:48   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
So, has the M$ technician still got his job then?
Do they pay good money for someone who does know how to edit the registry?

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\Extension

Remove any subkeys/strings relating to m3u & mp3

also look in:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Plugins\MIME

Remove any subkeys/strings relating to audio/mpeg
(might be listed as any of: audio/mpegurl, audio/x-mpegurl, audio/x-mpeg)

Let me know if this works, otherwise I'll dig even deeper
DJ Egg is offline   Reply With Quote
Old 29th September 2001, 00:55   #7
criggs
Junior Member
 
Join Date: Jun 2001
Posts: 5
Nope, no good, sorry.

First of all, the first instruction was not relevant since there were NO keys relating to mp3 in that subdirectory. With regard to the second location, yes, there was an audio x-mpeg something-or-other key which I deleted. Do I have to reboot for changes in the registry to take place? Anyway, no change; Quicktime continued to grab ahold of this live streaming .mp3 URL. Any other ideas, or should I try rebooting the computer after making that registry change first?
criggs is offline   Reply With Quote
Old 29th September 2001, 02:18   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
audio/x-mpeg something-or-other? LOL
Was it audio/x-mpegurl ??????

You say there was no reference to mp3, what about m3u ?

MIME for mp3 is audio/mpeg or audio/x-mpeg (video/mpeg, with WMP)
MIME for m3u is audio/mpegurl or audio/x-mpegurl or audio/m3u

Yes, remove the keys, then reboot.

You must also first make sure you've officially unassociated mp3 + m3u from the QT prefs, as explained above (I've brought it up-to-date a little)

More reg keys to look at:

HKEY_CLASSES_ROOT\CLSID\{05589FA1-C356-11CE-BF01-00AA0055595A}\EnablePlugin\MIME


Under audio/x-mpeg something-or-other
Remove string in right pane "QuickTimeUseCount"

HKEY_CLASSES_ROOT\CLSID\{05589FA1-C356-11CE-BF01-00AA0055595A}\EnablePlugin

Under extension subkey (mp3, m3u)
Remove string in right pane "QuickTimeUseCount"

HKEY_LOCAL_MACHINE\SOFTWARE\Apple Computer, Inc.\QuickTime\Installed MIME Types

Remove any sub references to the afore-mentioned keys/strings (ext, MIME)
DJ Egg is offline   Reply With Quote
Old 4th September 2002, 15:48   #9
costy21
Junior Member
 
Join Date: Sep 2002
Posts: 1
Hi, im pretty new here, and im not so good with computers maybe someone can help. My computer will not download winamp. Whenever i click on download, i get the quicktime logo on a blank page. I was told that quicktime is my default, and that i need to disable it as my default. unfortunately, i have no idea what that means or how i can do it...anyone???? Thanx, costy
costy21 is offline   Reply With Quote
Old 4th September 2002, 17:44   #10
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
http://support.microsoft.com/support.../Q180/5/53.ASP
DJ Egg is offline   Reply With Quote
Old 5th September 2002, 20:19   #11
randy
Junior Member
 
Join Date: Jul 2001
Location: Houston
Posts: 24
streaming audio in winamp

My prob is similar but I don't know if it's same. I'm trying to stream from a radio network's website. Managed to get winamp to stream it, but it buffers, then plays about 20 seconds, then buffers, then plays about 20 seconds. And this is on a DSL line!

Is this a setting I haven't turned on or something?

Randy
randy is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump