Old 26th April 2001, 21:55   #1
Amir I
Junior Member
 
Join Date: Apr 2001
Posts: 2
Send a message via ICQ to Amir I Send a message via AIM to Amir I Send a message via Yahoo to Amir I
Ok, I'm quite sure this problem has been discussed before but I cannot find it anywhere (possibly because I haven't a clue of what keywords to search for as well) so I must be awakening an old subject here.

It's something which was not a problem in my old computer. In my current one, when I use the Winamp to listen to files, if other programs of mine (ICQ, Irc) also use applications that do sounds (like receiving and sending ICQ messages, for instance), the sound from both programs mix.

Now, this was not a problem with my old computer where, miraculessly, whenever I used Winamp, other programs made no sound. I suppose the Winamp has some sort of an option of blocking sounds, but if it does, I haven't been able to find it!

I'm using version 2.65 if that helps at all!

Amir I is offline   Reply With Quote
Old 26th April 2001, 23:25   #2
Sawg
Guest
 
Posts: n/a
Belive it or not this is a bug fix. Not haveing sounds overlap was considered a abd thing. So newer systems (newer windows versions, newer sound card drivers) corrected this. This is not a feature, but a bug fix. So, the sort anwser: Nope.
  Reply With Quote
Old 27th April 2001, 02:48   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
If your soundcard doesn't have the option to disable multiple audio streams* (either via its own control panel; or via Multimedia Control Panel -> Devices -> Audio Devices -> soundcard -> Properties -> Settings; or via System Control Panel -> Device Manager -> Sound....controllers -> soundcard -> properties -> settings tab), then try this workaround:

Sounds Control Panel
Click the "Save As" button to save your current sound scheme.
Give it a name such as default configuration or whatever.
Now from the drop-down menu under Sound Schemes, select "No Sounds"
This will then disable all Windows sound events & will thus allow you to listen to your music in peace.
Use "No sounds" scheme when listening with Winamp (etc), and use your saved original settings at all other times. (these will be available from the drop-down menu under whatever name you saved it as)


Another option is to try and prioritize Winamp to the max:

Winamp Prefs -> Output -> WaveOut -> config
Move the priority slider up to the highest setting

Check all the input plugins to see if they have priority options, eg.
Prefs -> Input -> MPEG Audio Decoder -> config
Priority = highest (default)


* eg. for SBLive cards:
Audio HQ -> Device Controls -> Wave tab
Maximum Simultaneous Wave Playback : slider = 0 to 32
Try setting it to "1" ?!?!


Another option is to try using the Kernel Streaming Output Plugin (with winamp closed, save to the Winamp\Plugins dir, then open winamp and select the plugin in Prefs -> Output).
This will prevent other DirectSound apps from outputting to the soundcard,
but I'm not sure if it also prevents waveout . . .
Apparently, the plugin is designed for Win2k/XP only.
DJ Egg is offline   Reply With Quote
Old 27th April 2001, 08:31   #4
Amir I
Junior Member
 
Join Date: Apr 2001
Posts: 2
Send a message via ICQ to Amir I Send a message via AIM to Amir I Send a message via Yahoo to Amir I
Ok thanks people. I get it, I'm screwed :-)

I don't have a problem of disabling other sounds, I just don't want to, although I do. My sound card does not have this option...

As for the overlap... They should have atleast kept it as an option. Obviously there are people who like it that way.

Thanks anyway!
Amir I is offline   Reply With Quote
Old 27th April 2001, 23:27   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Quote:
Originally posted by Amir I
I don't have a problem of disabling other sounds, I just don't want to, although I do.
ROTFL
DJ Egg is offline   Reply With Quote
Old 17th May 2001, 10:15   #6
Pseudopedia
Junior Member
 
Join Date: May 2001
Location: Melbourne, Australia
Posts: 8
Send a message via ICQ to Pseudopedia
mmm well, i have a new sys, and the latest winamp... and my sounds don't overlap (which i think is a bad thing)... any ideas for a workaround/setup that MAKES the other sounds mix?
Pseudopedia is offline   Reply With Quote
Old 17th May 2001, 15:35   #7
war4peace
Junior Member
 
Join Date: May 2001
Location: Romania
Posts: 18
Well, pseudopedia, tell me more about your windows version and your soundcard type and driver.
war4peace is offline   Reply With Quote
Old 18th May 2001, 04:54   #8
Pseudopedia
Junior Member
 
Join Date: May 2001
Location: Melbourne, Australia
Posts: 8
Send a message via ICQ to Pseudopedia
win98 SE
soundblaster 128
driver:
Provider: Creative
Date: 8-15-2000
File version: 4.12.01.2011
Pseudopedia is offline   Reply With Quote
Old 11th November 2001, 07:21   #9
Ultima0
Junior Member
 
Join Date: Nov 2001
Posts: 10
Quote:
Originally posted by Pseudopedia
win98 SE
soundblaster 128
driver:
Provider: Creative
Date: 8-15-2000
File version: 4.12.01.2011
process priority doesn't have anything to do with sound priority and real-time priority is dangerous because if winamp freezes for some reason, so will the entire OS.

What MAY work, is to use the DirectSound output plugin and set it to exclusive mode.
Ultima0 is offline   Reply With Quote
Old 11th November 2001, 11:59   #10
mayorbill11
Junior Member
 
Join Date: Jun 2001
Location: Toronto.
Posts: 9
Send a message via ICQ to mayorbill11 Send a message via AIM to mayorbill11
maybe it could be an option in 2.78? i hate hearing the ICQ "uh,oh" while listening to some good zepplin.
mayorbill11 is offline   Reply With Quote
Old 11th November 2001, 12:15   #11
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
just to shut people up:
it is NOT possible for Winamp to decide if system sounds are can be played or not. it depends on your OS, soundcard and its drivers. if you are unhappy with the way it works on your system, get newer/older sound card.

(well, directsound exclusive mode might help in some cases, but as far as i know it doesn't affect system sounds, it affects only other directsound apps (system sounds go via waveout)).

if you hate ICQ sounds, why don't you just disable them ?
peter is offline   Reply With Quote
Old 8th February 2010, 02:26   #12
Longwalks619
Registered User
 
Join Date: Feb 2010
Posts: 2
I found a way to play winamp loud without bringing up the volume of system sounds or sounds of other programs. I use a program called vitual audio cable. It allows mixing of sounds from different programs. I have winamp go directly to my sound card, but I make system sounds go to a virtual cable. Then I use an audio repeater program (that comes with the virtual cable software)to send the system sounds to my sound card. Once thats set up, I can control the system sounds volume independetly through windows volume control for the virtual cable. Sorry if that sounds confusing, dont know how to make it clearer. There is also now clutter on the task bar from the audio repeater program, but its worth it. Anyone else using this solution, or have something similar?
Longwalks619 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump