Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 2nd May 2001, 22:29   #1
patito
Junior Member
 
Join Date: May 2001
Posts: 4
I have winamp 2.74, I have instaled CDReader and Sqr crossfading. I already tried activating CDReader or in_cdda.dll (Nullsoft). Every time I insert an audio CD winamp opens but it doesn't begin to play the CD instead it pops the 'Open File(s)' dialog.
You winamp's gurus please help me!!!!!
I really need to autoplay my CDs
Thanks a lot in advance!!!
patito is offline   Reply With Quote
Old 3rd May 2001, 01:39   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
I'm beginning to think that this is a 2.74 bug.
I have exactly the same problem as well!

I use CDReader, and I was going to suggest that maybe the "associate with audio cd" function only works (via autorun feature) if you have the default plugin enabled (in_cdda.dll), but seeing you say that it doesn't work with this either, then yes, it looks like we've unearthed some kinda weird bug ?!?!

I only discovered this myself yesterday, whilst testing out a theory or two (regarding another post about another winamp/cd related problem) . . . 'cos my normal default cd player is CDSpectrum Pro, not Winamp.

Anyway, I've (yet again) managed to come up with a manual fix

If "associate with audio cd" is checked in Winamp Prefs -> Filetypes
Goto: Windows Folder Options -> File Types tab
Scroll down for "AudioCD" entry -> hi-lite -> Edit
Action box : hi-lite "Play" -> Edit
You'll see that the default command line is just the plain path to Winamp.
The following parameter switch needs to be added:
cda://d (where d is the letter of your CD-ROM drive), eg.
"C:\Program Files\Winamp\Winamp.exe" cda://d
Naturally, you'll need to change the drive letter accordingly, and if you have more than one CD-ROM drive (DVD/Re-Writer/etc), you'll need to change the letter again b4 inserting the CD (doh!)
nb. The single space inbetween ".....exe" & cda is also required!

Autorun should now work again.
This is a pretty crappy solution, but the main thing is that it works!

Important:
You'll also need to uncheck "Register files on Winamp start" (Prefs -> Filetypes)
Otherwise the command line will reset itself next time you close & open Winamp.

2.75 Lite Std Full has been released, but I don't see any mention of this bug being addressed or fixed in the whatsnew.txt file.
Maybe I should install 2.75 myself to find out, eh?
I'm still using 2.74 'cos I'm waiting a little bit longer just in case there's any last minute modifications made b4 2.75 is officially announced on the winamp.com site.


DJ Egg is offline   Reply With Quote
Old 3rd May 2001, 02:19   #3
patito
Junior Member
 
Join Date: May 2001
Posts: 4
Yes DJEgg, I really think that it's a winamp bug, 'cos I have the same problem since 2.72 version.
The default command for play in the AudioCD registry key is '"C:\Program Files\winamp\winamp.exe" %1' and it's interpreted by windows like 'C:\Programs Files\winamp\winamp.exe E:\' (where %1 = E:\, if this is your CD-ROM drive letter)
So, I did some test trying to run winamp from the DOS command line (C:\Programs Files\winamp\winamp.exe E:\) and I get the same behavior (winamp opens but it brings the open file dialog)
Conclusion: I think that this is a kinda weird bug maybe not detected by Nullsoft yet 'cos there are some old postings not aswered in the forums about the same problem.

BTW, the only way (that I have discovered) to play a CD from the command line (and in consecuence from play command in the AudioCD registry key) is 'C:\Program Files\winamp\winamp.exe cda://E' (the same that you suggest me in your answer)

I really hope that this bug dissapear from winamp soon.

Thanks for your suggest and your fast answer.
patito is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump