Old 30th May 2001, 02:11   #1
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
ok...i use winamp to stream all of my streaming audio..always have...today...when i turned on my comp...for some reason..when i clicked the same links ive been clicking everyday...instead of opening up winamp and streaming my music...my browser goes to another page with a quicktime plugin on it...why and how did this happen???

and how do i fix it??

i already deleted quicktime..now it brings me to a page and says i dont have the correct software to play this type of file...i hgave gone into winamp options and associated all files with win amp..and still...nothing..

this is extremely annoying and frustrating being that i refuse to use anything other then winamp to listen to music with...

mods.....HELP!!!!!
agent lead is offline   Reply With Quote
Old 30th May 2001, 04:26   #2
Sawg
Guest
 
Posts: n/a
Did they change formats?
What format is the stream?
What browser?
Does this happen in both IE and Netscape?
  Reply With Quote
Old 30th May 2001, 17:43   #3
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
no the site did nto change formats...i only use ie 5.5

this hadhappened to me once b4 but i forgot how i fixed it
agent lead is offline   Reply With Quote
Old 30th May 2001, 23:11   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Oops, you uninstalled QuickTime . . . bad move!

QuickTime Control Panel -> browser plug-in (from drop-down menu)
MIME settings button -> uncheck all formats you don't want the QT plugin to handle.

Okay everything & exit QT Prefs.

Winamp Prefs -> FileTypes
Select associations -> Close Prefs.
DJ Egg is offline   Reply With Quote
Old 1st June 2001, 02:16   #5
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
i tried that b4 i uninstalled quicktime...

this fucking sucks the lamma's ass

what am i to do??????

nothing works
agent lead is offline   Reply With Quote
Old 1st June 2001, 04:10   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Hmm . . . as sawg asked:
What format/extension are the stream links?
Are they M3U or PLS playlists?
Are they direct links to MP3's ?
Are these 3 all selected in Winamp Prefs -> FileTypes ?
(also try checkmarking "Register Files...", then close & reopen Winamp)
Can you open the stream by right clicking the actual link -> copy shortcut -> paste into Winamp's Open Location box (Ctrl+L)

Answer these few questions & we'll take things from there.
In the meantime, don't worry, we'll get it sorted!
DJ Egg is offline   Reply With Quote
Old 1st June 2001, 18:47   #7
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
they are m3u links from http://www.mp3.com/teamalliance

i did that register file thing too...and i have all files selected for winapm...still no luck
agent lead is offline   Reply With Quote
Old 1st June 2001, 22:44   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
If you've still got QT installed:

Go back to QT Control Panel:

Browser Plugin -> MIME Settings button

Make sure MP3 Audio & MP3 Playlists are NOT checked (double click entry to uncheck)
This will unassociate QT from the m3u MIME types:
audio/mpegurl | audio/x-mpegurl | audio/m3u
It will also unassociate QT from all MP3 MIME types:
audio/mpeg | audio/x-mpeg | audio/mp3 | audio/x-mp3

File Type Associations (from drop-down menu)
Uncheck: Internet File Types
Uncheck: Notify me.....

Close QT Control Panel

Open Winamp
Repeat instructions for Winamp Prefs -> FileTypes
(select MP3, M3U, PLS)
Close Prefs

Windows Folder Options -> File Types
Scroll down for "Winamp Playlist File" (PLS M3U)
(Here's where I could do with knowing what Windows OS you have, as the settings vary)
Win9x:
Hi-lite entry -> Edit
WinME/200:
Hi-lite entry -> Advanced
Change the MIME setting to: audio/scpls (instead of audio/mpegurl)
Okay everything

Now scroll up & check to see if QT has left a conflicting entry.
I don't have QT5 installed, I've still got QT4, so I don't know under what entry it might be . . . at a guess, it'll be something like:
MP3 Playlists -OR- Quicktime/QT Playlists.
If this entry exists, hi-lite it & click "Remove"

All I know is that QT4 doesn't even support M3U or PLS Playlists . . .
Obviously this has changed in QT5

Close Folder Options

Try streaming again.

If the problem persists, then the only option you have left is to edit the Registry.
Let me know what version of Windows & what version of WinMediaPlayer you have.
You're in luck if it's Win9x, 'cos I'll be able to give you an auto RegFix.
If it's WinME or Win2k, alas, it's gonna have to be a manual fix,
and I'll also require a bit more info from you first.

[Edited by DJEgg on 06-01-2001 at 06:18 PM]
DJ Egg is offline   Reply With Quote
Old 2nd June 2001, 23:56   #9
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
wow...you really qwent into detail there..thanx alot for your help...but..it still dont work..

i dled qt 5 again...changed all the settings like you said...did all of the above...and still no dice

im using win 98 btw
agent lead is offline   Reply With Quote
Old 3rd June 2001, 12:56   #10
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Something's definitely not right here!
Normally, following those precise instructions should've fixed the problem.
Hmm . . . It looks like QT5 has joined the evil realms of RP8 by also seriously messing with the registry. Very sad indeed

btw, do you still have any older version of QT installed? (v3 or v4)
If so, is there an entry in Windows Control Panel for them?
If there is, repeat the above instructions for these too!

If all else fails . . .

Try this MIME regfix:
Download the auto MIME RegFix here

Further info c/o this tutorial in TSGH:
How to Unassociate RP8 from Streaming Playlists & Make Winamp the Default Instead

Just treat the whole thread by replacing any mention of RealPlayer with QT, and you'll see that your problem is (kind of) exactly the same.

Try the suggestion of making WindowsMediaPlayer the default player first, just to fix the registry backups!
WMP -> View -> Options -> Formats tab:
Select: MP3 Format Sound (mp3, m3u)
Then go back to Winamp Prefs -> FileTypes & select MP3, M3U, PLS.

If this or the auto MIME regfix still doesn't fix it for ya
there's a link further down the page to a complete regfix.
This is 100% compatible with Win9x, but be sure to read the readme.txt and only use the fix if you installed Winamp to the default dir:
C:\Program Files\Winamp

Also definitely worth mentioning is mp3.com's supposed guaranteed fix:
http://www.btinternet.com/~meggamusi...ips/MP3Fix.exe
Further help/info : http://www.google.com/search?q=mp3fix.exe
It's been reported to work for some, but for many others only my regfix has worked.

Let me know how you get on ASAP!

[Edited by DJEgg on 06-03-2001 at 08:20 AM]
DJ Egg is offline   Reply With Quote
Old 3rd June 2001, 18:14   #11
agent lead
Junior Member
 
Join Date: May 2001
Posts: 10
WOW...HOLY SHIT

thank you so much dj egg..im forever in debt to you....the reg fix didnt work...but the mp3.com thing did....your the best...

thank you so much for all your time and effort..i really appreciate it my man....now i can go back to listening to my music...

btw...

check some of my shit out

http://www.mp3.com/teamalliance
agent lead is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump