Old 13th June 2001, 06:24   #1
drummzz7
Junior Member
 
Join Date: Jun 2001
Posts: 1
I have enjoyed using Winamp for almost two years now, but have suddenly run into a problem. In the past, when I would insert an audio CD in my CD-Rom drive, Winamp would play it and get the CD's information from CDDB and put all the songs into the Playlist window. Everything worked great! Then a couple of days ago, I uninstalled 'MusicMatch Jukebox 4' (a Realplayer audio player) because I never used it, and now when I put in a CD, Winamp does not recognize the CD being in my CD-rom drive, and it won't play it automatically. It will only play it when I open Winamp and click 'Play Audio CD.' I have tried to turn on the 'Associate with audio CD's' box in the Preferences -> File Types box, but it will not hold. Whenever I check the box, then close the Preferences window, and return to the File Types window, it is always unchecked again!! This is very frustrating!! I have checked Windows media player and Real player, and neither of them are associated with playing audio CD's, so I can't figure out why my Winamp used to have an autoplay feature, and now does not. Something in my computer is not allowing Winamp's autoplay feature to function correctly. I am using version 2.76 and have tried using the CD reader plug-in, but to no avail. Please help or give me some suggestions to fix my problem - anyone!!
drummzz7 is offline   Reply With Quote
Old 13th June 2001, 12:50   #2
. - .... .- -. ....
Backpacking
Moderator
 
. - .... .- -. ....'s Avatar
 
Join Date: Nov 2000
Location: საქართველო (Georgia)
Posts: 10,104
Send a message via ICQ to . - .... .- -. .... Send a message via Yahoo to . - .... .- -. ....
Couple of things to check:

1. Does your PC actually play Audio CD's and, if so, what is the current default player ?

2. Can you play CD's in Winamp by using the "Play Audio CD" option in the File Menu ?

3. Have you installed the latest version of your soundcard drivers?

4. Have you checked out Windows "Settings -> Folder Options -> File Types" to see if there is an entry for Audio CD ?
Click on "Edit" and then "New".
In the Action Field, type : Play In Winamp
In the App. Field, type : "C:\PROGRAM FILES\WINAMP\WINAMP.EXE"

Click OK, then in the original Edit Box, hi-lite this new entry and click "Set Default".

5. Do you have the autolaunch option enabled for your CD-ROM drive?

right click on "my computer" -> properties -> device manager -> cd rom -> click on the correct drive -> properties -> settings -> check the auto insert notification box.



Like my photography? Buy some here....
. - .... .- -. .... is offline   Reply With Quote
Old 13th June 2001, 18:41   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
The uninstallation of MMJB causes the AudioCD registry key to be deleted.
Thus making it impossible for any other player to become the default autoplayer.
This is a known fact about MMJB and they don't even try to deny it.
Pure evil . . . pure shite! I'm not surprised you never used it!

As ethan said, goto: Folder Options -> File Types
If the AudioCD entry is still there, then you're in luck.

However, I've a very strong feeling that it won't be

Seeing AudioCD doesn't have an extension (like MP3, WAV, EXE, JPG, etc), you cannot simply click the NEW button to recreate it.

The easiest way to solve the problem is:
1) Add/Remove Programs Control Panel -> Windows SetUp tab
2) Hi-lite: Multimedia Components, click "Details"
3) Uncheck: CD Player -> Okay -> Okay (thus removing CD Player)
4) Close Add/Remove Programs CPL
5) Repeat steps 1-2
6) Checkmark: CD Player
7) Okay everything & reboot
8) Winamp -> Prefs (Ctrl+P) -> File Types: checkmark "Associate with Audio CD"

If this doesn't fix the problem, then the only other way to recreate the AudioCD key is by editing the registry. Details of how to do this can be found here:
http://forums.winamp.com/showthread.php?threadid=40123

If you're not comfortable with using RegEdit, then let me know & I'll knock you up an auto RegFix.
Warning: Manually editing the registry is not recommended unless you are both fully experienced and qualified.

Further autorun help/tips = here:
http://forums.winamp.com/showthread.php?threadid=48777

[Edited by DJEgg on 06-28-2001 at 08:48 PM]
DJ Egg is offline   Reply With Quote
Old 10th May 2002, 00:30   #4
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Auto Play Fix for XP Home

Actually this is a major problem with Win XP Home. The default registry keys are incorrect. If this is a Win XP Operating System that you're having problems with then the fix is as follows:

Auto Play Fix for Win XP Home
The problem with auto play or autorun not playing cd's has nothing to do with winamp but is a glitch with Win XP. I just found a fix and tested it on my system at home that was having the same issue. To fix it the following registry values need to be changed. Caution: If you've never modified the registry before always back it up first so that you can restore it if you have any problems.

Anway, click start>run>regedit

then modify the following values:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\ NoDriveTypeAutoRun = 0x00000095 (current drive type = 91 so if this value reads 0x00000091 then change it to 95

and also change this reg key value for NoDriveTypeAutoRun
HKEY_USERS\.DEFAULT\Software\ Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun =0X00000095(The default is probably 91) so if this value reads 0x00000091 then change it to 95

close your registry

insert a cd or dvd into your drive and close the tray and whoila your autorun should now work.

Hope this helps!
gailmor1 is offline   Reply With Quote
Old 10th May 2002, 02:20   #5
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Re: Auto Play Fix for XP Home

Quote:
Originally posted by gailmor1
Actually this is a major problem with Win XP Home. The default registry keys are incorrect. If this is a Win XP Operating System that you're having problems with then the fix is as follows:

Auto Play Fix for Win XP Home
The problem with auto play or autorun not playing cd's has nothing to do with winamp but is a glitch with Win XP. I just found a fix and tested it on my system at home that was having the same issue. To fix it the following registry values need to be changed. Caution: If you've never modified the registry before always back it up first so that you can restore it if you have any problems.

Anway, click start>run>regedit

then modify the following values:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\ NoDriveTypeAutoRun = 0x00000095 (current drive type = 91 so if this value reads 0x00000091 then change it to 95

and also change this reg key value for NoDriveTypeAutoRun
HKEY_USERS\.DEFAULT\Software\ Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun =0X00000095(The default is probably 91) so if this value reads 0x00000091 then change it to 95

close your registry

insert a cd or dvd into your drive and close the tray and whoila your autorun should now work.

Hope this helps!
If you have Win XP Home, I have created two (2 registry keys) and placed them in a zip file to save you time. Save the attached zip file to to your desktop. When uzipped you should see two files: currentusersautoplay.reg and usersautorun.reg. These files have been tested on a Win XP Home system with fat32. They should work with NTFS as well but I specifically created them for the fat32 system. Once you save them to your desktop, click on each file one at a time. Windows will ask you if you would like to add the info from this file to your registry. Answer yes and the corrected information will be saved to your registry. Do this again for the second file answering yes to the question aforementioned. This will/should save you the time of having to search for these keys and make this change quickly and effortlessly.

I hope this helps,

Mark
Attached Files
File Type: zip cdautoplay.zip (805 Bytes, 817 views)
gailmor1 is offline   Reply With Quote
Old 10th May 2002, 02:55   #6
herbey53
Junior Member
 
Join Date: Oct 2001
Posts: 6
Send a message via AIM to herbey53
had the same exact problem, and this worked like a charm for me (win 98)

The easiest way to solve the problem is:
1) Add/Remove Programs Control Panel -> Windows SetUp tab
2) Hi-lite: Multimedia Components, click "Details"
3) Uncheck: CD Player -> Okay -> Okay (thus removing CD Player)
4) Close Add/Remove Programs CPL
5) Repeat steps 1-2
6) Checkmark: CD Player
7) Okay everything & reboot
8) Winamp -> Prefs (Ctrl+P) -> File Types: checkmark "Associate with Audio CD"
herbey53 is offline   Reply With Quote
Old 10th May 2002, 03:10   #7
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Autoplay / Auto Run for CD's

Herbie,

I agree with you but it all depends on the OS. The changes that you recommended are correct and should work but for some reason or another Win XP Home changes the two keys that I provided reg files to prevent autoplay with other devices. I tried all of the options you suggested long before I went to www.microsoft.com/technet to research this issue. Windows will not fess up to these keys having incorrect values but I suspect that the latest version of Windows Media Player changes these two values on Win XP Home systems. This way no other device can autoplay cd's and dvd's. I knew it was not my system or the cd player. On a Win XP Home system you can right-click on the cd drive (letter of drive) and select properties. Then go to autoplay and ensure that this device is checked. Also, in the task list there are specific services that need to be running that, if turned off, can render autoplay inactive. I hope your suggestion works for some but if we're talking about WIN XP then your recommendations will not work for Win XP users. Most of us have tried your recommendations with no luck. Trust me on this one bud. As an IT professional I research an issue as long as possible till I find a fix. Still, for those people wondering which fix to choose they should make sure that autoplay is checked on the cd using your suggestions or, if Win XP, right click on your cd drive from my computer. Go to properties and hit enter. Then click on the autoplay tab. I have checked the button that says prompt me each time to choose an action because Win XP refuses to add Winamp to the list for Music Players. This way if Winamp is the default player on this sytem Windows Media will not attempt to steal the default control back. There are so many suggestions to make and hopefully Herbie everyone will read carefully and choose the options that work for them.
gailmor1 is offline   Reply With Quote
Old 13th May 2002, 04:36   #8
ye_olde_jp
Junior Member
 
Join Date: May 2002
Location: Australia
Posts: 7
my 2 cents worth...

to gailmor1:

This is a most interesting problem.
What intrigues me is the fact that I cannot replicate this problem _at all_.
I have done countless installs of & upgrades to XP Home/Pro, all with the exact same results each time - Auto Play works just fine, and is done so by using the application that _I_ (not WMP or Windows) specify.
Another interesting point is the Reg Values you put up. I do not _ever_ get 91 or 95 as the last digits (amongst others, I tend to get "00" or "b1", depending on the option(s) set).

What baffles me is why so many people dislike WMP, yet insist on using it... why not just uninstall it if it's so troublesome?

Happy MP3-ing!
ye_olde_jp is offline   Reply With Quote
Old 13th May 2002, 07:17   #9
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Autorun/Autoplay

Hey ye_olde_jp,

I'm not sure that anyone is unhappy with winamp. Haven't read very many messages about that but I totally agree with you about your comments. I mean, if you're unhappy with Winamp why not uninstall it? Anyway, the reg files that I put up with the 000***95 are totally correct according to Microsoft.com/technet. I actually created those two files based on microsoft.com/technet. They actually had a specific response for why autoplay could possibly be not working. Also, just of of curiosity take the two files (reg) and change the extensions to .txt instead of .reg and look at each file. Then, go to your registry using the specific path and see if those particular keys really do end in 00. It will totally suprise me if you say that they do because according to microsoft they are supposed to end in 95. Well, I'm up late and I gotta take the dog out in for hours so I'm headed to bed. Let me know what the total numbers are that you end up with. I'm super curious now.

Mark
gailmor1 is offline   Reply With Quote
Old 13th May 2002, 14:42   #10
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Uninstall Winamp?
Unheard of, mate!

ye_olde_jp meant: uninstall WMP (Windows Media Player)
or WiMP as we prefer to call it round these parts
DJ Egg is offline   Reply With Quote
Old 5th July 2006, 18:08   #11
zerostress
Junior Member
 
Join Date: Jul 2006
Posts: 1
Thanks Mark for the .REG files. Worked fine with me on Windows XP PRO French.
zerostress is offline   Reply With Quote
Old 5th July 2006, 21:43   #12
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
zerostress...

You've revived a LONG dead thread. Mark (gailmor1) hasn't been here since 2002. His last post above is dated 5-13-2002 and his last post in these forums was back on 9-11-2002.

Please don't resurrect 4-year old dead threads.
Bubba Smith is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump