Old 9th January 2002, 03:25   #1
Screw_Michigan
Junior Member
 
Join Date: Jan 2002
Posts: 4
2.78c and locking up when trying to add songs

Just DL'd 2.78c and now I can't add any songs without Winamp locking up.

Have to CTRL-ALT-DEL every time it freezes.

I checked all the FAQ's and guides and I couldn't find the solution.

Thanks for the help.
Screw_Michigan is offline   Reply With Quote
Old 9th January 2002, 08:03   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
if your using windows XP

don't drag and drop from the add box

its a windows bug.....



if not try re-installing winamp
Rocker is offline   Reply With Quote
Old 10th January 2002, 03:32   #3
Screw_Michigan
Junior Member
 
Join Date: Jan 2002
Posts: 4
Nope, I've got ME. But I'm going to re-DL it and reinstall it anyway.

Thanks for your help.
Screw_Michigan is offline   Reply With Quote
Old 10th January 2002, 04:00   #4
Screw_Michigan
Junior Member
 
Join Date: Jan 2002
Posts: 4
Nope, didn't help.
Screw_Michigan is offline   Reply With Quote
Old 10th January 2002, 04:40   #5
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
does it crash when your loading the songs

or does it crash when you press play.. after you load the songs
Rocker is offline   Reply With Quote
Old 10th January 2002, 16:42   #6
Screw_Michigan
Junior Member
 
Join Date: Jan 2002
Posts: 4
It locks up as soon as I click on add file, it doesn't even bring up the directory, so I can't even press play.
Screw_Michigan is offline   Reply With Quote
Old 11th January 2002, 00:49   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Try the following:

1) Run ScanDisk & Virus Scanner, just to make sure (better safe than sorry)

2) With Winamp closed, goto the Winamp dir in Explorer.
Open winamp.ini in Notepad
Scroll down for the following line:
cwd=

cwd stands for current window directory
Maybe it's got stuck on some obscure dir, eg. Temp Internet Files?
Change the entry to your music dir, eg.
cwd=C:\Music


3) Open Winamp, goto:

Prefs (Ctrl+P) -> Plugins -> Input -> MIDI Plugin -> config -> file types tab.
Unselect some of the more obscure extensions in the list, to disassociate in_midi.dll from them.
eg. unselect: the bottom 5 extensions (CMF, GMD, MIDS, MIZ, HMZ)

Repeat this action for both the MOD & WAV input plugins:

eg.

Module Decoder (in_mod.dll) -> config -> Loaders tab
Select the bottom 7 formats (one at a time) and uncheck "Enabled" (on the right)
This will disassociate rare MTM, ULT, 669, FAR, AMF, OKT, PTM formats.

Waveform Decoder (in_wave.dll) -> config
Uncheck: SVX & IFF (plus any others of your choice)
The most common waveform formats are WAV, AU, SND, AIF.
The rest of the extensions in the list are more rare/obscure and can be deselected for now.

You could also remove eg. MP2;MP1;APL from the extension list in the Nullsoft MPEG Audio Decoder (in_mp3.dll) config, leaving just MP3 and AAC.

Okay everything & close prefs.


4) Try clicking "Add -> Add File" button again.


Hope this helps.
Fingers crossed.


ps. If you have installed any extra 3rd-party plugins, I recommend you remove/disable them to see if one of these is to blame.


If the worst comes to the worst, try this:

Clean Install procedure:
http://forums.winamp.com/showthread....d=161361#clean
DJ Egg is offline   Reply With Quote
Old 10th May 2002, 16:24   #8
fredthemasterofpuppets
Junior Member
 
Join Date: Aug 2001
Posts: 25
thanks it works !
fredthemasterofpuppets is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump