Old 12th March 2002, 21:32   #1
Loomis2
Junior Member
 
Join Date: Mar 2002
Posts: 2
Winamp won't play MPEGa files?

But there's more...First off, I just installed the newest Winamp player (2.78c) The music files I want to play are opened automatically by RealOne player and play there, but when I open my music directory file in Winamp where the songs are stored nothing is shown UNLESS I choose "all file types". Then the songs are shown, and when selected they play and show all the file details in the window and everything just like it should. So the files do work with Winamp, but Winamp won;t recognize them and I can;t make Winamp my default player for them. Any suggestions?

BTW, I recently Clean Restored my computer back to factory settings when it crashed last week. I had Winamp and RealOne and WMP before and everything worked fine. I can;t figure out why it won't recognize the files anymore.
Loomis2 is offline   Reply With Quote
Old 12th March 2002, 22:44   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
What extension do these files have?
Are they .mp3 or .mpga
RealPlayer p.o.s. has a tendancy to modify the registry and uses .mpga instead of .mp3

You should've unchecked all the options during RealOne setup, eg.
Make Real the default music player / associate with files / maintain associations etc (not sure what the exact options are, but you should've unchecked them all anyway)

Go into the Real Preferences and unassociate it from all non-RealPlayer formats. Then open Winamp and re-associate MP3 and other formats via Prefs -> Filetypes. More precise instructions can be found here.

You could also try renaming all your mpeg audio files (if they have the .mpga extension) to *.mp3
Note, you'll need to make sure extensions aren't hidden first:
Windows Folder Options -> View tab:
Uncheck: Hide extensions for known filetypes

You can also try adding MPGA to the associated extension list in Winamp.
Prefs (Ctrl+P) -> Plugins -> Input -> MPEG Audio Decoder -> config:
Extension list:
MP3;MP2;MP1;MPGA

Then select all these extensions in Winamp -> Prefs -> Filetypes.


Another possible cause/fix relates to removing some supported extensions from Winamp's input plugins. Not sure if this is relevant to your case, but it's worth a shot. The fix is referenced within this troubleshooter.

Hope some of this helps ?!?!
DJ Egg is offline   Reply With Quote
Old 13th March 2002, 00:46   #3
Loomis2
Junior Member
 
Join Date: Mar 2002
Posts: 2
It worked!

I'm not sure which one of those suggestions worked since I pretty much did them all at once, but if I had to guess I would say adding the .mpga extension to the MPEG decoder was it. Like an idiot I had tried that but added .MPEG as the extension instead of .MPGA. Don't ask me why. Anyway, Winamp works like it used to. Thanks a lot.
Loomis2 is offline   Reply With Quote
Old 13th March 2002, 01:18   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
Yeah, if you visit the tech forums often, you'll discover I always prefer to include all the possible causes/fixes wherever possible. It saves having to type them later if the first suggestion doesn't work.

The downside is that my posts tend to end up being pretty huge, whereas most other people stick to a few short and precise sentences. But hey, I've always been different . . . part of my life story . . .

As ya say, it probably was adding MPGA to in_mp3.dll config which fixed it, especially if those files have the .mpga extension . . .

Anyway, glad to see it worked & everything's sweet again. Yay!
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump