Old 24th March 2002, 16:09   #1
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Making Winamp your default player in XP?

Hi,

For some reason I can't make Winamp my default player in XP. Everytime I check the box to make it the default player it doesn't work. I have Media Player also and it won't let me uncheck that one to not make it the default player. Does anyone know if Winamp can be the default player in XP? Any help would be apprecaited.
Jerry
Lyons00 is offline   Reply With Quote
Old 24th March 2002, 17:26   #2
binary hero
Banned
 
Join Date: Jun 2001
Posts: 7,004
Send a message via ICQ to binary hero
in winamp, perss ctrp+p, then go to file types. make sure all the files you want winamp to be associated with are highlighted, take two of these pills every 6 hours, and if the problem persists, call back in the morning
binary hero is offline   Reply With Quote
Old 24th March 2002, 17:40   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Is it just with AudioCD's you're having the problem with?
If so....

From: TSGH -> Useful Links

RE: Problems with AudioCD : Playback / Association / Autorun / CDDB
http://forums.winamp.com/showthread.php?threadid=69942 (WMP=default in XP)

Maybe this link too?
http://support.microsoft.com/support.../Q259/4/73.ASP
DJ Egg is offline   Reply With Quote
Old 24th March 2002, 18:16   #4
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

It's just in Audio CD's that I'm having the problem. I did what you said and I'm still having problems with WMP. Anything else I can do?

Thanks, Jerry
Lyons00 is offline   Reply With Quote
Old 24th March 2002, 20:28   #5
HybridAngel
Junior Member
 
Join Date: Mar 2002
Posts: 37
I have it as my default player in XP.

1. select all formats in Winamp
2. uncheck MP3&WMA in Windows Media Player

That should do it!

your MP3 & WMA files icons will change to the Winamp type

HybridAngel is offline   Reply With Quote
Old 24th March 2002, 20:37   #6
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

I tried that and it still doesn't use Winamp only WMP. I've tried everything got to be doing something wrong, but I don't know what it is. Help!!!!

Jerry
Lyons00 is offline   Reply With Quote
Old 24th March 2002, 20:52   #7
HybridAngel
Junior Member
 
Join Date: Mar 2002
Posts: 37
Ok... I'll try to help... uncheck
-AU Format Sound
-MP3 ""
-DVD
-Midi ""

and in Winamp select ALL TYPES OF FORMATS


That's what I did!

HOPE THIS HELPS...
HybridAngel is offline   Reply With Quote
Old 24th March 2002, 21:54   #8
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

Sorry it didn't work either. Thx for trying to help but still not working.

Jerry
Lyons00 is offline   Reply With Quote
Old 24th March 2002, 21:56   #9
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Yeah, but the problem is only with AudioCD's.....

If there's a CDA filetype in Media Player -> Tools -> Options -> Formats
then uncheck/de-select this also.
Close WMP, including any systray icon.

Open Winamp
Select CDA in Winamp -> Prefs -> Filetypes.

Does the "associate with AudioCD" checkmark remain checked?
Or does it mysteriously uncheck itself each time you go back in?

Have you tried going into Windows "Folder Options -> File Types tab" yet?
Scroll down for: N/A - AudioCD
Click "Advanced"
Hi-lite "Play", click "Edit"
Make sure the app used command line path leads to Winamp.exe
Click "Okay"
Back in the original "Advanced" section, hi-lite "Play" again
Click "set default"
DJ Egg is offline   Reply With Quote
Old 24th March 2002, 22:00   #10
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

It disappears every time I do that. I have tried what you said and still won't work with audio CD's.

Jerry
Lyons00 is offline   Reply With Quote
Old 24th March 2002, 22:36   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Errmmm . . . what disappears every time you do what?
Can you be more specific?

And does the "N/A - AudioCD" entry exist in Windows Folder Options -> File Types?

It's starting to sound like the old MusicMatchJukeBox bug:

RE: Problems with AudioCD : Playback / Association / Autorun / CDDB]
http://forums.winamp.com/showthread.php?threadid=52410 (MMJB associate with bug)
http://forums.winamp.com/showthread.php?threadid=40123 (Win9x/ME regfix)
http://support.microsoft.com/support.../Q259/4/73.ASP (Win2k/XP fix)
http://forums.winamp.com/showthread.php?threadid=31749 (associate with again)
http://forums.winamp.com/showthread.php?threadid=29853 (more of the same)
DJ Egg is offline   Reply With Quote
Old 24th March 2002, 22:40   #12
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

The assicate auto cd's disappears after I check it then I go right back in and it's unchecked. There is N/A-Audio CD in there.

Jerry
Lyons00 is offline   Reply With Quote
Old 9th May 2002, 22:06   #13
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Making Winamp your default player in XP

Hey Folks,

This whole issue appears to be with Win XP and not with Winamp. I know a bunch of you are used to autoplay running without prompt but I'm about 90% sure this is a Windows issue and not a Winamp prob. I say this because not only do my cd's not play but my dvd's also that used to play under Win 98 and Millenium no longer auto start and the associations of cda's, etc have placed me in a constant battle with Windows Media Player. I'm still researching this issue but the latest version of Windows Media Player seems to be the culprit from what I can gather. Apparently, it places a few switches in the registry that disable autoplay unless Windows Media Player is the default player for cda's and dvd's, etc. I'm pretty sure this is what happened because my cd's and dvd's played fine and automatically until I upgraded to the latest version of Windows Media Player. I've tried a zillion options but have no fear, Mark is here. I promise to post a Windows fix as soon as I can find it on technet's website.
gailmor1 is offline   Reply With Quote
Old 10th May 2002, 21:55   #14
heybill
Junior Member
 
Join Date: May 2002
Posts: 2
Change the default player for XP Professional

Gailmor1 1 was close.

I have winamp 2.8 on Windows XP Professional. To change the default player for music CDs:

right click my computer select Properties
right cllck the Audio CD Drive select Properties
select the AutoPlay tab
from the drop down box select Music CD (don't confuse it with 'Music Files' option)
Select play AudioCD using Winamp.


I have not rebooted yet, but even Microsoft is not that dastardly

Bill
heybill is offline   Reply With Quote
Old 10th May 2002, 23:32   #15
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hey! You're not Bill Gates by any chance, are you?
DJ Egg is offline   Reply With Quote
Old 11th May 2002, 05:50   #16
gailmor1
Junior Member
 
Join Date: May 2002
Location: USA
Posts: 10
Send a message via AIM to gailmor1
Auto Play or Auto Run

Hey Bill,

I actually wasn't talking so much about making winamp your default as I was speaking of getting it to work. I have XP Pro on one machine at home and XP home on another. The option you mentioned is correct if you're trying to get winamp to be your default player but if you're having trouble with autorun then my option should work if you're suggestions are tried and after inserting a cd it still doesn't auto play. Also in the task list which you can get to clicking on start>run and typing in services.msc will show you all of the services currently enabled on your pc. I have disabled a lot of the unnecessary services. Anyway, under the services tab is a service called Removable Storage. If this device is disabled then try changing it to manual or automatic and this should also bring you one step closer to resolving autoplay issues if this is the problem. It can be changed by double-clicking on it and using the pull down arrow next to the Startup Type.

Anyway Bill I know we're all trying to help everyone with winamp issues and actually Microsoft is a bit diabolical. I've been an MCSE for quite a few years now and know how to get around a lot of the registry keys and switches that microsoft adds to their system to make their own devices as the default processes. In some cases this is the only way around them.

Have a great weekend.

Mark
gailmor1 is offline   Reply With Quote
Old 11th May 2002, 20:17   #17
Lyons00
Junior Member
 
Join Date: Mar 2002
Posts: 9
Hi,

I was the one that started this post and I can't get mine to work still. I don't want to mess with the registry, I have tried most everything on here. Did what u said in was already on manual. Anybody know of anything else I can do?

Thanks, Jerry
Lyons00 is offline   Reply With Quote
Old 13th May 2002, 03:39   #18
ye_olde_jp
Junior Member
 
Join Date: May 2002
Location: Australia
Posts: 7
You may need to simply UNassociate your .CDA File Type.
DISable Auto-insert Notification (temporarily if you insist on using it).
Open WMP and make sure it's not set as the default CD Audio player;
Close WMP;
Go to Folder Options->File Types (one way of getting to that is by running Windows Explorer and look for Tools on the menubar);
Locate the .CDA extension from the list and select it, then hit DELETE to remove the association;
Click APPLY, then OK.
Start WinAmp and make sure that the option to "Associate with Audio CDs" is enabled, then put an Audio CD in your Drive but do NOT play anything yet.
Close WinAmp and re-open it.
Check to see if the option is still checked in WinAmp (it should be).
Press play and voila

This is true in all versions of Windows. If this doesn't work, you can always uninstall WMP

Happy MP3-ing!
ye_olde_jp is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump