Old 26th April 2002, 00:06   #1
bjay125
Member
 
Join Date: Nov 2000
Posts: 82
Audigy owners read

If you have an Audigy sound card, and you get skipping or have other general problems with any of the directsound plugins, here is how you fix it....

Start>Run and type "dxdiag" without the quotes
go to the Sound tab
reduce directsound acceleration - which is the slider

I had to reduce it to "Basic" but now I have absolutely no problems with any directsound plugins. I also didn't notice any cpu hit by doing this, at least while playing Winamp. I didn't test any games, so maybe you might want to bump acceleration back up to play games and reduce it to play winamp. If you have any sound related issues while playing games then definitely reduce the acceleration. Several of us have reported this issue on Creative's newsgroup server so I can only hope someone is listening and it gets fixed in a future driver release.

I hope this helps someone out there!
bjay125 is offline   Reply With Quote
Old 26th April 2002, 00:11   #2
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
now this is interesting, the same option fixed some weird problems with my sblive under xp. thanks for posting it here.
peter is offline   Reply With Quote
Old 26th April 2002, 00:20   #3
Sawg
Guest
 
Posts: n/a
SoundBlaster Users (SBLive/Audigy) : Read This First

Noted there (Stickey in this forum).
  Reply With Quote
Old 26th April 2002, 00:49   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Also added to the SB Audigy/Live! thread in TSGH.

Cheers
DJ Egg is offline   Reply With Quote
Old 26th April 2002, 03:44   #5
bjay125
Member
 
Join Date: Nov 2000
Posts: 82
Oops, I take that "no change in cpu" statement back. There is a noticeable change in CPU usage as you decrease the directsound acceleration, but its still not quite as bad as the wav out plugin. Definitely worth the benefit of the excellent output plugins written by the Winamp crew and Peter!

I would recommend backing the acceleration down a notch at a time until your problems go away. I would imagine the amount of needed acceleration reduction might vary depending on the particular system.
bjay125 is offline   Reply With Quote
Old 26th April 2002, 10:28   #6
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
yes, it DOES eat extra CPU due to hw acceleration being disabled, but it's probably still faster than waveOut most of time anyway, and the amount of extra CPU time is unnoticeable on 1GHz+ machines.
[edit] quick note that above info applies to win2k/xp machines, on win9x disabling dsound acceleration means emulating dsound on waveOut, which will always eat more CPU than waveOut itself.
peter is offline   Reply With Quote
Old 8th May 2002, 02:53   #7
Bax
Junior Member
 
Join Date: Jan 2001
Posts: 24
I got Windows XP/Audigy and I had this same problem in 2.80(always used wavout prior to 2.80).
Anyway, try setting your Preset to custom and use a Buffer length of 500 ms and a prebuffer of 30%.
I've experimented alot and this works flawless so far.
Bax is offline   Reply With Quote
Old 31st May 2002, 05:08   #8
Bagheera
Junior Member
 
Join Date: May 2002
Posts: 13
Send a message via ICQ to Bagheera Send a message via AIM to Bagheera
I got the EXACT same problem, dude! Skipping in DirectSound plugin when using WinAmp with DirectSound plugin.

What's funny is that 1) I could use my SB Live 5.1 with the DirectSound plugin without any problem, 2) WaveOut plugin works fine with Audigy without skipping.

I bet it's another one of Audigy's driver issues.. grrr. I don't think Creative acknowledge this bug though. They did acknowledge two other bugs I reported with regard to MIDI.
Bagheera is offline   Reply With Quote
Old 5th June 2002, 15:47   #9
HI THERE
Junior Member
 
Join Date: Jun 2002
Posts: 1
hey... thanks a lot for the fix... i was just about the melt my sound card n piss on it... works great now... no more skips
HI THERE is offline   Reply With Quote
Old 6th June 2002, 06:15   #10
somejackass22
Junior Member
 
Join Date: Jun 2002
Posts: 1
thank you, thank you, thank you

You'd think frigging creative would know about this. When I called them to complain that sounds were skipping in all my favorite games (hadn't upgraded to 2.8/directsound out yet), they said "try a different PCI slot". IDIOTS! Anyway, downgrading to basic worked BETTER than a charm. THANK YOU! Goodbye, snap, crackle, pop, and er, skip!

Good riddance!
-somejackass22
somejackass22 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump