No announcement yet.

SHOUTcast DNAS 2 Beta (Build 17) 02/17/2011

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • SHOUTcast DNAS 2 Beta (Build 17) 02/17/2011

    Presenting the latest BETA drop of the SHOUTcast DNAS server for broadcasters, developers and testers. This build is our latest GM release candidate and introduces new features as listed in the “Changes” section below, as well as addresses bugs reported in the previous BETA builds.

    This BETA release is now available for the following platforms:
    • Windows 32-bit and 64-bit versions) (Windows 2000 and up)
    • Windows 64-bit (Windows XP64 and up)
    • Linux
    • Linux 64-bit
    • Mac OS X (Intel)
    • BSD 8.x


    You can download the updated version of the DNAS v2 from the direct downloads for the operating system version you require:


    Build 17 (02/17/2011):
    • Added per stream versions of the following configuration options (prefix with 'stream' to use them in addition to the master options e.g. streampassword): password, adminpassword, publicserver, allowrelay, allowpublicrelay, riponly, autodumpsourcetime, autodumpusers, listenertime, songhistory, uvoxcipherkey, introfile, backupfile, banfile, ripfile
    • Added 'logclients' configuration option to allow for client connections and disconnects to not be logged (default behaviour is to log these events)
    • Added summary administration page accessed via admin.cgi or admin.cgi?sid=0 instead of going to the default stream summary page (only works with 'adminpassword' access)
    • Added '&iponly=1' support to admin.cgi?mode=viewxml so listener stats (in standard mode or when using &page=3) will only output the listener's IP address instead of all other information
    • Changed 'admin.cgi?mode=reload' to only be available via the new summary administration page instead of on each stream administration page
    • Changed the /currentsong and <songtitle> values to be a formatted title as 'artist - title' if the v2 stream source metadata allows instead of just showing 'title'
    • Changed the /listen* actions to auto-fill the server IP in the generated playlist files if 'dstip / destip' is not set so the playlist is more likely to be valid
    • Changed the /home action to open the stream url in a new window / tab instead or replacing the current view of the admin pages
    • Changed the server to not load if appropriate passwords have not been specified (including per stream configurations) to improve security especially with per-stream password support
    • Changed the title produced for v1 clients to be 'artist - title' instead of 'artist - album - title' to resolve some legacy client related issues
    • Changed some of the admin page text spacing and other misc html changes
    • Changed administration pages to not allow access to the 'tail logfile' and 'view logfile' pages when using 'streamadminpassword' to prevent information from other stream configuration groups being seen
    • Fixed the Ban and Reserve IP administration actions to not re-add an already banned or reserved IP (overlap of single vs subnets still happens)
    • Fixed stream configuration options not being applied correctly when using the plain name (without _X on the end) for streamid=1 configurations
    • Fixed /stream/sid client access not working correctly if an invalid station id (sid) was passed on the connection attempt
    • Fixed the root index.html page occassionally reporting streams as available when they are not
    • Fixed 'admin.cgi?mode=reload&sid=#' not always updating or removing stream configurations correctly despite reporting it had especially with streamid=1 changes or the source password changed
    • Fixed YP2 connections not following the 'yptimeout' configuration option
    • Fixed 'admin.cgi?sid=#&mode=updinfo' only updating the default stream configuration instead of the stream configuration required
    • Removed invalid link for the IRC stream entry on the administration pages
    • Updated Configuration Builder to latest version
    • Updated documentation to reflect new options and related errata

    Getting Started

    If you already have a running instance of the DNAS v2 then there should not be any issues with replacing your current version with this new version.

    If this is a new install then make sure to read through the information in 'docs\getting_started.txt' along with the example configuration files provided in this new version which should make it easier to get started. Alternatively you should consider looking at the configuration builder which is included in the 'config_builder' folder.

    Finally, all copies of the documentation can also be found online at

    Reporting Issues

    If you do come across an issue with the DNAS v2, then please do post in this thread with as much information as possible about what you're doing at the time, the system you are using and anything else which will make it easier to understand what is or isn't going on with your install.

    Known Issues

    The following are known issues with the v2 DNAS raised in previous releases but not currently fixed / fully confirmed as needing to be fixed (i.e. intended behaviour):
    • If the external IP is bound to a different device than the primary on the machine then the server will not work as expected (e.g. eth1 instead of eth0)
    • Listing a relayed stream when using the YP2 mode is known to not work and will return a 474 error code from the attempt to connect to the YP. Setting the server as non-public or using the v2 DNAS in legacy mode (yp2=0) will allow the stream to be listed but means you lose all of the YP2 features. This is being worked on.
    • When connecting Winamp 5.60x to a v2 SHOUTcast stream when using the Bento or Big Bento skins will cause the Winamp UI to lockup for up to 60seconds (depends upon the machine, etc). Install to resolve this issue (this patch will be shipped with the next version of Winamp after 5.60x)

    Additional Information

    Windows versions of the DNAS v2 are built with a dependency against the Microsoft Visual C++ 2008 SP1 Redistributable Package. If sc_serv is unable to start due to a dependency issue then you will need to install the correct version of the package so it can run which depends on the version of sc_serv you are attempting to run:

    32-bit -
    64-bit -

    This new version has been tested on a number of current Linux versions (Ubuntu, Fedora, CentOS) so should hopefully run on other versions as well and without any dependency or locale related issues (as affected the first version).

    Discussion about the previous version of the server including changelogs can be found in the following threads
    WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog

  • #2
    didn't launch with working good config of build 14, os debian 6.0 x64, turn on screenlog = 1, all starts ok but can't connect on 8000port, kill process, return build 14, all start ok


    • #3
      send me all of your sc_serv2 configuration files along with a copy of the log (if possible with full debug logging enabled) please.

      WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


      • #4
        Still having relay problems with this...

        My relays work fine as long as I have YP registration disabled... as soon as I change publicserver to always, this happens.

        Weirdly I can see the stream on the web console, and it even shows the right track metadata, but trying to play the stream (in winamp) gives a 404.

        2011-02-18 12:03:43 I msg:[] Connecting as relay.
        2011-02-18 12:03:43 I msg:[MICROSERVER] Listening for connection on port 9001
        2011-02-18 12:03:43 I msg:[MICROSERVER] Listening for connection on port 9000
        2011-02-18 12:03:44 D msg:[YP2] pvt_add No entry for key=1
        2011-02-18 12:03:44 D msg:[YP2] pvt_add add for key=1 [0]
        <?xml version="1.0" encoding="utf-8"?>
        <yp version="2">
        <cmd op="add" seq="1">
        <source>Legacy / Unknown</source>
        2011-02-18 12:03:44 I msg:[RELAY sid=1] Relay connected using SHOUTcast protocol
        2011-02-18 12:03:44 I msg:[YP2] Connecting to
        2011-02-18 12:03:44 E msg:[DST sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
        2011-02-18 12:03:44 I msg:[DST sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester'
        2011-02-18 12:03:45 D msg:gotResponseReqest key=1 cmd=0
        Response body=[
        <?xml version="1.0" encoding="UTF-8"?>
        <yp version="2"><resp seq="1"><error><code>474</code><message>Relay URL does not exist</message></error></resp></yp>

        2011-02-18 12:03:45 E msg:[YP2] /yp/resp/updatefreq missing
        2011-02-18 12:03:45 E msg:[YP2] Connection attempt failed. YP2 error code is 474 (Relay URL does not exist)
        2011-02-18 12:06:21 E msg:[DST sid=1] SHOUTcast 2 client connection rejected. Stream not available. WinampMPEG/5.58, Ultravox/2.1
        2011-02-18 12:06:21 I msg:[DST sid=1] SHOUTcast 2 client connection closed (0 seconds) [Bytes: 0] Agent: `WinampMPEG/5.58, Ultravox/2.1'


        • #5
          mattcamp: it's still a known issue (is listed in the first post) as the problem is on the YP side of things and not directly with the DNAS (as is shown by running the DNAS in private or legacy mode with yp2=0).

          and as the DNAS will not allow clients to connect if running in public mode, that's why you're getting client 404's when running in public mode. it does make sense for it to work in that way though maybe an exception option to override that might be useful though i've a feeling that would cause more confusion with it allowing connections but not being able to be seen in the listings.

          at the moment i cannot give an eta on when this will be resolved as there's a number of things to be changed / updated from what i can work at the moment. alas it's one of those beta things still present with the YP2 system but is known and is one of the priority aspects to be resolved to get things out of beta (hopefully sooner rather than later).

          WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


          • #6
            | Opus Audio Codec plugins 2.0 | Embedded Album Art | DiskWrite |
            | Save your playlist first! | Live voice-over | X-Fade 2.5 |
            | AterKast (Source DSP) | More of my stuff... |


            • #7
              @maksimilian: please check your pms or action my previous reply to your first post as this needs to be fixed ASAP if it is a legitimate issue and i cannot replicate it without the information required from you as this is now hold back some required upgrades.

              WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


              • #8
                Unfortunately I seem to have found an issue with the private pages: The &pass= string doesn't seem to work anymore, because the 'adminpassword' is ignored somehow.
                The following string is used with an ASP script:


                If I try to open this link with my web browser unlike before user name and password are requested.

                According to the updated documentation no change has been made there...


                • #9
                  DigiBC: will check it out, had a feeling there might be some sort of bug with the password handling due to all of the internal changes made to allow for the per-stream passwords.

                  WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                  • #10
                    seems everything screwed up when i upgraded it.
                    i stoped the radio.. uploadded the new files and used the config builder and now it wont be able to broadcast using the dsp just cant connect it.
                    same port and same pw. So i used the backup config that i took before i replace the sc_serv.conf and its still the same thing
                    the worst is i cant even stop it
                    i had to stop killthe pid to do that
                    ive sent you the pm of the config

                    [root@zer0 shoutcast1]# ./sc_serv sc_serv.conf
                    2011-02-23 04:22:53 I msg:<***> Logger startup
                    2011-02-23 04:22:53 I msg:<***> version build
                    2011-02-23 04:22:53 D msg:<***>
                    2011-02-23 04:22:53 I msg:*******************************************************************************
                    2011-02-23 04:22:53 I msg:** SHOUTcast Distributed Network Audio Server (DNAS)
                    2011-02-23 04:22:53 I msg:** Copyright (C) 1999-2011 Nullsoft, Inc. All Rights Reserved.
                    2011-02-23 04:22:53 I msg:** Use "sc_serv filename.conf" to specify a config file.
                    2011-02-23 04:22:53 I msg:*******************************************************************************
                    2011-02-23 04:22:53 I msg:[SHOUTcast] DNAS/posix(linux x64) v b (Feb 17 2011) starting up...
                    2011-02-23 04:22:53 I msg:[MAIN] PID: 17240
                    2011-02-23 04:22:53 I msg:[MAIN] Loaded config from sc_serv.conf
                    2011-02-23 04:22:53 I msg:[MAIN] Calculated CPU count is 8
                    2011-02-23 04:22:53 I msg:[MAIN] Starting 8 network threads
                    zetaf is online now Report Post Reply With Quote


                    • #11
                      zetaf: i've just tried it with your config (though i've only been able to test the linux x86 version at the moment) and i had no lockups or issues with connecting the DSP to the DNAS though this was all done though a local lan setup (real Windows machine to Linux VM on a bridged network connection). only changes i made to the config files were the paths of the files.

                      i've also tried it in my Windows version and that didn't show any issues.

                      i'll see if i can run it on linux x64 over the next day or so, otherwise i'd suggest you check you DSP settings and that it's pointing to the correct IP though the one you provided in the pm was dead at the time of testing. also i can't remember if you were running the DSP on the local lan or doing it over the internet.

                      WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                      • #12
                        Originally Posted by DrO
                        @maksimilian: please check your pms or action my previous reply to your first post as this needs to be fixed ASAP if it is a legitimate issue and i cannot replicate it without the information required from you as this is now hold back some required upgrades.
                        if i don't hear anything by tomorrow morning i'm going to ignore the incomplete bug report you've made especially if you've logged into the forums but aren't bothered to provide information requested a number of times to attempt to replicate and resolve the issue.

                        WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                        • #13

                          just installed build 17 and ran into some problems.

                          I've used the same config as for build 7 and build 10



                          With build 17 i cant get the titleupdate to work. Im using sam 4. With build 10 i have connected to sc and everythink works fine. Winamp and statuspage viewed Interpret - Title properly. With build 17 winamp only shows the streamurl and statuspage shows nothing.

                          Since i have set yp2=0 sc should use shoutcastprotocol 1 and normaly it should work like on build 10 and and previous or did i miss something in the config? I havent found anything about this in the documentation.

                          Normaly it wont be a problem cause we are streaming over sc-trans and not directly to the streamserver, but sometimes we also use a direct streamconnection to the shoutcastserver, for example when sc-trans is offline or failed for some reason (what never happens till now)



                          • #14
                            my initial guess until i check it out is that it's the same issue as DigiBC has reported as there were a lot of changes with the internal password handling to have it cope with master and per-stream options, so looks like i managed to break that.

                            so if it's not working, that's why the title isn't appearing on the admin pages (as most empty options will be hidden like the aim or irc stuff, etc).

                            also it'd be a better comparison to compare against build 14 as that was the last build than to builds 7 or 10.

                            WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                            • #15
                              Hi DrO,

                              thanks, will check later.
                              I have streamed a few title, but the logfile only shows a line that a source connected and the connection was accepted nothing more. Nothing about bad password or anything.
                              So for me in the logfile it looks like sam doesnt even send a titleupdate even it did.

                              Hope that might help.