Announcement

Collapse
No announcement yet.

Frame settings changed, could cause playback problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HG2S
    replied
    I am running SC Server 2.6.1 build 777‚Äč on Ubuntu 20.04 with BUTT 0.1.37 and am seeing these warnings frequently. Does anyone have any ideas where these warnings come from? I have not tried ratelimit = (0 | 1) yet.

    Leave a comment:


  • djSpinnerCee
    replied
    do the log errors complain about the bitrate and/or the samplerate -- in other words, what difference does the dnas see in the source data that it's throwing a WARNing about?

    there's something about the source that the dnas is complining about, and more importantly unable to correct or ignore.

    channels? mp3s can be stereo or joint stereo -- i think the dsp encodes joint stereo -- almost all of my mp3s are 44khz CBR 2-channel stereo -- i haven't installed the latest dnas yet to see what the dnas says, but maybe there's something there as well.

    ratelimit=0|1 a debug option enabled [=1] by default, try disabling [=0] and see if it makes a difference.

    Leave a comment:


  • SoLoRiZe
    replied
    OK,

    Quick update, I re-encoded some of my mp3's to 256kbps CBR
    and then cleaned out my playlist and added these files in.
    So all the files were at 256kbps CBR.

    I then set my Shoutcast DSP Output to MP3 256kbps and
    started the stream.. all was well for about 15 minutes and
    then I started getting the errors again and the stream started
    to drop.

    So I guess that putting all the MP3's to a Constant Bit Rate
    did not help =(

    I have now changed both my streams to AAC+ one at HE-AACv2 56kbps
    and the other at AAC LC 128kbps, and now so far both streams are working
    well and do not have any of the errors that the MP3 stream was having.

    What I don't understand now is why there was a problem with my MP3
    stream, even though it was using the same source as the AAC+ streams =/

    Obviously I would like to offer my listeners the option of an MP3 stream,
    But if I can not get it to be stable then there is not really any point and
    I will have to stick to the AAC+ streams.

    Does anyone have any ideas why I am having problems with the MP3 stream?


    FYI
    I am running shoutcast on my old laptop, which has the following spec's:

    HP nc6000
    Intel Pentium M processor 1400Mhz
    1.0GB RAM

    Leave a comment:


  • SoLoRiZe
    replied
    Hi DjSpinnerCee,

    Thanks for your reply.

    My playlist consists of various kbps encoded MP3 files.
    (but all are at a samplerate of 44100khz) and could also
    be a mixture of CBR and VBR.

    i.e 96kbps, 128kbps, 256kbps etc..

    The problem is the collection of MP3's have been collected over the past 15 or
    so years, and therefore some of them were encoded at lower bitrates. The more
    recent ones where encoded at higher rates. So the playlist is a mixture bitrates.

    Would it be better for me to re-encode them all to the same bitrate i.e 256kbps CBR?

    I know that this would / could degrade the quality of the audio, but I would rather
    sacrifice a little bit of audio quality and have a stable stream, rather than it
    dropping out all the time.

    I could try doing this for a bunch of them and then see if the stream is more stable.

    Also should my stream bitrate be the same as the bitrate of my mp3's?
    i.e. If my MP3's are encoded 256kbps then my shoutcast stream should be 256kbps?
    or does it not matter for them to be the same bitrate?

    Leave a comment:


  • djSpinnerCee
    replied
    are your source mp3s vbr? - it's better if all source mp3s are cbr and the same samplerate -- i don't think source dsp's do a good job resampling vbr files frame-by-frame -- that's why sometimes you'll see the stream status say it's vbr when actually it's not.

    Leave a comment:


  • BLCR
    replied
    I am finding the same:

    Frame settings changed, could cause playback problems: bitrate 384(128) samplerate 32000(44100)

    Any idea what this means and why?

    Our encoder is set to 128kbps, 44,100kHz

    Leave a comment:


  • BLCR
    replied
    I am getting same thing with this new update. Can someone comment on what this all means? Our DJ is currently streaming at 128k, 44,100kHz.

    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:55226 sid=1] Frame settings changed, could cause playback problems: bitrate 48(128) samplerate 0(44100)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:50814 sid=1] Frame settings changed, could cause playback problems: bitrate 128(48)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:58955 sid=1] Frame settings changed, could cause playback problems: bitrate 48(128) samplerate 0(44100)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:63347 sid=1] Frame settings changed, could cause playback problems: bitrate 128(48)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:52138 sid=1] Frame settings changed, could cause playback problems: bitrate 48(128) samplerate 0(44100)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:22690 sid=1] Frame settings changed, could cause playback problems: bitrate 128(48)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:11229 sid=1] Frame settings changed, could cause playback problems: bitrate 48(128) samplerate 0(44100)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:41514 sid=1] Frame settings changed, could cause playback problems: bitrate 128(48)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:55440 sid=1] Frame settings changed, could cause playback problems: bitrate 48(128) samplerate 0(44100)
    2017-10-25 11:02:39 WARN [DST xx.xx.xx.xx:60111 sid=1] Frame settings changed, could cause playback problems: bitrate 128(48)

    Leave a comment:


  • Frame settings changed, could cause playback problems

    Hi,

    I wonder if someone can explain why I am getting the following Warning message
    in my ShoutCast Server (ver. 2.5.5.733) window:

    "Frame settings changed, could cause playback problems... .. . "

    Please refer to screen capture below:





    As you will be able to see in the above, I am getting various warning messages about
    frame settings changing along with various bitrate and sample rate being
    reported as could cause playback problems.

    I am unsure why I am getting these warnings, and why the varying biterates and
    sample rates? As my Encoder settings are set as: 80kbps, 44100hz, Stereo.
    Why would it be stating a warning message showing various other values?

    Also every couple of hours this MP3 stream drops out.


    FYI

    I have two streams;
    Configured in shoutcast DSP (ver. 2.2.3[build 122], as follows:
    (FYI, I can't use the later version 2.3.5, as this keeps crashing)

    Output 2 = AAC+ stream; HE-AAC v2 @ 56kbps, (port: 8020)
    Output 3 = MP3 stream; 80kbps, 44100hz, Stereo, (port: 8003)

    The AAC+ stream is rock-solid and streams without any drop-outs. But the MP3
    stream keeps dropping out every couple of hours or so, which I have no idea why?


    Additional information:

    I tried to use Shoutcast DSP ver. 2.3.5, but that keeps freezing and locking up winamp,
    so I have to keep with ver. 2.2.3, which at least when the MP3 stream drops out it reconnects
    again and does not freeze Winamp.

    OS: Windows XP SP3

    WinAMP version: 5.666 build 3516

    Shoutcast DSP version: 2.2.3 build 122

    Shoutcast DNAS server: 2.5.5.733

    So, if anyone can help / advise or pass comment on what is happening and how
    I can possibly rectify these problems, it would be greatly appreciated.
Working...
X
😀
🥰
🤢
😎
😡
👍
👎