No announcement yet.

Can't login to Radiomanager

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't login to Radiomanager


    I've needed to login to Radiomanager to create an Authhash for my station but whenever I go to login, it takes me to a login page that says it doesn't recognise my details (says my email or password is invalid). I am registered with Shoutcast (as far as I know).

    I contacted Shoutcast support nearly two weeks ago but I've had no response yet.

    Any help appreciated. I can provide my details upon request.


  • #2
    Originally Posted by Marcus632
    I'm also having trouble connecting to the Radio manager
    regardless of the computer or web browser that I use (including Chrome or Torch). Pages are timing out and I can't connect to my audio page. Any thoughts as to why?
    Any thoughts as to why?


    • #3
      can't connect to radiomanager

      Hi everybody

      I got the same problem. It's really strange...

      I can connect to and reset my password eventually

      but can't connect to

      If I click forgot password, it's says it sends an email to reset password but i never get it.

      so i can't manage authhash:-(

      This is really annoying

      Please help !'

      [edit] caps line adjusted , in forum language using this means you are shouting . ~NJK[/edit]


      • #4
        Same here!!! Impossible to enter the account !!! Please resolve it soon!!!


        • #5
          Still no answer from moderators? No solution? No response? Please solve this trouble soon!


          • #6
            Same problem here. No connection to although my account is valid. What is going wrong. Server keeps saying "email or password invalid".

            Asked support twice to help via mail. No respons.
            No mail after 'resetting' password.

            I like to authhash my station.


            • #7
              Having same problem, please help?


              • #8
                Absolute silence at Shoutcast support

                3rd time I wrote to Shoutcast support revering to this problem.
                Until now: absolute silence (even no 'mail received conformation')
                Very unprofessional not to respons or solve the problem.
                It's frustrating as hell


                • #9
                  Luckily, I can sign up. I can't hear my stream about it either, but otherwise it all works.


                  • #10
                    does anyone else still have this issue?


                    • #11
                      I don't know if it's same problem but may be it will help. Don't know...

                      I had the "invalid password" message for a month and could not connect to rmo until I realized that I had to choose a plan first and follow intructions on the pricing page of shoutcast. After this moment I had no more problem connecting... Did you choose a plan on this page?


                      • #12
                        OMG! THAT WORKED! Thank you so much, dare I say... i love you! lol