No announcement yet.

MilkDrop generates DirectX err msg Win 8

  • Filter
  • Time
  • Show
Clear All
new posts

  • MilkDrop generates DirectX err msg Win 8

    I just installed Winamp Pro on my new computer (Dell OptiPlex 9050, Win 8 touchscreen, Intel HD 400 graphics adapter, runs DirectX v11). When I try to run the Visualization window (set to MilkDrop; which is why I bought Winamp), I get the following message:

    "DirectX initialization failed (GetDeviceCaps).

    This means that no valid 3D-accelerated display adapter could be found on your computer. If you know this is not the case, it is possible that your graphics subsystem is temporarily unstable; please try rebooting your computer, and then try to run the plugin again. Otherwise, please install a 3D-accelerated display adapter."

    Everything worked fine on my Win 7 computer. I didn't find any "3D-accelerated display adapters" to install. Any thoughts?

  • #2
    I guess you need to additionally install DirectX 9. As far as I know, Microsoft broke compatibility with older versions when introducing DirectX10, so MD cannot use anything later than DirectX 9.0c. Same for older games which require version 9. Games designed for DirectX 7 would run with DirectX 8 or 9, but not with versions later than 9.

    To enable some sort of backwards compatibility, MS made it possible to install both versions. Installing DirectX 9 should not delete your version 11... Well, I cannot guarantee that it works, but it should be possible to have both versions in parallel.


    • #3
      Direct X 9 won't install

      I very belatedly got back to this forum to discover your message that installing DirectX 9 should solve my Win 8 MilkDrop error. Sadly, the installer won't install DirectX 9 if a newer version in already installed. What's disappointing is that I paid for WinAmp, I use it for all my audio and was hoping to use it for video as well but it generates the same error (because I hate the new full-screen-only Win 8 video player). Sigh...

      Thanks for your help! -Will


      • #4
        i doubt it'll help, but try the 5.64 release (just out as of a few hours ago) to see if that makes any difference. if not then we can try to look into the issue with your assistance (trying out test builds. etc) as i'd not seen this thread previously (anything about issues in the vis sub-forums often get missed).
        WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


        • #5
          Just thought I would chime in because I use the visualizations in Winamp and I got a new computer with Windows 8.1. I did get it working easily but I had to run the DirectX update, which will update your files for DirectX 9, 10 compatibility. It is called the DirectX End-User Runtime Web Installer (Get it from the Official Microsoft Download Center) here Milkdrop works just like it did with Windows 7 now even without doing the latest Winamp update.