No announcement yet.

Winamp 5.01 hangs on start on Win 98SE

  • Filter
  • Time
  • Show
Clear All
new posts

  • Winamp 5.01 hangs on start on Win 98SE

    Suddenly 5.01 hangs up on startup. The task manager list shows the equalizer not responding. I've uninstalled, deleted the directory, cleaned the registry, re-downloaded and reinstalled. Same behavior.

    This is probably a conflict with some other VB runtime; etc.

    Does anyone have any ideas? I really like the new library functions with the filters and would like to keep using the program.

  • #2
    The EQ shows as a separate entry in Task Manager?

    Modern or classic skin?

    What other programs are running at the time?
    Maybe a StartUpList might help us determine where the conflict lies?
    Attach the log to a new post
    (attachment feature available c/o Post A Reply button).

    Playlist | Twitter | Albums


    • #3
      I've attached startlist.txt as suggested.

      Close Program ((CTL-ALT-DEL)) Shows
      "Winamp Equalizer (Not Responding)".

      I've tried both skins.


      • #4

        I have the same issue -- also running 98se, fully patched. I may be able to give you some more details on what is going on ... (although I don't have an answer to the problem, so I'm posting here to get one, really) ...
        • The Equalizer window has focus and displays as the process title.
        • Winamp never gets far enough to create a taskbar entry or a systray entry
        • Winamp does create child windows before its demise: Main, Equalizer, Media Library, etc.
        • The condition is irrespective of where the window is positioned on the screen. It occurred originally on the top right hand corner and after several successive fresh installs, it showed the same problems in the default screen area.
        • Both skins crap out just the same. I have edited the INI to load the classic or the modern, and neither one gets any farther.
        • I have noticed that this problem happened in tandem with v3.0 as well, but only after I had installed 5.01. (v3.0 worked fine for almost 6 months prior to that, and now won't work at all, even with a clean install.)
        • I had no trouble with 5.01 for a few days, then suddenly it stopped working completely. I believe the last major area of the application I messed with was the Media Library. IIRC, the program crashed when I added a 17GB+ directory of MP3s. I tried turning it off manually via the INI, but that did not help.
        • I have come to the tentative conclusion that this is related to the WASABI architecture in some way -- the old versions of Winamp still work fine (v2). Could you give a list of DLLs to check for corruption related to those libraries that are not installed by Winamp? (ie, WASABI dependencies that won't be fixed with a fresh install)
        • I have manually killed all running applications except for Explorer and the problem persists. AFAICT, it's not an application conflict. (Like I said before, I've never had a problem with this before, and I didn't change anything except for installing the new version of Winamp.)
        • I have COMPLETELY uninstalled ALL traces of ANY version of Winamp from my computer SEVERAL times. Afterwards, rebooting a few times and manually cleaning the registry, then rebooting a few more times and then reinstalling the new version, but it never works.
        • I have updated to Dx9 as your website recommended, but that did not help. Problems originally started on a stable install of Dx8.01a.
        • Although I'm not sure how, this does appear to behave like a DDE conflict. That may be a track worth exploring on your end.
        • I am running a Creative SoundBlaster Audigy (first gen) with current drivers. Between working and nonworking times, the drivers were not manipulated at all. An update did not fix the issue after it stopped working.
        • After running this gimpped installation, my entire system becomes unstable. If I open Windows Explorer, it stops when it has to display a folder under the first drive letter listed. The trees never fill out. It just stops, dead. (Reasons I think it's DDE related...)

        If you want other details or you have a specific question, ask me. I hope that helps you guys. This is a real problem somewhere. I'm not sure your code is causing it, per se, but it definitely takes two to tango, and any track I could try for a resolution would be greatly appreciated. I don't want to be without my Winamp!


        • #5
          I've gone back to 2.91 and its working just fine. I can live without the fancy features of later versions. The library functions meet my needs. I basically queue up a few hours of music, play, minimize, and go about my business.

          I don't have any more information to contribute toward the analysis of this problem right now but will monitor the thread and chime in if I have anything to offer.

          Fat, dumb, and happy(or at least content) in East Maine, New York.


          • #6
            Well, as far as I can see, the only common denominator here is Win98SE.
            If 2.x is working fine, then I guess it could be an issue with one of the extra plugins in 5.x, eg. modern skin support, ripping/burning, hotkeys, etc.

            There has been only two other reported cases of this weird phenonemum,
            and we did seem to have some success with one of them.

            Howzit....Whatzit...what tha...? How to tune up, and keep your Winamp player humming along. Search this Forum to find others who have driven down your road and have advice and tips to help you out.


            Playlist | Twitter | Albums


            • #7
              I'm going to take a shot at some of the tips in the success thread. For now, some stuff I neglected to mention, which does correlate, unfortunately:
              • AMD Athlon Thunderbird 1.4G overclocked to 1.507GHz on 143MHz FSB
              • 512MB Corsair ECC SDRAM (Single chip, DIMM)
              • SoundBlaster Audigy
              • Abit KT-7A Mobo (VIA KT133A Chipsets)
              • ATI Radeon 7500 AGP @ 4x
              • Video in Composite Sync mode for a Sun monitor VGA->13W3 adapter

              Specifically, AMD and Abit correlate each to at least three of four cases, possibly all. That lends me to believe it's instruction related or perhaps a chipset problem, but the question is with which binary or which part of the chipset, and why fail over time? Why not be flaky or simply not work at all? In two cases (mine and the jerk's), the systems were overclocked -- although his much more so than mine. I currently can't try taking the clock speed down because I don't have a real monitor, so I don't get video until I get into Windows. I don't think that's related, though -- the other two systems don't seem to be pressed too much.

              Thanks for taking notice of this thread when it resurfaced, Egg. If you won't mind sticking this one out with us, I'll be happy to help everyone get this one solved.


              • #8
                Ok. Thanks for the info

                Yes, it could be a combination of abit / AMD (oc'ed ?!) / Win98SE,
                though we didn't get Mixolydian specs.

                Sure, I'm more than willing to stick this one out...

                Also note that 5.02 is the latest version.
                Though I've no idea whether this particular issue has been addressed, or whether it is infact a Winamp issue. But hopefully we can get to the bottom of it somehow.

                Playlist | Twitter | Albums


                • #9
                  I upgraded to 5.02 before posting.

                  I wouldn't follow the OC track. It doesn't make any sense. When you have OC problems, it is a result of unset or preset bits that you didn't want. That causes unpredictable instructions to fail in the course of computing. This problem is entirely predictable.

                  My first instinct is to ask what libraries the program has accessed at this point during the run. We know most of the window structure has already been generated, but most of the controls are missing and there's no response from paint messages.


                  • #10
                    My system is an old 450 PIII. I'm not sure of the motherboard but Device Manager shows an Intel chipset. All that I've added since I got it almost 6 years ago is 512Meg memory and a CD-RW drive. I do use a USB hub since there are only two ports on the system board. My graphics card is a Matrox MGA-G200 AGP.


                    • #11
                      that seems to rule out the hardware theory. shoot.

                      i should also mention that i have MSVS6 on my PC, so i have access to all the debuggers and stuff therein.
                      • When I attach the debugger to the stuck process, it hangs MSVC++ while trying to load symbol info.
                      • Dr. Watson finds "nothing obviously wrong" ... and neither does the process show up as "Not responding" on the task manager.
                      • There is only one thread started for the Winamp process at the time that it hangs.
                      • The DDE Spy shows no messages going in or out of the Winamp process after it freezes (unfortunately, I can't monitor all processes and then start Winamp -- I have to bind to a process that's already running, so I can't tell you what leads up to the crash ... the same applies to the tracer.)
                      • VBSpy does allow me to extract handle info from the main window and view the window tree from that point.

                      Now i'm going to go retire to some star trek with my newly acquired headache ...


                      • #12
                        OK Good news and bad news. I've done a clean install of 5.02 with the MINIMUM options selected (no fun stuff, just the core winamp), and IT WORKS. Just fine.

                        I'm going to slowly add components back on top of this installation and see what fails ...
                        • Minimal ... OK!
                        • Minimal, Modern Skin Support (modern skin active) ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support, Agent (not active) ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support, Agent (active), Visualizations ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support, Agent (not active), Visualizations, Extra Audio Output ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support, Agent (not active), Visualizations, Extra Audio Output, Video File Support ... OK!
                        • Minimal, Modern Skin Support (modern skin active), UI Extensions, Audio Files Support, Agent (not active), Visualizations, Extra Audio Output, Video File Support, Library ... FAIL!

                        I'm going to reboot and then test a clean install with just the library to see if it still fails.

                        Slight Correction to the above post: my task manager DOES show "Not Responding" next to "Winamp Equalizer" ...
                        Last edited by Scorch999; 11 February 2004, 05:02.


                        • #13
                          Dash it all -- I rebooted, uninstalled, rebooted, and then reinstalled with just the core and the Library, and it still worked. The Library must be conflicting with something else. I'm testing other components now ...
                          • Minimal, Library ... OK!
                          • Minimal, Library, Modern Skin Support ... OK!
                          • Minimal, Library, UI Extensions ... OK!
                          • Minimal, Library, Audio Output ... OK!
                          • Minimal, Library, Agent (not active) ... OK!
                          • Minimal, Library, Audio Files Support ... FAIL!
                          • Minimal, Library, Video Files Support ... OK!
                          • Full, No Audio Support ... OK!

                          Now tracking down the problem to a specific audio filter ...
                          • On a hunch, I tested with a Full installation, minus the Sonic Burn/Rip support ... OK!

                          That's your problem. The Library module is conflicting with the Sonic burn/rip plugin. If you uninstall one or the other, everything else works fine. So, the tentative solution for these problems is to simply deselect burn/rip support when installing under these conditions.

                          Ergo, what kind of burner/ATAPI drivers is everyone running?

                          Damn straight. Now I'm going to bed.
                          Last edited by Scorch999; 11 February 2004, 05:45.


                          • #14
                            Wayhey. Wow, you've certainly been busy.
                            Process of elimination. Never fails!

                            I take it you rebooted after installing Sonic Burning/Ripping Support?
                            Though I'm almost certain you get prompted to do this on Win9x/ME.

                            Of course there's the possibility that the Sonic Engine has compatibility issues under Win98SE with certain hardware setups.

                            So, yes, it looks like a list of cd/rw drive make/models is required,
                            plus whatever other burning software/drivers are installed
                            (eg. Adaptec ASPI Layer version, ECDC/Roxio, Nero, Sonic RecordNow, etc).

                            And maybe some StartUpLists might prove useful after all? Just to see if there's a potential conflict with any other concurrently running software.

                            btw, you could also try using SysInternals' Filemon to monitor processes in real-time.

                            I'll also add a link to this thread in the Sonic Engine Bugs thread.


                            Playlist | Twitter | Albums


                            • #15
                              Thanks Scorch...I eliminated the Sonic component and 5.02 works for me, too.

                              For what its worth, I have a Toshiba DVD-ROM SD-M1202 (came with the system) and a LITE-ON LTR-522465. I have Nero with the Incd component. There are probably odd components lying around from the software for my defunct Adaptec PlexWriter 12/10/32A as well.

                              An awesome piece of problem determination. Reminds me of the old days when I was doing OS development for IBM 360/370. Device support problems are a bear.