No announcement yet.

Mouse Scroll not working in Vista

  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    For Laptop users another option is to DISABLE the synaptics touchpad --the touchpad is often the cause of the cursor randomly jumping around on Laptops and other "rodent" (mice) related problems -- if you've ever had this problem you know how irritatating it can be and severe cases can almost render a laptop useless. Problem even more acute if you are using "Virtualisation" software such as vmware.

    Download the generic synaptics driver from the synaptics site --works for pretty well all laptops. Load the version relevant for your OS and install -- there's a special version for 64 bit vista as well.

    Disable the touchpad - problem (and a host of other one's fixed).




    • #47

      Hi !

      I had the exact same problem. A workaround that I found for Wireless Intellimouse Explorer 2.0 is selecting another type of mice : Wireless IntelliMouse Explorer for Bluetooth. It works great and you don`t lose any functionality. Scroll UP/DOWN works as it should, with the extended options too.

      Moppix suggested this fix for a wired mouse probably and someone said that there is still a lag. No lag on IntelliMouse Explorer 2.0 Wireless with the Bluetooth version selected.

      Cheers !


      • #48
        When you say "select another mouse"

        Where do you mean to do this?


        • #49
          @almostworked - Inside Control Panel you have the mouse configuration icon. If the intelli point software is installed, when you click the icon the software should pop up and there you can set the function of the buttons, etc., including the option to choose what kind of mouse do you have. The option is on bottom right in the first tab, just under the picture with the mouse

          Cheers !


          • #50
            That workaround doesn't seem to work for my Comfort Optical Mouse 3000. Went through the whole list trying every other mouse to see if it would work. Using the 6.3 version of the software. This is very frustrating, still no fix from Microsoft or Winamp.


            • #51
              Windows 7 64-bit with a Microsoft Optical Comfortmouse 3000. I can scroll up, but scrolling down is near impossible unless I force it hard, which causes it to skip either too much or too little.

              Basically, it's useless to use the wheel in winamp for me. What's worse, is, if I try to use my wacom intous3 mousewheel or the zoom slider, it doesn't work right either. Seems windows 7 just plain cannot handle winamp with mouse scrolling, period.

              I've tried the vista intellimouse drivers AND the windows 7 beta ones, both have this issue. Currently, WinAmp and facebook app "FarmTown" are the only two programs giving me this problem now.


              • #52
                I can confirm that in Windows 7 with (or without) the new Intellipoint v7 beta driver, this issue is STILL present.

                Can scroll up at a million miles an hour, and scroll down at a snails pace if I scroll fast.

                Any ideas yet guys? I've logged it with MS, but I think they'll bum this one out and throw it back to you.
                Win2k Rules. Period.


                • #53
                  it's due to the handling of the delta value passed in the wm_mousewheel message assuming a delta of 120 but some mice have a smaller delta (as is allowed on vista/win7) which breaks the previous logic. one of the devs was meant to be looking into changing the handling but that never happened i believe and without knowing what mice exhibit this finer level of scrolling (as i need a new mouse but can't get a definite answer) i'm not going to shell out for something that won't help.

                  WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                  • #54
                    Well I can tell you for a fact that it happens with almost every Microsoft mouse on the market.
                    Generic mice and Logitechs don't seem to have the issue.

                    It's the same whether intellipoint is installed or not (any version).

                    I hope that helps you out. I'm not a programmer, but if I can help you guys get this issue fixed, i'm all for it!

                    Let me know if theres something I can do. I've got access to a lot of hardware, so I should be able to be productive.

                    Thanks for the response too, it's good to know at least where the issue is!
                    Win2k Rules. Period.


                    • #55
                      This is really annoying.
                      Will help you out by listing my mouse which has the problem.

                      The issues is present on Microsoft Comfort Optical Mouse 3000.

                      So as has been said, seems to be on pretty much every Microsoft mouse, logitechs & other generic mice are fine.

                      Really would like this sorted.


                      • #56
                        Yes we know mate. It's just Microsoft Mice it seems.

                        Problem is not fixed in v5.56
                        Win2k Rules. Period.


                        • #57
                          no one has worked on it despite being known what needs to be done to fix the issue no one has (i don't have code access now so won't be trying to resolve it).

                          WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                          • #58
                            no one has worked on it despite being known what needs to be done to fix the issue
                            That statement does nothing but want me to try another player for the first time in 8 years.


                            • #59
                              explorer mouse owners, just change your mouse to "intellimouse explorer 4.0" (Win 7 32 bits)

                              but yes it's a shame that it's still not fixed, ms' fault or not.


                              • #60
                                Originally posted by psik0tik
                                explorer mouse owners, just change your mouse to "intellimouse explorer 4.0" (Win 7 32 bits)
                                I only had the option for "Microsoft USB Intellimouse Explorer 4.0 (IntelliPoint)".
                                Changing to this driver did NOT work.

                                It's a Winamp bug, pure and simple. After a few years now, i'm hoping a solution is forthcoming!
                                Win2k Rules. Period.