No announcement yet.

BUG: ML search doesn't search comment field

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally Posted by ron2112 View Post
    Now... in the spirit of not just fixing, but identifying the cause of, the problem... I'm thinking of the best way to proceed.
    I re-thought my earlier plan a bit, and did the following instead.

    First I cleared my media library entirely. Then I started adding artist folders to the library in batches. During this process, I discovered that this feature (highlight multiple folders > right-click > Add To Winamp's Media Library) is rather buggy. Sometimes folders would add to the library, other times not. Sometimes they would enqueue, other times not. Not wanting to miss any folders, I cleared the media library and started over.

    I started adding folders to my Watch Folders list, doing re-scans each time. Then I would try ?comment = ". Each time it worked fine, until I had the entire drive loaded back into the media library.

    So I cleared the library again, and did a full re-scan of the entire drive. Once everything was loaded back in, I tried the comment search again... worked like a charm.

    So the good news is, I'm not crashing anymore. The bad news is, I'm unable to report what might have caused it in the first place. I didn't change any files, so I'm at a loss to explain it.