No announcement yet.

Greek Characters in winamp and Windows 2000 problem

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Greek Characters in winamp and Windows 2000 problem

    I have hundreds of songs with Greek characters and so far i was using Windows 98 and winamp without any problem and the songs were recognised by winamp...

    But i change to Windows 2000 and now the songs with Greek Characters in the filename are not recognized by Winamp...I get questionmarks (?) and different symbols from winamp and the files can't be played.

    Note that in Windows 2000 i have no problem in writing or dysplaying greek characters, only winamp can't recognize them...

    I've read about some language packs or about other solutions but i couldn't find a definitive one that could help me (renaming the files from greek to english characters is out of the question)

    Can someone help to solve this problem???

    Please if you know the answer to this topic, then help!

    Thank you!

  • #2
    I think there was a plugin which fixes that, but I'm not sure. This is definitely a bug IMO (something messed up with unicode ?).


    • #3
      Don't think it's just a language pack problem

      I used to have Greek characters in Winamp working fine, with version 2.65 under Windows '98SE.

      Using v2.65 and a functioning language pack under Windows 2000 doesn't work either. Not only does it not support the Greek filenames, but it doesn't support Greek in the ID3 tag either, which it did under '98SE.

      Come on moderators! We've had 2000 for nearly two-years now, why isn't this fixed yet?


      • #4
        this is not only a problem with greek characters, it messes up on all international characters (according to what people complain about, i've never researched it). i'll report it to Justin.


        • #5
          I Found a Solution !!!!

          This worked for me and for other friends of mine...

          Go to the contol panel and click in the regional options

          In the first tab click in the "Set Default" button and in the new window select the "greek" from the combo box and click on ok

          It will prompt for restart, click Yes

          Magically winamp is able to recognize greek characters and works fine!!!

          Try it and let me know...


          • #6
            typed "Final Fantasy" playlist filename in russian. didn't work. oh well. i guess that it will start working when i set regional settings to russian, but it should work without messing with control panel.
            DJEgg ? TSGH buglist update ?
            [edit]tried to research this stuff. too bad, it can't be fixed on input plugin side and requires global changes (sending filenames via either utf8 or unicode). also, looks like WA3 has exactly the same problem.


            • #7
              it is known that winamp doesn't support international charakters (eg. Japanese) with englisch operating systems, you have to use a language specific os

              it seems to be a windows problem (maybe system font related?)
              it does work for languages with latin characters eg. french
              englisch windows versions don't seem to have fonts for non-latin charakters so that those filenames are displayed with wired combinations of ansi-signs, maybe winamp cannot deal with some of those signs?


              • #8
                Looks like file names are being converted from unicode to default system code page; if there are any characters that aren't present in that codepage, they're being replaced with "?" (or something like that); there's no way to restore them. The only good solution is to make Winamp use unicode or utf8 internally (and modify input plugin specs).


                • #9
                  using the correct code page is one thing but showing foreign charakters is another thing
                  you'll still need fonts for those charakters and they are complied into the language packs
                  even with modified input plugin specs you'd see only garbage in your playlist if you don't have the language pack installed, just imagine a playlist with Japanese, Greek, Cyrillic, Chinese and Arabic named files

                  so what we need in winamp3 is unicode display of filenames/id3tags in playlist and media library with the needed fonts included


                  • #10
                    messed up fonts and total inability to play files with evil filenames are two different things. language packs have nothing to do with playing files.


                    • #11
                      i know, but what's the use of greek filenames when winamp opens them but displays garbage in the playlist?
                      he said he has many of those files
                      just imagine he also has many files with Japanese charakters, he'd need to switch between the language packs just to identify the playlist entries

                      the inability to play them has to be fixed first though


                      • #12
                        Hello Everyone

                        Here is my guide to getting greek (or for that matter any other language!) fonts enabled in Winamp's Playlist if you are having problems (i.e text is being displayed as gibberish!) and changing your regional settings to that locale is not working I know it does not solve the problem about opening files but at least it's a cludge that can work for some people hopefully

                        1) Download the Tixoft Font Plug II plugin for winamp from

                        and install it.

                        2) Download an appropriate font for your language and install it. If you are using greek download the fonts from

                        I personally use the Times New Roman Greek font from there but you can use anyone you want to

                        If you do not know how to install fonts in your system look at the following website for windows systems

                        or macintosh systems


                        3) Right-Click in the main window and from the button of the menu choose

                        Configure Tixoft Font Plug II

                        4) In the new window that appears click on Setup and then make sure the check box that says

                        "Enable Font Plug for playlist text(win 9x Only)"

                        is checked

                        5) Click on Setup->Fonts

                        and choose the font you want to display the text in

                        6) If all is well everything should appear as you want

                        Optional Step:
                        If you would like to convert the ID3 tags from the Greek Codepage (CP-1253 for example) to unicode you can use the following utility "Character Set Converter 1.01". Download it from

                        Fonts, software, and keyboards for multilingual computing

                        At the moment it only supports western layouts but it can also be programmed to use other character sets/codepages.

                        Hopefully this will help people out there. In case of any queries do not hesitate to e-mail me at:

                        [email protected]

                        As I am not greek please e-mail me in English if you need any assistance. Bye for now



                        • #13
                          nice tutorial but how does it affect the problems that are dicussed in this thread?

                          1. problem: winamp doesn't open unicode files
                          2. problem: winamp doesn't display two or more non-latin charakter-sets at once

                          we already knew what you are discribing but we want more!

                          about your tutorial:
                          - tixsoft plugin doesn't work on winamp for mac, so why mac fonts?
                          - playlist font settings are only availible for win9x: you could always edit the skin configuration file (pledit.txt) if you want a different font under NT


                          • #14
                            Whoops, I made a mistake with the mac aspect. I presumed that the plugin worked on the Mac so sorry about that.

                            playlist font settings are only availible for win9x: you could always edit the skin configuration file (pledit.txt) if you want a different font under NT
                            Thanks for that tip. I didn't know that you could do that under windows NT.

                            I posted this tutorial after spending many weeks trying to get at least some sort of support for Greek in the playlist.
                            The aspect you mentioned about two non-latin character sets not being supported should in theory be solved if Winamp started supporting Unicode because even trying to support two or more non-latin character sets is going to be a pain


                            • #15
                              International Characters in Windows 2000 (ID3 and Filename)

                              A plug-in is not required to fix this under Windows 2000.

                              I have Greek characters in both filenames and ID3 tags on my machine, working fine under Windows 2000.

                              What you need to do is this:

                              Start->Settings->Control Panel->Regional Options

                              Make sure your locale is set to your normal home, then in the Language Settings for the System box, make sure that the Language you wish to support is checked. Click Apply.

                              Select the language again, and this time click set default. This enables both international characters for that language in filenames and any input box on the machine.

                              To add the international keyboard for that language, click the Input Locales tab, then click add. In the Input Locale tab, select the language you wish to support, then in the Keyboard Layout box select the character set you wish to use. Click OK, then OK again.

                              Probably a few re-starts have happened by now.

                              Then use Alt-Shift to switch Input locales.

                              Cheers dudes.