Announcement

Collapse
No announcement yet.

winamp v5.2: No entry point - DRMClien.dll

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • winamp v5.2: No entry point - DRMClien.dll

    winamp says some-long-name entry point ?QueryXferToJD@CDRMLiteCryto@@QAEJPBDPAEK1@Z was not found in DRMClien.dll ... A fresh copy of DRMClien.dll didn't help. I have two new plug-ins: modern skin and autostart. Maybe it involves a library search problem that appeared in the 5.2 beta.

  • #2
    Edit:
    Now that the problem has been later identified/resolved,
    please ignore this post and see further down for the solution and/or fixed pmp_p4s.dll



    When does the error message appear exactly?

    Are there any drm-protected wma files in your library?

    If so, do said files play ok in Windows Media Player?

    What version of WMP is installed?

    This error message usually suggests that there's a problem (corruption?) with your Windows DRM installation:
    Microsoft support is here to help you with Microsoft products. Find how-to articles, videos, and training for Microsoft 365 Copilot, Microsoft 365, Windows, Surface, and more.



    Edit:
    See my main post further down for the solution (re: disabling pmp_p4s.dll).
    Or see Will's post even further down for a fixed pmp_p4s.dll (if you require P4S device support). Note that this issue is fixed in newer versions of Winamp & pmp_p4s.dll, so make sure you've got the latest version first.

    Playlist | Twitter | Albums

    Comment


    • #3
      MP10 crashes yesterday.
      MP9 reinstalled and seems to work.
      Library is mostly mp3pro & mp3surround
      from thompson convertion.
      These players are not working right either.
      I'll try the DRM clean up soon.

      Comment


      • #4
        Entry point problem appears each time I start winamp full
        .
        Win DRM review per above link was not a success...
        no DRM folder in either docs or registry
        winamp problem mentioned in registry
        no know DRM permissions in first place
        .
        been testing:
        not working quite right with MP3pro support...
        MP3pro, MP3surround, winamp full
        working just fine without MP3pro support...
        MP9
        working just fine with MP3pro support...
        winamp lite
        .
        MP10 and winamp v5.2 beta was stuck in some library search

        Comment


        • #5
          working just fine without MP3pro support...
          I guess a lot of problems are related to the Thompson MP3Pro decoder for Winamp, wich is simply bullshit.


          [Edit --> DJ Egg]
          Sure is
          My Winamp Info Report | My Winamp Backup Log | My WACUP Info Report

          Own Projects: | Winamp Tray Control Icon Pack v3.5.3 | Winamp Backup Tool v3.6.0 | >> Winamp Info Tool v6.1.0 << |
          German Translations: | Offizielle Deutsche Winamp Sprachdatei v5.66 | Offizielle Deutsche Winamp Sprachdatei Plus Version 5.666
          Useful Winamp Plug-ins: | SNESAmp | 64th Note | NotSo FatSo | Highly Experimental PSF Player | Yar Matey! Playlist Copier v1.12 |

          Comment


          • #6
            you're not alone pal


            I can use winamp w/out any probs, but when starting winamp i get this annoying msg.

            Comment


            • #7
              Ok.. let's see if we can find out what's causing it.

              Did you all install support for Portable Media Players (ml_pmp)?
              (Installer Options > Screen 2 > Components > Winamp Library > Portables)
              If so, did you also install support for MS Plays for Sure Devices (pmp_p4s.dll)?

              Do you actually have any Portable Media Players, and if so, are they P4S Devices?

              Try disabling pmp_p4s.dll (Winamp\Plugins folder), eg. by closing Winamp
              and then either moving that file somewhere else or renaming it to pmp_p4s.off


              Let us know if the error message still occurs, and we'll take things from there.

              _____________________________________________________________

              [Edit] The rest of my post can now be ignored [/Edit]
              _____________________________________________________________

              Important:
              Please also include your Windows OS , including Service Pack (eg. WinXP sp2),
              and your Windows Media Player version in any reply.

              afaik, P4S support will only load under WinXP, and probably requires a minimum of sp1.

              If you do have a P4S player and you need support for it,
              then you can try updating the Windows Media DRM package from here:

              Playlist | Twitter | Albums

              Comment


              • #8
                My HP Pavilion PC has a fresh install of WinXP-SP2 without portable devices. The problem occured the day I tried MP3-Surround and upgraded from Winamp Lite to Winamp Full. Toay I followed your advice... renaming the file to pmp_p4s.dll.old... and the problem disappeared. I wonder what happened otherwise. Thank you. My humble library sounds decent and works pretty good.

                Comment


                • #9
                  Originally posted by Metafox
                  you're not alone pal


                  I can use winamp w/out any probs, but when starting winamp i get this annoying msg.
                  I've been getting that error every time I open the media library. Later I will try messing with portable support. (I don't own any portables so I don't care about ml_pmp)

                  Comment


                  • #10
                    Originally posted by Rellik
                    I've been getting that error every time I open the media library. Later I will try messing with portable support. (I don't own any portables so I don't care about ml_pmp)
                    Ok, I just removed pmp_p4s.dll and the error went away.

                    Comment


                    • #11
                      Thanks, DJ Egg. Renaming pmp_p4s.dll works.

                      Comment


                      • #12
                        Yup, it works.Deleting pmp_p4s.dll or renaming it.
                        Do we get to lose anything by deleting/renaming it?

                        Comment


                        • #13
                          You lose support for Microsoft Plays For Sure compatible portable media players.
                          But I assume none of you have got one of those devices anyway,
                          and probably should've unchecked that option in the installer.

                          Playlist | Twitter | Albums

                          Comment


                          • #14
                            thanks for the info - mine was doing the same thing - renaming the file - fixed it up good.

                            Comment


                            • #15
                              pmp_p4s.dll

                              Thanks folks... I was just about to uninstall the whole darned thing permenently and go on to something else. Not being a geek and understanding the wherewithalls, if it don't work right... it's gone

                              Winnmn

                              Comment

                              Working...
                              X
                              😀
                              🥰
                              🤢
                              😎
                              😡
                              👍
                              👎