Announcement

Collapse
No announcement yet.

Winamp 5.8 Beta, Build 3660 (official)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Winamp 5.8 Beta, Build 3660 (official)

    Winamp 5.8 Beta, Build 3660

    Info |
    Direct Download

    Winamp 5.8
    * New: Windows Audio (WASAPI) Output plug-in (w.i.p.)
    * Improved: Added an option to completely disable Winamp's video support
    * Improved: Added an auto-fullscreen option to video prefs
    * Improved: Added /ENUMPLAYLISTS to the command-line support
    * Improved: Windows 8.1 and 10 compatibility
    * Improved: [in_mod] OpenMPT-based Module Player (replaces old MikMod player)
    * Improved: [ml_playlists] Added browse path & edit title functions in Ctrl+E editor
    * Improved: [Bento] Updated scrollbars and buttons and other tweaks (thanks Martin)
    * Improved: [Bento & Modern skins] Added a Playlist Search feature (thanks Victor)
    * Fixed: New URLs not being remembered after using Reset history in Open URL dialog
    * Fixed: Various memory leaks
    * Fixed: [gen_tray] Not showing correct current icon pack in preferences
    * Fixed: [in_avi] Divide-by-zero crash with badly formed files (thanks ITDefensor)
    * Fixed: [in_mp3] Crashing with some ID3v2 tags
    * Fixed: [ml_wire] Slow loading issue
    * Fixed: [ssdp] Crash on load if jnetlib was not correctly initialized
    * Misc: Minimum required OS is now Win XP sp3 (Windows 7 or higher recommended)
    * Misc: More general tweaks, improvements, fixes and optimizations
    * Misc: Moved shared DLLs to Winamp\Shared folder
    * Removed: All former "Pro" licensed functions (Winamp is now 100% freeware again)
    * Removed: gen_jumpex & UnicodeTaskbarFix (making way for native implementations)
    * Removed: ml_nowplaying
    * Removed: [in_wm] DRM support
    * Replaced: CD playback and ripping now using native Windows API (instead of Sonic)
    * Replaced: MP3 Decoder now mpg123 based (instead of Fraunhofer)
    * Replaced: AAC Decoder now using Media Foundation (Vista and higher)
    * Replaced: H.264 Decoder now using Media Foundation (Vista and higher)
    * Replaced: MPEG-4 Pt.2 Decoder now using Media Foundation (Vista and higher)
    * Updated: [in_vorbis] libogg 1.3.3 & libvorbis 1.3.6
    * Updated: [libFLAC] FLAC 1.3.2
    * Updated: [libyajl] libyajl v2.1.0
    * Updated: [OpenSSL] OpenSSL v1.0.1i
    * Updated: [png] libpng v1.5.24

    ____________________________________________________________


    Language Packs
    - Polish | Info
    - Spanish | Info
    - More to follow


    Tip

    We recommend using the "custom" install option instead of "standard".

    Custom install lets you choose components, like before, whereas standard defaults to "all" on clean installs, or "previous" on upgrades.


    Notes:

    Some features are works-in-progress, e.g. new in_mod & out_wasapi plugins

    Sorry, no CD burning, autotag or cddb features yet.
    No multinational version with lang packs yet either.


    Changes since unofficial build 3563

    Removed ml_nowplaying; updated libogg, libvorbis, libflac & libopenmpt; copyright updates; added more genres to file info dialog; new digital cert; various other general tweaks, fixes and prep work....

    More to follow.

    ___________________________________________________________
    Last edited by Pawel; 27 February 2020, 17:13.

    Playlist | Twitter | Albums

  • #2
    What about language support?
    WINAMP EN ESPAƑOL:
    Spanish Language Pack for Winamp v5.9 | Spanish Language Pack Extended

    Bento Classified Good Ol' Color Classic Skin | NiwradSoft | Linuxeros.org | Twitter @niwrad

    Comment


    • #3
      lol, somebody forgot to update the installer window text.
      | Opus Audio Codec plugins 2.0 | Embedded Album Art | DiskWrite |
      | Save your playlist first! | Live voice-over | X-Fade 2.5 |
      | AterKast (Source DSP) | More of my stuff... |

      Comment


      • #4
        In progress for the 6.x version

        Originally Posted by niwrad777 View Post
        What about language support?
        The 58 beta version does not support multilanguage profile. So, this feature can be avariable soon or in the closed beta of Winamp 6.x.

        Comment


        • #5
          A possibility to attach FFMPEG/Libav codecs for Windows XP?

          Originally Posted by DJ Egg View Post
          Winamp 5.8 Beta, Build 3660

          The new Winamp Player offers the best of everything, bringing your streaming services, podcasts, radio stations, audio books and downloads together. Enjoy all your music in one place, and customize your listening experience with the legendary Winamp Player.


          Winamp 5.8
          * New: Windows Audio (WASAPI) Output plug-in (w.i.p.)
          * Improved: Added an option to completely disable Winamp's video support
          * Improved: Added an auto-fullscreen option to video prefs
          * Improved: Added /ENUMPLAYLISTS to the command-line support
          * Improved: Windows 8.1 and 10 compatibility
          * Improved: [in_mod] OpenMPT-based Module Player (replaces old MikMod player)
          * Improved: [ml_playlists] Added browse path & edit title functions in Ctrl+E editor
          * Improved: [Bento] Updated scrollbars and buttons and other tweaks (thanks Martin)
          * Improved: [Bento & Modern skins] Added a Playlist Search feature (thanks Victor)
          * Fixed: New URLs not being remembered after using Reset history in Open URL dialog
          * Fixed: Various memory leaks
          * Fixed: [gen_tray] Not showing correct current icon pack in preferences
          * Fixed: [in_avi] Divide-by-zero crash with badly formed files (thanks ITDefensor)
          * Fixed: [in_mp3] Crashing with some ID3v2 tags
          * Fixed: [ml_wire] Slow loading issue
          * Fixed: [ssdp] Crash on load if jnetlib was not correctly initialized
          * Misc: Minimum required OS is now Win XP sp3 (Windows 7 or higher recommended)
          * Misc: More general tweaks, improvements, fixes and optimizations
          * Misc: Moved shared DLLs to Winamp\Shared folder
          * Removed: All former "Pro" licensed functions (Winamp is now 100% freeware again)
          * Removed: gen_jumpex & UnicodeTaskbarFix (making way for native implementations)
          * Removed: ml_nowplaying
          * Removed: [in_wm] DRM support
          * Replaced: CD playback and ripping now using native Windows API (instead of Sonic)
          * Replaced: MP3 Decoder now mpg123 based (instead of Fraunhofer)
          * Replaced: AAC Decoder now using Media Foundation (Vista and higher)
          * Replaced: H.264 Decoder now using Media Foundation (Vista and higher)
          * Replaced: MPEG-4 Pt.2 Decoder now using Media Foundation (Vista and higher)
          * Updated: [in_vorbis] libogg 1.3.3 & libvorbis 1.3.6
          * Updated: [libFLAC] FLAC 1.3.2
          * Updated: [libyajl] libyajl v2.1.0
          * Updated: [OpenSSL] OpenSSL v1.0.1i
          * Updated: [png] libpng v1.5.24

          ____________________________________________________________


          Notes:

          Some features are works-in-progress, e.g. new in_mod & out_wasapi plugins

          Sorry, no CD burning, autotag or cddb features yet.
          No multinational version with lang packs yet either.


          Changes since unofficial build 3563

          Removed ml_nowplaying; updated libogg, libvorbis, libflac & libopenmpt; copyright updates; added more genres to file info dialog; new digital cert; various other general tweaks, fixes and prep work....

          More to follow.

          ___________________________________________________________

          One question...

          Exist a possibilty to use the FFMPEG and/or Libav codecs for H.264/X.264 and/or many others for Windows XP SP3 usage?

          Comment


          • #6
            it should be noted you will lose any milkdrop 2 presets / sprites when you update if you dont back them up first .. just found out the hard way ..

            Comment


            • #7
              And clicking on the OPTIMIZE button in the Skin->Modern Skin->General tab crashes Winamp. (Windows 10)

              Update: The crash has apparently to do with alphabackground xml-tag in my skin, which creates a transparent background in the "About" window.
              Quinto Black CT

              Comment


              • #8
                This is confusing. Here it's said that a few features are work-in-progress. On the main page it says that this is not an ongoing project.

                This version is not an ongoing project but be sure that we are currently working hard on a future new Winamp.
                What's happening with 5.8 now?

                Comment


                • #9
                  They've only released it because their hand was forced into it.... nearly 5 years its taken to get to this stage. Radionomy don't care for Winamp

                  I for one won't be installing Winamp again that ship has sailed here as I suspect it will have done for other users.



                  RadioDJ - Winamp - SAMBC

                  Comment


                  • #10
                    Originally Posted by PeterK. View Post
                    And clicking on the OPTIMIZE button in the Skin->Modern Skin->General tab crashes Winamp. (Windows 10)
                    No issues on my end , did it multiple times no crash

                    Comment


                    • #11
                      @niwrad777

                      No lang packs in this build.
                      5.8 should still support the 5.666 lang packs,
                      but they need updating.....

                      We should probably revive the xlat site/project,
                      but unfortunately, it's been a long time since any activity/contact :-(


                      @thinktink

                      Correct. My bad, lol.
                      It's been changed for the next build.


                      @evil_pro

                      There might be e.g. a 5.81 and further updates.
                      We shall see.


                      @eliotime3000

                      It will install on XP, but as you've found, it requires Vista or newer for Windows Media Foundation based codec support such as AAC & MP4 (MPEG-4 part 2, H.264, etc) and also the native Windows api for CD playback.
                      For AAC, you'd need to replace in_mp3.dll with the version from 5.666, plus old system\aacdec.w5s decoder, and also remove in_avi.dll, in_mp4.dll & in_mkv.dll and add AVI;MP4;MKV (etc) to in_dshow config instead.


                      @PeterK.

                      Which skin? Is there anything we can do to prevent that? Or is it something skinners will need to address?


                      @joatmon

                      Please explain further. I couldn't reproduce the milkdrop issue with the installer.
                      Reinstall and select the "custom" option. Make sure Milkdrop is checkmarked....

                      Playlist | Twitter | Albums

                      Comment


                      • #12
                        If confronted with "Windows protected your PC" dialog on Win10 (see attached screenshot), this will be due to our new digital signing certificate which won't yet have been recognized in the internal MS database.

                        Note where it says "prevented an unrecognized app from running".

                        It doesn't say there's a virus or any malware detected, just that it's unknown
                        and it will be due to the new cert (possibly in combination with the filename).

                        It is safe to click "Run anyway".
                        Though obviously note that it's still "beta" software.....

                        _____________________________________
                        Attached Files

                        Playlist | Twitter | Albums

                        Comment


                        • #13
                          Just installed 5.8.3660.
                          No playlist generator plugin shipped with this one?
                          Is this because that plugin stopped working in older versions and wouldn't also work in 5.8?
                          Or do I just need to download it somewhere else (if so, where?)

                          Comment


                          • #14
                            Hi, just installed. Almost everything works for me. Except one problem with wasapi: everytime there is a music break (next song, stop and play, ..) the windows sound volume is set to 0 and inside Winamp I have to change volume a bit to set this back.

                            Comment


                            • #15
                              My audio problem of jittering/crackling still persists with this version. I am waiting for a moderator to post my thread about this issue.

                              Comment

                              Working...
                              X