No announcement yet.

WMA Plugin freezes and crashes Winamp (fix inside)

  • Filter
  • Time
  • Show
Clear All
new posts

  • WMA Plugin freezes and crashes Winamp (fix inside)

    I'm using Winamp 5.03 and
    the new WMA plugin (I don't have the directShow plugin installed). Also I have WiMP 6.4 the WMP9 codecs installed. I'm noticing that whenever I play a WMA file, it will freeze Winamp, to the point it won't terminate properly.

    When I ran a test install (Reinstalling Winamp with only the DirectSound and WMA plugins into another directory) it crashes with this message:

    Windows 98 Version 4.10.1998
    WINAMP.EXE caused fault #c0000005 in WMVCORE.DLL at address 0177:4f51e59a

    EAX=00000000 CS=0177 EIP=4f51e59a EFLGS=00010246
    EBX=00f9d534 SS=017f ESP=00739f40 EBP=00739f6c
    ECX=00000000 DS=017f ESI=00863530 FS=58d7
    EDX=00739f5c ES=017f EDI=00739fcc GS=0000

    Bytes at CS:EIP:
    8b 08 ff 51 44 85 c0 89 45 10 0f 8c 9e 04 00 00

    Stack dump:
    00000000 00739f5c 0045a190 0045d160 00000000 0084532f 000c0000 00000000 00000000 10167f74 00000000 00739f8c 00f85f87 00863530 00739fbc 00000000

    Right now I'm back to using the old WMA plugin which works perfectly. Can this be a problem with the new plugin?

  • #2
    Hmm, strange...
    Any chance of uploading one of these WMA files somewhere and posting a link?
    Might be wise to zip it up first...

    Playlist | Twitter | Albums


    • #3
      I'll see what I can do. I only have 56k, so It'll take a while. But is the WMA plugin independent of any other 3rd party application's DLL files, as in DirectShow or Windows Media Player?


      • #4
        Here's the WMA file


        • #5
          I have a similar problem, my winamp 5.03 crashes whenever I try to play a WMA-file! I think this also has something to do with 'wmvcore.dll'
          If you want, I can send the so called fault-reports windows is giving! Let me know




          • #6
            Same problem here. Upgraded from 5.02 to 5.03, and a wma stream I listen to crashes winamp. Switching back to the old, v1 wma plugin fixes the problem. The url of the stream is .


            • #7
              Well, that stream plays fine in for me with Winamp 5.03a and the latest in_wm.dll.
              No idea what I was listening to... the first tune sounded a bit like Sister Machine Gun,
              followed by some pretty hefty grunge tune
              (shame it doesn't show what's playing, 'cos I quite liked this one),
              then some dude started speaking in part Dutch / part English,
              but the next tune was a bit crappy so I switched off.

              Could you all please provide some more information?
              We need to know the following:
              Basic system specs, including sound card/chip
              Windows OS
              Windows Media Player version
              Version of WMA codecs installed
              wmvcore.dll version (this can be found in your System dir, rt click -> properties -> version tab).

              Plus any other useful information, including error reports/logs
              (zip them up and use the Attachment feature c/o Post A Reply button).

              Also include a list of all extra 3rd-party Winamp plugins installed, if any.

              As for QZKotL's sample file, well, lord knows how I missed it first time around,
              but the link is dead now, so I never got to test it.
              But yes, links to sample files would certainly help...
              (again, it would be best to zip them up first).

              Playlist | Twitter | Albums


              • #8
                Crash details

                It's KinkFM, a dutch 'alternative' radio station. There are some playlists on, though only of the non-stop programs.

                I tried a fresh install of winamp 5.03a (the previous was installed over other versions of 5, though not over 2), and it still crashed. Details of my system are:
                • Athlon 900, 256MB RAM, Creative SB Live! Value
                • Windows 2000 Professional SP4
                • Clean full install of winamp 5.03a
                • Windows Media Player
                • wmvcore.dll version
                • Audio codec versions were a bit hard to find out; I finally found this: wmv version, wma version 4.2.0, directshow wma decoder, directshow wma voice decoder, directshow wmv decoders and

                I've also attached the drwatson crash log (zipped) for the last crash. I've got a few other crash logs, but the stack trace is the same.

                Let me know if there is anything else I can do to help.
                Attached Files


                • #9
                  Wimamp Crashes on .wma stream

                  I am getting the same error.

                  Attached is a jpg showing the gpf dialog box. 'nuff said already by others.
                  Attached Files


                  • #10
                    -Pentium(R) 4 CPU 2.00GHz, 256 MB RAM Creative SB Live! Value
                    -Windows XP Home version 5.1.2600 (Dutch)
                    -Also a clean full install of WinAmp 5.03a
                    -Windows Media Player
                    -DivX WMA Audio Compressor versie 4.02
                    -wmvcore.dll version

                    also I included a link to a sample WMA-file (the smallest I could find, but it crashes) and the standard crash-log, WinXP gives me.


                    • #11
                      Hmm, well all the sample streams/files are playing ok for me.
                      No crashes whatsoever.

                      WinXP sp1 (english)
                      WMP9 / WMA9 codecs
                      wmvcore.dll version


                      I've studied the dr watson crashlog, but I'm not too sure what I'm looking for.

                      Application exception occurred:
                      App: (pid=1584)
                      Exception number: c0000005 (access violation)

                      Could be an incompatibility issue with old WMP6.4... not sure yet.
                      Maybe someone else will know?


                      The stream plays ok for me. Anyone else?

                      "The instruction at 0x* referenced memory at 0x00000000. The memory could not be read"

                      This error is more than often caused by a potentially dodgy/old 3rd-party plugin.
                      Do you have any extra 3rd-party plugins installed?

                      btw, are you aware that Digitally Imported also broadcasts mp3 streams?

                      Navbar at top -> Trance -> mp3 streams...
                      These same streams are also accessible at
                      and via Winamp Library -> Internet Radio.


                      Again, thanks for the report.
                      Does the problem still occur if you disable the wincue plugin?
                      (I have to ask this, as it is the only 3rd-party plugin I can see that you've got installed).

                      Also, I'm not sure about this:
                      "DivX WMA Audio Compressor"
                      Have you tried disabling this codec and using the microsoft one instead?

                      Anyway, I'll be keeping my eye on this thread,
                      and will also report it to the dev team.


                      Playlist | Twitter | Albums


                      • #12
                        I was having a WMA streaming issue, Winamp 5.03 crashed or just closed. It is a pre wmvcore.dll 9.0x conflict. Updating to WMP9 (wmvcore.dll solved the problem.
                        Please do not PM me for tech support. Any request for tech support through PM will be ignored.
                        Read the Stickies
                        ---> | | | | <--- Knowledge is power


                        • #13
                          No problems.
                          Just had a look at the mysterious wmvcore.dll and it is indeed version that I'm using.



                          • #14
                            I have switched my WMA plugin back to version 1.13 and it works fine. This is the version that was with WinAmp 5.0.

                            I tried doing a clean uninstall, clean install, etc, and no luck. I even uninstalled all plugins but the WMA 2.0 version, and still had the error.

                            Only after going downlevel with the WMA plugin can I get it to work.

                            My System:
                            Windows 2000 SP4
                            Windows Media Player:

                            Regarding my usage of WMA streams for services such as DI. It turns out that work figured out a way to block MP3 streams, but WMA streams still work. Also, as I work remotely, and connect via VPN to work, I need to limit bandwidth due to limit$ set by my ISP.


                            • #15
                              Yes - installing WM9 fixes the problem.