No announcement yet.

Can't open encoder

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't open encoder

    Hi, I've just purchased and downloaded Winamp Pro 5.093. When I try to rip tracks from a CD I get the error message;

    "Error ripping track #1: Can't open encoder. Aborting"

    I've tried reinstalling but still get the same message. Any ideas?

  • #2
    Solved it, there must be a bug. It won't work for WAV encoding until you've used MP3 encoding, then after that everything works OK.


    • #3
      Incredible -- but it really works

      I would never have thought of that. I switched Wnaspi32.dll files until my fingers were bleeding, but following your solution, making the first rip an MP3 rip, problem seems to be solved.

      (Maybe this solution should go into the "Sticky" troubleshooting section).


      • #4
        Hmm... I'll look further into this, but at a guess it could have something to do with the fact there is no actual enc_wav plugin (the wave encoder is built in). There are plans to write a separate enc_wav, which will hopefully be bundled with a Winamp 5.34 release, so I reckon this will fix whatever weird issue you guys were experiencing here.

        Playlist | Twitter | Albums


        • #5
          How do you make a MP3 rip


          • #6
            Ok, I changed the format in Options> Prefrences> CD Ripping from WAV to MP3 and still doesn't work???


            • #7
              invasian, be patient as forums members are unpaid volunteers and they will respond to your posts as soon as possible.

              Also, please do not crosspost/hijack threads! [reference]

              The Winamp.INI File for Dummies
              Tips and Tricks for MSVCRT.dll Errors


              • #8
                Ok I'm very sorry, I was just eager as you can tell... hmm... well thanks to this forum or I have never known that I can rip Mp3's from CD's with PRO!


                • #9
                  Sorry to dredge up such an old thread but I've tried the above and it's still no go

                  The funny thing is that it's only just started happening, I've always been able to rip CDs onto Winamp perfectly well before and now it's just stopped working for no reason (I've been using Winamp ever since my iTunes bailed out on me in November, also for no apparent reason! Really don't want Winamp to stop working too!).

                  Any advice would be great


                  • #10
                    yep, it seems something's wrong with the new wersion, although the last time i used Winamp for CD ripping was several years ago, nowadays i've used different rippers, but automatic file naming / tagging seemed attractive.
                    anyway, i tried to rip to mp3, and it failed with "Error ripping track #1: Cannot open encoder | Aborting."
                    i have the latest version as of today (5.35), and it only happens with mp3 encoder (v1.34), all the other encoders worked fine.


                    • #11
                      problem solved (for me). the previous error occures when in VBR or ABR mode i chose the minimal bitrate to be below 32 kbps. 32 and anything above works.
                      it is still strange. why encode a second of silence even 32 kbps??? and why the opportunity to set it lower when it doesn't work?


                      • #12
                        Thing is, I haven't changed my version of Winamp recently either

                        I'm totally rubbish with this sort of stuff, by the way, so this could take a while...


                        • #13
                          I've used the encoder for years and it's always worked well but doesn't work at all for me now. I'm trying to convert flac to mp3 at 320 and it just says, "Error, can't open encoder"

                          I've reinstalled it over and over, using Winamp 5.621.

                          Help please?
                          Win 11 Pro
                          Winamp Pro 5.9.0 Build 9999 (x86)