No announcement yet.

Rip Decoder Broke-ded?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Rip Decoder Broke-ded?

    I'v searched the forums and I can't find anything on this. For some reason, every time I try to rip a CD now, it says that there was an error openning the decoder and "Aborting..."

    I did a full reinstall, and nothing changed. What's the issue here?

  • #2
    Anyone, please. I really need a solution to this. I can't figure it out, and I'v been at it for an hour.


    • #3
      I'v gone as far as doing a 12day Windows System Restore and installing 5.08, and still I get the "Can't open decoder. Aborting." error. None of the solutions on this forum for similar problems have helped. I'm getting a little desperate.

      Perhaps if someone were to post the plugin, I could replace mine with one that's sure to work?


      • #4
        Try to be patient, someone will help. It is christmas after all.

        Posting full system specs, a high-jack this log would help. Perhaps some more info, I.E, are you using the provided Sonic Ripping/Burning Engine, what encoder are you using, is it MP3, what ripping settings?

        You get the point.


        • #5
          I forget my system specs off the top of my head, but they are sufficient and uninvolved with the problem.

          I turned Sonic Engine off, am setting it to rip off CD at 360kbps "Very High" quality, useing Nullsoft's "MP3 Encoder v1.21"(default). However, no encoder is working right, as I tried ripping to .ogg and that didn't work either. I get the same error,

          "Error ripping track #1: Can't open encoder.


          Version 5.08 gave me the exact same error when I uninstalled Winamp and reinstalled the older version.

          What other significant information may be necessary?


          • #6
            A High-Jack This log, and tell us your system specs. There are sometimes individual problems with certain CD/DVD drives. At least, with some programs there are. It would still help.

            Try and at least tell us what the drive your ripping from is called. I'm not really a tech expert, but someone will soon come along with more answers. In the mean time, system specs and a 'highjack this' log would be very helpful.

            [Edit --> DJ Egg]

            Required info:
            -Windows OS
            -CD-ROM Drive make/model
            -Concurrently running programs (hjt log)
            Winamp Settings:
            -Prefs > CD Ripping > Output File Settings: Destination Folder & Naming Convention
            -List of any 3rd-party plugins installed
            -Confirmation of clean install of 5.12 Full/Pro
            (see sticky faq for more details, if required)


            • #7
              Windows Xp
              HP dvd640 (has worked fine until now. No changes.)
              No Concurrently running programs.

              Destination Folder: Desktop
              3rd-party plugins: It's been so long that I can't pick them out of defaults plugins. They've seen no changes and have worked simultaneously with dozens of rips.
              Clean Install: Check... several times.

              (HiJack this coming soon)


              • #8
                Ok, try downloading a new encoder, try ripping any other way possible, see if your computer is ripping anything at all. Try also using the DiskWriter plugin. if all else fails, try to install a different MP3 Codec.


                • #9
                  No ripping of any sort is working. I tried useing a third-party plugin to rip into .ogg and I received the same error. DiskWriter? New Codec? I know I sound slow but I need a little more information, I'm sorry. Not sure what you're saying.


                  • #10
                    Here's another link to the sticky FAQ I referred to:
                    Howzit....Whatzit...what tha...? How to tune up, and keep your Winamp player humming along. Search this Forum to find others who have driven down your road and have advice and tips to help you out.

                    We need a my_plugins_list.txt log and a HJT log.
                    Zip them up and attach them to a reply in this thread.

                    Winamp > Prefs > CD Ripping > Output File Settings
                    Copy & paste BOTH "Destination Folder" and "Naming Convention" fields here!

                    If you've just got "Desktop" as your destination folder (as stated in your previous reply), then that'll be why you're getting the error, because Desktop is not the full/correct path to your actual desktop dir.

                    Playlist | Twitter | Albums


                    • #11
                      In a bit of Christmas hurry, so I can't post an HJT log and I can't find the my_plugins file. But here's information refering to file destination/naming. (note: the error is for the encoder, not file destination.)

                      C:\Documents and Settings\Ernie\My Documents\My Music\!_ Unsorted Downloads _!

                      <Artist> - <Album>\## - <Artist> - <Title>


                      • #12
                        In the first post you said the error pertained to the Decoder, now you're saying it's the Encoder. Please make your mind up! Post the EXACT error message ;-)

                        Try creating & using a destination folder with standard alphanumeric characters, eg. My Music\Unsorted Downloads, not !_ Unsorted Downloads _!

                        Note: said folder MUST already exist. Please confirm this!

                        So... you're definitely not trying to play & rip the CD at the same time, are you?
                        You can play it, or rip it, but you can't rip it whilst it's actually playing.

                        Is CDDB working? ie. are "artist - album - # - title" tags being automatically filled in prior to ripping?

                        FYI: Details for how to post a HJT log and my_plugin_list can be found via the FAQ link I posted. Have you even clicked/read it yet?

                        Once you provided ALL the required info, then we should be able to diagnose the problem, but not until.

                        Playlist | Twitter | Albums


                        • #13

                          Installed Winamp plugin list
                          Plugin directory is: C:\Program Files\Winamp\Plugins\
                          Using Winamp version: 5.11

                          << Input plugins >>

                          Nullsoft CD plug-in (CDDB2) v3.11 [in_cdda.dll]
                          Nullsoft DirectShow Decoder v0.96 [in_dshow.dll]
                          LineIn plugin v1.80 (x86) [in_line.dll]
                          Nullsoft LineIn plug-in v3.1 [in_linein.dll]
                          Nullsoft MIDI player 3.09 [in_midi.dll]
                          Nullsoft Module Decoder v2.2.12 (x86) [in_mod.dll]
                          Nullsoft MPEG(Layer1-3/CT AAC+/Dolby AAC) Audio Decoder 3.33 [in_mp3.dll]
                          Nullsoft MP4 demuxer v0.71 [in_mp4.dll]
                          Nullsoft NSV Decoder v1.05 [in_nsv.dll]
                          64th Note v1.0 FINAL 11/23/05 [in_usf.dll]
                          Nullsoft Vorbis Decoder v1.42 [in_vorbis.dll]
                          Nullsoft Waveform Decoder v2.06 [in_wave.dll]
                          Nullsoft WMA plug-in v2.14(x86) [in_wm.dll]

                          << Output plugins >>

                          Nullsoft Disk Writer plug-in v2.0c (x86) [out_disk.dll]
                          DirectSound output v2.41 (d) [out_ds.dll]
                          Chun-Yu's MP3 Writer plug-in v3.0 [Out_MP3.dll]
                          waveOut output v2.1 (d) [out_wave.dll]

                          << Visualisation plugins >>

                          Advanced Visualization Studio v2.81b [vis_avs.dll]
                          MilkDrop 1.04b [vis_milk.dll]
                          Nullsoft Tiny Fullscreen 2001 (v2.05) [vis_nsfs.dll]

                          << DSP plugins >>

                          Nullsoft Signal Processing Studio DSP v0.36 [dsp_sps.dll]

                          << General Purpose plugins >>

                          EQ Hotkeys v1.0 [gen_eq_hotkeys.dll]
                          Nullsoft Modern Skins Support v1.08 [gen_ff.dll]
                          Nullsoft Global Hotkeys v1.3 [gen_hotkeys.dll]
                          Jump To File Extra v0.96fg [gen_jumpex.dll]
                          Nullsoft Winamp Library v2.20 [gen_ml.dll]
                          One for Nunz v1.8 [gen_nunzio.dll]
                          Nullsoft Tray Control v0.2 [gen_tray.dll]
                          Winamp [Key]Controller v4.04 (gen_wkc4.dll)
                          NxS XFade control v0.7 [gen_xfadedlg.dll]

                          << Media Library plugins >>

                          gUSB v1 build 005 [ml_gusb_us.dll]
                          Winamp iPod support v1.30 [ml_ipod.dll]
                          Transcoder v0.5 [ml_transcode.dll]
                          SHOUTcast Wire v1.01 [ml_wire.dll]
                          ml_xpdxs v1.0.2 [ml_xpdxs.dll]

                          << Summary of installed plugins >>


                          Hijack This:

                          Logfile of HijackThis v1.99.1
                          Scan saved at 3:31:35 PM, on 12/25/2005
                          Platform: Windows XP (WinNT 5.01.2600)
                          MSIE: Internet Explorer v6.00 (6.00.2600.0000)

                          Running processes:
                          C:\Program Files\Common Files\LightScribe\LSSrvc.exe
                          C:\Program Files\VMware\VMware Workstation\vmware-authd.exe
                          C:\Program Files\Java\jre1.5.0_04\bin\jusched.exe
                          C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe
                          C:\Program Files\QuickTime\qttask.exe
                          C:\Program Files\HP DVD\Umbrella\DVDTray.exe
                          C:\Program Files\dvd43\dvd43_tray.exe
                          C:\Program Files\V-Stream Multimedia\PVR Plus\TVR\Scheduled.exe
                          C:\Program Files\Logitech\MouseWare\system\em_exec.exe
                          C:\Program Files\Google\Google Desktop Search\GoogleDesktop.exe
                          C:\Program Files\Winamp\winampa.exe
                          C:\Program Files\Common Files\Real\Update_OB\realsched.exe
                          C:\Program Files\Google\Google Desktop Search\GoogleDesktopIndex.exe
                          C:\Program Files\AIM\aim.exe
                          C:\Program Files\Creative\Shared Files\Media Sniffer\MtdAcq.EXE
                          C:\Program Files\Google\Google Talk\googletalk.exe
                          C:\Program Files\Compaq\Compaq 11 Mbps Wireless USB Adapter\configA.exe
                          C:\Program Files\Mozilla Sunbird\sunbird.exe
                          C:\Program Files\Mozilla Thunderbird\thunderbird.exe
                          C:\Program Files\Google\Google Desktop Search\GoogleDesktopCrawl.exe
                          C:\Program Files\Mozilla Thunderbird\TBTray.exe
                          C:\Program Files\V-Stream Multimedia\TV88X Utilities\C8XRCtl.exe
                          C:\Program Files\NYKO\Gamepad Mapping Tools\ngpmap.exe
                          C:\Program Files\Mozilla Sunbird\SunTray.exe
                          C:\Program Files\Mozilla Firefox\firefox.exe
                          C:\Program Files\Valve\Steam\Steam.exe
                          c:\program files\valve\steam\steamapps\[email protected]\counter-strike\hl.exe
                          C:\Program Files\V-Stream Multimedia\PVR Plus\PVR Plus\TVPlus.exe
                          C:\Program Files\V-Stream Multimedia\PVR Plus\TVR\honestechTV.EXE
                          C:\Program Files\Winamp\Winamp.exe
                          C:\Documents and Settings\Ernie\My Documents\HijackThis.exe

                          O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
                          O3 - Toolbar: (no name) - {FEEEB9C2-E466-4A83-876C-6FD2DDF1A3D1} - (no file)
                          O4 - HKLM\..\Run: [SoundMan] SOUNDMAN.EXE
                          O4 - HKLM\..\Run: [SunJavaUpdateSched] C:\Program Files\Java\jre1.5.0_04\bin\jusched.exe
                          O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe
                          O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
                          O4 - HKLM\..\Run: [Logitech Utility] Logi_MwX.Exe
                          O4 - HKLM\..\Run: [DVDTray] "C:\Program Files\HP DVD\Umbrella\DVDTray.exe"
                          O4 - HKLM\..\Run: [DVDBitSet] "C:\Program Files\HP DVD\Umbrella\DVDBitSet.exe" /NOUI
                          O4 - HKLM\..\Run: [dvd43] C:\Program Files\dvd43\dvd43_tray.exe
                          O4 - HKLM\..\Run: [SmcService] C:\PROGRA~1\Sygate\SPF\smc.exe -startgui
                          O4 - HKLM\..\Run: [WinPatrol] "C:\PROGRA~1\BILLPS~1\WINPAT~1\WinPatrol.exe"
                          O4 - HKLM\..\Run: [PVR Agent] C:\Program Files\V-Stream Multimedia\PVR Plus\TVR\Scheduled.exe
                          O4 - HKLM\..\Run: [Openwares LiveUpdate] C:\Program Files\LiveUpdate\LiveUpdate.exe
                          O4 - HKLM\..\Run: [Google Desktop Search] "C:\Program Files\Google\Google Desktop Search\GoogleDesktop.exe" /startup
                          O4 - HKLM\..\Run: [WinampAgent] C:\Program Files\Winamp\winampa.exe
                          O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
                          O4 - HKLM\..\Run: [Task Catcher] C:\PROGRA~1\BILLPS~1\TASKCA~1\tasktrap.exe
                          O4 - HKCU\..\Run: [ccleaner] "C:\Program Files\CCleaner\ccleaner.exe" /AUTO
                          O4 - HKCU\..\Run: [AIM] C:\Program Files\AIM\aim.exe -cnetwait.odl
                          O4 - HKCU\..\Run: [MtdAcq] C:\Program Files\Creative\Shared Files\Media Sniffer\MtdAcq.EXE /s
                          O4 - HKCU\..\Run: [googletalk] "C:\Program Files\Google\Google Talk\googletalk.exe" /autostart
                          O4 - Startup: NYKO Gamepad Mapping Tools.lnk = C:\Program Files\NYKO\Gamepad Mapping Tools\ngpmap.exe
                          O4 - Startup: SunTray.lnk = C:\Program Files\Mozilla Sunbird\SunTray.exe
                          O4 - Global Startup: Adobe Reader Speed Launch.lnk = C:\Program Files\Adobe\Acrobat 7.0\Reader\reader_sl.exe
                          O4 - Global Startup: Compaq Wireless Configuration.lnk = C:\Program Files\Compaq\Compaq 11 Mbps Wireless USB Adapter\configA.exe
                          O4 - Global Startup: Mozilla Sunbird.lnk = C:\Program Files\Mozilla Sunbird\sunbird.exe
                          O4 - Global Startup: Mozilla Thunderbird.lnk = C:\Program Files\Mozilla Thunderbird\thunderbird.exe
                          O4 - Global Startup: Slim Multimedia Keyboard.lnk = C:\Program Files\Slim Multimedia Keyboard\MagicKey.exe
                          O4 - Global Startup: TB-Tray.lnk = C:\Program Files\Mozilla Thunderbird\TBTray.exe
                          O4 - Global Startup: TV Remote Control.lnk = C:\Program Files\V-Stream Multimedia\TV88X Utilities\C8XRCtl.exe
                          O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000
                          O8 - Extra context menu item: Open Link Target in Firefox - file://C:\Documents and Settings\Ernie\Application Data\Mozilla\Firefox\Profiles\uwk2pxrk.Default User\extensions\{5D558C43-550F-4b12-84AB-0D8ABDA9F975}\firefoxviewlink.html
                          O8 - Extra context menu item: View This Page in Firefox - file://C:\Documents and Settings\Ernie\Application Data\Mozilla\Firefox\Profiles\uwk2pxrk.Default User\extensions\{5D558C43-550F-4b12-84AB-0D8ABDA9F975}\firefoxviewpage.html
                          O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_04\bin\npjpi150_04.dll
                          O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.5.0_04\bin\npjpi150_04.dll
                          O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
                          O9 - Extra button: AIM - {AC9E2541-2814-11d5-BC6D-00B0D0A1DE45} - C:\Program Files\AIM\aim.exe
                          O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - C:\WINDOWS\System32\Ati2evxx.exe
                          O23 - Service: ATI Smart - Unknown owner - C:\WINDOWS\system32\ati2sgag.exe
                          O23 - Service: Creative Service for CDROM Access - Creative Technology Ltd - C:\WINDOWS\System32\CTSvcCDA.EXE
                          O23 - Service: LightScribeService Direct Disc Labeling Service (LightScribeService) - Hewlett-Packard Company - C:\Program Files\Common Files\LightScribe\LSSrvc.exe
                          O23 - Service: O&O Defrag 2000 (OOD2000) - O&O Software GmbH - C:\WINDOWS\system32\OOD2000.exe
                          O23 - Service: Sygate Personal Firewall (SmcService) - Sygate Technologies, Inc. - C:\Program Files\Sygate\SPF\smc.exe
                          O23 - Service: VMware Authorization Service (VMAuthdService) - VMware, Inc. - C:\Program Files\VMware\VMware Workstation\vmware-authd.exe
                          O23 - Service: VMware DHCP Service (VMnetDHCP) - VMware, Inc. - C:\WINDOWS\System32\vmnetdhcp.exe
                          O23 - Service: VMware NAT Service - VMware, Inc. - C:\WINDOWS\System32\vmnat.exe



                          "Error ripping track #1: Can't open decoder.


                          (Sorry, type before. Problem is the decoder.)


                          File Dest:
                          C:\Documents and Settings\Ernie\Desktop\Downloaded Files

                          Name Convention:
                          <Artist> - <Album>\## - <Artist> - <Title> (default)

                          I'm done several clean installs. Two system restores. Every possible combination thereof. It won't rip to any format.

                          I'm sorry that I'v taken so long to get all this information available. I'v been having a hectic few days.

                          Winamp is not working even with absolutely no plugins, since I backed up the plugins and did a clean install, and even with no plugins nothing worked. It did still recognize that I was a Pro member, so I know somewhere there's data related to Winamp I missed.


                          • #14
                            i also have problems ripping cds. it says CD drive is busy, and error finding codec and stuff... very annoying


                            • #15
                              Originally posted by Malaeus
                              i also have problems ripping cds. it says CD drive is busy, and error finding codec and stuff... very annoying
                              That's a totally different issue. Reinstall the drives for your CD-rom.