No announcement yet.

Add RSS subscription fails with 404 - invalid HTML?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Add RSS subscription fails with 404 - invalid HTML?

    I am trying to subscribe to a BBC radio podcast e.g.
    I am doing a copy/paste from the url shown on the website -

    Sometimes when I do so it works fine. Other times I get a dialog saying 'invalid link (404 or timeout)' so I got a wireshark trace (aka ethereal) and the HTML GET request seems malformed, ie "GET /podcasts/radio4/today/rss.xml\004?****** HTTP/1.1", where the \004????? refers to non-ASCII chars (04 3f 3f 3f etc). When i run itunes and do the same thing, the GET is formatted normally. I'm not an HTML guru or anything, but I'm pretty sure it should be ascii, right?

    This is a clean (first time) install with no plugins added.
    PC - Sony VGNFZ11M, core2duo T7100, 2Gb RAM
    sound - sigmatel
    video - geforce 8400GT
    vista home premium, "6.0 build 6000"
    directx 10
    winamp 5.5 (free download)
    no plugins

    Workaround Solution

  • #2
    Attached Files


    • #3
      wireshark trace
      Attached Files


      • #4
        plugin list
        Attached Files


        • #5
          1) the browser is firefox But I just tried IE 7.0.6000.16546 and got the same result.
          2) I also tried associating rss files with winamp (in firefox) and then using the direct RSS link on the BBC webpage, when I do this I get and error message in the top right pane of winamp, '1. [Error syncing to stream]'


          • #6
            Hmm, strange. All of those BBC podcasts work first time for me, without fail.

            Though this is on WinXP sp2, so not sure if it's a Vista-specific parsing issue, or if you're doing something wrong....
            Attached Files

            Playlist | Twitter | Albums


            • #7
              I get the same error when trying to add Podshow's Podfinder

              and some other podcasts.


              • #8
                this is a problem that i have had since the third recent beta release. the thing is that sometimes it will add the podcast stream, sometimes it will not. when it doesn't add on streams, it does so with my full compliment of plugins and with only the default 5.35 plugins running.

                this is also on a vista machine.


                • #9
                  "when it doesn't add on streams, it does so with my full compliment of plugins and with only the default 5.35 plugins running."

                  What do you mean?

                  Howzit....Whatzit...what tha...? How to tune up, and keep your Winamp player humming along. Search this Forum to find others who have driven down your road and have advice and tips to help you out.

                  Playlist | Twitter | Albums


                  • #10
                    i use the plugin starter that has profiles that turn on and off certain plugins. i have a profile that is only the default installed plugins for winamp 5.35 and in case winamp freezes up, i turn that on to see if it was a winamp issue or a plugin issue. saves a lot of posts in the tech support forum and a lot of needless clean installs to diagnose a problem.


                    • #11
                      I'm having the same problem.

                      Using Winamp 5.5, Vista, and fresh install.

                      Error is:

                      "Error adding URL

                      Invalid link (404 or timeout)"

                      Does not happen consistently. Restarting Winamp seems to fix it, but not always. After adding two or three podcasts, adding the next podcast results in the above error, requiring a restart of Winamp.

                      Also, after entering about 10 podcasts in this way, Winamp crashes on exit, and on restarting Winamp all subscribed podcasts have been deleted.

                      Podcasts I've been trying to add are at:
                      Radio National goes beyond the news headlines to examine a diverse range of topics, including arts and culture, business and current affairs, health, science and technology, Indigenous culture and issues, and religion and ethics.
                      Attached Files


                      • #12
                        Hi all,

                        My first post here!

                        Please count me in with the exact same error as above that nqwi posted. I don't have the crash on shutdown, but I don't have 10 subcriptions yet, only 6. Several of them are from the TWiT network, and the last 3 that I want for now will not add in with the above error. I was able to get the rest in by restarting and adding in a podcast, but it refuses the last 3. They are Security now!, Jumping Monkees, and Munchcast. They can all be found at twit(dot)tv.

                        The only thing I have added is the ml_ipod plugin. With its functionality, I can finally dump iTunes! I even uninstalled it to see if it was the problem, but no luck. If I can only get my podcasts. And I guarantee I will become a WinAmp Pro user.

                        Edit: I forgot my system info
                        cpu4 3ghz
                        ram:3 GB
                        Vista Ultimate with all latest patches
                        display card is Radeon 9550 based
                        Soundmax integrated digital audio
                        WinAmp Free 5.5 x86 Oct 10, 2007
                        Installed it 2 days ago
                        only additional plugin is the latest release version of ml_ipod 3.2

                        Thanks for the help.

                        Last edited by captapollo; 29 November 2007, 19:58.


                        • #13
                          Jumping Monkeys: http://leoville****podcasts/jm.xml
                          Security Now: http://leoville****podcasts/sn.xml
                          Munchcast: http://leoville****podcasts/mc.xml

                          Are those the rss feeds url's that you added via:
                          Winamp > Media Library > Podcast Directory -> Subscriptions -> Add button?

                          Note, I got those url's by changing the Subscribe drop-down menu to RSS, then copying the resulting url from the browser address bar...

                          They all work fine here on WinXP, though I am using an internal 5.51 beta

                          I haven't tested on Vista yet, but will do shortly...

                          Playlist | Twitter | Albums


                          • #14
                            Hi DJ Egg,

                            Thanks for the quick reply. Yes, those are the feeds and that is how I got them.

                            It does seem to be a Vista issue. I went home last night and added all of my podcasts on my Win XP machine without a problem.

                            Please let me know if I can do anything to help solve this issue. I would rather have the podcast subscriptions on the work computer because it is on all day long playing my music for me.

                            Thanks again, John.


                            • #15
                              Yeah, most strange. I get the same results on Vista.

                              But works fine on XP

                              Hmm, I guess this will need to be looked into further...

                              Playlist | Twitter | Albums