No announcement yet.

walkman sync no advanced tab

  • Filter
  • Time
  • Show
Clear All
new posts

  • walkman sync no advanced tab

    Short Story -- Songs synced to walkman keep asking to be deleted and re-added.

    Long Story -- A small problem I've been working on lately. Every time time I sync, Winamp wants to delete and re-add the same handful of songs to the device, even though they are already on the device. It says they are not in the Local Media Library.

    I've changed my walkman, via driver update, into a drive, assigned it a drive letter, and sync'ed it as a drive. This gives me the -preferences, portables, advanced tab-, which has the buttons 'Refresh Cache' and 'Save and Rescan', which clears the songs caught in limbo. But sync'ing like this doesn't transfer info info too well, like album art and some artist info.

    I have no -advanced tab- when I have the walkman assigned as an MTP device, therefore no 'Refresh Cache' and 'save and Rescan' options. I'm guessing if I could perform these actions, I would be able to clean up the songs in caught in limbo?

    I've reset and reformatted my walkman, and even ran a disk cleaner on it, but to no avail.

    Is there a known workaround for this?

    running Winamp 5.572 x86, XP SP3

    --the four portable device plug-ins that are installed are:
    Last edited by deckard253; 28 May 2010, 11:46. Reason: device plug-ins list

  • #2

    since the edit button is gone, here's an update via reply, in case anyone else is experiencing this issue.

    things i've tried that haven't worked:

    clean uninstall/reinstall of winamp
    reset/format walkman
    remove cache/ini files from device
    re-tag music tracks
    re-format music tracks

    if i could fix this, i'd be happy as a clam


    • #3
      from what i am understanding from the devs that issue like this are being fixed in the next version of winamp
      which should be out within the next couple of months

      best solution is to take the walkman out of mtp mode and put it in msc mode (if available)
      since the problem is mostly caused by the p4s plugin
      mtp= p4s
      also before you disconnect the player physically hit the eject button since there is a delayed write to the drive
      thanks rob
      (c)rob 2013 (picture & SN)

      (please note) As users we can't give others help unless we get full details of the problem that you are having


      • #4
        thanks for the response and info, Major.

        here's how i changed it into an usb (msc) device:

        "Open Device Manager. (To do this, open Windows Explorer and right click on "My Computer">Properties>Hardware tab>Device Manager)Find your Sansa Express under Portable Devices. Right click>Properties>Driver tab>Update driver. Select: No, not this time, Next.

        Select: Install from a list or specific location (Advanced), Next.

        Select: Don’t Search. I will choose the driver to install, Next.

        Be sure to check the box beside Show compatible hardware.

        Highlight USB Mass Storage Device, Next.

        Your SE screen should go dark, then light back up. Look at Device Manager. You should now see your SE listed amongst the USB Host Controllers and Root Hubs (signifying a USB mass storage device). If you got an error, Device cannot be started, ignore this. Close that window, and any Help center window that opens. Do a Hard Reset (center Select button & volume up) with SE plugged in. Your SE screen will light up. You can now use your SE as a UMS device. This will allow you, for example, to see hidden files in the SE memory. However, WMP 11 wil not see your SE while using the UMS drivers.

        To return to using your SE in MTP mode, repeat steps 1-6 above, and at step 7 select MTP Device."

        winamp now reads the walkman as USB Drive E:

        and now i eject it from winamp, AND from windows explorer.

        it syncs nicely now, with the only trade-off being 20% of album art missing, as far as i can tell. i posted the above instructions just in case anyone else wants to give it a try, it may save some google'ing.


        • #5
          i'm glad the info worked for you
          for album art i believe the best thing you can probably do is embed the art into the files
          currently i have found mp3tag is pretty easy to use to do this (since i used to use itunes to do so)

          to other users:
          for the transfer mode
          not all players will work this way
          some have a internal setting inside them to do this (read your instructions)
          thanks rob
          (c)rob 2013 (picture & SN)

          (please note) As users we can't give others help unless we get full details of the problem that you are having


          • #6

            after the latest release, and after re-tagging my entire library with mp3tag (something i wanted to do anyway, it needed it), i tried to sync my walkman as a MTP device (been using a standard USB mass storage device driver last couple of months) and still the same problem. the same songs keep asking to be re-written to the walkman.

            when this happens in USB mass storage device, i have the tab where i can refresh the cache, and all is good, but still no refresh option when in MTP mode.

            also, when in MTP mode, navigating the device through Winamp doesn't show as much info as when in MTP mode.

            and playlists don't trasfer when in USB mass storage mode

            but i'll keep hoping for a fix


            • #7
              problem fixed

              update: problem fixed

              Apparently, it's is how the tags were written that was the problem. anything in the metadata that has / or colons, and probably other punctiations, will not be written/read by sony walkman. When I replaced used hyphens instead in album titles, composers, and other basic info that walkmans display, everything worked great, no problems what-so-ever.

              i hope this helps anyone who runs into the same frustration.