No announcement yet.

Windows 7 Display Size Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 Display Size Issue

    I use my big screen TV for my main monitor on my media pc, and in order to see text better I've set Windows 7 to enlarge everything to 150%. (Control Panel -> Appearance and Personalization -> Display)

    I believe, however, that Winamp doesn't scale properly because certain items are no longer responding to mouse clicks and as an example my media library items can only be clicked on from the right 70% of their on-screen appearance.

    I hope this makes sense and I suppose that a bug report would be more appropriate, but maybe I'm just missing something.

    I need the scaling for the rest of the applications I use, but if possible I'd be willing to down-scale just Winamp in order to get it working.


  • #2
    its known there are issues but i don't think anyone on the dev team has had the time / chance to look into it. hopefully it'll get fixed at some point.

    WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


    • #3
      Windows 7 Display Size Issue


      I am having the same problem, I have my computer connected to my HDTV and one thing that bugs me a lot from Winamp is that when scaling the size in windows (150 dpi), I am unable to use the options in the Library.

      Search becomes unusable and so does clicking in any option.

      If I leave windows in normal size (scaled to 125 dpi), and scale only winamp. The bento Skin becomes larger (which helps a bit) but the fonts are unreadable (way too small to read from 2 meters away)

      Please I would like someone to find a solution for this. I have been using Winamp since its beginnings and I refuse to use any other music players just to have a readable HTPC.

      Thanks a lot.


      • #4
        Worked for me!

        Been struggling with the same issue this evening on setting up my Media Center for Windows 7 on my plasma TV.

        Try this solution:

        Navigate to your WinAMP install folder and right click the Winamp.exe -> Properties

        Click on the Compatibility Tab -> Settings

        Tick the box for -> Disable display scaling on high DPI settings

        Apply changes and restart WinAMP.

        I came across this when having some issues with games that would not resize correct (ie stretching past the screen edges) and solved my issue. It was a long shot that it would work on WinAMP but so far so good!

        Also, I found that the WinAMP Classic Skin seemed to be unaffected for me as another alternative.


        • #5
          @aussiedroid, I wouldn't call disabling display scaling a solution.

          Those of us who have increased scaling likely need it.
          Without increased scaling, winamp text is largely illegible on my 60" @ 1920x1080.

          I'm a long time VLC user and have recently given winamp another go.
          I'll be uninstalling due to this issue and that when the windowshade is docked to the bottom of the screen, it expands off the bottom of the screen rather than upwards.

          How long has this application been in development?!


          • #6
            Spot on, dk0r.
            Aussiedroid: [lame] 'workaround', not 'solution', is the operative word.

            Loss of mouse operability in the Media Library pane. Winamp developers, you got a real problem here... and have had it for a long time. More and more people use HTPC big-screen HDTVs for their PC monitor -- on which Winamp's Visualization is downright kickass btw! -- it's a technology that's been here for years. Please please please Winamp see into the wave of the future and prioritize finding the "time / chance to look into it" and get this fixed!


            • #7
              Bumping this as it accurately describes my issue. I've done the patchwork "fix" mentioned above with disabling the scaling on Winamp, but that only makes the mouse clicks work like they should. Sitting 13 feet away, I can't read a thing on my TV. The rest of my PC is scaled to 150% for a reason. Shocking that this program doesn't seem to support that.


              • #8
                ergh, please don't start posting in multiple related threads.

                i've already replied in your own thread about this and how to work around things and i did not say to disable the scaling globally, just for winamp itself (which you do via right-clicking winamp.exe and changing the compatibility settings).

                WACUP Project <‖> "Winamp Ramblings" - Indie Winamp Dev Blog


                • #9
                  I for one appreciate the double-posting because it's the only way I would have seen DrO's tips on addressing this issue which was brought up in this thread 1½ yrs ago and remained essentially unaddressed here... after that much time, a person typically gives up on scanning the forum for new threads.

                  Since the issue didn't get effectively addressed in this thread, bvbull200's decision to create a new one seems quite logical. Thanks for the post here bvbull200 and for the link to the other thread DrO.