No announcement yet.

Auto Tag Stopped working after 5.601 pro update

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auto Tag Stopped working after 5.601 pro update

    I have the standard pro install with no extra plugins or anything added. When using the "send to" menu and then auto tag it says done on the first item in the list and stays at analyzing on the second item. On the done item nothing is changed. Also...when using auto tag from the "file Info" menu on a single item it always say "Match not found" imediately after hitting auto tag. Does not matter what tracks I do this on. I have another computer running 5.56 and it works fine.

    I am running Windows7 64bit with all updated patches.

    Any help is much appreciated. I have completely uninstalled and reinstalled from scratch several time and no go. It is like it is just connecting to gracenote. I have turned off all firewalls and such just to be sure and of course that did not work either.


  • #2
    Can anyone at least point me in the direction of where the gracenote config is kept or the local file it makes for the cddb? It is almost like something is corrupt but is not removed in the uninstall. My pro key and all of my settings are there when I reinstall as well as this problem and I am removing the winamp dir after I uninstall.


    • #3
      Wow....No one has any ideas....Come on tech support guys....I paid for this app and want to work with the auto-tag gracenote used to work!!!


      • #4
        No replies usually means no one else is seeing the same problem on their setup. My Vista 64-bit PC is happy with AutoTag, used it just a few minutes ago.

        Does it work when you try and rip a CD? Pop a disk in and then look at the CD Ripping section. Are the track names filled in?

        The money you paid for Pro went to the MP3 and H264 licences. There is not many spare Winamp staff around to do the support. It is just us Winamp fans.

        Check the Winamp preferences. Down the bottom, in Plug-ins\Media Library you should find "Nullsoft Auto-Tagger v2.04 [ml_autotag.dll]" listed. Now also go and double check if you can locate the .dll in Winamp's plugins folder.


        • #5
          Still can't figure it out

          Thanks for the reply...I have been out of town. I have the dll in the proper place. Have uninstalled and re-installed and it still does not work. Have it working on a Vista 32 and 64 bit with no issues. Not sure what could be causing it. It does not work for CDs either. It either just hangs or gets no match found every time. Any ideas of other things to try I would appreciate it.


          • #6
            The settings for Winamp are found in %appdata%\winamp (Or C:\Users\helpers\appdata\roaming\winamp)

            In there you can find a gracenote folder. With winamp closed, you could try renaming/deleting this folder. I just tried on mine, and found that a fresh folder was generated by Winamp when I next used the Gracenote database.

            As you suggested earlier, you may have a corrupt database.


            • #7
              I have a very similar problem. Since I installed 5.6.1 (Pro latest) on 5-4-2011, Gracenote crashes my system. Even Windows Explorer does not respond anymore.

              This happens when ripping a cd, Gracenote connects and when it's processing it complete freezes.

              I fully uninstalled and this worked, but a few weeks later the same problem came back. Reinstalling and keeping user settings did not solve the problem. Deleting the gracenote folder in roaming/winamp/plugins/gracenote didn't help either. Switching to 5.5.8 didn't fix it.

              Completely reinstalling: no fix.

              There's definitely something wrong with Gracenote, it has worked for months without problems on the same computer (Windows 7 64 bit)


              • #8
                @najarip: Does Gracenote only crash when tagging a CD? OR can you trigger a crash by using the Send To -> Auto-Tag function from within the media library?


                • #9
                  @Batter Pudding: When I use the Auto Tag functionality, WinAmp does not crash. I can see that it connects to Gracenote. It's a CD that is not on gracenote and WinAmp crashes when inserting the CD. When I rip with another program and use Auto-tag in Winamp on the tracks, WinAmp does not crash, but doesn't find the trackinfo either (figures).

                  Does this help?


                  • #10
                    @najarip: As mentioned above, I am not a dev so just trying to help narrow this down.

                    Where are you ripping your CD to? Are you in the Win 7 User Folders (i.e. My Music) or trying to do this somewhere weird like C:\Program Files\ ?

                    I see you have tried the sensible - rip tracks elsewhere and then autotag. Which at least shows us that Gracenote in general is working.

                    Usually when a CD that Gracenote does not recognise is inserted for ripping, Gracenote causes a dialog box to appear asking you to add in the details to their database. I am going to dig through my CDs and find one that Gracenote will not know and see what happens. It could be a bug with that dialog box causing a crash.

                    Does Gracenote work okay on a normal recognised CD when ripping?


                    • #11
                      okay. Stuffed in an unrecognised CD, but still got a Gracenote window appear. And this time I saw the one that asked me if I wanted to submit details.

                      No crash of Winamp...

                      BUT... I use the Opera Web Browser, and at some point in the past an installer for it associated it with more files that it should have. And when I had this unrecognised CD inserted - I got a dialog box appear with an Opera title telling me the program had quit because it could not locate MSVCR90.dll (And yet Opera was not involved as it was running happy in the background...)

                      So - could you have other programs registered to Auto-Play a CD that are mis-firing and then clashing with Winamp?


                      • #12
                        I think I may have a clue.... do you have the advertising "Show Info" panel open at the bottom of the Winamp ripping window? This is why Opera is "crashing" for me as that window tries to load URLs and other links connected to the CD being ripped.

                        Opera, for me, does not crash as it catches the exception, complains about a missing dll, and then allows me to exit. This implies to me that AOL is trying to launch by web browser in an odd way from the wrong location.

                        Normally I have this "Show Info" window hidden, and on top of that I block the advertising \ "more info" URLs that AOL tries to access.

                        When I had that panel open, I had dozens of the Opera Dialogs flashing up which I had to dismiss one by one.

                        So - my theory is - a CD that is not in the gracenote database causes problems for these AOL adverts, and depending on which web browser you use as default depends on the "crash" action that happens next.


                        • #13
                          No such luck. Even with the Show Info panel hidden WinAmp crashes when looking up the CD. It stops processing on "Verwerken..." (Dutch), which means "processing..." I guess.

                          Are there no Winamp people in this forum who may know a fix for this?


                          • #14
                            If you want any chance of official help, you need to read the sticky and start adding in full details of your plugins, etc.

                            The key thing to notice is - this is only happening to you. Other people would scream otherwise. So there is something "not standard" about your setup causing this.


                            • #15
                              Finally got around to doing some work on the problem. I uninstalled Winamp en reinstalled it, no fix. Then I uninstalled WinAmp with Your Uninstaller en reinstalled it, this fixed it. My guess is, something indeed was wrong with WinAmp and not my system...

                              Anyway, fixed for now.